You are not logged in.

#1 2014-05-04 16:53:52

Ansible
Member
Registered: 2014-05-04
Posts: 4

Alsamixer doesn't save settings?

I'm trying to change audio playback devices on arm7 arch.  I can bring up alsamixer fine, and it allows me to select between the two devices that are available.  However, when I exit alsamixer and restart it, the sound card is back to what it was before. 

I'm using Esc to exit.  Does that also reset to the previous settings?  If there's something else I should be using to save the settings, its not obvious. 

I get this same behavior on Debian too.

Offline

#2 2014-05-04 17:06:07

ooo
Member
Registered: 2013-04-10
Posts: 1,631

Re: Alsamixer doesn't save settings?

Exiting via Esc should save the settings just fine. does changing the settings actually change the volume even though it reverts back when exiting?
does alsamixer work for root? If so adding your user to 'audio' group could help on some cases: https://wiki.archlinux.org/index.php/Ad … stallation

Users with a local login (at a virtual terminal or a display manager) have permission to play audio and change mixer levels. To allow this for a remote login, the user has to be added to the audio group. Membership in the audio group also allows direct access to devices, which can lead to applications grabbing exclusive output (breaking software mixing) and breaks fast-user-switching, and multiseat. Therefore, adding a user to the audio group is not recommended, unless you specifically need to.

Offline

#3 2014-05-04 17:24:59

Ansible
Member
Registered: 2014-05-04
Posts: 4

Re: Alsamixer doesn't save settings?

The user in question is already a member of audio.  I'm remotely logged in through ssh.  I tried ssh as root just to make sure and I still get the same result; can make changes in the alsamixer gui but they are reverted when I go back into alsamixer.

As root:

the only device that works is spdif, which doesn't have any controls.  I can do aplay and I get sound through spdif. 

I get go into alsamixer and switch devices, then ctrl-z and do aplay, the sound is still through spdif.

Offline

#4 2014-05-04 17:27:54

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,999

Re: Alsamixer doesn't save settings?

As this is an ARM system, I am moving this to "Other Architectures".  I do this mostly because I am not certain that the solution for your system would be applicable to Intel based Arch.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#5 2014-05-04 17:46:46

Ansible
Member
Registered: 2014-05-04
Posts: 4

Re: Alsamixer doesn't save settings?

It might be worth noting that the same thing happens on my debian laptop, and on a fedora laptop:  I go into alsamixer, use F6 to select a device, use Esc to exit, restart alsamixer and settings are back to what they were before.  In the case of the laptops that would be pulseaudio.  On the laptops I'm using sudo to open alsamixer.

Offline

#6 2014-05-05 15:44:36

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 1,344

Re: Alsamixer doesn't save settings?

What 2 cards are you talking about?
Because, if you refer to default and your sound card, this would be the case.
If you choose the specified card, it would jump back to default, cause it is.

Offline

#7 2014-05-05 19:36:29

Ansible
Member
Registered: 2014-05-04
Posts: 4

Re: Alsamixer doesn't save settings?

Yeah it turns out the 'bug' was really a misconception on my part that one could choose the default card from alsamixer.  Regardless of which card you select, it has no effect on the default card, you have to set that some other way, apparently.

Offline

Board footer

Powered by FluxBB