You are not logged in.

#1 2014-05-05 19:41:36

flammi
Member
Registered: 2014-05-05
Posts: 1

Thinkpad T440s - Sound issues with docking station

Hi everyone,

I bought a docking station for my Lenovo ThinkPad T440s Laptop and I have some trouble to get the sound working with the docking station. If I remove the sound jack from the docking station, I hear sound from the internal laptop speakers. If I plug it into the docking station, I hear no sound. The speakers are working... If I plug the sound jack into the laptop directly, I can also hear sound.

It seems, that this problem is also mentioned here: http://permalink.gmane.org/gmane.linux.alsa.user/36896. As suggested by the author, I added "options snd-hda-intel model=thinkpad" to a file in /etc/modprobe.d/ but I had no success...

Does anybody have an idea how I can solve this problem? I am using Gnome 3.12.1 with pulseaudio and the 3.14.2-1-ARCH Kernel.

Offline

#2 2014-05-10 20:55:27

acrodaniel
Member
Registered: 2014-04-10
Posts: 8

Re: Thinkpad T440s - Sound issues with docking station

how did you manage du get your secound screen working?

on my x1 carbon the only thing what is working is the network connection and the usb hub

all the best

Offline

#3 2014-06-20 10:16:50

madevr
Member
Registered: 2013-11-18
Posts: 5

Re: Thinkpad T440s - Sound issues with docking station

@acrodaniel: There was a firmware update for the dock (and kernel patches AFAIK), so updating either kernel or dock fixed the second monitor for the Thinkpad T440s. Don't know about the x1 carbon though.

The audio problem mentioned here is fixed, a patch exists it seems. Mailing list: http://permalink.gmane.org/gmane.linux. … vel/122601

If I'm not mistaken, the patch is this one: https://gitorious.org/opensuse/kernel/c … f58a496d53

Could we get this into Arch? smile

Offline

#4 2014-06-20 12:09:02

Bevan
Member
Registered: 2009-09-08
Posts: 55

Re: Thinkpad T440s - Sound issues with docking station

On a L430 I had the same issue with the docking station. The solution was

options snd-hda-intel model=lenovo-dock

in /etc/modprobe.d/...

Note the different model: lenovo-dock instead of thinkpad. Maybe worth a try.

Offline

#5 2014-06-23 22:03:16

madevr
Member
Registered: 2013-11-18
Posts: 5

Re: Thinkpad T440s - Sound issues with docking station

Thanks for that suggestion! However, it didn't improve the situation on my T440s, sound via dock is still not working...

Could I initiate a process to get the patch from my last post into Arch? I have no idea how to do that though, would someone give me a hint..?

Offline

#6 2014-06-23 22:51:31

codemac
Member
From: Cliche Tech Place
Registered: 2005-05-13
Posts: 786
Website

Re: Thinkpad T440s - Sound issues with docking station

Arch maintains very few patches.

madevr, it looks like parts of that patch are already in mainline linux, see line 4711 in sound/pci/hda/patch_realtek.c:

	[ALC292_FIXUP_TPT440_DOCK] = {
		.type = HDA_FIXUP_PINS,
		.v.pins = (const struct hda_pintbl[]) {
			{ 0x16, 0x21211010 }, /* dock headphone */
			{ 0x19, 0x21a11010 }, /* dock mic */
			{ }
		},
		.chained = true,
		.chain_id = ALC269_FIXUP_LIMIT_INT_MIC_BOOST
	},

I have a t440s, and am trying to get this dock sorted out. I'll post back here if my audo ever starts working.

Offline

#7 2014-06-26 21:08:14

mquandalle
Member
Registered: 2014-06-26
Posts: 2

Re: Thinkpad T440s - Sound issues with docking station

I encounter the same issue with my new T440s and its docking station and I confirm that `options snd-hda-intel model=lenovo-dock` doesn't solve the problem.

Also as @acrodaniel asked, I haven't manage to get two external screens (VGA+DisplayPort) working independently (they are mirrored).
Have you upgraded the dock firmware to 2.17 using Windows? Or is there a kernel patch?

Offline

#8 2014-06-26 22:20:14

mquandalle
Member
Registered: 2014-06-26
Posts: 2

Re: Thinkpad T440s - Sound issues with docking station

The sound problem is solved in kernel 3.16 (currently RC2).

Offline

#9 2014-07-02 08:54:56

madevr
Member
Registered: 2013-11-18
Posts: 5

Re: Thinkpad T440s - Sound issues with docking station

As far as I know, either using an up-to-date kernel or updating the dock firmware (using Windows, there might be ways to do it without Windows, but they seemed complicated) should fix the dock monitor problem (previously, an external monitor connected to the dock would not work AT ALL).

BUT DisplayPort is another story, I remember reading that VGA/DVI + DisplayPort would still be mirrored because the kernel is not yet ready for anything more sophisticated. So using one monitor on the dock via DVI (my case) works just as expected, and nothing is mirrored. AFAIK DisplayPort, currently, is always mirrored.

Offline

#10 2020-03-25 14:28:22

apson
Member
Registered: 2020-03-25
Posts: 1

Re: Thinkpad T440s - Sound issues with docking station

Year 2020. I can confirm I had the same issue with the docking station on Thinkpad L430  using linux kernel 5.5.11-arch1-1 and setting lenovo-dock option solved the issue for me

Bevan wrote:

On a L430 I had the same issue with the docking station. The solution was

options snd-hda-intel model=lenovo-dock

in /etc/modprobe.d/...

Note the different model: lenovo-dock instead of thinkpad. Maybe worth a try.

Offline

#11 2020-03-25 16:18:35

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,074

Re: Thinkpad T440s - Sound issues with docking station

If you want to investigate, make your own post containing information and up to date logs from your own system. Even if the symptoms are similar the cause will likely have shifted in 6 years.

Please don't necrobump: https://wiki.archlinux.org/index.php/Co … bumping%22

Closing.

Offline

Board footer

Powered by FluxBB