You are not logged in.

#1 2014-05-12 16:07:08

kc3
Member
Registered: 2012-02-24
Posts: 32

[Solved] Jedi-Vim Nuisance

Okay so I got jedi-vim working for editing python in vim however though the auto-complete is very useful, the new window that describes each function however stays even when say continuing onto a new line unless I manually close it, very annoying. Is there anyway of automating that? Or maybe just making it pull up the docs on command rather than automatically with the auto-complete?

Last edited by kc3 (2014-05-23 02:36:14)

Offline

#2 2014-05-22 20:15:35

olantwin
Member
Registered: 2014-05-21
Posts: 28

Re: [Solved] Jedi-Vim Nuisance

Have a look at the FAQ on github: https://github.com/davidhalter/jedi-vim#faq

I think the first question/answer refers to you problem.

autocmd FileType python setlocal completeopt-=preview

This should disable the automatic preview.
To bind it to a command try:

Here are a few more defaults for actions, read the docs (:help jedi-vim) to get more information. If you set them to "", they are not assigned.

(also from the github readme).

Sorry for bumping this topic, if you managed to solve it on your own by now.

Offline

#3 2014-05-23 02:35:56

kc3
Member
Registered: 2012-02-24
Posts: 32

Re: [Solved] Jedi-Vim Nuisance

I did but that's quiet alright, maybe someone else will see the post and find it useful, thanks for the response though

Last edited by kc3 (2014-05-23 02:36:33)

Offline

Board footer

Powered by FluxBB