You are not logged in.

#1 2014-05-15 12:59:22

alex3772
Member
Registered: 2013-10-18
Posts: 4

[solved] Firefox 29.0.1 missing dependency for glibc

Hi!

I am holding back on kernel upgrades for now because of https://bugzilla.kernel.org/show_bug.cgi?id=68761 .

Therefore i have an old glibc.

When i try to start firefox 29.0.1 i get the following error message:

XPCOMGlueLoad error for file /usr/lib/firefox/libxul.so:
/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib/firefox/libxul.so)
Couldn't load XPCOM.

I think this means firefox requires a newer glibc but the firefox package itslef has no dependency to any version of glibc.

Is this correct/should the dependency be added?

Last edited by alex3772 (2014-05-15 13:47:35)

Offline

#2 2014-05-15 13:42:58

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,984

Re: [solved] Firefox 29.0.1 missing dependency for glibc

No. Arch generally only does versioned deps when there is more than one version available in the repos. There are exceptions, but this is not one of them.

Partial upgrades are not supported. You're on your own.

Offline

#3 2014-05-15 13:47:14

alex3772
Member
Registered: 2013-10-18
Posts: 4

Re: [solved] Firefox 29.0.1 missing dependency for glibc

ok, thank you!

downgrade worked for me anyway, just wanted to ask.

Offline

#4 2014-05-15 14:35:23

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: [solved] Firefox 29.0.1 missing dependency for glibc

The kernel is pretty self-contained, so you should be able to stick to one kernel version without holding back glibc.

Offline

Board footer

Powered by FluxBB