You are not logged in.

#1 2014-05-16 12:54:14

arch_on_pi
Member
Registered: 2014-05-16
Posts: 3

[Solved] Apache: undefined symbol: ap_cache_cacheable_headers_in

Hello Archers,

while editing I found the solution for my Problem. I still want to post, so that the solution is easier to spot.

I'm was trying to install Apache with SSL. However it threw this error message:


# apachectl graceful
httpd: Syntax error on line 92 of /etc/httpd/conf/httpd.conf: Cannot load modules/mod_cache_socache.so into server: /etc/httpd/modules/mod_cache_socache.so: undefined symbol: ap_cache_cacheable_headers_in

I used the settings suggested on these pages: (later on I want to host a repo, but for now I want the Apache to start)
https://wiki.archlinux.org/index.php/LAMP
https://wiki.archlinux.org/index.php/Subversion_Setup

I have searched the webs for solutions and found this one:
http://evanthika.blogspot.de/2010/07/ho … -text.html

uncommenting the Line in the httpd.conf

LoadModule cache_module /usr/lib/apache2/modules/mod_cache.so

helped a lot.

I followed the  two tutorials closely. I don't know if these errors happen with my specific configuration (rhapsberry pi) or if these are general issues. Perhaps updating the wiki would help newbies like me. If someone can confirm this problem, I will update the relevant wiki article.

Thank you

arch on pi

Offline

#2 2014-06-05 10:42:09

geekinthesticks
Member
From: England
Registered: 2011-09-21
Posts: 131
Website

Re: [Solved] Apache: undefined symbol: ap_cache_cacheable_headers_in

Thanks for posting that solution. I have just had the exact same problem configuring a Linode server. Uncommenting:

LoadModule cache_module /usr/lib/apache2/modules/mod_cache.so

fixed it for me.

Offline

Board footer

Powered by FluxBB