You are not logged in.

#1 2014-05-19 20:29:18

Registered: 2013-11-16
Posts: 13

Lid switch not detected after suspend - Thinkpad X1 Carbon

I got a new 2nd gen Thinkpad X1 Carbon and installed Arch Linux on it. Almost everything's great, except for some minor issues and one major issue:
Whenever I open the lid after I have closed it before for sleep mode, the laptop does not wake up.

As the laptop does not return form sleep, I cannot check /proc/acpi/button/lid/LID/state when I enable sleep on closing the lid.
If I disable sleep on closing the lid,
after opening the lid:

cat /proc/acpi/button/lid/LID/state outputs
state:      open

after closing the lid:

state:      closed

Unfortunately, I have not found any other way of waking up, as the only other way of triggering wake up is SLPB, which is Fn + ESC and Fn does not work for the 2nd gen X1 Carbon (compare The other devices listed in /proc/acpi/wakeup are unknown to me. If you can please point out, what the devices are, I might be able to provide you with more information, potentially on the lid state after waking up:

localhost:tmp:% cat /proc/acpi/wakeup
Device  S-state   Status   Sysfs node
LID       S4    *enabled
SLPB      S3    *enabled
IGBE      S4    *enabled   pci:0000:00:19.0
EXP2      S4    *disabled  pci:0000:00:1c.1
XHCI      S3    *enabled   pci:0000:00:14.0
EHC1      S3    *enabled   pci:0000:00:1d.0

Basically, the symptoms are similar to

Kernel: 3.14.4-1-Arch

I followed the instructions in the referenced thread and installed the patched kernel linux-samsung-netbook, but the system still does not return from sleep mode.

Last edited by hanslovsky (2014-05-19 20:30:52)


#2 2014-06-07 05:46:37

From: Nice, France
Registered: 2013-12-10
Posts: 12

Re: Lid switch not detected after suspend - Thinkpad X1 Carbon


If you think this bug hasn't been solved already, please send an email to the kernel acpi team at this address:, or create a bug report at, specifying ACPI in the category as I did for my Samsung laptop. They will help you finding the origin of the issue and might be able to create a patch very quickly.

As a temporary solution, you can disable the lid switch detection. If you are using systemctl-logind (the default in archlinux), add this line to /etc/systemd/logind.conf:


Otherwise, if you are using the power manager of your desktop environment (KDE, Gnome, Xfce), configure it to disable the lid switch detection.



#3 2014-06-08 22:41:59

Registered: 2013-11-16
Posts: 13

Re: Lid switch not detected after suspend - Thinkpad X1 Carbon

supposedly, a BIOS update will work: … 5#p1403075
(This might be considered solved then, I did not test it yet, though).

Unfortunately, I have not had a lot of time recently, and my first try on updating the BIOS failed, as somehow my FreeDOS USB was not bootable. I will try again soon.

For now I am following the advice of disabling lid switch detection, thank you for your advice!


Board footer

Powered by FluxBB