You are not logged in.

#1 2014-05-22 14:09:42

metak
Member
Registered: 2009-09-27
Posts: 115

Deepin Desktop Environment on Arch

I've finnaly made it work on my arch! :-)

Here are my PKGBUILD files and repo for most of the packages if anyone is interested.

First things first...
- I'm using "compiz-ubuntu" from unity-for-arch repo because "deepin-compiz" still needs old boost (1.53) version...

OF COURSE THE USUAL WARNINGS APPLY:  IT WILL EAT YOUR CAT, HAMSTER... BLAHBLAH  :-)

[home_metakcahura_arch-deepin_Arch_Extra]
SigLevel = Never
Server = http://download.opensuse.org/repositories/home:/metakcahura:/arch-deepin/Arch_Extra/$arch
#Server = http://anorien.csc.warwick.ac.uk/mirrors/download.opensuse.org/repositories/home:/metakcahura:/arch-deepin/Arch_Extra/$arch

And some obligatory screenshots... (those are "deepin-movie" player and deepin-terminal below... btw)

001.png 002.png 003.png


UPDATE: After contacting FaSheng (one of the developers on Deepin team) and showing him the current progress I made, he pointed out that I forgot to add python2 to makedepends and that's why those packages wouldn't build (startdde and deepin-desktop-environment). Now, they're all in OBS repo and available for testing.

Last edited by metak (2014-05-26 01:46:53)

Offline

#2 2014-05-22 16:21:03

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: Deepin Desktop Environment on Arch

Great work! I'm really surprised Deepin has moved on to be more Mac-like. The earlier version pretty much resembled Windows 7, even down to the Display Settings dialog.

Offline

#3 2014-05-26 01:44:23

metak
Member
Registered: 2009-09-27
Posts: 115

Re: Deepin Desktop Environment on Arch

blackout23 wrote:

Great work! I'm really surprised Deepin has moved on to be more Mac-like. The earlier version pretty much resembled Windows 7, even down to the Display Settings dialog.

It might seem Mac-like at first sight because of the dock, but that's where all similarities end. Deepin dock has full-screen launcher, quick launch and taskbar in one, new widgets to show mounted media, volume control, docker to show system tray icons, clock and trash...

They also added new control center (on the right side of the screen in previous screenshot)...

New animated login screen... +++ many new things.

UPDATE: After contacting FaSheng (one of the developers on Deepin team) and showing him the current progress I made, he pointed out that I forgot to add python2 to makedepends and that's why those packages wouldn't build (startdde and deepin-desktop-environment). Now, they're all in OBS repo and available for testing. :-)

Offline

#4 2014-05-26 11:42:39

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,147
Website

Re: Deepin Desktop Environment on Arch

Ooh, looks pretty neat. I have my hands full right now, but it boredom prevails, I might give it a whirl.


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

#5 2014-05-26 11:52:05

rAX
Member
From: Algiers
Registered: 2011-05-27
Posts: 85

Re: Deepin Desktop Environment on Arch

I'm installing it right now, thank you so much!

Installed deepin-movie at first and it gave me:

Traceback (most recent call last):
  File "/usr/bin/deepin-movie", line 47, in <module>
    from window import Window
  File "/usr/share/deepin-movie/window.py", line 24, in <module>
    from PyQt5 import QtGui, QtCore, QtQuick
ImportError: libQt5Quick.so.5: cannot open shared object file: No such file or directory

Offline

#6 2014-05-26 12:11:22

rAX
Member
From: Algiers
Registered: 2011-05-27
Posts: 85

Re: Deepin Desktop Environment on Arch

Another issue: sad

 
error: failed retrieving file 'golang-graphics-go-0.0~git20140306-1-x86_64.pkg.tar.xz' from download.opensuse.org : Maximum file size exceeded
warning: failed to retrieve some files
error: failed retrieving file 'go-xgbutil-1~git20140312+800bc6fc-2-x86_64.pkg.tar.xz' from download.opensuse.org : Maximum file size exceeded
warning: failed to retrieve some files
error: failed retrieving file 'golang-sqlite3-0.0~git20140226-1-x86_64.pkg.tar.xz' from download.opensuse.org : Maximum file size exceeded

I cleared the cache and I'm trying again.

Offline

#7 2014-05-26 12:40:13

VenomGameworld
Member
Registered: 2009-07-12
Posts: 36

Re: Deepin Desktop Environment on Arch

I thought Deepin was GTK-based, but now I see Deepin-Movie uses QT?

Offline

#8 2014-05-26 21:05:05

metak
Member
Registered: 2009-09-27
Posts: 115

Re: Deepin Desktop Environment on Arch

rAX wrote:

I'm installing it right now, thank you so much!

Installed deepin-movie at first and it gave me:

Traceback (most recent call last):
  File "/usr/bin/deepin-movie", line 47, in <module>
    from window import Window
  File "/usr/share/deepin-movie/window.py", line 24, in <module>
    from PyQt5 import QtGui, QtCore, QtQuick
ImportError: libQt5Quick.so.5: cannot open shared object file: No such file or directory

Install 'qt5-declarative' or just sync and update 'deepin-movie' and you should have it.

Offline

#9 2014-05-26 21:06:19

metak
Member
Registered: 2009-09-27
Posts: 115

Re: Deepin Desktop Environment on Arch

rAX wrote:

Another issue: sad

 
error: failed retrieving file 'golang-graphics-go-0.0~git20140306-1-x86_64.pkg.tar.xz' from download.opensuse.org : Maximum file size exceeded
warning: failed to retrieve some files
error: failed retrieving file 'go-xgbutil-1~git20140312+800bc6fc-2-x86_64.pkg.tar.xz' from download.opensuse.org : Maximum file size exceeded
warning: failed to retrieve some files
error: failed retrieving file 'golang-sqlite3-0.0~git20140226-1-x86_64.pkg.tar.xz' from download.opensuse.org : Maximum file size exceeded

I cleared the cache and I'm trying again.

If download.opensuse.org gives you troubles just use the alternative mirror I've posted in my first post. :-)

Offline

#10 2014-05-26 21:11:43

rAX
Member
From: Algiers
Registered: 2011-05-27
Posts: 85

Re: Deepin Desktop Environment on Arch

metak wrote:
rAX wrote:

I'm installing it right now, thank you so much!

Installed deepin-movie at first and it gave me:

Traceback (most recent call last):
  File "/usr/bin/deepin-movie", line 47, in <module>
    from window import Window
  File "/usr/share/deepin-movie/window.py", line 24, in <module>
    from PyQt5 import QtGui, QtCore, QtQuick
ImportError: libQt5Quick.so.5: cannot open shared object file: No such file or directory

Install 'qt5-declarative' or just sync and update 'deepin-movie' and you should have it.

Yeah, I figured it out. I just wanted you to know. smile

But After installing deepin-desktop-environment, I login from GDM and it freezes, nothing happen. sad

Offline

#11 2014-05-26 21:44:33

rAX
Member
From: Algiers
Registered: 2011-05-27
Posts: 85

Re: Deepin Desktop Environment on Arch

BTW, same problem with 2nd server (less broken files though):

:: File /var/cache/pacman/pkg/go-xgb-0~git+defcb6d44-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (checksum)).
Do you want to delete it? [Y/n]

Offline

#12 2014-05-26 23:39:35

dodgejcr
Member
Registered: 2014-05-26
Posts: 11

Re: Deepin Desktop Environment on Arch

Nice! Thank you. I have been trying to build this for the last month or so then they updated. Having a few issues. One of which is when I try to start dde-control-center. Output as follows.

QQmlComponent: Component is not ready
file:///usr/share/dde-control-center/frame/views/Main.qml:67 Type PanelWindow unavailable
file:///usr/share/dde-control-center/frame/views/PanelWindow.qml:132 Type PanelContent unavailable
file:///usr/share/dde-control-center/frame/views/PanelContent.qml:249 Type HeaderArea unavailable
file:///usr/share/dde-control-center/frame/views/HeaderArea.qml:49 Type DRoundImage unavailable
file:///usr/lib/qt/qml/Deepin/Widgets/DRoundImage.qml:2 module "QtGraphicalEffects" is not installed

Any ideas on what I am missing?

Offline

#13 2014-05-27 00:19:40

metak
Member
Registered: 2009-09-27
Posts: 115

Re: Deepin Desktop Environment on Arch

rAX wrote:

Yeah, I figured it out. I just wanted you to know. smile

But After installing deepin-desktop-environment, I login from GDM and it freezes, nothing happen. sad

I haven't tried it with GDM so I don't know... can you try installing lightdm from this repo that has greeter set to lightdm-deepin-greeter? It works for me that way.

systemctl start lightdm    and I get that fancy animation. smile

BTW many packages have been updated and rebuilt. wink  OBS has some weird tricks and when it rebuilds package the service file automatically sets the version in PKGBUILD which is great in theory and works for most part, BUT the problem is when version doesn't change and package is just rebuilt, it doesn't do pkgrel bumps which would trigger update. Not that I know anyway... That's why you're getting those errors about downloaded packages. Removing the old package in /var/cache/pacman/pkg and re-downloading fixes this issue in most cases if the OBS mirrors are synced.

Last edited by metak (2014-05-27 00:26:01)

Offline

#14 2014-05-27 00:22:53

metak
Member
Registered: 2009-09-27
Posts: 115

Re: Deepin Desktop Environment on Arch

dodgejcr wrote:

Any ideas on what I am missing?

I've added 'qt5-graphicaleffects' to depends and rebuilt the 'dde-control-center'.

pacman -S deepin compiz-ubuntu

Should get you everything you need. smile

... and if you want already configured lightdm from this repo, do:

pacman -S home_metakcahura_arch-deepin_Arch_Extra/lightdm deepin compiz-ubuntu

Last edited by metak (2014-05-27 00:51:36)

Offline

#15 2014-05-27 01:37:57

dodgejcr
Member
Registered: 2014-05-26
Posts: 11

Re: Deepin Desktop Environment on Arch

metak wrote:

I've added 'qt5-graphicaleffects' to depends and rebuilt the 'dde-control-center'.

I re-synced and reinstalled every package now. It somehow got worse lol. I still get the same qmlcomponent error on dde-control-center, and now to add to it. I have strange graphic glitches across the board (compiz related I believe) where It seems I do not have a decoration around windows that are deepin native. Finally the last thing I noticed is the side panel with configurations seems to be gone now.

I'd like to help you figure out what is causing my issues so you can get these packages fit for stable. Let me know what I can do

Offline

#16 2014-05-27 03:06:50

metak
Member
Registered: 2009-09-27
Posts: 115

Re: Deepin Desktop Environment on Arch

dodgejcr wrote:

I re-synced and reinstalled every package now. It somehow got worse lol. I still get the same qmlcomponent error on dde-control-center, and now to add to it. I have strange graphic glitches across the board (compiz related I believe) where It seems I do not have a decoration around windows that are deepin native. Finally the last thing I noticed is the side panel with configurations seems to be gone now.

I'd like to help you figure out what is causing my issues so you can get these packages fit for stable. Let me know what I can do

These packages are built straight from github so you can forget about them being 'stable'.  smile
They're adding and modifying lots of things code related and otherwise, so, it's necessary to also keep updating pkgbuild files for changes in packaging.

I've made some modifications to dde-control-center pkgbuild and also triggered update for some other packages. Can you try now?

Last edited by metak (2014-05-27 03:07:35)

Offline

#17 2014-05-27 09:41:59

Archer1X
Member
From: Astral World
Registered: 2013-01-31
Posts: 27
Website

Re: Deepin Desktop Environment on Arch

Can you tell me how can I start this DE using xinitrc?


Arch Linux all the way..

Offline

#18 2014-05-27 09:52:54

metak
Member
Registered: 2009-09-27
Posts: 115

Re: Deepin Desktop Environment on Arch

Archer1X wrote:

Can you tell me how can I start this DE using xinitrc?

exec startdde

in .xinitrc should do the trick. smile

Offline

#19 2014-05-27 10:05:01

Archer1X
Member
From: Astral World
Registered: 2013-01-31
Posts: 27
Website

Re: Deepin Desktop Environment on Arch

This is the error that I get when I tried to install:

error: failed to commit transaction (conflicting files)
/usr/lib/go/bin exists in both 'go' and 'go-dlib'
Errors occurred, no packages were upgraded.

Is there anything that I can do?


Arch Linux all the way..

Offline

#20 2014-05-27 14:13:08

rAX
Member
From: Algiers
Registered: 2011-05-27
Posts: 85

Re: Deepin Desktop Environment on Arch

OK, I'll try again. Just a heads up, you seem to have missed some dependencies for deepin-movies : deepin-ui deepin-menu deepin-qml-widgets qt5-multimedia qt5-webkit qt5-graphicaleffects
and a daemon (not sure yet if `dde-daemon` or `deepin-gnome-settings-daemon`

Offline

#21 2014-05-27 15:18:11

metak
Member
Registered: 2009-09-27
Posts: 115

Re: Deepin Desktop Environment on Arch

@Archer1X

Already fixed it...

@rAX

Thanx, already added and packages are rebuilding... I've removed 'deepin-gnome-settings-daemon' from repo and rebuilt packages to use gnome-settings-daemon from extra repo.
When you find others just post them here.  smile

Last edited by metak (2014-05-27 15:18:56)

Offline

#22 2014-05-27 16:25:51

rAX
Member
From: Algiers
Registered: 2011-05-27
Posts: 85

Re: Deepin Desktop Environment on Arch

Okay, I seem to have advanced a little. Now I can start the greeter and log in to what looks like a Deepin desktop. But both have problems:

1- LightDM: https://dl-web.dropbox.com/get/Public/I … hthOdwockQ

2- Desktop: https://dl-web.dropbox.com/get/Public/I … PBLjau1E7g

???

Offline

#23 2014-05-27 18:52:11

metak
Member
Registered: 2009-09-27
Posts: 115

Re: Deepin Desktop Environment on Arch

rAX wrote:

Okay, I seem to have advanced a little. Now I can start the greeter and log in to what looks like a Deepin desktop. But both have problems:

1- LightDM: https://dl-web.dropbox.com/get/Public/I … hthOdwockQ

2- Desktop: https://dl-web.dropbox.com/get/Public/I … PBLjau1E7g

???

I get Error (403) on both of those links?

Offline

#24 2014-05-27 18:56:26

rAX
Member
From: Algiers
Registered: 2011-05-27
Posts: 85

Offline

#25 2014-05-27 20:20:56

dodgejcr
Member
Registered: 2014-05-26
Posts: 11

Re: Deepin Desktop Environment on Arch

metak wrote:

These packages are built straight from github so you can forget about them being 'stable'.  smile
They're adding and modifying lots of things code related and otherwise, so, it's necessary to also keep updating pkgbuild files for changes in packaging.

I've made some modifications to dde-control-center pkgbuild and also triggered update for some other packages. Can you try now?

Ive been trying forever to use this DE mainly because it wasnt an easy install. I love the challenge and cant quit until I get it right. Its still not working but tonight I will tear into some of the PKGBUILDs to see if there is something I can get working proper. Ill let you know if I find anything. Cheers and thank you for all you have done so far!

Offline

Board footer

Powered by FluxBB