You are not logged in.

#1 2003-11-19 19:03:17

Guest
Guest

Neomagic 256 ZX with kernel 2.6

I'm using Archlinux current with 2.6test9 kernel on a Dell Latitude CPi R 400gt that is a notebook equipped with on board Neomagic 256ZX audio device.

I tried that with OSS and ALSA modules.
The card works as I can see it in kernel messages, but it works horribly when playing mp3s or other audio files. Mp3 plays like if they're bad ripped. The sound isn't fluid. It keeps on jumping ,like if you have a scratched cd.. (don't know how to explain better in english)

I tried also to change prebuffering percentage in xmms, but without any good result.

What could be the problem?

(when I bought the notebook it was running windows 98 and sound did work well)

These are kernel messages as I load modules snd_es1371 and snd_nm256:

ZX audio driver, version 1.1p
PCI: Enabling device 0000:01:00.1 (0000 -> 0002)
NM256: Found card signature in video RAM: 0x3fec00
NM256: Mapping port 1 from 0x3e6c00 - 0x3fec00
Initialized NeoMagic 256ZX audio in PCI native mode
Initialized AC97 mixer

#2 2003-11-19 21:02:08

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Neomagic 256 ZX with kernel 2.6

Just as a test, try playing the music with mplayer (mplayer <file.mp3>).  I know with my laptop (and no alsa) I can only play 48khz sounds, it doesn't do the resampling in hardware.

That could be the same problem here.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#3 2003-11-20 12:01:44

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: Neomagic 256 ZX with kernel 2.6

Hi,

please try playing with xine-player. If you tweak the settings like this:
configuration expierience level to: expert (at least)
apply
audio: forcerate to 48000
apply

if this plays appropriate than you can try to tweak your alsa settings:
create a new file with root privileges /etc/asound.conf

pcm.!default {
    type plug
    slave sl2
}
ctl.!default {
    type hw
    card 0
}
pcm_slave.sl2 {
    pcm "hw:0,0"
    rate 48000
}

than your alsa sound will always be resampled to 48kHz by the driver

HTH
neri

Offline

Board footer

Powered by FluxBB