You are not logged in.

#1 2014-05-27 06:42:30

wchouser3
Member
From: Indiana USA
Registered: 2013-08-13
Posts: 157
Website

xfce power manager settings ignored

I’m starting to think ths is a bug, but given the fact that I’ve gotten no response about this problem, it’s makes me a little un-easy.

For at least a year now, the setting relevent to what to do when the laptop battery reaches it’s critical level is ignored completely. No matter what setting you use, the battery willl drain to the value dictated by the /etc/upower/upower.conf file, it will then go into a “hybrid sleep” mode. But this is only where it begins to get weird. About 7 or 8 seconds after going into the hybrid-sleep mode, the system wakes it’s self back up, then runs until the battery is completely drained. Changing any setting relevent to this in the Xfce power manager is ineffectual. Changing other settings in the Xfce power manager work just fine. It’s just those settings that are supposed to control critical battery option that are ignored.

I remember some time back when Upower upgraded, there was the news that the suspend, hybernate, and shutdown functionality of Upower had been depricated. It got me to wondering if Xfce power manager relied on Upower to execute those commands, thus causing the bug that I’m experiencing. It’s been over a year and the same condition exists.

Of several things I tried, one was to remove the xml file in the dbus folder that starts the Upower service, but that created more problems than it solved. I was however satisfied with the hack once I had installed laptop-mode-tools, and got that configured right. It still seemed clunky. I was satisfied until I set up the battery monitor panel plugin to issue the command: “systemctl suspend” when my battery got down to 2% power, only to see it re-start it’s self again after about 7 or 8 seconds.

Alas, it seems as though I’m experiencing two related problems though not easily addressed by one single fix. I think things should work properly. I want Xfce power manager’s setting obeyed, and I don’t want the machine waking it’s self up without me telling it to.

Please Help

Thank you


If you can't be helpful, don't say anything at all. Fair enough?

Offline

#2 2014-05-28 17:53:04

ooo
Member
Registered: 2013-04-10
Posts: 1,607

Re: xfce power manager settings ignored

If I understand correctly hibernating, suspending etc. with upower is deprecated because it's more logical to use systemd+logind+polkit combination to achieve that capability for non-root users. However upower is still used for other power management tasks and if I'm not mistaken monitoring battery levels and doing hibernating on critical level would be one of those tasks.

Have you tried changing the "CriticalPowerAction=" in /etc/UPower/UPower.conf to something else than HybridSleep?

Offline

#3 2014-05-28 19:52:28

wchouser3
Member
From: Indiana USA
Registered: 2013-08-13
Posts: 157
Website

Re: xfce power manager settings ignored

ooo wrote:

If I understand correctly hibernating, suspending etc. with upower is deprecated because it's more logical to use systemd+logind+polkit combination to achieve that capability for non-root users. However upower is still used for other power management tasks and if I'm not mistaken monitoring battery levels and doing hibernating on critical level would be one of those tasks.

Have you tried changing the "CriticalPowerAction=" in /etc/UPower/UPower.conf to something else than HybridSleep?

Actually I think Hibernate, and Shutdown is depricated. No matter what setting you use, it defaults to HybridSleep. I wish they would have deprecated all three. The other settings in the Upower config file are obeyed (percentage, etc.) I've tried commenting out the lines, setting them to 0 and everything. Letting the system suspend at low battery power just doesn't work any-more for some reason. The machine always wakes it's self right back up. Now, suspending either with systemd, or with the simple "suspend" command manually works just fine. It's only when the command is executed at critical battery level, the machine wakes it's self back up after 7 or 8 seconds.


If you can't be helpful, don't say anything at all. Fair enough?

Offline

#4 2014-05-28 20:20:34

ooo
Member
Registered: 2013-04-10
Posts: 1,607

Re: xfce power manager settings ignored

wchouser3 wrote:

Actually I think Hibernate, and Shutdown is depricated. No matter what setting you use, it defaults to HybridSleep.

I'm using gnome which definitely uses upower, and at least Hibernate works work me on critical battery level. I don't even have a option for hybridsleep in gnome settings

Offline

#5 2014-05-28 21:11:08

wchouser3
Member
From: Indiana USA
Registered: 2013-08-13
Posts: 157
Website

Re: xfce power manager settings ignored

ooo wrote:
wchouser3 wrote:

Actually I think Hibernate, and Shutdown is depricated. No matter what setting you use, it defaults to HybridSleep.

I'm using gnome which definitely uses upower, and at least Hibernate works work me on critical battery level. I don't even have a option for hybridsleep in gnome settings

Yea...that's the strange thing. Although Upower is a dependency of Xfce4-session, it's not a dependency of Xfce4-power-manager. Xfce4-power-manager has no hybrid-sleep option either, but no matter what you set it on, that's what you get.


If you can't be helpful, don't say anything at all. Fair enough?

Offline

Board footer

Powered by FluxBB