You are not logged in.

#1 2014-06-03 14:24:05

rusty725
Member
Registered: 2014-02-16
Posts: 82

[WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

Did an update today and system is half usable now, every other apps is not opening Im getting this

 leafpad[726]: segfault at 7fff37c71fe8 ip 00007faf425230ff sp 00007fff37c71ff0 error 6 in libc-2.19.so[7faf424b9000+1a4000]"
systemd-journald[190]: Failed to write entry (26 items, 37929567 bytes) despite vacuuming, ignoring: Argument list too long
[  198.872476] systemd-journald[190]: Deleted empty journal /var/log/journal/83ce0cb99a864d9384c0ec864b8b7cf3/user-620@6896673038ee45df8bbec39840456067-0000000000000000-0000000000000000.journal (6557696 bytes) 

Tried rolling back kernel without luck.

cpu 3930k
ram 16gb
gpu evga 670gtx
mobo asus rampage iv gene
/ - 256gb ssd /home 1tb hdd

Last edited by rusty725 (2014-06-07 02:54:49)

Offline

#2 2014-06-03 14:27:11

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,758

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

That's leafpad segfaulting, not journald.

Online

#3 2014-06-03 14:29:00

rusty725
Member
Registered: 2014-02-16
Posts: 82

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

not only leafpad, I get this with chromium, checkgmail, skype, gns3

Offline

#4 2014-06-03 14:44:06

rusty725
Member
Registered: 2014-02-16
Posts: 82

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

that's what got upgraded

[2014-06-03 03:15] [PACMAN] upgraded clutter-gst (2.0.10-2 -> 2.0.12-1)
[2014-06-03 03:15] [PACMAN] upgraded ffmpeg (1:2.2.2-3 -> 1:2.2.3-1)
[2014-06-03 03:15] [PACMAN] upgraded gdk-pixbuf2 (2.30.7-1 -> 2.30.8-1)
[2014-06-03 03:15] [PACMAN] upgraded gedit (3.12.1-1 -> 3.12.2-1)
[2014-06-03 03:15] [PACMAN] upgraded gmime (2.6.20-1 -> 2.6.20-2)
[2014-06-03 03:15] [PACMAN] upgraded gnome-calculator (3.12.1-1 -> 3.12.2-1)
[2014-06-03 03:15] [PACMAN] upgraded gnome-icon-theme-symbolic (3.12.0-1 -> 3.12.0-2)
[2014-06-03 03:15] [PACMAN] upgraded gnome-icon-theme (3.12.0-1 -> 3.12.0-2)
[2014-06-03 03:15] [PACMAN] upgraded json-glib (1.0.0-1 -> 1.0.2-1)
[2014-06-03 03:15] [PACMAN] upgraded libatasmart (0.19-2 -> 0.19-3)
[2014-06-03 03:15] [PACMAN] upgraded libgdata (0.15.0-1 -> 0.15.1-1)
[2014-06-03 03:15] [PACMAN] upgraded libinput (0.1.0-1 -> 0.2.0-1)
[2014-06-03 03:15] [PACMAN] upgraded libmms (0.6.2-1 -> 0.6.4-1)
[2014-06-03 03:15] [PACMAN] upgraded libxcursor (1.1.14-1 -> 1.1.14-2)
[2014-06-03 03:15] [PACMAN] upgraded linux (3.14.4-1 -> 3.14.5-1)
[2014-06-03 03:15] [PACMAN] upgraded linux-headers (3.14.4-1 -> 3.14.5-1)

Offline

#5 2014-06-03 14:54:15

rusty725
Member
Registered: 2014-02-16
Posts: 82

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

ok problem found it. it's libxcursor 1.1.14-2 , downgrade it
cd /var/cache/pacman/pkg/
sudo pacman -U libxcursor-1.1.14-1-x86_64.pkg.tar.xz

Last edited by rusty725 (2014-06-03 15:11:14)

Offline

#6 2014-06-03 15:21:47

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,758

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

Online

#7 2014-06-03 15:24:55

rusty725
Member
Registered: 2014-02-16
Posts: 82

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

thank you for reporting this I still need to create an account there. the other person in antergos forums had the same issue.

Offline

#8 2014-06-04 00:59:30

twelveeighty
Member
From: Alberta, Canada
Registered: 2011-09-04
Posts: 638

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

Why is this thread marked [solved]? I don't see a resolution to the bug yet? Or are we simply stating with [solved] that a bug report was created?

Offline

#9 2014-06-04 03:16:21

rusty725
Member
Registered: 2014-02-16
Posts: 82

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

twelveeighty wrote:

Why is this thread marked [solved]? I don't see a resolution to the bug yet? Or are we simply stating with [solved] that a bug report was created?

solved cause you can rollback at least that's why.

Offline

#10 2014-06-04 04:14:45

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,413

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

rusty725 wrote:

solved cause you can rollback at least that's why.

Yeah... that's not really a solution.  It is a temporary workaround, but certainly not a solution.

Offline

#11 2014-06-04 15:47:46

psycho
Member
Registered: 2013-04-26
Posts: 29

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

Downgraded to 1.1.14-1 and the problem persists. I can't use rxvt, weechat, and maybe other packages too.

~ > pacaur -Qs libxcursor
local/lib32-libxcursor 1.1.14-1
    X cursor management library (32-bit)
local/libxcursor 1.1.14-1
    X cursor management library

~ > grep 2014-06-03 /var/log/pacman.log
[2014-06-03 15:52] [PACMAN] Running 'pacman -Syy'
[2014-06-03 15:52] [PACMAN] synchronizing package lists
[2014-06-03 15:55] [PACMAN] Running 'pacman -S -u'
[2014-06-03 15:55] [PACMAN] starting full system upgrade
[2014-06-03 15:56] [PACMAN] upgraded ffmpeg (1:2.2.2-3 -> 1:2.2.3-1)
[2014-06-03 15:56] [PACMAN] upgraded gdk-pixbuf2 (2.30.7-1 -> 2.30.8-1)
[2014-06-03 15:56] [PACMAN] upgraded gnome-icon-theme-symbolic (3.12.0-1 -> 3.12.0-2)
[2014-06-03 15:56] [PACMAN] upgraded gnome-icon-theme (3.12.0-1 -> 3.12.0-2)
[2014-06-03 15:56] [PACMAN] upgraded gpgme (1.4.3-1 -> 1.5.0-1)
[2014-06-03 15:56] [PACMAN] upgraded json-glib (1.0.0-1 -> 1.0.2-1)
[2014-06-03 15:56] [PACMAN] upgraded lftp (4.5.0-1 -> 4.5.1-1)
[2014-06-03 15:56] [PACMAN] upgraded libmms (0.6.2-1 -> 0.6.4-1)
[2014-06-03 15:56] [PACMAN] upgraded libxcursor (1.1.14-1 -> 1.1.14-2)
[2014-06-03 15:57] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2014-06-03 15:57] [ALPM-SCRIPTLET] >>> Generating initial ramdisk, using mkinitcpio.  Please wait...
[2014-06-03 15:57] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2014-06-03 15:57] [ALPM-SCRIPTLET] ==> Starting build: 3.14.5-1-ARCH
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2014-06-03 15:57] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2014-06-03 15:57] [ALPM-SCRIPTLET] ==> Creating gzip initcpio image: /boot/initramfs-linux.img
[2014-06-03 15:57] [ALPM-SCRIPTLET] ==> Image generation successful
[2014-06-03 15:57] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2014-06-03 15:57] [ALPM-SCRIPTLET] ==> Starting build: 3.14.5-1-ARCH
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2014-06-03 15:57] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2014-06-03 15:57] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: smsmdtv
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2014-06-03 15:57] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2014-06-03 15:57] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2014-06-03 15:57] [ALPM-SCRIPTLET] ==> Creating gzip initcpio image: /boot/initramfs-linux-fallback.img
[2014-06-03 15:57] [ALPM-SCRIPTLET] ==> Image generation successful
[2014-06-03 15:57] [PACMAN] upgraded linux (3.14.4-1 -> 3.14.5-1)
[2014-06-03 15:57] [PACMAN] upgraded mpc (0.25-1 -> 0.26-1)

~ > grep 2014-06-04 /var/log/pacman.log
[2014-06-04 15:30] [PACMAN] Running 'pacman -S -u'
[2014-06-04 15:30] [PACMAN] starting full system upgrade
[2014-06-04 15:30] [PACMAN] upgraded e2fsprogs (1.42.9-2 -> 1.42.10-1)
[2014-06-04 15:30] [ALPM] warning: /etc/passwd installed as /etc/passwd.pacnew
[2014-06-04 15:30] [ALPM] warning: /etc/group installed as /etc/group.pacnew
[2014-06-04 15:30] [PACMAN] upgraded filesystem (2013.05-2 -> 2014.05-2)
[2014-06-04 15:30] [PACMAN] upgraded lib32-libdbus (1.8.0-1 -> 1.8.2-1)
[2014-06-04 15:30] [PACMAN] upgraded libsystemd (212-3 -> 213-5)
[2014-06-04 15:30] [PACMAN] upgraded libatasmart (0.19-2 -> 0.19-3)
[2014-06-04 15:30] [PACMAN] upgraded mercurial (3.0-1 -> 3.0.1-1)
[2014-06-04 15:30] [PACMAN] upgraded python-setuptools (3.6-1 -> 4.0.1-1)
[2014-06-04 15:30] [PACMAN] upgraded python2-setuptools (3.6-1 -> 4.0.1-1)
[2014-06-04 15:30] [PACMAN] upgraded systemd (212-3 -> 213-5)
[2014-06-04 15:30] [PACMAN] upgraded systemd-sysvcompat (212-3 -> 213-5)
[2014-06-04 15:59] [PACMAN] Running 'pacman -Syy'
[2014-06-04 17:29] [PACMAN] synchronizing package lists
[2014-06-04 17:40] [PACMAN] Running 'pacman -S python-httplib2'
[2014-06-04 17:40] [PACMAN] installed python-httplib2 (0.9-2)
[2014-06-04 17:43] [PACMAN] Running 'pacman -S -u'
[2014-06-04 17:43] [PACMAN] starting full system upgrade
[2014-06-04 17:44] [PACMAN] upgraded libwbclient (4.1.7-1 -> 4.1.8-1)
[2014-06-04 17:44] [PACMAN] upgraded cifs-utils (6.2-1 -> 6.3-1)
[2014-06-04 17:44] [PACMAN] upgraded cpupower (3.14-2 -> 3.14-3)
[2014-06-04 17:44] [PACMAN] upgraded libpurple (2.10.9-1 -> 2.10.9-2)
[2014-06-04 17:44] [PACMAN] upgraded finch (2.10.9-1 -> 2.10.9-2)
[2014-06-04 17:44] [PACMAN] upgraded graphviz (2.36.0-2 -> 2.36.0-3)
[2014-06-04 17:45] [PACMAN] upgraded perl (5.18.2-2 -> 5.20.0-2)
[2014-06-04 17:45] [PACMAN] upgraded vim-runtime (7.4.307-3 -> 7.4.307-4)
[2014-06-04 17:45] [PACMAN] upgraded gvim (7.4.307-3 -> 7.4.307-4)
[2014-06-04 17:45] [PACMAN] upgraded imagemagick (6.8.9.1-2 -> 6.8.9.1-3)
[2014-06-04 17:45] [PACMAN] upgraded libproxy (0.4.11-2 -> 0.4.11-3)
[2014-06-04 17:45] [PACMAN] upgraded perl-crypt-openssl-random (0.06-1 -> 0.06-2)
[2014-06-04 17:45] [PACMAN] upgraded perl-html-parser (3.71-2 -> 3.71-3)
[2014-06-04 17:45] [PACMAN] upgraded perl-xml-fast (0.11-4 -> 0.11-5)
[2014-06-04 17:45] [PACMAN] upgraded perl-xml-parser (2.41-4 -> 2.41-5)
[2014-06-04 17:45] [PACMAN] upgraded postgresql-libs (9.3.4-1 -> 9.3.4-2)
[2014-06-04 17:45] [PACMAN] upgraded rxvt-unicode-terminfo (9.20-1 -> 9.20-2)
[2014-06-04 17:45] [PACMAN] upgraded rxvt-unicode (9.20-1 -> 9.20-2)
[2014-06-04 17:45] [PACMAN] upgraded smbclient (4.1.7-1 -> 4.1.8-1)
[2014-06-04 17:45] [PACMAN] upgraded subversion (1.8.9-1 -> 1.8.9-2)
[2014-06-04 17:45] [PACMAN] upgraded weechat (0.4.3-1 -> 0.4.3-2)
[2014-06-04 17:45] [PACMAN] upgraded xfconf (4.10.0-3 -> 4.10.0-4)
[2014-06-04 18:25] [PACMAN] Running 'pacman -U /var/cache/pacman/pkg/libxcursor-1.1.14-1-x86_64.pkg.tar.xz'
[2014-06-04 18:25] [PACMAN] downgraded libxcursor (1.1.14-2 -> 1.1.14-1)

Last edited by psycho (2014-06-04 15:58:49)


~ > fortune
I never met a piece of chocolate I didn't like.

Offline

#12 2014-06-04 18:35:00

Gadileth
Member
Registered: 2013-08-02
Posts: 32

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

Weird. I use the actual package (14-2) and I have no problems at all. Not a single one.

Offline

#13 2014-06-04 20:32:05

7k
Member
Registered: 2014-06-04
Posts: 3

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

I can confirm this bug.

http://postimg.org/image/jp6wj3gwj/

Downgrade to libxcursor-1.1.14-1-x86_64.pkg.tar.xz and everything works again.

Offline

#14 2014-06-05 06:54:49

the7erm
Member
Registered: 2014-06-05
Posts: 2

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

I too had to downgrade using `pacman -U libxcursor-1.1.14-1-x86_64.pkg.tar.xz`

Offline

#15 2014-06-05 07:13:05

the7erm
Member
Registered: 2014-06-05
Posts: 2

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

I moved ~/.icons to ~/.icons.bak and did a pacman -Syu so 14-2 would be installed.
Some stuff stopped crashing, but keepassx had problems. I guess I'm stuck with 14-1

Offline

#16 2014-06-05 13:53:11

plenty
Member
From: Brighton, UK
Registered: 2011-12-07
Posts: 5

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

Also,
"Continue to update your system, ignoring libxcursor 1.1.14-1, by adding libxcursor to the IGNORE list in /etc/pacman.conf"

Credit: 'lots.0.logs', Antergos forum

Offline

#17 2014-06-05 14:17:39

ProtoTech
Member
Registered: 2014-05-31
Posts: 25

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

plenty wrote:

Also,
"Continue to update your system, ignoring libxcursor 1.1.14-1, by adding libxcursor to the IGNORE list in /etc/pacman.conf"

Credit: 'lots.0.logs', Antergos forum

Thanks for this tip, I might actually use this and then and check periodically for libxcursor updates with pacman -Su libxcursor.

Offline

#18 2014-06-05 14:36:06

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 898

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

ProtoTech wrote:
plenty wrote:

Also,
"Continue to update your system, ignoring libxcursor 1.1.14-1, by adding libxcursor to the IGNORE list in /etc/pacman.conf"

Thanks for this tip, I might actually use this and then and check periodically for libxcursor updates with pacman -Su libxcursor.

Actually you will see whether the available update is newer than 1.1.14-2 when just doing the pacman update - which can have the ignored package on the command line, which currently gives for me:

# pacman -Syu --ignore libxcursor
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community                          2.2 MiB  3.32M/s 00:01 [###############################] 100%
:: Starting full system upgrade...
warning: libxcursor: ignoring package upgrade (1.1.14-1 => 1.1.14-2)

If I see that last line move to a later version than 1.1.14-2 then I will just rerun pacman without the --ignore.


Mike C

Offline

#19 2014-06-05 16:48:42

powerpoint45
Member
Registered: 2013-03-06
Posts: 24

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

Would someone be kind enough to upload the libxcursor 1.1.14-1 package? I happened to clear my Pac man cache...


Developer of Lucid Launcher for Android

Offline

#20 2014-06-05 17:04:51

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

powerpoint45 wrote:

Would someone be kind enough to upload the libxcursor 1.1.14-1 package? I happened to clear my Pac man cache...

That what the Arch Rollback Machine is for.
http://seblu.net/a/arm/packages/l/

Offline

#21 2014-06-05 17:09:57

powerpoint45
Member
Registered: 2013-03-06
Posts: 24

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

blackout23 wrote:
powerpoint45 wrote:

Would someone be kind enough to upload the libxcursor 1.1.14-1 package? I happened to clear my Pac man cache...

That what the Arch Rollback Machine is for.
http://seblu.net/a/arm/packages/l/

Thanks I will look into it seblu.net/a/arm/packages/l/libxcursor/

Last edited by powerpoint45 (2014-06-05 18:23:03)


Developer of Lucid Launcher for Android

Offline

#22 2014-06-06 02:22:00

thiagowfx
Member
Registered: 2013-07-09
Posts: 553

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

I cannot reproduce this issue here; I'm using the -2 version. Anything I could do to try to reproduce it?

Offline

#23 2014-06-06 13:10:59

ProtoTech
Member
Registered: 2014-05-31
Posts: 25

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

thiagowfx wrote:

I cannot reproduce this issue here; I'm using the -2 version. Anything I could do to try to reproduce it?

What applications have you tried running? Chromium, Chrome, Hexchat and Guake all would not open.

Offline

#24 2014-06-06 13:35:43

brix
Member
Registered: 2014-05-26
Posts: 68

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

I was getting nothing but death by segfault (libc-2.19.so error 6) when trying to launch libreoffice (with or without the --writer or --calc options) and leafpad. On the other hand gmpc would run normally until I tried to enter a character in a search (text-entry) field, whereupon it would die with the same error.

I'm running Gnome with the default Adwaita cursor theme. Downgrading to libxcursor 1.1.14-1 fixed everything.


Enough is more.

Offline

#25 2014-06-06 16:06:17

thiagowfx
Member
Registered: 2013-07-09
Posts: 553

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

ProtoTech wrote:
thiagowfx wrote:

I cannot reproduce this issue here; I'm using the -2 version. Anything I could do to try to reproduce it?

What applications have you tried running? Chromium, Chrome, Hexchat and Guake all would not open.

Chromium, Thunar.

Apparently the reason this issue isn't affecting me is because I'm using the Human cursor theme (available in the AUR). See the bug report, at least one more user says this is a workaround.

Last edited by thiagowfx (2014-06-06 16:07:16)

Offline

Board footer

Powered by FluxBB