You are not logged in.

#1 2014-06-05 07:54:34

hobarrera
Member
From: CABA, Argentina
Registered: 2011-04-12
Posts: 322
Website

Wierd flickering with latest chromium

I've been having some wierd flickering with the latest chromium.
I get black portions of the screen (including outside the chromium window). I ocasionally get a black i3-statusbar when scrolling with chromium, and the I see a lot of wierd artifacts on the entire screen.

For example, a moment ago, while scrolling a wikipedia article, half of a duckduckgo logo appeared for a moment, though ddg was open on a different tab.

Sometimes when scrolling, I'll see the top of the page overlayed with the current portion (it's not a lagged redraw, since both the current portion and the top portion get overlayed).

Here's another example.
Notice how the tab-bar is black, and the i3-statusbar (at the bottom) is black too.

Screenshots are very hard to capture because it's usually just a couple of frames and at unpredictable intervals. sad

Does anyone else have this issue? I'm suspecting of aura, chromium's new toolkit, but would like to know if I'm the only one.


GPG Key | AUR packages | github

caffeine-ng: Temporarily disable screensaver/sleeping with a simple click.

Offline

#2 2014-06-10 23:19:44

3rt
Member
Registered: 2013-03-07
Posts: 3

Re: Wierd flickering with latest chromium

I've got the same problem. 
It's really weird because the "fragments" are rendered ontop of the xfce bar for example. 
I have no idea what causes those problems. At first I suspected X to have something to do with it then went on and try to test different video drivers because I suspected opengl but without any luck. 

1
2


Are you using an intel grafics card by any chance?

Offline

#3 2014-06-11 01:23:54

CarlEitsger
Member
Registered: 2014-04-06
Posts: 19

Re: Wierd flickering with latest chromium

(Edited) I first thought I may see a related problem due to related timing and symptoms in KDE desktop (not in Chromium). But it maybe isn't ...  Now the text is there: https://bbs.archlinux.org/viewtopic.php?id=182699

Last edited by CarlEitsger (2014-06-11 13:45:10)

Offline

#4 2014-06-11 02:27:25

hobarrera
Member
From: CABA, Argentina
Registered: 2011-04-12
Posts: 322
Website

Re: Wierd flickering with latest chromium

3rt wrote:

I've got the same problem. 
It's really weird because the "fragments" are rendered ontop of the xfce bar for example. 
I have no idea what causes those problems. At first I suspected X to have something to do with it then went on and try to test different video drivers because I suspected opengl but without any luck. 

<snipped images>


Are you using an intel grafics card by any chance?

That's my exact same issue (great job taking the screenshots, they usually last one or two frames and I've found it pretty hard).

Yes, I'm using an Intel HD 5000.


GPG Key | AUR packages | github

caffeine-ng: Temporarily disable screensaver/sleeping with a simple click.

Offline

#5 2014-06-11 07:46:35

struppi
Member
Registered: 2014-06-11
Posts: 2

Re: Wierd flickering with latest chromium

I also have exactly the same problem.

Actually I have no access to the affected computer, but when you start chromium from the terminal you get a message. I did search yesterday after it, but I didn't find a solution.

It's not an urgent problem, since Firefox works as usual, but it's a really strange bug.

Offline

#6 2014-06-11 07:49:55

corner578
Member
Registered: 2012-06-16
Posts: 10

Re: Wierd flickering with latest chromium

You can try

/etc/chromium/default

CHROMIUM_FLAGS="--ignore-gpu-blacklist"

Offline

#7 2014-06-11 10:51:36

hobarrera
Member
From: CABA, Argentina
Registered: 2011-04-12
Posts: 322
Website

Re: Wierd flickering with latest chromium

struppi wrote:

I also have exactly the same problem.

Actually I have no access to the affected computer, but when you start chromium from the terminal you get a message. I did search yesterday after it, but I didn't find a solution.

It's not an urgent problem, since Firefox works as usual, but it's a really strange bug.

I've always prefered firefox too anyway. But when I ocasionally use chromium, it screws up the entire desktop, and that sucks. sad

corner578 wrote:

You can try

/etc/chromium/default

CHROMIUM_FLAGS="--ignore-gpu-blacklist"

It would seem that this fixes it (or the random glitches have simply not shown up simply by coincidence). Are Intel cards blacklisted and this ignores that blacklist?


GPG Key | AUR packages | github

caffeine-ng: Temporarily disable screensaver/sleeping with a simple click.

Offline

#8 2014-06-11 11:30:24

corner578
Member
Registered: 2012-06-16
Posts: 10

Re: Wierd flickering with latest chromium

I don't know. But this help for me on my i7-4702

Offline

#9 2014-06-11 14:06:18

struppi
Member
Registered: 2014-06-11
Posts: 2

Re: Wierd flickering with latest chromium

hobarrera wrote:

I've always prefered firefox too anyway. But when I ocasionally use chromium, it screws up the entire desktop, and that sucks. sad

That's true, but if you don't use chromium then it's ok smile
And I wasn't able to use it with this bug in anyway.

corner578 wrote:

You can try

/etc/chromium/default

CHROMIUM_FLAGS="--ignore-gpu-blacklist"

thanx, I will try it when I have access to the computer with this problem.

EDIT: It works - Thanx!

Last edited by struppi (2014-06-11 18:17:42)

Offline

#10 2014-06-23 16:03:51

ugjka
Member
From: Latvia
Registered: 2014-04-01
Posts: 593

Re: Wierd flickering with latest chromium

I have intel graphics and had something similar happen with Steam aswell. The only fix was to use "AccelMethod"  "glamor" in xorg.conf

Offline

Board footer

Powered by FluxBB