You are not logged in.

#1 2014-06-21 10:55:53

Chazza
Member
From: United Kingdom
Registered: 2013-06-02
Posts: 448

Compiz - GL_EXT_x11_sync_object support: testers needed

Please see post below for details.

Last edited by Chazza (2014-06-23 08:10:32)

Offline

#2 2014-06-22 14:51:00

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

Okay. I fill in the details, since i am using this patch, have talked with it's author [from nvidia] and have also been in touch with some of the involved compiz devs wink

Backstory: For months there has been a patch floating around for compiz that implements the GL_EXT_x11_sync_object extension [OpenGL] into compiz. This patch is intended to fix the nvidia refresh issue / possibly other rendering bugs experienced by nvidia users. [although, if using another driver that supports  GL_EXT_x11_sync_object, you would likely benefit too. It adds the ability to use X11 synchronization fences/objects in Compiz [ and nvidia supports this extension ]. The support is about "deep pipelining" not parallelism, the idea is that you have X number of syncs and by the time we fold back to the beginning Y number of syncs should be flushed and thus 'ready', which should avoid any stalling in compiz. As an aside; the mutter devs have also ported this to their framework.

http://www.opengl.org/registry/specs/EX … object.txt

OpenGL Specification wrote:

Synchronization objects added the ability to better coordinate operations between multiple GL command streams. However, it is desirable to have the same level of coordination between GL command streams and external rendering APIs. This extension introduces two new concepts to build upon the synchronization infrastructure provided by ARB_sync:

1) A means to import an X Synchronization Fence object into the GL and use it as a sync object.

2) The concept of a reusable sync object.

The latter is necessary because the import operation is expensive and performing it every time a synchronization point was reached would make the synchronization prohibitively slow.

This extension stops short of allowing the GL to change the state of imported/reusable sync objects, but does not add any language that would prohibit such functionality from being added in a subsequent extension.

Original LP bug report; https://bugs.launchpad.net/compiz/+bug/269904 ...

Why hasn't this patch been integrated into Compiz???

1). Nvidia released the code as MIT, But Canonical requires CLA for contributions [copyright assignment]. Nvidia wouldn't accept those terms.
2). because of #1 - the patch hasn't really had a whole lot of testng / exposure, aside from a single ppa

Now, since we are on Arch - the CLA/Ubuntu thing is not our problem, thus it would be nice to see to get this code into people's hands and tested. We can then report back issues, [hopefully] get any problems sorted out and possibly be able to carry/use the patch, regardless of Canonical not including it in Compiz. [although, having it tested might help it get into compiz/apply some pressure]. So that all being said, we need some testers smile
__________

TESTING:
__________


I'll provide a compiz package, based on compiz-core-bzr in AUR. Found here; https://www.dropbox.com/s/xryiqlozviwya … src.tar.gz (updated link/package)

There are a few things tester will need to note: First, you will need to start compiz from the commandline for testing [ie: 'compiz --replace ccp' in terminal]

1). I have debug/logging for this patch enabled by default. We need to be able to see if the patch is working or having problems. * but the logging may degrade performance. That being said, you can rebuild the package, without debugging, by commenting/uncommenting the correct patch;

#  msg "applying compiz-nvidia-refresh"
#  patch -Np1 -i "$srcdir/compiz-nvidia-refresh.patch"

  msg "applying compiz-nvidia-refresh_debug.patch - ** DEBUG BUILD - may degrade performance"
  patch -Np1 -i "$srcdir/compiz-nvidia-refresh_debug.patch"

2). The number of x11 sync fences/objects is arbitrary, so it is possible, depending on setup that you may require more syncs. I have also dealt with this in the pkgbuild, via line 88;

  sed -i 's#NUM_X11_SYNCS = 10#NUM_X11_SYNCS = 16#' "${srcdir}/compiz-nvidia-refresh.patch"

...in the patch the default is 10. I have up'd it to 16. [so has the compiz dev in his package]. So, if you happen to get messages like this;

compiz (opengl) - Info: Initializing sync objects
compiz (opengl) - Warn: We should never wait for a sync -- add more syncs?
compiz (opengl) - Error: Timed out waiting for sync object.
compiz (opengl) - Info: Destroying sync objects
compiz (opengl) - Info: Initializing sync objects
compiz (opengl) - Error: glClientWaitSync failed
compiz (opengl) - Error: Timed out waiting for sync object.
compiz (opengl) - Info: Destroying sync objects

... then you could try increasing the NUM_X11_SYNCS value. Myself, I had to increase them + disable some logging before the patch stabilized for me.

3). You should also open CCSM and do two things; Navigate to "General  Options"->"Focus and Raise Behavior" and disable "auto-raise" [it was causing problems for me/with this patch]. Next, Navigate to "Workarounds" section and disable "force synchronization between X and GLX" [and make sure that "OpenGL" section in CCSM has "X11 Sync Objects" enabled.]

---

Reporting tests:  You can report back your findings in this thread, but if you are on Launchpad - you can also report back in a couple of places;

nvidia refresh bug - https://bugs.launchpad.net/compiz/+bug/269904

or file a bug against and/or contact Chris from this branch on LP; https://launchpad.net/~townsend/+archiv … fresh-test

otherwise, any issues reported here - I will take to the concerned parties, personally.

---

If this patched-compiz is stable for you - then you can rebuild it for 'production', rebuilding with the non-debug compiz nvidia-refresh.patch


** but please make sure to report back, before disabling logging.

cheerz

EDIT: Note the below bunch of comments were myself and a user working out some initial issues [one in my packaging], then the next getting compiz + config working for him. My PKGBUILD should be fine now for testing and i have updated the link/instructions/pkgbuild. - sorry for any inconvenience.

Last edited by triplesquarednine (2014-06-24 00:30:59)

Offline

#3 2014-06-23 17:23:19

thedeli
Member
Registered: 2010-02-14
Posts: 53

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

I had this issue in Ubuntu and townsend's ppa helped to fix it. I installed Arch today with Xfce4. And I'm installing your fixed compiz. But I should ask something. I didn't install compiz from AUR. Should I install first from there to ensure that it has problem?

-I thought first I should try your patched version. But;

 Scanning dependencies of target opengl
[ 21%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/screen.cpp.o
[ 21%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/matrix.cpp.o
[ 21%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/vector.cpp.o
[ 22%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/texture.cpp.o
[ 22%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/vertexbuffer.cpp.o
[ 22%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/window.cpp.o
[ 22%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/opengl.cpp.o
[ 22%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/paint.cpp.o
[ 22%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/program.cpp.o
[ 22%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/programcache.cpp.o
[ 22%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/shadercache.cpp.o
[ 22%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/framebufferobject.cpp.o
[ 22%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/xtoglsync.cpp.o
/home/thedeli/Desktop/compiz-core-bzr/src/compiz/plugins/opengl/src/xtoglsync.cpp: In member function ‘GLenum XToGLSync::checkUpdateFinished(GLuint64)’:
/home/thedeli/Desktop/compiz-core-bzr/src/compiz/plugins/opengl/src/xtoglsync.cpp:165:6: error: expected primary-expression before ‘return’
      return GL_WAIT_FAILED;
      ^
/home/thedeli/Desktop/compiz-core-bzr/src/compiz/plugins/opengl/src/xtoglsync.cpp: In member function ‘void XToGLSync::reset()’:
/home/thedeli/Desktop/compiz-core-bzr/src/compiz/plugins/opengl/src/xtoglsync.cpp:176:2: error: expected primary-expression before ‘return’
  return;
  ^
/home/thedeli/Desktop/compiz-core-bzr/src/compiz/plugins/opengl/src/xtoglsync.cpp: In member function ‘void XToGLSync::handleEvent(XSyncAlarmNotifyEvent*)’:
/home/thedeli/Desktop/compiz-core-bzr/src/compiz/plugins/opengl/src/xtoglsync.cpp:200:6: error: expected primary-expression before ‘return’
      return;
      ^
/home/thedeli/Desktop/compiz-core-bzr/src/compiz/plugins/opengl/src/xtoglsync.cpp: In member function ‘GLenum XToGLSync::checkUpdateFinished(GLuint64)’:
/home/thedeli/Desktop/compiz-core-bzr/src/compiz/plugins/opengl/src/xtoglsync.cpp:167:1: warning: control reaches end of non-void function [-Wreturn-type]
 }
 ^
At global scope:
cc1plus: warning: unrecognized command line option "-Wno-unused-private-field"
cc1plus: warning: unrecognized command line option "-Wno-unused-private-field"
cc1plus: warning: unrecognized command line option "-Wno-unused-private-field"
cc1plus: warning: unrecognized command line option "-Wno-unused-private-field"
cc1plus: warning: unrecognized command line option "-Wno-unused-private-field"
plugins/opengl/CMakeFiles/opengl.dir/build.make:356: recipe for target 'plugins/opengl/CMakeFiles/opengl.dir/src/xtoglsync.cpp.o' failed
make[2]: *** [plugins/opengl/CMakeFiles/opengl.dir/src/xtoglsync.cpp.o] Error 1
CMakeFiles/Makefile2:12630: recipe for target 'plugins/opengl/CMakeFiles/opengl.dir/all' failed
make[1]: *** [plugins/opengl/CMakeFiles/opengl.dir/all] Error 2
Makefile:147: recipe for target 'all' failed
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
    Aborting... 

this happened. I don't know that well. Is there anything I should do?

Last edited by thedeli (2014-06-23 17:40:30)

Offline

#4 2014-06-23 17:37:46

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

thedeli wrote:

I had this issue in Ubuntu and townsend's ppa helped to fix it. I installed Arch today with Xfce4. And I'm installing your fixed compiz. But I should ask something. I didn't install compiz from AUR. Should I install first from there to ensure that it has problem?

The 'test' compiz-core-bzr package here IS the PKGBUILD found in AUR - Just with the added bits [mentioned above]. So no, you can just install this one [as for all intensive purposes, you will have installed the AUR package, as far as pacman is concerned...].

cheerz

Offline

#5 2014-06-23 17:42:08

thedeli
Member
Registered: 2010-02-14
Posts: 53

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

triplesquarednine wrote:
thedeli wrote:

I had this issue in Ubuntu and townsend's ppa helped to fix it. I installed Arch today with Xfce4. And I'm installing your fixed compiz. But I should ask something. I didn't install compiz from AUR. Should I install first from there to ensure that it has problem?

The 'test' compiz-core-bzr package here IS the PKGBUILD found in AUR - Just with the added bits [mentioned above]. So no, you can just install this one [as for all intensive purposes, you will have installed the AUR package, as far as pacman is concerned...].

cheerz

it just gave an error. I edited my post.

Offline

#6 2014-06-23 18:05:06

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

thedeli wrote:
triplesquarednine wrote:
thedeli wrote:

I had this issue in Ubuntu and townsend's ppa helped to fix it. I installed Arch today with Xfce4. And I'm installing your fixed compiz. But I should ask something. I didn't install compiz from AUR. Should I install first from there to ensure that it has problem?

The 'test' compiz-core-bzr package here IS the PKGBUILD found in AUR - Just with the added bits [mentioned above]. So no, you can just install this one [as for all intensive purposes, you will have installed the AUR package, as far as pacman is concerned...].

cheerz

it just gave an error. I edited my post.

Interesting... I'm thinking something is missing somewhere on your [newly installed system] causing it to fail, maybe. Here is mine;

Scanning dependencies of target opengl
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/framebufferobject.cpp.o
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/matrix.cpp.o
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/opengl.cpp.o
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/shadercache.cpp.o
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/programcache.cpp.o
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/paint.cpp.o
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/vertexbuffer.cpp.o
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/program.cpp.o
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/window.cpp.o
[ 21%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/xtoglsync.cpp.o
[ 21%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/screen.cpp.o
[ 21%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/vector.cpp.o
[ 21%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/texture.cpp.o
[ 21%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/__/__/generated/opengl_options.cpp.o
Linking CXX shared library libopengl.so

.

I am just gonna make sure my system is up-to-date and check a few other things - can you try building compiz-core-bzr in AUR, in the meantime? ...and report back if it builds okay?

[I'll get back to you in a while, once i investigate my system]

Last edited by triplesquarednine (2014-06-23 18:05:56)

Offline

#7 2014-06-23 18:10:32

thedeli
Member
Registered: 2010-02-14
Posts: 53

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

triplesquarednine wrote:
thedeli wrote:
triplesquarednine wrote:

The 'test' compiz-core-bzr package here IS the PKGBUILD found in AUR - Just with the added bits [mentioned above]. So no, you can just install this one [as for all intensive purposes, you will have installed the AUR package, as far as pacman is concerned...].

cheerz

it just gave an error. I edited my post.

Interesting... I'm thinking something is missing somewhere on your [newly installed system] causing it to fail, maybe. Here is mine;

Scanning dependencies of target opengl
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/framebufferobject.cpp.o
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/matrix.cpp.o
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/opengl.cpp.o
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/shadercache.cpp.o
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/programcache.cpp.o
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/paint.cpp.o
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/vertexbuffer.cpp.o
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/program.cpp.o
[ 20%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/window.cpp.o
[ 21%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/xtoglsync.cpp.o
[ 21%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/screen.cpp.o
[ 21%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/vector.cpp.o
[ 21%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/src/texture.cpp.o
[ 21%] Building CXX object plugins/opengl/CMakeFiles/opengl.dir/__/__/generated/opengl_options.cpp.o
Linking CXX shared library libopengl.so

.

I am just gonna make sure my system is up-to-date and check a few other things - can you try building compiz-core-bzr in AUR, in the meantime? ...and report back if it builds okay?

[I'll get back to you in a while, once i investigate my system]

Installed from AUR. No problem there. I will try and let you know if anything happens (good or bad:))

Offline

#8 2014-06-23 18:21:59

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

thedeli wrote:

Installed from AUR. No problem there. I will try and let you know if anything happens (good or bad:))

my system is pretty much up-to-date, but i did notice a cmake update. [generally, those kinds of errors would make me suspect compiler / build system]. Something odd is happening here.

anyway, I am updating my system, will reboot and see if my system fails to compile it. - Give me a while to get back to you though, because i also have to head out for a little while...

so give me an hour or so, k?

Offline

#9 2014-06-23 19:08:00

thedeli
Member
Registered: 2010-02-14
Posts: 53

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

triplesquarednine wrote:
thedeli wrote:

Installed from AUR. No problem there. I will try and let you know if anything happens (good or bad:))

my system is pretty much up-to-date, but i did notice a cmake update. [generally, those kinds of errors would make me suspect compiler / build system]. Something odd is happening here.

anyway, I am updating my system, will reboot and see if my system fails to compile it. - Give me a while to get back to you though, because i also have to head out for a little while...

so give me an hour or so, k?

I started with compiz --replace. And windows borders turn to Adwaita, so I understood that compiz is working smile And then I saw flicker thing on firefox while serching on Wiki. Will try to compile from the PKGBUILD in here.

Offline

#10 2014-06-23 19:25:13

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

thedeli wrote:

I started with compiz --replace. And windows borders turn to Adwaita, so I understood that compiz is working smile And then I saw flicker thing on firefox while serching on Wiki. Will try to compile from the PKGBUILD in here.

The problem appears to be cmake. [ i can reproduce your issue, now].  This is very unfortunate timing. I may just downgrade cmake and build some generic-X86_64 binaries of this test package, while i figure out how to solve the problem with latest cmake.... So, I am gonna go out now, but will come back to this later this afternoon / evening. [regardless of fixing the build with cmake  - I'll get binaries posted that work].

Offline

#11 2014-06-23 21:03:22

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

@thedeli - could you try building this one, instead; https://www.dropbox.com/s/tv89zkaj34p3t … src.tar.gz ... and verify that it compiles?

note: it will take much longer to compile than usual build.

Offline

#12 2014-06-23 21:57:41

thedeli
Member
Registered: 2010-02-14
Posts: 53

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

triplesquarednine wrote:

@thedeli - could you try building this one, instead; https://www.dropbox.com/s/tv89zkaj34p3t … src.tar.gz ... and verify that it compiles?

note: it will take much longer to compile than usual build.

Just in the beginning sad

 Linking C executable gtk-window-decorator
[  2%] Built target gtk-window-decorator
Scanning dependencies of target compiz-gnome-keybindings
[  2%] Generating 50-compiz-navigation.xml
/bin/sh: -c: line 0: syntax error near unexpected token `('
/bin/sh: -c: line 0: `cd "/home/thedeli/Desktop/compiz-core-bzr (2)/src/compiz/build/gtk/gnome" && /usr/bin/intltool-merge -c /home/thedeli/Desktop/compiz-core-bzr\ (2)/src/compiz/build/.intltool-merge-cache --no-translations -x -u /home/thedeli/Desktop/compiz-core-bzr\ (2)/src/compiz/gtk/gnome/50-compiz-navigation.xml.in /home/thedeli/Desktop/compiz-core-bzr\ (2)/src/compiz/build/gtk/gnome/50-compiz-navigation.xml'
gtk/gnome/CMakeFiles/compiz-gnome-keybindings.dir/build.make:52: recipe for target 'gtk/gnome/50-compiz-navigation.xml' failed
make[2]: *** [gtk/gnome/50-compiz-navigation.xml] Error 1
CMakeFiles/Makefile2:2277: recipe for target 'gtk/gnome/CMakeFiles/compiz-gnome-keybindings.dir/all' failed
make[1]: *** [gtk/gnome/CMakeFiles/compiz-gnome-keybindings.dir/all] Error 2
Makefile:147: recipe for target 'all' failed
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
    Aborting... 

I started compiling again but this time I didn't erase the '#' before 80. line. Which is supposed to be used for debug and log. It just finished. I didn't see any flicker. But compiz seems to not working except window borders. I tried all the things that I know of ccsm but no animations sad

Last edited by thedeli (2014-06-23 22:43:11)

Offline

#13 2014-06-23 22:56:33

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

thedeli wrote:

I started compiling again but this time I didn't erase the '#' before 80. line. Which is supposed to be used for debug and log. It just finished. I didn't see any flicker. But compiz seems to not working except window borders. I tried all the things that I know of ccsm but no animations sad

hmm.. Okay, I'll have a look, but i built with debugging yesterday and everything was fine... strange

here is a binary, btw; https://www.dropbox.com/s/v1gzneza7cj2b … pkg.tar.xz [it has 16 sync objects]

...as far as CCSM - do you have 'window decorations' enabled plus path to gtk-window-decorator set in plugin? [it should say; command ... /usr/bin/gtk-window-decorator]

...or you can manually start the deocration;

gtk-window-decorator --replace

EDIT: sorry you meant all you can see is window decorations?

Last edited by triplesquarednine (2014-06-23 23:02:35)

Offline

#14 2014-06-23 23:04:12

thedeli
Member
Registered: 2010-02-14
Posts: 53

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

triplesquarednine wrote:
thedeli wrote:

I started compiling again but this time I didn't erase the '#' before 80. line. Which is supposed to be used for debug and log. It just finished. I didn't see any flicker. But compiz seems to not working except window borders. I tried all the things that I know of ccsm but no animations sad

hmm.. Okay, I'll have a look, but i built with debugging yesterday and everything was fine... strange

here is a binary, btw; https://www.dropbox.com/s/v1gzneza7cj2b … pkg.tar.xz [it has 16 sync objects]

...as far as CCSM - do you have 'window decorations' enabled plus path to gtk-window-decorator set in plugin? [it should say; command ... /usr/bin/gtk-window-decorator]

...or you can manually start the deocration;

gtk-window-decorator --replace

I think I couldn't make it clear smile Decorations are working. but only decorations working. No animations, no desktop cube (not that I use). And it didn't change with the package that you upload. But it is probably sth else. sure thing is there isn't flicker smile

Offline

#15 2014-06-23 23:04:53

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

I found the build problem, stupid mistake. I'll fix shortly / post new pkgbuild. but yeah, leaving line 80 commented out - will allow it to build.

Offline

#16 2014-06-23 23:09:30

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

thedeli wrote:

I think I couldn't make it clear smile Decorations are working. but only decorations working. No animations, no desktop cube (not that I use). And it didn't change with the package that you upload. But it is probably sth else. sure thing is there isn't flicker smile

do the window decorations have shadows?

... this problem, i have not seen. I'm not sure how to proceed here - you may have to fool around a bit and see if you can effect it.

...maybe you can reset settings in CCSM [preferences] to fix the problem?

Offline

#17 2014-06-23 23:16:25

thedeli
Member
Registered: 2010-02-14
Posts: 53

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

triplesquarednine wrote:
thedeli wrote:

I think I couldn't make it clear smile Decorations are working. but only decorations working. No animations, no desktop cube (not that I use). And it didn't change with the package that you upload. But it is probably sth else. sure thing is there isn't flicker smile

do the window decorations have shadows?

... this problem, i have not seen. I'm not sure how to proceed here - you may have to fool around a bit and see if you can effect it.

...maybe you can reset settings in CCSM [preferences] to fix the problem?

Decorations have shadows. and reset didn't work. I'll be looking around on google. Thanks smile

Offline

#18 2014-06-23 23:34:02

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

thedeli wrote:
triplesquarednine wrote:
thedeli wrote:

I think I couldn't make it clear smile Decorations are working. but only decorations working. No animations, no desktop cube (not that I use). And it didn't change with the package that you upload. But it is probably sth else. sure thing is there isn't flicker smile

do the window decorations have shadows?

... this problem, i have not seen. I'm not sure how to proceed here - you may have to fool around a bit and see if you can effect it.

...maybe you can reset settings in CCSM [preferences] to fix the problem?

Decorations have shadows. and reset didn't work. I'll be looking around on google. Thanks smile

very odd. I don't think i have bumped into that before. Sorry i don't have a good answer. I'm sure google will turn up something... I'm not sure [but don't think] if that would be related to the patch or not [i haven't seen anything like that]. It seems like maybe a bug. A couple of questions;

- which config backend are you using? [gsettings, flatfile...]
- what Nvidia card are you using? [just out of curiousity]...

Also, I have linked to a new package [with fixed debugging] and fixed my 1st post to reflect that, so i appreciate your input - it was a really stupid mistake on my part. Totally overlooked something that i had changed around, last night. no biggie though, fixed.

Last edited by triplesquarednine (2014-06-23 23:34:40)

Offline

#19 2014-06-23 23:49:45

thedeli
Member
Registered: 2010-02-14
Posts: 53

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

I don't know the first questins answer, but I'm using Xfce4. And my card is Nvidia GTX670 PCI model, not a laptop or mobile Gpu. I will try to compile the new PKGBUILD. I commented the 85. line first. I guess 86 is for debugging. Which I don't know how to...  you can give me the command for debugging after compile.

Offline

#20 2014-06-24 00:03:04

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

thedeli wrote:

I don't know the first questins answer, but I'm using Xfce4. And my card is Nvidia GTX670 PCI model, not a laptop or mobile Gpu. I will try to compile the new PKGBUILD. I commented the 85. line first. I guess 86 is for debugging. Which I don't know how to...  you can give me the command for debugging after compile.

it says how in my first post - run compiz from the commandline. ie:

compiz --replace ccp

You can see which backend you are using in CCSM->Preferences ... You should be using gsettings, but i was just curious... Though, if you are using gsettings [currently], you could try switching to flat-file config [which would be like using 'reset'. Especially since this is a new install/on your box  and you wouldn't have existing settings stored by compiz/INI file].

another thing you can try is disabling CCSM->OpenGL->X11 Sync Objects ,,,

if you then have window contents - the patch is likely responsible. [note: you may need to restart compiz]

Last edited by triplesquarednine (2014-06-24 00:16:52)

Offline

#21 2014-06-24 00:17:05

thedeli
Member
Registered: 2010-02-14
Posts: 53

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

I looked up and I'm using GSettings. After I started compiz with ccp all the effects started to work smile But I'm getting

 compiz (opengl) - Info: Destroying sync objects
compiz (opengl) - Info: Initializing sync objects
compiz (opengl) - Error: Sync object is not ready -- were events handled properly? 

everytime an animation works. And no flicker smile I guess I can compile the non debug version if you don't have anything to ask smile
PS : It's 3:15 AM here and I need to sleep for work. If you have sth I will lok at in the morning. Thanks for everything smile

Offline

#22 2014-06-24 00:23:48

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

thedeli wrote:

I looked up and I'm using GSettings. After I started compiz with ccp all the effects started to work smile But I'm getting

 compiz (opengl) - Info: Destroying sync objects
compiz (opengl) - Info: Initializing sync objects
compiz (opengl) - Error: Sync object is not ready -- were events handled properly? 

everytime an animation works. And no flicker smile I guess I can compile the non debug version if you don't have anything to ask smile
PS : It's 3:15 AM here and I need to sleep for work. If you have sth I will lok at in the morning. Thanks for everything smile

okay. We are making progress wink  ... so the patch is working, but it is complaining about snyc objects not being ready. Good to know.

If you want to experiment more [maybe not tonight, but tomorrow - keep a debug package around and you could try increasing x11 sync bjects, to see if the last error goes away. Myself, i had to disable the logging that creates the other two messages before compiz stopped complaining about sync objects not being ready. [so yours could be due to that - or possibly some racy code in compiz]... it also could be XYZ plugin / or option that is causing those messages; but due to the fact how complex / configurable compiz is - it would be hard to know without a lot of experimentation...

if/when you have time, play around with the debug build. but yes, for general use - i would build a non-debug build.

keep me posted and thx wink

Offline

#23 2014-06-24 08:24:52

thedeli
Member
Registered: 2010-02-14
Posts: 53

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

Ok smile I can make it 20 I guess. I will do it tonight. Will continue using debug package smile

Offline

#24 2014-06-24 15:36:11

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

thedeli wrote:

Ok smile I can make it 20 I guess. I will do it tonight. Will continue using debug package smile

cool. thx - Later i am going to see if i can find the source of the missed syncs [u think it may be in animation plugin, eh?]

Offline

#25 2014-06-24 20:28:13

thedeli
Member
Registered: 2010-02-14
Posts: 53

Re: Compiz - GL_EXT_x11_sync_object support: testers needed

I made it to 20. no flicker. compiz works googd. But I'm getting the same error. I guess it's not related to animations. the error repeats sometimes when moving windows sometime don't give error. same thing with the animations.

Offline

Board footer

Powered by FluxBB