You are not logged in.

#1 2014-06-22 09:54:59

Registered: 2010-05-06
Posts: 206

[SOLVED] avahi browser segfaults on attempted connection

I run upto date 3.15.1-1-ARCH x86_64. When I run the bssh command I see the expected ssh hosts; however, when I click on the connect button bssh segfaults. I struggled to get a coredump, but eventually wrote a pattern to /proc/sys/kernel/core_pattern and got a core file. Running gdb over that I see this as the cause of the segfault

warning: Could not load shared library symbols for
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/".
Core was generated by `bssh'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007f6c2c6e636c in g_type_check_instance_cast ()
   from /usr/lib/

anyone know what this means? I use openbox as WM under slim as DM so it could be almost anything like not having the right terminal program or something.

Edit: I think this is caused by having avahi-gtk2 installed instead of the more up to date avahi which does connect OK.

Last edited by replabrobin (2014-06-23 19:36:49)


Board footer

Powered by FluxBB