You are not logged in.

#1 2014-06-22 14:13:44

Registered: 2014-06-22
Posts: 1

Dell 1564 - Intel I5-M430 - Overheating issues, very slow performance

I have a dell 1564, with an I5 M430 cpu. I have cooling issues and as a result my CPU temperature peaks close to 90~95 degree Celsius sometimes on extended full cpu usage. In such situations , I cut down my usage , and manage to bring the temperature down back to reasnoble ranges of 60~75 degrees. However often in these situations even after cooling down, my cpu performance becomes very miserable. Normal browsing which usually uses 10~15% cpu show up as taking 80~90% cpu (as per top/ and other process monitors). I ran the "N-Queens" benchmark from  hardinfo show drastically reduced performance. Post overheating the benchmark takes 35s, after a reboot it takes only 7seconds. I'm trying to track down the reason for this but can't seem to figure out what's the issue. Can someone help me out in this? I'm basically looking for a solution where I don't have to reboot every time I cross the temperature threshold just to get normal CPU performance again. Ideally if its downclocking somehow I'm hoping that it should reset back normally after temperature returns to normal ranges.

Stuff I've tried:
* dmesg : No new messages added during/after the overheating
* cpu scaling : cpu frequency reported by /proc/cpuinfo are back to the normal 2.26 GHz which is my peak scaling. Also I've tried all scaling governors , and even locking the frequency to 2.26GHz , doesn't seem to bring back the performance.
* suspending and resuming , in hopes of reseting any CPU modes. No luck, CPU still in bad performance. Only a reboot fixes it.

Output of cat /proc/cpuinfo

processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 37
model name	: Intel(R) Core(TM) i5 CPU       M 430  @ 2.27GHz
stepping	: 2
microcode	: 0x9
cpu MHz		: 2267.000
cache size	: 3072 KB
physical id	: 0
siblings	: 4
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 11
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm ida arat dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips	: 4523.40
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

... repeats 3 more times ...

Any suggestions , to either fix this , or ways to track down the issue, will be much appreciated. Will be happy to provide more details , logs, or specs if required. I'm right now totally clueless as to even how to figure out what's going wrong so anything is welcome.


Board footer

Powered by FluxBB