You are not logged in.

#1 2014-06-25 19:03:20

windy
Member
Registered: 2013-11-10
Posts: 19

Gnome sound inidicator after removing PulseAudio

Hello,

PulseAudio produces clicking and other noises when I try to play a game from steam. The easiest way was to remove PulseAudio completely and replacing gnome-settings-daemon with gnome-settings-daemon-nopulse from AUR.

However, the sound indicator seems broken now. There are two sliders, one without any symbol and one with a microphone. Changing any of them does not have any effect on the volume.

So my question is: How do I get a working sound applet for Gnome without using PulseAudio? Or is there perhaps a way to fix my broken sound in steam games? The 32-bit libraries are already installed.

Offline

#2 2014-06-25 19:11:06

ooo
Member
Registered: 2013-04-10
Posts: 1,078

Re: Gnome sound inidicator after removing PulseAudio

afaik the sound indicator won't work without pulseaudio, at least I haven't found a way.
There are some outdated extensions, but they don't integrate with the new unified menu, even if you got them to work with latest gnome.

let us know if you find a solution :)

EDIT. Just noticed this github repo: https://github.com/metherealone/gnome-s … -alsamixer
It should work with gnome 3.12 according to metadata.json

Last edited by ooo (2014-06-25 19:14:44)

Offline

#3 2014-06-25 19:17:09

windy
Member
Registered: 2013-11-10
Posts: 19

Re: Gnome sound inidicator after removing PulseAudio

Yeah, I just found the same extension. wink

However, the slider does not work properly:

https://github.com/metherealone/gnome-s … r/issues/1

But the delevoper seems to react quickly, I hope this will be fixed soon.

Offline

#4 2014-06-25 23:59:16

Pse
Member
Registered: 2008-03-15
Posts: 383

Re: Gnome sound inidicator after removing PulseAudio

You could have just disabled PulseAudio for that specific game (pasuspender, etc).

Offline

Board footer

Powered by FluxBB