You are not logged in.

#1 2006-01-29 01:27:51

lumiwa
Member
Registered: 2005-12-26
Posts: 712

udev 0.83-1

Hi!

After upgrade udev to 0.83-1 version I had a problem to use Sony memory stick reader:
Initializing USB Mass Storage driver...
usb 2-1: new full speed USB device using uhci_hcd and address 3
I did try to mount /dev/sdex and nothing.

I downgrade to version 0.79-1 and works again.

Mitja

Offline

#2 2006-01-29 06:20:31

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: udev 0.83-1

Isn't udev 0.83 in /testing ?


Microshaft delenda est

Offline

#3 2006-01-29 13:36:16

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: udev 0.83-1

scarecrow wrote:

Isn't udev 0.83 in /testing ?

Yes, it is and it was to late...

Offline

#4 2006-01-29 15:44:48

rayjgu3
Member
From: Chicago IL usa
Registered: 2004-07-04
Posts: 692

Re: udev 0.83-1

after a few week battle i figured out my own problem
http://bbs.archlinux.org/viewtopic.php? … highlight=
you should also check this
http://wiki.archlinux.org/index.php/Usi … o_a_device

Offline

#5 2006-01-30 18:00:15

Samuel Cengel
Member
From: Slovak Republic
Registered: 2005-11-19
Posts: 55

Re: udev 0.83-1

Yes, I have the same problem with udev 083-1 from testing. I downgraded to 079-1.

Offline

#6 2006-01-31 14:29:04

Samuel Cengel
Member
From: Slovak Republic
Registered: 2005-11-19
Posts: 55

Re: udev 0.83-1

The exact problem is with udev 084-1 from testing. Usb flash disk doesnt works.

Offline

#7 2006-01-31 20:38:46

rayjgu3
Member
From: Chicago IL usa
Registered: 2004-07-04
Posts: 692

Re: udev 0.83-1

write a udev rule  to make it work

Offline

#8 2006-02-01 01:27:39

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: udev 0.83-1

rayjgu3 wrote:

write a udev rule  to make it work

I tried but didn't work. Which udev do you have? For new one (now is 0.84 or something) I don't have in the /dev nothing about sda or sde. With old one I have /dev/+sde and /dev/+sde1.

udevinfo -a -p 'udevinfo -q path -n /dev/sd?' doen't works with udev 0.84 but with old one I get a message:
couldn't get the class device

I will stay with old one. Thanks.

Offline

#9 2006-02-01 07:18:27

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: udev 0.83-1

too me this sounds like that the module you need to access the device is not loaded anymore.
do you have MODAUTOLOAD="yes" in rc.conf?

Offline

#10 2006-02-01 09:37:53

Samuel Cengel
Member
From: Slovak Republic
Registered: 2005-11-19
Posts: 55

Re: udev 0.83-1

Hi tpowa, in my rc.conf I have MODAUTOLOAD="no". Usb flash disk works fine with udev 079-1. With udev 084-1 will it work with MODAUTOLOAD="no"?
Must I edit /etc/rc.conf to MODAUTOLOAD="yes"?
I dont understand.

Offline

#11 2006-02-01 09:47:52

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: udev 0.83-1

argh ...
MOD_AUTOLOAD="yes" is the new default on all installs, it enables module autoloading, else you will see what you posted here. Nothing will be loaded and you need to do all by hand.

Offline

#12 2006-02-01 09:56:07

Samuel Cengel
Member
From: Slovak Republic
Registered: 2005-11-19
Posts: 55

Re: udev 0.83-1

Udev Reminder:
NOTE: If you were using hotplug in your DAEMONS array to auto-load your modules, you should replace it with one of the other auto-detection utilities: hwdetect or hwd.

To use hwd: Just install the lshwd package and replace hotplug with hwd in your DAEMONS array.

To use hwdetect: Look for a line in /etc/rc.conf that starts with MOD_AUTOLOAD and set it to "yes". If you don't have the line, add it:

    MOD_AUTOLOAD="yes"


I replaced hotplug with hwd in my DAEMONS array.
I am using hwd (not hwdetect MODAUTOLOAD="yes").

Offline

#13 2006-02-01 10:09:32

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: udev 0.83-1

don't use hwd, it's not perfect as you see just enable MOD_AUTOLOAD="yes", udev does the rest

Offline

#14 2006-02-01 17:01:16

Samuel Cengel
Member
From: Slovak Republic
Registered: 2005-11-19
Posts: 55

Re: udev 0.83-1

Thanks, tpowa.

Offline

#15 2006-02-02 01:28:45

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: udev 0.83-1

tpowa wrote:

don't use hwd, it's not perfect as you see just enable MOD_AUTOLOAD="yes", udev does the rest

If I have MOD_AUTOLOAD="yes" and I don't load hwd I don't have network
lo="lo 127.0.0.1"
eth0="dhcp"
INTERFACES=(lo eth0)

Offline

#16 2006-02-02 06:14:19

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: udev 0.83-1

8139cp or 8193too card?
that are the only ones with the same number in kernel.
you have to load these by hand

Offline

#17 2006-02-02 11:19:57

rayjgu3
Member
From: Chicago IL usa
Registered: 2004-07-04
Posts: 692

Re: udev 0.83-1

it looks like you solved your problem im guessing
as far as looking up udev info if it doesnt give you a block device in /dev
then you need a diffrent approach

udevinfo -a -p /sys/devices/pci0000:00/0000:00:10.4/usb1/1-1 

which is what i needed cause my usb device creates a character device not a block
my version of udev is same as yours i upgraded to testing to see if it would fix my problem it didnt so i had fun learning bout writing udev rules  big_smile

Offline

#18 2006-02-02 12:16:37

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: udev 0.83-1

tpowa wrote:

8139cp or 8193too card?
that are the only ones with the same number in kernel.
you have to load these by hand

In KDE KInfoCenter I have about my card which is on board:

02:05.0 Ethernet controller: 3Com Corporation 3c940 10/100/1000Base-T [Marvell] (rev 12)

First time when I commented hwd and use MOD_AUTOLOAD was okay. Than I turned comp. off because freezing when I tried to run rosegarden and after that I have a problem. I use hwd again and is okay just I cannot use memory stick reader, ahhhhhhhhh.

Offline

#19 2006-02-02 12:28:51

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: udev 0.83-1

what udev are you using?

Offline

#20 2006-02-02 12:33:27

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: udev 0.83-1

tpowa wrote:

what udev are you using?

The last one, I think that is 0.84...

Offline

#21 2006-02-02 12:38:14

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: udev 0.83-1

do you also use complete testing?

Offline

#22 2006-02-02 12:50:13

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: udev 0.83-1

tpowa wrote:

do you also use complete testing?

yes

Offline

#23 2006-02-02 13:09:31

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: udev 0.83-1

is the module not loaded? because else it could be a timing issue

Offline

#24 2006-02-02 14:35:53

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: udev 0.83-1

tpowa wrote:

is the module not loaded? because else it could be a timing issue

I didn't check. I installed old one which works everything smile.
Thanks for your help and I am sorry that I took your time...

Offline

#25 2006-02-03 12:08:50

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: udev 0.83-1

lumiwa wrote:
tpowa wrote:

is the module not loaded? because else it could be a timing issue

I didn't check. I installed old one which works everything smile.
Thanks for your help and I am sorry that I took your time...

Again me...udev 0.84 works now. I don't know why but I did try again, reboot twice and works. Maybe was a problem because Rosegarden freezing the computer and shutdown was not correct.

Thank you again for help smile

Offline

Board footer

Powered by FluxBB