You are not logged in.

#1 2014-06-27 16:04:04

Sudowoodo
Member
From: Saturn Valley
Registered: 2014-04-27
Posts: 62

[SOLVED] Error when compiling conky with audacious support

Edit: See post #8 for solution
Hello.
When trying to compile conky with the --enable-audacious option, I get the following error.

checking for Audacious... configure: error: Package requirements (audacious >= 1.4.0 audclient dbus-glib-1 glib-2.0 gobject-2.0) were not met:

No package 'audclient' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables Audacious_CFLAGS
and Audacious_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

==> ERROR: A failure occurred in build().
    Aborting...

My PKGBUILD is the one in the repos, with the addition of an --enable-audacious line. See below:

# $Id: PKGBUILD 205494 2014-02-06 05:24:01Z bisson $
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: James Rayner <james@archlinux.org>
# Contributor: Partha Chowdhury <kira.laucas@gmail.com>

pkgname=conky
pkgver=1.9.0
pkgrel=4
pkgdesc='Lightweight system monitor for X'
url='http://conky.sourceforge.net/'
license=('BSD' 'GPL')
arch=('i686' 'x86_64')
makedepends=('docbook2x')
depends=('glib2' 'curl' 'lua' 'wireless_tools' 'libxml2' 'libxft' 'libxdamage' 'imlib2')
source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha1sums=('a8d26d002370c9b877ae77ad3a3bbd2566b38e5d')

backup=('etc/conky/'conky{,_no_x11}.conf)
options=('!emptydirs')

build() {
	cd "${srcdir}/${pkgname}-${pkgver}"

	CPPFLAGS="${CXXFLAGS}" LIBS="${LDFLAGS}" ./configure \
		--prefix=/usr \
		--sysconfdir=/etc \
		--enable-ibm \
		--enable-curl \
		--enable-rss \
		--enable-weather-xoap \
		--enable-imlib2 \
		--enable-wlan \
                --enable-audacious \

	make
}

package() {
	cd "${srcdir}/${pkgname}-${pkgver}"
	make DESTDIR="${pkgdir}" install
	install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
	install -Dm644 extras/vim/syntax/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/syntax/conkyrc.vim
	install -Dm644 extras/vim/ftdetect/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/ftdetect/conkyrc.vim
}

Note: While similar, I don't think this problem is the same as this one.

Last edited by Sudowoodo (2014-06-29 10:07:02)


archlinux
Sudowoodo!

Offline

#2 2014-06-27 16:17:04

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 4,068
Website

Re: [SOLVED] Error when compiling conky with audacious support

Remove the "\" from the end of "--enable-audacious". Does it work now?

EDIT: Also, there's already a package for conky-audacious in the AUR.

Last edited by drcouzelis (2014-06-27 16:18:13)

Offline

#3 2014-06-27 16:49:39

Sudowoodo
Member
From: Saturn Valley
Registered: 2014-04-27
Posts: 62

Re: [SOLVED] Error when compiling conky with audacious support

drcouzelis wrote:

Remove the "\" from the end of "--enable-audacious". Does it work now?

No, it's exactly the same.

drcouzelis wrote:

EDIT: Also, there's already a package for conky-audacious in the AUR.

I tried it, that doesn't compile either, and its orphan & outdated.

For the record, its PKGBUILD is
Edit: Remove unnecessary text. See post #8 for solution.
and the error is the same:
Edit: Remove unnecessary text. See post #8 for solution.

Have you been able to reproduce the problem? I'm using an amd64 processor and trying to build with "makepkg -s". Thank you for replying.

Last edited by Sudowoodo (2014-06-28 12:13:28)


archlinux
Sudowoodo!

Offline

#4 2014-06-27 17:35:16

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 4,068
Website

Re: [SOLVED] Error when compiling conky with audacious support

I'm not home at the moment... But I wonder if "audclient" is even needed anymore since Audacious comes with audtool.

Try removing the "audclient" dependency but keeping "--enable-audacious". Does that work?

Offline

#5 2014-06-27 17:46:22

Sudowoodo
Member
From: Saturn Valley
Registered: 2014-04-27
Posts: 62

Re: [SOLVED] Error when compiling conky with audacious support

makedepends=('docbook2x')
depends=('glib2' 'curl' 'lua' 'wireless_tools' 'libxml2' 'libxft' 'libxdamage' 'imlib2')

No audclient at all. sad
Also, the error doesn't appear when compiling without --enable-audacious.


archlinux
Sudowoodo!

Offline

#6 2014-06-27 22:15:05

Radioactiveman
Member
From: Germany
Registered: 2010-05-13
Posts: 386

Re: [SOLVED] Error when compiling conky with audacious support

Audacious 3.5 does not contain audclient anymore.
See "Removed features" at http://audacious-media-player.org/news/ … 5-released.

Offline

#7 2014-06-27 22:23:30

Sudowoodo
Member
From: Saturn Valley
Registered: 2014-04-27
Posts: 62

Re: [SOLVED] Error when compiling conky with audacious support

Radioactiveman wrote:

Audacious 3.5 does not contain audclient anymore.
See "Removed features" at http://audacious-media-player.org/news/ … 5-released.

That's interesting. So... it's impossible to have audacious support, isn't? sad Downgrading isn't an option.


archlinux
Sudowoodo!

Offline

#8 2014-06-28 01:48:22

jlindgren
Member
Registered: 2011-02-27
Posts: 224

Re: [SOLVED] Error when compiling conky with audacious support

I have uploaded a separate libaudclient tarball.  Here is a PKGBUILD.
http://pastebin.com/raw.php?i=SFJJ9sU0

Offline

#9 2014-06-28 06:34:49

Sudowoodo
Member
From: Saturn Valley
Registered: 2014-04-27
Posts: 62

Re: [SOLVED] Error when compiling conky with audacious support

jlindgren wrote:

I have uploaded a separate libaudclient tarball.  Here is a PKGBUILD.
http://pastebin.com/raw.php?i=SFJJ9sU0

Thank you!! This solves everything! big_smile
Now conky compiles and works perfectly with support for audacious!


archlinux
Sudowoodo!

Offline

Board footer

Powered by FluxBB