You are not logged in.

#1 2014-07-01 01:21:12

Alad
Wiki Admin/IRC Op/TU
From: Bagelstan
Registered: 2014-05-04
Posts: 1,995
Website

[SOLVED] GTK2/QT window decorations broken on maximize in GNOME 3.12.2

When maximizing non-GTK3 (GTK2/QT4) applications in GNOME 3.12.2, the window decorations are not properly displayed. This happens regardless when maximizing via the shortcuts, dragging the window, or double-clicking the title bar. Here is one particularly bad example:

http://i.imgur.com/NhUQ1bU.png

Hovering the mouse over the missing areas, or focusing a different window restores the decorations. Google or the GNOME Bugzilla didn't bring further clues, but I didn't have this problem in GNOME 3.10 (or FWIW, Cinnamon 2.2).

My specs:

$ inxi -Fx
System:    Host: arbellen Kernel: 3.14.9-1-ck x86_64 (64 bit gcc: 4.9.0) 
           Desktop: Gnome 3.12.2 (Gtk 3.12.2) Distro: Arch Linux 
Machine:   System: ASUS product: All Series
           Mobo: ASUSTeK model: H81M-PLUS v: Rev X.0x
           Bios: American Megatrends v: 0805 date: 02/20/2014
CPU:       Dual core Intel Celeron G1820 (-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10793 
           Clock Speeds: 1: 1897 MHz 2: 1843 MHz
Graphics:  Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
           bus-ID: 00:02.0
           Card-2: Advanced Micro Devices [AMD/ATI] Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM]
           bus-ID: 01:00.0
           Display Server: X.Org 1.15.1 drivers: ati,radeon,intel (unloaded: fbdev,vesa)
           Resolution: 1024x768@60.00hz
           GLX Renderer: Mesa DRI Intel Haswell Desktop
           GLX Version: 3.0 Mesa 10.2.2 Direct Rendering: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller 
           driver: snd_hda_intel bus-ID: 00:1b.0 
           Card-2 Advanced Micro Devices [AMD/ATI] Caicos HDMI Audio [Radeon HD 6400 Series] 
           driver: snd_hda_intel bus-ID: 01:00.1 
           Card-3 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller 
           driver: snd_hda_intel bus-ID: 00:03.0 
           Sound: Advanced Linux Sound Architecture v: k3.14.9-1-ck
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 100 Mbps duplex: full 
           mac:
Drives:    HDD Total Size: 373.0GB (17.1% used)
           ID-1: /dev/sdb model: SAMSUNG_SP2504C size: 250.1GB
           ID-2: /dev/sda model: Maxtor_6Y120M0 size: 122.9GB
Partition: ID-1: / size: 113G used: 15G (14%) fs: ext4 dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 34.0C mobo: N/A gpu: 40.0 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 126 Uptime: 1 day Memory: 1298.3/3822.7MB 
           Init: systemd Gcc sys: 4.9.0 
           Client: Shell (bash 4.3.181) inxi: 2.1.28



-- mod edit: read the Forum Etiquette and only post thumbnails http://wiki.archlinux.org/index.php/For … s_and_Code [jwr] --

Last edited by Alad (2014-09-02 00:00:33)


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby
Honest Alad's Package Emporium—Now with added bugs! (Grand reopening: December 1st 2018)

Offline

#2 2014-07-01 10:12:17

dimman
Member
Registered: 2012-11-23
Posts: 3

Re: [SOLVED] GTK2/QT window decorations broken on maximize in GNOME 3.12.2

I'm having a smiliar problem in Flubox with qt4 applications, however not only related to fullscreen.
Even qtconfig-qt4 is broken in its appearance. nVIDIA gfx card here and everything up to date.

Downgrading qt4 package doesn't seem to help hmm

Virtualbox is also broken in its GUI, gives console messages like:

Qt WARNING: X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x0

EDIT: No need saying but No I haven't changed any qt/gtk/whatever configuration in between.

EDIT2: Picture here

Last edited by dimman (2014-07-01 10:54:24)

Offline

#3 2014-08-11 10:59:11

dimman
Member
Registered: 2012-11-23
Posts: 3

Re: [SOLVED] GTK2/QT window decorations broken on maximize in GNOME 3.12.2

Ok, problem seems to be with how X is started, shared memory policies being changed in QT4 (to be more restrictive) and the X server not having permission to access it.

This is a temporary workaround for others with the same issue:

export QT_X11_NO_MITSHM=1

EDIT: My .xinitrc contains "exec startfluxbox", otherwise I'm running Slime login manager. Anyone with a suggestion how to properly fix this?

EDIT2: Background info http://openbsd.7691.n7.nabble.com/qt4-a … 94i20.html

Last edited by dimman (2014-08-11 11:03:27)

Offline

#4 2014-08-11 12:07:25

gedgon
Member
From: Poland
Registered: 2011-01-27
Posts: 94

Re: [SOLVED] GTK2/QT window decorations broken on maximize in GNOME 3.12.2

Offline

#5 2014-08-30 23:11:08

andiY
Member
Registered: 2014-08-30
Posts: 4

Re: [SOLVED] GTK2/QT window decorations broken on maximize in GNOME 3.12.2

I'm also encountering this serious bug (gnome shell 3.13.2 on gentoo), but i have found that exporting

CLUTTER_PAINT=disable-clipped-redraws:disable-culling

fixes it.

Offline

#6 2014-08-30 23:13:33

andiY
Member
Registered: 2014-08-30
Posts: 4

Re: [SOLVED] GTK2/QT window decorations broken on maximize in GNOME 3.12.2

Sorry typo, running gnome-shell 3.12.2 (not 3.13.2)

Offline

#7 2014-08-31 04:36:17

Alad
Wiki Admin/IRC Op/TU
From: Bagelstan
Registered: 2014-05-04
Posts: 1,995
Website

Re: [SOLVED] GTK2/QT window decorations broken on maximize in GNOME 3.12.2

^^ Thank you, will try it when I get the chance.


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby
Honest Alad's Package Emporium—Now with added bugs! (Grand reopening: December 1st 2018)

Offline

#8 2014-09-01 10:44:54

Alad
Wiki Admin/IRC Op/TU
From: Bagelstan
Registered: 2014-05-04
Posts: 1,995
Website

Re: [SOLVED] GTK2/QT window decorations broken on maximize in GNOME 3.12.2

Nope, doesn't seem to fix it, sadly.


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby
Honest Alad's Package Emporium—Now with added bugs! (Grand reopening: December 1st 2018)

Offline

#9 2014-09-01 20:27:37

andiY
Member
Registered: 2014-08-30
Posts: 4

Re: [SOLVED] GTK2/QT window decorations broken on maximize in GNOME 3.12.2

Hm, that's strange, I'm using this now since days and haven't encountered the bug anymore.
Did you export the environment variable before X (gnome-shell) starts?

Offline

#10 2014-09-01 20:35:59

andiY
Member
Registered: 2014-08-30
Posts: 4

Re: [SOLVED] GTK2/QT window decorations broken on maximize in GNOME 3.12.2

It seems like this is also coupled with the graphics driver, see comments in gnome bugzilla (comment 4)

Offline

#11 2014-09-02 00:00:20

Alad
Wiki Admin/IRC Op/TU
From: Bagelstan
Registered: 2014-05-04
Posts: 1,995
Website

Re: [SOLVED] GTK2/QT window decorations broken on maximize in GNOME 3.12.2

It seems like this is also coupled with the graphics driver, see comments in gnome bugzilla (comment 4)

Well I've enabled dri3 for xf86-video-intel and patched it; tried uxa and glamor, as well as my Radeon 6450, and the issue persisted.

andiY wrote:

Hm, that's strange, I'm using this now since days and haven't encountered the bug anymore.
Did you export the environment variable before X (gnome-shell) starts?

Ah, I had exported it when X was running. exporting it before gnome-session solved it, thanks. big_smile


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby
Honest Alad's Package Emporium—Now with added bugs! (Grand reopening: December 1st 2018)

Offline

Board footer

Powered by FluxBB