You are not logged in.

#1 2014-07-09 13:33:47

vargagab
Member
Registered: 2014-07-09
Posts: 3

Asrock Q1900-ITX

Hi!

I have an Asrock Q1900-ITX motherboard. There has an integrated Intel Celeron J1900 CPU.
I installed Arch linux (kernel version 3.15.3 and 3.15.4) to a flash drive, but I have randomly reboots, crash (CPU error, etc.). I checked all the components (RAM, PSU, HDD-s, Flash drive), they are OK.

But I noticed: in UEFI I can see, that the CPU is scalable from 1334 MHz to 1999 MHz. But the Arch Linux says, the CPU is scalable from 1600 MHz to 2900 MHz. Can I change this settings? (When I echo the real value to the /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq and /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq, they wont changed.) Or this is a bug in Arch?

I checked with Ubuntu Server 14.04 (kernel version 3.13.0), the values are OK (min is 1328MHz, max is 1993 MHz), no crash. But I would like to use Arch linux.

Offline

#2 2014-07-11 07:41:20

vargagab
Member
Registered: 2014-07-09
Posts: 3

Re: Asrock Q1900-ITX

Hi!

So, I think, the intel_pstate scaling driver is buggy. I noticed, that the Ubuntu use the acpi-cpufreq scaling driver by default, and the Arch uses the intel_pstate.
With acpi-cpufreq the min_freq is 1328 MHz, and the max is 1993 MHz. With intel_pstate the values are 1600 MHz and 2900 MHz. The problem is, that the J1900 CPU has a maximal burst frequency 2,41 GHz, so the 2900 MHz is too much.

So, I added the

intel_pstate=disable

to the boot options, so with Arch I use the acpi-cpufreq scaling driver with the frequencies above. I now, so I haven't the turbo frequecy yet...

Offline

#3 2014-07-13 06:50:16

DepletionMode
Member
Registered: 2014-06-07
Posts: 8

Re: Asrock Q1900-ITX

Disabling the pstate driver worked for me. There's clearly something wrong with it!

As you say, no Turbo, but I never had that before and it was maxing out at 1.8Ghz and now it's at 2.1Ghz so much improved...

Offline

Board footer

Powered by FluxBB