You are not logged in.

#1 2014-08-07 03:04:16

Registered: 2014-03-30
Posts: 26

[SOLVED] Known issue: intel_do_flush_locked failed:invalid argument

Hello, everyone,
I am using a computer with core2 and 945gm.
So, before some days, the error in the title occurred and any opengl apps cannot be executed, but the restart fix it.

But today, I have this error every time, and I can't even use KWin!

I'm not sure my graphics card is working, but I think it is a driver/software problem.

BTW, I'm using the testing repo (which is not recommended, but my driver is from the stable repo.)

Anyone helps?

EDITED: Not every time but VERY often.

Last edited by ishitatsuyuki (2014-08-20 08:26:19)


#2 2014-08-12 04:14:58

Registered: 2014-03-30
Posts: 26

Re: [SOLVED] Known issue: intel_do_flush_locked failed:invalid argument

This is the kwin output on crash:
kwin(1024) KWin::GlxBackend::initBuffer: Buffer visual (depth  24 ): 0x "76"
OpenGL vendor string:                   Intel Open Source Technology Center
OpenGL renderer string:                 Mesa DRI Mobile Intel® GM45 Express Chipset
OpenGL version string:                  2.1 Mesa 10.2.5
OpenGL shading language version string: 1.20
Driver:                                 Intel
GPU class:                              i965
OpenGL version:                         2.1
GLSL version:                           1.20
Mesa version:                           10.2.5
X server version:                       1.16
Linux kernel version:                   3.15.8
Direct rendering:                       yes
Requires strict binding:                no
GLSL shaders:                           yes
Texture NPOT support:                   yes
Virtual Machine:                        no
kwin(1024) KWin::GlxBackend::init: Direct rendering: true
kwin(1024) KWin::SceneOpenGL2::slotColorCorrectedChanged: Color correction: false
kwin(1024) KWin::SceneOpenGL2::SceneOpenGL2: OpenGL 2 compositing successfully initialized
kwin(1024) KWin::currentRefreshRate: Vertical Refresh rate  60 Hz
intel_do_flush_locked failed: Invalid argument
...and more

Opengl crash everytime i suspended, and if i run kwin in failsafe it will run.
By the way, i reinstalled Arch and it doesn't occured on startup. Now i'm using stable repo.


#3 2014-08-19 18:13:23

Registered: 2011-11-09
Posts: 5

Re: [SOLVED] Known issue: intel_do_flush_locked failed:invalid argument

I't a known kernel issue:

Unless the bug is fixed, use linux-lts just as do I smile


Board footer

Powered by FluxBB