You are not logged in.

#1 2014-08-16 15:19:02

Ploppz
Member
Registered: 2013-09-14
Posts: 168

[Solved] No more than one audio source at a time.

I used alsa, now I'm using pulseaudio. The exact problem and all errors persist regardless of that.

If any program uses audio, even if it isn't at the moment doing that, I can't use other audio sources. For example, speaker-test says "Playback open error: -16,Device or resource busy" when another program that uses audio is running.

When vbox is running, without immediately playing any sound, I also have this problem. But I avoided it lately by setting "Null audio driver" in vbox settings so that I can listen to music while working in windows. Even when speaker-test is running, mpd, youtube, skype, vbox, can't play any sound.

Something maybe worth noting is that I recently had this problem resolved: https://bbs.archlinux.org/viewtopic.php?id=184314 . I don't know if I did some changes back then which are important for this problem.

Thanks.

Last edited by Ploppz (2014-08-23 17:48:07)

Offline

#2 2014-08-17 09:11:48

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: [Solved] No more than one audio source at a time.

Did you install pulseaudio-alsa package? You would need to disable ~/.asoundrc or any other configuration overwriting the redirection of alsa to pulseaudio. Does virtual box work with pulseaudio?

Did you switch to pulseaudio, because of skype?

Offline

#3 2014-08-23 17:47:52

Ploppz
Member
Registered: 2013-09-14
Posts: 168

Re: [Solved] No more than one audio source at a time.

Disabling .asoundrc helped, thanks!

Offline

Board footer

Powered by FluxBB