You are not logged in.

#1 2006-02-06 17:19:19

eyolf
Member
From: Copenhagen
Registered: 2005-11-29
Posts: 336
Website

More xorg problems - missing Xresources

After the upgrade to xorg 7, the x apps like xterm, xman, and xscreensaver, don't work properly. They run fine, but the fonts aren't correct, and the colors don't work. They give the output:

Warning: Color name "black" is not defined
Warning: Cannot convert string "-adobe-helvetica-bold-r-normal--*-120-*-*-*-*-iso8859-*" to type FontStruct
xterm: Cannot allocate color red
xterm: Cannot allocate color red3

I suspect it has to do with some missing or misplaced files. In
/usr/share/X11/xinitrc, it says:

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/usr/share/X11/xinit/.Xresources
sysmodmap=/usr/share/X11/xinit/.Xmodmap

None of these files exist, at least not in the places indicated. The two system files are in /usr/share/X11/xdm and /usr/bin/ (with names without the initial dot, and with lower-case initials), and I don't have any files like that in the home directory.
I've tried to copy them to the indicated directories and give them "correct" names, but it doesn't seem to have had any effect.
I should say that it doesn't bother me that much, the only programs that seem to be affected by it are the x-only resources,
Any  clues? Should I change anything in any of those files, move files, copy them to my home directory? Is anyone else having this problem?

Offline

#2 2006-02-06 20:37:59

jaboua
Member
Registered: 2005-11-05
Posts: 634

Re: More xorg problems - missing Xresources

It's not xmodmap as it's the keyboard mapper (I know because I had to make one to get my multimedia keys working).

/usr/share/X11/xinit/.Xresources don't exist here either, but colors are working fine (xorg 6). Maybe the xorg configuration file has changed a little bit, have you re-run xorgconfig after you installed xorg 7?

Offline

#3 2006-02-06 20:38:35

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: More xorg problems - missing Xresources

Your paths in xorg.conf are wrong. Make sure your Files section in Xorg.conf looks similar to this:

Section "Files"
    RgbPath     "/usr/share/X11/rgb"

    FontPath   "/usr/share/fonts/local/"
    FontPath   "/usr/share/fonts/misc/"
    FontPath   "/usr/share/fonts/75dpi/:unscaled"
    FontPath   "/usr/share/fonts/100dpi/:unscaled"
    FontPath   "/usr/share/fonts/Type1/"
    FontPath   "/usr/share/fonts/75dpi/"
    FontPath   "/usr/share/fonts/100dpi/"       
        FontPath   "/usr/share/fonts/terminus"
        FontPath   "/usr/share/fonts/artwiz-fonts/"

        ModulePath "/usr/lib/xorg/modules"
EndSection

Offline

#4 2006-02-06 20:40:57

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: More xorg problems - missing Xresources

Did you change the RgbPath  and FontPath in xorg.conf? You need to change these in xorg7.

Offline

#5 2006-02-06 21:03:12

eyolf
Member
From: Copenhagen
Registered: 2005-11-29
Posts: 336
Website

Re: More xorg problems - missing Xresources

That was the culprit. I had changed the path, but I had also added .txt to the rgb - after a recommendation in some other thread. So the color problem is solved.
There stills seems to be an issue with the fonts, however. I have changed all the font paths to the correct ones, but I still get the following warning when I start xterm:

Warning: Cannot convert string "-adobe-helvetica-bold-r-normal--*-120-*-*-*-*-iso8859-*" to type FontStruct

and the option to use truetype fonts is greyed out in the menu. Where is this set?

Offline

Board footer

Powered by FluxBB