You are not logged in.

#1 2014-08-19 17:57:10

undersound
Member
Registered: 2014-08-12
Posts: 11

Adding undetected resolution - xrandr: Configure crtc 0 failed

FIrst time arch user here and I have trouble with setting my screen resolution for my primary screen. My second screen is a laptop screen with a working 1920x1080 resolution.

Problem:
I am trying to add a resolution of 1920x1080 for this primary screen as currently I am only offered 1600x1200 for this.
The resolution was recognized on a previous laptop running 10.04LTS with a KVM switch in between. I removed the KVM switch for now just to be sure that the switch is not causing the problem

Based on :
https://wiki.archlinux.org/index.php/xr … esolutions

I executed:

xrandr --newmode "1920x1200_60.00"  193.16  1920 2048 2256 2592  1200 1201 1204 1242  -HSync +Vsync
xrandr --addmode VGA1 1920x1200_60.00
xrandr --output VGA1 --mode 1920x1200_60.00

After that last command I receive:

xrandr: Configure crtc 0 failed

I guess my monitor is not sending the appropriate EDID but I am not sure what's the best way to continue now.
I have read about manually creating a /etc/X11/xorg.conf.d/10-monitor.conf file and also forcing modes https://wiki.archlinux.org/index.php/ke … s_and_EDID but until I had no luck with this.

My screen:
Nec MultiSync EA241WM


Output of xrandr:

Screen 0: minimum 8 x 8, current 3600 x 1080, maximum 32767 x 32767
eDP1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1920x1080     60.21*+  40.14  
   1400x1050     59.98  
   1280x1024     60.02  
   1280x960      60.00  
   1024x768      60.00  
   800x600       60.32    56.25  
   640x480       59.94  
VGA1 connected primary 1680x1050+1920+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1600x1200     60.00  
   1680x1050     59.95* 
   1400x1050     59.98  
   1280x1024     75.02    60.02  
   1440x900      59.89  
   1360x768      59.80  
   1152x864      75.00  
   1280x720      59.97  
   1024x768      75.08    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    60.00  
   720x400       70.08  
   1920x1200_60.00  60.00  
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Output /var/log/Xorg.0.log:

[  2402.183] 
X.Org X Server 1.16.0
Release Date: 2014-07-16
[  2402.186] X Protocol Version 11, Revision 0
[  2402.187] Build Operating System: Linux 3.15.5-2-ARCH x86_64 
[  2402.189] Current Operating System: Linux 3.15.8-1-ARCH #1 SMP PREEMPT Fri Aug 1 08:51:42 CEST 2014 x86_64
[  2402.189] Kernel command line: initrd=\initramfs-linux.img root=/dev/sda2 rw
[  2402.190] Build Date: 31 July 2014  11:53:19AM
[  2402.191]  
[  2402.192] Current version of pixman: 0.32.6
[  2402.193] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[  2402.193] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2402.196] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Aug 10 22:48:25 2014
[  2402.197] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  2402.198] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2402.198] (==) No Layout section.  Using the first Screen section.
[  2402.198] (==) No screen section available. Using defaults.
[  2402.198] (**) |-->Screen "Default Screen Section" (0)
[  2402.198] (**) |   |-->Monitor "<default monitor>"
[  2402.198] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[  2402.198] (==) Automatically adding devices
[  2402.198] (==) Automatically enabling devices
[  2402.198] (==) Automatically adding GPU devices
[  2402.198] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  2402.198] 	Entry deleted from font path.
[  2402.198] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  2402.198] 	Entry deleted from font path.
[  2402.198] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  2402.198] 	Entry deleted from font path.
[  2402.198] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[  2402.198] 	Entry deleted from font path.
[  2402.198] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[  2402.198] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[  2402.198] 	Entry deleted from font path.
[  2402.198] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[  2402.198] (==) FontPath set to:
	/usr/share/fonts/misc/
[  2402.198] (==) ModulePath set to "/usr/lib/xorg/modules"
[  2402.198] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[  2402.198] (II) Loader magic: 0x818d80
[  2402.198] (II) Module ABI versions:
[  2402.198] 	X.Org ANSI C Emulation: 0.4
[  2402.198] 	X.Org Video Driver: 18.0
[  2402.198] 	X.Org XInput driver : 21.0
[  2402.198] 	X.Org Server Extension : 8.0
[  2402.200] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c4
[  2402.200] (II) xfree86: Adding drm device (/dev/dri/card0)
[  2402.200] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
[  2402.201] (--) PCI:*(0:0:2:0) 8086:0416:1558:5455 rev 6, Mem @ 0xf7800000/4194304, 0xe0000000/268435456, I/O @ 0x0000f000/64
[  2402.201] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  2402.201] (II) LoadModule: "glx"
[  2402.201] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  2402.202] (II) Module glx: vendor="X.Org Foundation"
[  2402.202] 	compiled for 1.16.0, module version = 1.0.0
[  2402.202] 	ABI class: X.Org Server Extension, version 8.0
[  2402.202] (==) AIGLX enabled
[  2402.202] (==) Matched intel as autoconfigured driver 0
[  2402.202] (==) Matched intel as autoconfigured driver 1
[  2402.202] (==) Matched modesetting as autoconfigured driver 2
[  2402.202] (==) Matched fbdev as autoconfigured driver 3
[  2402.202] (==) Matched vesa as autoconfigured driver 4
[  2402.202] (==) Assigned the driver to the xf86ConfigLayout
[  2402.202] (II) LoadModule: "intel"
[  2402.202] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[  2402.202] (II) Module intel: vendor="X.Org Foundation"
[  2402.202] 	compiled for 1.16.0, module version = 2.99.914
[  2402.202] 	Module class: X.Org Video Driver
[  2402.202] 	ABI class: X.Org Video Driver, version 18.0
[  2402.202] (II) LoadModule: "modesetting"
[  2402.202] (WW) Warning, couldn't open module modesetting
[  2402.202] (II) UnloadModule: "modesetting"
[  2402.202] (II) Unloading modesetting
[  2402.202] (EE) Failed to load module "modesetting" (module does not exist, 0)
[  2402.202] (II) LoadModule: "fbdev"
[  2402.202] (WW) Warning, couldn't open module fbdev
[  2402.202] (II) UnloadModule: "fbdev"
[  2402.202] (II) Unloading fbdev
[  2402.202] (EE) Failed to load module "fbdev" (module does not exist, 0)
[  2402.202] (II) LoadModule: "vesa"
[  2402.202] (WW) Warning, couldn't open module vesa
[  2402.202] (II) UnloadModule: "vesa"
[  2402.202] (II) Unloading vesa
[  2402.202] (EE) Failed to load module "vesa" (module does not exist, 0)
[  2402.202] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[  2402.202] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[  2402.202] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[  2402.202] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[  2402.202] (++) using VT number 1

[  2402.202] (--) controlling tty is VT number 1, auto-enabling KeepTty
[  2402.202] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20080730
[  2402.203] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4600
[  2402.203] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2
[  2402.203] (II) intel(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[  2402.203] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[  2402.203] (==) intel(0): RGB weight 888
[  2402.203] (==) intel(0): Default visual is TrueColor
[  2402.203] (II) intel(0): Output eDP1 has no monitor section
[  2402.203] (--) intel(0): Found backlight control interface acpi_video0 (type 'firmware') for output eDP1
[  2402.203] (II) intel(0): Output VGA1 has no monitor section
[  2402.203] (II) intel(0): Output HDMI1 has no monitor section
[  2402.203] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[  2402.203] (II) intel(0): Output VIRTUAL1 has no monitor section
[  2402.203] (--) intel(0): Output eDP1 using initial mode 1920x1080 on pipe 0
[  2402.203] (==) intel(0): TearFree disabled
[  2402.203] (==) intel(0): DPI set to (96, 96)
[  2402.203] (II) Loading sub module "dri2"
[  2402.203] (II) LoadModule: "dri2"
[  2402.203] (II) Module "dri2" already built-in
[  2402.203] (II) Loading sub module "present"
[  2402.203] (II) LoadModule: "present"
[  2402.203] (II) Module "present" already built-in
[  2402.203] (==) Depth 24 pixmap format is 32 bpp
[  2402.203] (II) intel(0): SNA initialized with Haswell (gen7.5, gt2) backend
[  2402.203] (==) intel(0): Backing store enabled
[  2402.203] (==) intel(0): Silken mouse enabled
[  2402.203] (II) intel(0): HW Cursor enabled
[  2402.203] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[  2402.203] (==) intel(0): DPMS enabled
[  2402.203] (II) intel(0): [DRI2] Setup complete
[  2402.203] (II) intel(0): [DRI2]   DRI driver: i965
[  2402.203] (II) intel(0): [DRI2]   VDPAU driver: i965
[  2402.203] (II) intel(0): direct rendering: DRI2 enabled
[  2402.203] (II) intel(0): hardware support for Present enabled
[  2402.203] (==) intel(0): display hotplug detection enabled
[  2402.203] (--) RandR disabled
[  2402.219] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[  2402.219] (II) AIGLX: enabled GLX_ARB_create_context
[  2402.219] (II) AIGLX: enabled GLX_ARB_create_context_profile
[  2402.219] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[  2402.219] (II) AIGLX: enabled GLX_INTEL_swap_event
[  2402.219] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[  2402.219] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[  2402.219] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[  2402.219] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[  2402.219] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[  2402.219] (II) AIGLX: Loaded and initialized i965
[  2402.219] (II) GLX: Initialized DRI2 GL provider for screen 0
[  2402.220] (II) intel(0): switch to mode 1920x1080@60.2 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[  2402.233] (II) intel(0): Setting screen physical size to 508 x 285
[  2402.251] (II) config/udev: Adding input device Power Button (/dev/input/event4)
[  2402.251] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  2402.251] (II) LoadModule: "evdev"
[  2402.251] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[  2402.251] (II) Module evdev: vendor="X.Org Foundation"
[  2402.251] 	compiled for 1.16.0, module version = 2.9.0
[  2402.251] 	Module class: X.Org XInput Driver
[  2402.251] 	ABI class: X.Org XInput driver, version 21.0
[  2402.252] (II) systemd-logind: got fd for /dev/input/event4 13:68 fd 16 paused 0
[  2402.252] (II) Using input driver 'evdev' for 'Power Button'
[  2402.252] (**) Power Button: always reports core events
[  2402.252] (**) evdev: Power Button: Device: "/dev/input/event4"
[  2402.252] (--) evdev: Power Button: Vendor 0 Product 0x1
[  2402.252] (--) evdev: Power Button: Found keys
[  2402.252] (II) evdev: Power Button: Configuring as keyboard
[  2402.252] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input8/event4"
[  2402.252] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[  2402.252] (**) Option "xkb_rules" "evdev"
[  2402.252] (**) Option "xkb_model" "pc104"
[  2402.252] (**) Option "xkb_layout" "us"
[  2402.265] (II) config/udev: Adding input device Video Bus (/dev/input/event11)
[  2402.265] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[  2402.266] (II) systemd-logind: got fd for /dev/input/event11 13:75 fd 17 paused 0
[  2402.266] (II) Using input driver 'evdev' for 'Video Bus'
[  2402.266] (**) Video Bus: always reports core events
[  2402.266] (**) evdev: Video Bus: Device: "/dev/input/event11"
[  2402.266] (--) evdev: Video Bus: Vendor 0 Product 0x6
[  2402.266] (--) evdev: Video Bus: Found keys
[  2402.266] (II) evdev: Video Bus: Configuring as keyboard
[  2402.266] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input16/event11"
[  2402.266] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[  2402.266] (**) Option "xkb_rules" "evdev"
[  2402.266] (**) Option "xkb_model" "pc104"
[  2402.266] (**) Option "xkb_layout" "us"
[  2402.266] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[  2402.266] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  2402.266] (II) systemd-logind: got fd for /dev/input/event1 13:65 fd 18 paused 0
[  2402.266] (II) Using input driver 'evdev' for 'Power Button'
[  2402.266] (**) Power Button: always reports core events
[  2402.266] (**) evdev: Power Button: Device: "/dev/input/event1"
[  2402.266] (--) evdev: Power Button: Vendor 0 Product 0x1
[  2402.266] (--) evdev: Power Button: Found keys
[  2402.266] (II) evdev: Power Button: Configuring as keyboard
[  2402.266] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input5/event1"
[  2402.266] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 8)
[  2402.266] (**) Option "xkb_rules" "evdev"
[  2402.266] (**) Option "xkb_model" "pc104"
[  2402.266] (**) Option "xkb_layout" "us"
[  2402.267] (II) config/udev: Adding input device Lid Switch (/dev/input/event3)
[  2402.267] (II) No input driver specified, ignoring this device.
[  2402.267] (II) This device may have been added with another device file.
[  2402.267] (II) config/udev: Adding input device Sleep Button (/dev/input/event2)
[  2402.267] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[  2402.267] (II) systemd-logind: got fd for /dev/input/event2 13:66 fd 19 paused 0
[  2402.267] (II) Using input driver 'evdev' for 'Sleep Button'
[  2402.267] (**) Sleep Button: always reports core events
[  2402.267] (**) evdev: Sleep Button: Device: "/dev/input/event2"
[  2402.267] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[  2402.267] (--) evdev: Sleep Button: Found keys
[  2402.267] (II) evdev: Sleep Button: Configuring as keyboard
[  2402.267] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input6/event2"
[  2402.267] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 9)
[  2402.267] (**) Option "xkb_rules" "evdev"
[  2402.267] (**) Option "xkb_model" "pc104"
[  2402.267] (**) Option "xkb_layout" "us"
[  2402.268] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=3 (/dev/input/event12)
[  2402.268] (II) No input driver specified, ignoring this device.
[  2402.268] (II) This device may have been added with another device file.
[  2402.268] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=7 (/dev/input/event13)
[  2402.268] (II) No input driver specified, ignoring this device.
[  2402.268] (II) This device may have been added with another device file.
[  2402.268] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=8 (/dev/input/event14)
[  2402.268] (II) No input driver specified, ignoring this device.
[  2402.268] (II) This device may have been added with another device file.
[  2402.268] (II) config/udev: Adding input device Chicony USB 2.0 Camera (/dev/input/event9)
[  2402.268] (**) Chicony USB 2.0 Camera: Applying InputClass "evdev keyboard catchall"
[  2402.268] (II) systemd-logind: got fd for /dev/input/event9 13:73 fd 20 paused 0
[  2402.268] (II) Using input driver 'evdev' for 'Chicony USB 2.0 Camera'
[  2402.268] (**) Chicony USB 2.0 Camera: always reports core events
[  2402.268] (**) evdev: Chicony USB 2.0 Camera: Device: "/dev/input/event9"
[  2402.268] (--) evdev: Chicony USB 2.0 Camera: Vendor 0x4f2 Product 0xb35a
[  2402.268] (--) evdev: Chicony USB 2.0 Camera: Found keys
[  2402.268] (II) evdev: Chicony USB 2.0 Camera: Configuring as keyboard
[  2402.268] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-8/1-8:1.0/input/input15/event9"
[  2402.268] (II) XINPUT: Adding extended input device "Chicony USB 2.0 Camera" (type: KEYBOARD, id 10)
[  2402.268] (**) Option "xkb_rules" "evdev"
[  2402.268] (**) Option "xkb_model" "pc104"
[  2402.268] (**) Option "xkb_layout" "us"
[  2402.269] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event6)
[  2402.269] (II) No input driver specified, ignoring this device.
[  2402.269] (II) This device may have been added with another device file.
[  2402.269] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event7)
[  2402.269] (II) No input driver specified, ignoring this device.
[  2402.269] (II) This device may have been added with another device file.
[  2402.269] (II) config/udev: Adding input device HDA Intel PCH Front Headphone (/dev/input/event8)
[  2402.269] (II) No input driver specified, ignoring this device.
[  2402.269] (II) This device may have been added with another device file.
[  2402.269] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[  2402.269] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[  2402.269] (II) systemd-logind: got fd for /dev/input/event0 13:64 fd 21 paused 0
[  2402.269] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[  2402.269] (**) AT Translated Set 2 keyboard: always reports core events
[  2402.269] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[  2402.269] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[  2402.269] (--) evdev: AT Translated Set 2 keyboard: Found keys
[  2402.269] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[  2402.269] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[  2402.269] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 11)
[  2402.269] (**) Option "xkb_rules" "evdev"
[  2402.269] (**) Option "xkb_model" "pc104"
[  2402.269] (**) Option "xkb_layout" "us"
[  2402.270] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event10)
[  2402.270] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[  2402.270] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[  2402.270] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[  2402.270] (II) LoadModule: "synaptics"
[  2402.270] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[  2402.270] (II) Module synaptics: vendor="X.Org Foundation"
[  2402.270] 	compiled for 1.16.0, module version = 1.8.0
[  2402.270] 	Module class: X.Org XInput Driver
[  2402.270] 	ABI class: X.Org XInput driver, version 21.0
[  2402.270] (II) systemd-logind: got fd for /dev/input/event10 13:74 fd 22 paused 0
[  2402.270] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[  2402.270] (**) SynPS/2 Synaptics TouchPad: always reports core events
[  2402.270] (**) Option "Device" "/dev/input/event10"
[  2402.356] (II) synaptics: SynPS/2 Synaptics TouchPad: ignoring touch events for semi-multitouch device
[  2402.356] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5692 (res 66)
[  2402.356] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4680 (res 102)
[  2402.356] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[  2402.356] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[  2402.356] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right double triple
[  2402.356] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[  2402.356] (**) Option "TapButton1" "1"
[  2402.356] (**) Option "TapButton2" "2"
[  2402.356] (**) Option "TapButton3" "3"
[  2402.356] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[  2402.356] (**) SynPS/2 Synaptics TouchPad: always reports core events
[  2402.356] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio2/input/input11/event10"
[  2402.356] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 12)
[  2402.356] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[  2402.356] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MaxSpeed is now 1.75
[  2402.356] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) AccelFactor is now 0.037
[  2402.356] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[  2402.356] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[  2402.356] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[  2402.356] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[  2402.356] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[  2402.357] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[  2402.357] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
[  2402.357] (II) config/udev: Adding input device PC Speaker (/dev/input/event5)
[  2402.357] (II) No input driver specified, ignoring this device.
[  2402.357] (II) This device may have been added with another device file.
[  2447.861] (II) UnloadModule: "synaptics"
[  2447.861] (II) systemd-logind: releasing fd for 13:74
[  2447.929] (II) evdev: AT Translated Set 2 keyboard: Close
[  2447.929] (II) UnloadModule: "evdev"
[  2447.929] (II) systemd-logind: releasing fd for 13:64
[  2448.009] (II) evdev: Chicony USB 2.0 Camera: Close
[  2448.009] (II) UnloadModule: "evdev"
[  2448.009] (II) systemd-logind: releasing fd for 13:73
[  2448.089] (II) evdev: Sleep Button: Close
[  2448.089] (II) UnloadModule: "evdev"
[  2448.089] (II) systemd-logind: releasing fd for 13:66
[  2448.129] (II) evdev: Power Button: Close
[  2448.129] (II) UnloadModule: "evdev"
[  2448.129] (II) systemd-logind: releasing fd for 13:65
[  2448.169] (II) evdev: Video Bus: Close
[  2448.169] (II) UnloadModule: "evdev"
[  2448.169] (II) systemd-logind: releasing fd for 13:75
[  2448.209] (II) evdev: Power Button: Close
[  2448.209] (II) UnloadModule: "evdev"
[  2448.209] (II) systemd-logind: releasing fd for 13:68
[  2449.439] (EE) Server terminated successfully (0). Closing log file.

Last edited by undersound (2014-08-19 18:00:15)

Offline

#2 2014-08-19 19:31:51

Andy_Crowd
Member
From: 延雪平縣 Sweden
Registered: 2013-12-28
Posts: 119

Re: Adding undetected resolution - xrandr: Configure crtc 0 failed

You can try arandr it might help to manage xrandr little better. It is a gui for xrandr and can save settings as bash scripts with per-configured command line for xrandr, for faster change/set up of wanted resolutions.


Help to make Arora bug free!!
日不落 | Year 2081 | 笑傲江湖 | One more a really good book in my collection the Drystoll.

Offline

#3 2014-08-19 20:10:09

undersound
Member
Registered: 2014-08-12
Posts: 11

Re: Adding undetected resolution - xrandr: Configure crtc 0 failed

Thanks for the advice. Unfortuantely it doesn't fix the problem

Offline

#4 2014-08-19 21:05:52

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: Adding undetected resolution - xrandr: Configure crtc 0 failed

undersound wrote:

I guess my monitor is not sending the appropriate EDID but I am not sure what's the best way to continue now.

To confirm that, run

xrandr --props

You can use 'edid-decode' from AUR git package to read the information, post it here anyway.

Offline

#5 2014-08-19 21:27:57

undersound
Member
Registered: 2014-08-12
Posts: 11

Re: Adding undetected resolution - xrandr: Configure crtc 0 failed

Thanks, here are both outputs:


xrandr --props:

Screen 0: minimum 8 x 8, current 3600 x 1080, maximum 32767 x 32767
eDP1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
	_MUTTER_PRESENTATION_OUTPUT: 0 
	EDID: 
		00ffffffffffff0006afed1200000000
		00160104952213780206959757539426
		1c505400000001010101010101010101
		0101010101013c3780c0703820403064
		8e0058c110000018d32480c070382040
		30648e0058c110000018000000fe0041
		554f0a202020202020202020000000fe
		004231353648414e30312e32200a0022
	BACKLIGHT: 4882 
		range: (0, 4882)
	Backlight: 4882 
		range: (0, 4882)
	scaling mode: Full aspect 
		supported: None, Full, Center, Full aspect
	Broadcast RGB: Automatic 
		supported: Automatic, Full, Limited 16:235
	audio: auto 
		supported: force-dvi, off, auto, on
   1920x1080     60.21*+  40.14  
   1400x1050     59.98  
   1280x1024     60.02  
   1280x960      60.00  
   1024x768      60.00  
   800x600       60.32    56.25  
   640x480       59.94  
VGA1 connected primary 1680x1050+1920+0 (normal left inverted right x axis y axis) 518mm x 324mm
	EDID: 
		00ffffffffffff0038a34e6701010101
		101401030e342078ea9ef5a6564b9a25
		125054bfef8081c0818090408bc09500
		a940b300d1007d4b80a072b02d4088c8
		360006442100001c000000fd00384c1f
		5214000a202020202020000000fc0045
		41323431574d0a2020202020000000ff
		0030343130393234304e420a20200082
	_MUTTER_PRESENTATION_OUTPUT: 0 
   1600x1200     60.00  
   1680x1050     59.95* 
   1400x1050     59.98  
   1280x1024     75.02    60.02  
   1440x900      59.89  
   1360x768      59.80  
   1152x864      75.00  
   1280x720      59.97  
   1024x768      75.08    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    60.00  
   720x400       70.08  
HDMI1 disconnected (normal left inverted right x axis y axis)
	Broadcast RGB: Automatic 
		supported: Automatic, Full, Limited 16:235
	audio: auto 
		supported: force-dvi, off, auto, on
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

xrandr --props | edid-decode:

Extracted contents:
header:          00 ff ff ff ff ff ff 00
serial number:   06 af ed 12 00 00 00 00 00 16
version:         01 04
basic params:    95 22 13 78 02
chroma info:     06 95 97 57 53 94 26 1c 50 54
established:     00 00 00
standard:        01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01
descriptor 1:    3c 37 80 c0 70 38 20 40 30 64 8e 00 58 c1 10 00 00 18
descriptor 2:    d3 24 80 c0 70 38 20 40 30 64 8e 00 58 c1 10 00 00 18
descriptor 3:    00 00 00 fe 00 41 55 4f 0a 20 20 20 20 20 20 20 20 20
descriptor 4:    00 00 00 fe 00 42 31 35 36 48 41 4e 30 31 2e 32 20 0a
extensions:      00
checksum:        22

Manufacturer: AUO Model 12ed Serial Number 0
Made week 0 of 2012
EDID version: 1.4
Digital display
6 bits per primary color channel
DisplayPort interface
Maximum image size: 34 cm x 19 cm
Gamma: 2.20
Supported color formats: RGB 4:4:4
First detailed timing is preferred timing
Established timings supported:
Standard timings supported:
Detailed mode: Clock 141.400 MHz, 344 mm x 193 mm
               1920 1968 2068 2112 hborder 0
               1080 1088 1102 1112 vborder 0
               -hsync -vsync 
Detailed mode: Clock 94.270 MHz, 344 mm x 193 mm
               1920 1968 2068 2112 hborder 0
               1080 1088 1102 1112 vborder 0
               -hsync -vsync 
ASCII string: AUO
ASCII string: B156HAN01
Checksum: 0x22 (valid)
EDID block does NOT conform to EDID 1.3!
	Missing name descriptor
	Missing monitor ranges
	Detailed block string not properly terminated

Offline

#6 2014-08-19 22:07:25

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: Adding undetected resolution - xrandr: Configure crtc 0 failed

That EDID was for the eDP1 not VGA1.

Extracted contents:
header:          00 ff ff ff ff ff ff 00
serial number:   38 a3 4e 67 01 01 01 01 10 14
version:         01 03
basic params:    0e 34 20 78 ea
chroma info:     9e f5 a6 56 4b 9a 25 12 50 54
established:     bf ef 80
standard:        81 c0 81 80 90 40 8b c0 95 00 a9 40 b3 00 d1 00
descriptor 1:    7d 4b 80 a0 72 b0 2d 40 88 c8 36 00 06 44 21 00 00 1c
descriptor 2:    00 00 00 fd 00 38 4c 1f 52 14 00 0a 20 20 20 20 20 20
descriptor 3:    00 00 00 fc 00 45 41 32 34 31 57 4d 0a 20 20 20 20 20
descriptor 4:    00 00 00 ff 00 30 34 31 30 39 32 34 30 4e 42 0a 20 20
extensions:      00
checksum:        82

Manufacturer: NEC Model 674e Serial Number 16843009
Made week 16 of 2010
EDID version: 1.3
Analog display, Input voltage level: 0.7/0.3 V
Sync: Separate Composite SyncOnGreen 
Maximum image size: 52 cm x 32 cm
Gamma: 2.20
DPMS levels: Standby Suspend Off
RGB color display
First detailed timing is preferred timing
Established timings supported:
  720x400@70Hz
  640x480@60Hz
  640x480@67Hz
  640x480@72Hz
  640x480@75Hz
  800x600@56Hz
  800x600@60Hz
  800x600@72Hz
  800x600@75Hz
  832x624@75Hz
  1024x768@60Hz
  1024x768@70Hz
  1024x768@75Hz
  1280x1024@75Hz
  1152x870@75Hz
Standard timings supported:
  1280x720@60Hz
  1280x1024@60Hz
  1400x1050@60Hz
  1360x765@60Hz
  1440x900@60Hz
  1600x1200@60Hz
  1680x1050@60Hz
  1920x1200@60Hz
Detailed mode: Clock 193.250 MHz, 518 mm x 324 mm
               1920 2056 2256 2592 hborder 0
               1200 1203 1209 1245 vborder 0
               -hsync +vsync 
Monitor ranges (GTF): 56-76Hz V, 31-82kHz H, max dotclock 200MHz
Monitor name: EA241WM
Serial number: 04109240NB
Checksum: 0x82 (valid)

Try using these instead:

"1920x1200_60.00"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync
"1920x1200R"  154.00  1920 1968 2000 2080  1200 1203 1209 1235 +hsync -vsync

You could always try to figure out how Ubuntu or Mint does it.

Here is something that probably will be of interest to you, untested.

Edit: Try setting that resolution with only VGA1 connected, ergo with eDP1 disconnected.

Last edited by emeres (2014-08-19 22:09:26)

Offline

#7 2014-08-20 02:11:49

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,458

Re: Adding undetected resolution - xrandr: Configure crtc 0 failed

Andy_Crowd wrote:

You can try...

Moderator comment:

Andy_Crowd:  Posting here hoping to get your attention.  Please update your email address - I responded to your PM, but it bounced


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#8 2014-08-20 17:49:24

undersound
Member
Registered: 2014-08-12
Posts: 11

Re: Adding undetected resolution - xrandr: Configure crtc 0 failed

emeres wrote:

That EDID was for the eDP1 not VGA1.

thanks must have copied the wrong one

Can't believe I overlooked on this but I think the whole problem with this is that my screen's native resolution is 1920x1200 and my video card only support up to 1920x1080.

Could this be the problem?

Offline

#9 2014-08-20 18:08:20

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: Adding undetected resolution - xrandr: Configure crtc 0 failed

undersound wrote:

Can't believe I overlooked on this but I think the whole problem with this is that my screen's native resolution is 1920x1200 and my video card only support up to 1920x1080.

Could this be the problem?

I cannot decide if I should answer "You think?" or simply "Yes.". You do realize that many people invest their free time here? Get really good at something in [Arch] Linux and help others out, then you will be forgiven.

@ewaller try here:
https://bbs.archlinux.org/viewtopic.php?id=185748

Offline

#10 2014-08-20 19:45:57

undersound
Member
Registered: 2014-08-12
Posts: 11

Re: Adding undetected resolution - xrandr: Configure crtc 0 failed

Thanks for your help.

Offline

#11 2014-08-20 19:55:55

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: Adding undetected resolution - xrandr: Configure crtc 0 failed

You are welcome.

Offline

#12 2014-08-20 20:52:53

undersound
Member
Registered: 2014-08-12
Posts: 11

Re: Adding undetected resolution - xrandr: Configure crtc 0 failed

It works.

After trying your suggestion:

"1920x1200_60.00"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync

I got the following error message:

BadName (named color or font does not exist) 

Which led me to this post.

Summary in there is to use a new name:

xrandr --newmode "newname"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 1080 -hsync +vsync

When enabling the eDP1 screen again via Preferences -> Display I saw 1920x1200 available as an option for the VGA1. Selected that and resolution is properly being applied now.

Thanks again for your time and help.

Last edited by undersound (2014-08-20 20:54:38)

Offline

#13 2014-08-20 21:09:04

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: Adding undetected resolution - xrandr: Configure crtc 0 failed

So this limit was either an understatement from the manufacturer or a reference to a specific part/socket of the video card. You could notice image degradation however. Take a look here.

Offline

Board footer

Powered by FluxBB