You are not logged in.

#1 2014-08-29 14:51:38

Registered: 2013-11-18
Posts: 3

EFI-gpt system suddenly unable to boot via grub2

I had been an arch user for quite a while, about an year or so, and never had this kind of problem, until three days ago.
I switched off my computer and, when booted it up again it wouldn't boot in efi mode.

Let me be more clear here: i had an ssd (samsung ssd 840 evo, 250 Gb), it was where the system resided. I had also an hdd (WDC WD10EZEX-08M2NA0); there i had my data partition.

From the ssd i had dual-booting with windows, but it was installed later on the system, and i had a dd-copy of the ssd partitons before the windows installation. It was stored inside the hdd.

Here was my partition table (gpt for both drives):

sda: The hdd
sda1: 1Gb, 8300, mount point: none, filesystem: none
sda2: 50Gb, 8300, mount point: none, filesystem: ext4
sda3: 870Gb, 8300, mount point: /home, filesystem: ext4

sdb: The ssd
sdb1: 1Gb, ef00, mount point: /boot/efi, filesystem: fat32
sdb2: 2Gb, 8300, mount point: /boot, filesystem: ext4
sdb3: 4Gb, 8200, swap
sdb4: 50Gb, 8300, mount point: /, filesystem: ext4
sdb5: 50Gb, 8300, mount point: none, filesystem: ext4
sdb6: 20Gb, 8300, mount point: /home/build, filesystem: ext4
sdb7: 100Gb, i don't remember anything about this partition, sorry...

As you can see, i had some unused partition only for recovery purpose (sda1 and sda2 were designed to host an os in the undesirable scenario where my ssd broke in any way)

sdb7 contained windows, while sdb5 was created to test other linux distros.

All this may be completely reduntant for my problem, but i think it has something to do with it.
Before installing windows in sdb7, as i wrote before, i made a dd copy of sdb1, sdb2 and sdb4 (and stored the files in sda3), because in case of any partition corruption, i would have my system back on in a few steps.

Still, the windows installation wasn't a problem for the setup.

The problem began to appear 3 days ago, after the usual procedure (i use to do it every day): shutdown before bed, powerup after waking up: the motherboard was not able to read the bootloader.

The motherboard is an AsRock FM2A75 pro4

The bootloader i use(d) is grub (to be read as grub2).

My first idea was that an upgrade (pacman -Syu) broke my system, so i started trying to recover it. The first thing i tried was to boot from a live usb stick (knoppix was my first choice), an it booted up perfectly. So, i started checking the partitions for errors, but none appeared. So i tried to restore the dd copies. Still no success.

Then i begun trying to boot from different distros, to see if it was a problem with a grub upgrade. It was not (mint, slack, ubuntu, debian and fedora boot fine from the usb stick, both in bios and efi mode, if supported by the distro; i still didn't try to boot from cd).

At this point i became a bit confused (a day had passed), and decided to reinstall arch from the base (in efi mode, on the ssd). It did not work. Tried the same with other distros, no success.

So i began to think it was an ssd problem: tried to install in efi mode on the hdd, first arch and then mint. Still no success.

I wrote a new msdos partition table for the ssd, deleting the gpt. Then tried installing mint, with grub on the mbr. Success. Same with arch.

Now, that's great, but i want a gpt-efi system, so it will be easier to multi-boot and to install multiple bootloaders.

Does anyone have an idea of what is going on?
(i had not changed any configuration on my motherboard, until the problem happened)

thanks in advance for any help.

EDIT: even if i'm pretty sure the first partition of the ssd drive (in the partition table, sdb1) was marked as "EFI System" (code ef00), a friend of mine made me notice that gparted did not recognise the partition type, marking it as "unknown type" or something. I checked and gparted does recognise ef00 partition type, while it doesn't recognise ef02 ("BIOS boot partition", aka the partition type needed to boot in a "legacy BIOS way" grub2 residing in a hard drive with gpt).

This might mean that the motherboard doesn't support UEFI boot from the hard drives (unless, obviously, there is windows inside; also, it appears that the mobo "may" boot if the hard drives are formatted with RAID. I still don't know why).
Hope this gives you a hint about what's going on, because it doesn't help me.

Last edited by pertica (2014-08-30 14:36:58)


#2 2014-09-06 11:41:37

Registered: 2013-11-18
Posts: 3

Re: EFI-gpt system suddenly unable to boot via grub2

I'm really sorry that, apparently, i wasn't able to supply enough information to figure out what's going on.
The problem hasn't really been solved, i have now a working arch system installed on the ssd just because it has an mbr partition table.
It's not a solution to the problem, so i didn't mark the topic as solved.
Tell me if i have to.


Board footer

Powered by FluxBB