You are not logged in.

#1 2014-09-10 11:36:05

Registered: 2009-03-19
Posts: 891

[solved] /usr/bin/time missing (/wandering)?


man time lists several options for the time command that don't work. man time also says:

Note:  some  shells  (e.g., bash(1)) have a built-in time command that provides less functionality than the
       command described here.  To access the real command, you may need to specify its pathname  (something  like

There is no "time" there.
Where do I find time and why is the man page lying to me?
Is this a packaging / core utils problem (man page should not be included / or /usr/bin/time should be included )?
Or am I doing it wrong? I was.

which time says:

$ which time
time: shell reserved word

edit: on my third attempt I finally got "pkgfile" to --update and found out that "time" is currently residing in the "time" package in extra -.-"
( "time" is a PITA of a search keyword :3 )

Anyway... why was the man page there when the package was not installed? I'm very confused now.  Was it moved from one package to another while I wasn't looking?
Can't figure out why a script I wrote some years ago stopped working even though I never removed or installed the [time] package according to the logs... so I must have messed something up. Just don't know what...

Last edited by whoops (2014-09-10 13:58:34)


#2 2014-09-10 12:27:28

Registered: 2009-05-06
Posts: 25,440

Re: [solved] /usr/bin/time missing (/wandering)?

It clearly says it's a shell keyword:

$ type time
time is a shell keyword

not a package.
I do have 'time' package installed and it shows up fine:

$ which time

What exactly is the problem? If you want help with your script - post it.

Edit: As for the man page:

$ pacman -Qo /usr/share/man/man1/time.1.gz
/usr/share/man/man1/time.1.gz is owned by man-pages 3.72-1

Last edited by karol (2014-09-10 12:29:42)


#3 2014-09-10 12:30:42

Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 12,137

Re: [solved] /usr/bin/time missing (/wandering)?

whoops wrote:

Was it moved from one package to another while I wasn't looking?

Only if you've had your eyes closed since (before?) 2008. wink

As for why you have the manpage:

pacman -Qo /usr/share/man/man1/time.1.gz
/usr/share/man/man1/time.1.gz is owned by man-pages 3.71-1

Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.


#4 2014-09-10 13:57:51

Registered: 2009-03-19
Posts: 891

Re: [solved] /usr/bin/time missing (/wandering)?

Thanks! Looking back further than 2008 (/when I installed arch) solved the mystery!

karol wrote:

What exactly is the problem? If you want help with your script - post it.

Just tried to figure out exactly *why* my script stopped working because the total absence of "time" in my pacman log even though it used to work was sort of suspicious.

( And the answer just in case anyone's curious: I found about 34 ancient binaries (~2005) from unknown sources in /opt/bin - I probably copied them there from the Internets(tm) whenever I couldn't find a program on my ancient SUSE cd's and the PATH somehow made the transition from SUSE to Debian and from DEBIAN to arch but got lost when I switched from bash to zsh and cleaned stuff up. And that's why my script that "used to work" didn't any more. The things I messed up over the years and that are still around on my machine don't cease to amaze big_smile . Got rid of those old & potentially dangerous binaries and as a byproduct also figured out why I had "ssed" instead of "sed" in some of my old scripts and why it didn't work... => solved )

Last edited by whoops (2014-09-10 13:58:14)


Board footer

Powered by FluxBB