You are not logged in.

#1 2014-09-10 22:33:34

0X1A
Member
Registered: 2013-03-27
Posts: 43

[Solved] gnome-boxes: cannot create a VM

Currently cannot get gnome-boxes to work, even with the libvirt daemon running. Also, the current wiki page for libvirt doesn't make a bit of sense. Am I supposed to change the group in

/etc/libvirt/qemu.conf

to libvirt or qemu?

Error I currently get when running gnome-boxes as a user in the group user is:

(gnome-boxes:3743): Boxes-WARNING **: libvirt-broker.vala:90: Unable to open qemu+unix:///session: Failed to connect socket to '/run/user/1000/libvirt/libvirt-sock': No such file or directory

Last edited by 0X1A (2014-12-31 16:56:41)

Offline

#2 2014-09-11 16:52:30

gnunn
Member
Registered: 2013-10-21
Posts: 69

Re: [Solved] gnome-boxes: cannot create a VM

AFAIK gnome-boxes only supports session and not system scope so don't both with the daemon. Open a terminal and type the following:

libvirtd -d

Then try running boxes and see if it works.

Offline

#3 2014-09-16 19:14:33

gnunn
Member
Registered: 2013-10-21
Posts: 69

Re: [Solved] gnome-boxes: cannot create a VM

Just following up on this, after doing further reading it sounds like libvirtd should start automatically when using the qemu://session scope. I suspect the issue is related to the XDG_RUNTIME_DIR variable, I found the following bug report for Ubuntu which describes the issue well but still need to do some investigation on how to fix this in Arch

https://bugs.launchpad.net/ubuntu/+sour … ug/1074418

Offline

#4 2014-09-18 17:44:54

bricewge
Member
Registered: 2014-06-16
Posts: 1

Re: [Solved] gnome-boxes: cannot create a VM

Downgrading to libvirt 1.2.7-1 solved it for me. The actual version, 1.2.8-1, is bugged https://bugs.archlinux.org/task/30682.

Offline

#5 2014-09-26 06:42:59

ctown.myth
Member
Registered: 2010-02-10
Posts: 166

Re: [Solved] gnome-boxes: cannot create a VM

bricewge wrote:

Downgrading to libvirt 1.2.7-1 solved it for me. The actual version, 1.2.8-1, is bugged https://bugs.archlinux.org/task/30682.

The linked bug report is an old one, closed now. Here's a bug report for the current version: https://bugs.archlinux.org/task/42119.


AKA MyCookie!

Offline

Board footer

Powered by FluxBB