You are not logged in.

#26 2014-10-04 01:35:27

xingxing
Member
Registered: 2014-10-04
Posts: 1

Re: Virtualbox Segfault on Startup

You really saved me! Maybe someone familiar with the rules could add it to the wiki under troubleshooting. I looked there first. Thanks again!

Offline

#27 2014-10-04 11:53:58

alexdw
Member
Registered: 2013-03-25
Posts: 46

Re: Virtualbox Segfault on Startup

Just another message of thanks for posting this - had the same issue and now fixed as a result of this thread. smile

Offline

#28 2014-10-04 17:57:46

Vamp898
Member
From: ドイツではまだ住んでいる
Registered: 2009-01-03
Posts: 866
Website

Re: Virtualbox Segfault on Startup

I installed the VirtualBox Extension from the VirtualBox Homepage and hit this issue.

In my oppinion this is VirtualBox's fault, it should warn that the Extensions are outdated when you start it rather than segfaulting when you run a VM.

Offline

#29 2014-11-02 23:33:58

wrm
Member
From: Europe
Registered: 2005-06-09
Posts: 19

Re: Virtualbox Segfault on Startup

Thanks again!

yaourt -S virtualbox-ext-oracle did the fix!


knowledge is p0wer..

Offline

#30 2014-12-22 22:09:03

bartonc
Member
From: Minden, Nevada, USA
Registered: 2012-02-27
Posts: 25

Re: Virtualbox Segfault on Startup

bartonc wrote:

But...
There seems to be a regression on the Oracle side that break Direct3D.
I run Windows 7 VM with 3D acceleration on and use the "tick [] Direct3D Support checkbox then answer {No} in the virtualbox-guest-iso setup dialog" trick in order to get Aero working.
That breaks with this update. I'm currently reverting back to 4.3.14-4. We'll see how that goes.

UPDATE: I've got Aero back after reverting the virtualbox package to 4.3.14-4 and doing a custom PKGBUILD of virtualbox-ext-oracle .
               I've commented in the Oracle forum here
Barton

Here we are at 4.3.20 and this is still an issue, but I have found the root cause:
(See the bug report)
Ever since 4.3.16 there has been a regression affecting nVidia systems (it is unknown if this is true for nouveau - I was using the proprietary drivers).
I've pulled my video card and reverted to xf86-video-intel (i5 dell) i915 and no longer have to revert virtualbox and virtualbox-ext-oracle packages after updates!
For older systems running nVidia cards and proprietary drivers with this issue, perhaps the best first step may be trying the xf86-video-nouveau package.

Last edited by bartonc (2014-12-26 22:41:37)

Offline

#31 2015-03-03 23:44:05

bendavis78
Member
Registered: 2014-06-21
Posts: 39

Re: Virtualbox Segfault on Startup

I'm having this same issue, however installing virtualbox-ext-oracle from AUR did not fix the problem.

dmesg output:

[ 6854.675774] EMT[13644]: segfault at 1c ip 00007f4901128de9 sp 00007f49351d9c00 error 4 in VBoxDD.so[7f4901086000+17a000]

Offline

#32 2015-03-04 22:24:56

bartonc
Member
From: Minden, Nevada, USA
Registered: 2012-02-27
Posts: 25

Re: Virtualbox Segfault on Startup

bendavis78 wrote:

I'm having this same issue, however installing virtualbox-ext-oracle from AUR did not fix the problem.

dmesg output:

[ 6854.675774] EMT[13644]: segfault at 1c ip 00007f4901128de9 sp 00007f49351d9c00 error 4 in VBoxDD.so[7f4901086000+17a000]

Please supply

pacman -Qs virtualbox | grep local

Here's mine:

local/virtualbox 4.3.20-5
local/virtualbox-ext-oracle 4.3.20-1
local/virtualbox-guest-iso 4.3.20-1
local/virtualbox-host-modules 4.3.20-8

As well as

uname -a

as in

Linux Bridger 3.18.6-1-ARCH #1 SMP PREEMPT Sat Feb 7 08:44:05 CET 2015 x86_64 GNU/Linux

Offline

Board footer

Powered by FluxBB