You are not logged in.

#1 2014-09-13 18:07:17

DavidEGrayson
Member
Registered: 2012-12-11
Posts: 10

[SOLVED] libbaloo4 and baloo are in conflict

Hello.  I tried to upgrade my x86 arch installation this morning by running "sudo pacman -Syu".  Here is the output:

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
:: Replace glamor-egl with extra/xorg-server? [Y/n] 
:: Replace kactivities with extra/kactivities4? [Y/n] 
:: Replace kdenetwork-kdnssd with extra/kdenetwork-zeroconf-ioslave? [Y/n] 
:: Replace kdeutils-kwallet with extra/kdeutils-kwalletmanager? [Y/n] 
:: Replace libusbx with core/libusb? [Y/n] 
:: Replace lzo2 with core/lzo? [Y/n] 
:: Replace phonon-vlc with extra/phonon-qt4-vlc? [Y/n] 
:: Replace polkit-qt with extra/polkit-qt4? [Y/n] 
:: Replace shared-color-profiles with extra/colord? [Y/n] 
:: Replace twisted with extra/python2-twisted? [Y/n] 
resolving dependencies...
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency
looking for inter-conflicts...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: libbaloo4 and baloo are in conflict (baloo<=4.14.0-1)

So does anyone know how I can fix this problem so that I can update all the packages on my system?

I don't have any baloo packages installed right now.  I ran "pacman -Q | grep baloo" and it showed nothing.

I looked into it a little bit:

I'm using KDE, and some of their packages depend on baloo-widgets (which must be a recent change), so that is probably the root cause of my problem.

baloo-widgets is at 4.14.0-1.
baloo is at version 4.14.0-1.

baloo4-widgets is at version 4.14.0-1, provides replaces and conflicts with baloo-widgets,
libbaloo4 is at version 4.14.0-3, and conflicts with baloo<=4.14.0-1
baloo4 is at version 4.14.0-3, conflicts with baloo<=4.14.0-1, and is supposed to provide and replace baloo.

The three baloo4 packages were updated less than 24 hours ago by Andrea Scarpino (2014-09-13 07:35 UTC).  I'm not sure when they were created.

This thread from 11 hours ago seems to be related: baloo4 update and not more necessary.

I don't update my Arch system very often. It's possible that the last time I updated was before 2014-08-20, which was the last time the old baloo packages were updated.

I tried to install baloo4-widgets manually but got a weird error:

$ sudo pacman -S baloo4-widgets
resolving dependencies...
looking for inter-conflicts...

Packages (4): kfilemetadata-4.14.0-1  libbaloo4-4.14.0-3  xapian-core-1:1.2.18-1  baloo4-widgets-4.14.0-1

Total Download Size:    0.38 MiB
Total Installed Size:   9.30 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages ...
 kfilemetadata-4.14.0-1-x86_64                        68.0 KiB   267K/s 00:00 [############################################] 100%
 libbaloo4-4.14.0-3-x86_64                           262.7 KiB   535K/s 00:00 [############################################] 100%
 baloo4-widgets-4.14.0-1-x86_64                       57.3 KiB  9.33M/s 00:00 [############################################] 100%
(4/4) checking keys in keyring                                                [############################################] 100%
(4/4) checking package integrity                                              [############################################] 100%
(4/4) loading package files                                                   [############################################] 100%
(4/4) checking for file conflicts                                             [############################################] 100%
error: failed to commit transaction (conflicting files)
libbaloo4: /usr/lib/kde4/kio_tags.so exists in filesystem
libbaloo4: /usr/lib/kde4/kio_timeline.so exists in filesystem
libbaloo4: /usr/share/kde4/services/tags.protocol exists in filesystem
libbaloo4: /usr/share/kde4/services/timeline.protocol exists in filesystem
Errors occurred, no packages were upgraded.

Last edited by DavidEGrayson (2014-09-13 21:41:14)

Offline

#2 2014-09-13 18:11:44

DavidEGrayson
Member
Registered: 2012-12-11
Posts: 10

Re: [SOLVED] libbaloo4 and baloo are in conflict

Hm.  "sudo pacman -Syu --ignore=baloo" looks like it might work.  I'll try running that and post an update when it's done.

Offline

#3 2014-09-13 20:03:28

DavidEGrayson
Member
Registered: 2012-12-11
Posts: 10

Re: [SOLVED] libbaloo4 and baloo are in conflict

OK, the solution is to run:

sudo pacman -Syu --ignore=baloo

then

sudo pacman -Syu

The second command will ask you if you want to replace baloo-widgets with extra/baloo4-widgets and you should say yes.

Offline

#4 2014-09-13 20:32:16

mailman_123
Member
Registered: 2014-09-13
Posts: 1

Re: [SOLVED] libbaloo4 and baloo are in conflict

Sorry for hijacking this thread, but I am trying to install KDE on a fresh arch installation and experiencing the same error. The --ignore=baloo causes several problems for me (missing title bar, etc.) . Any hints on how to fix this? Or do I have to wait until KDE is again installable on arch? -.- (Any hints when this will be?)

Offline

#5 2014-09-13 20:55:31

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 2,128

Re: [SOLVED] libbaloo4 and baloo are in conflict

Baloo 4.14.0-1 needs to be removed from the repo. Open a bug report to notify the maintainer

Offline

#6 2014-09-13 21:35:59

DavidEGrayson
Member
Registered: 2012-12-11
Posts: 10

Re: [SOLVED] libbaloo4 and baloo are in conflict

Removing a package from a repository doesn't seem like a very nice thing to do, but is that how things are done in the Arch world?  Does it need to be removed so that all the packages listing a dependency on "baloo" will use "baloo4" instead?  I would prefer if packages never got deleted so I could restore my system to any arbitrary point in the past.

Offline

#7 2014-09-13 22:08:15

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 2,128

Re: [SOLVED] libbaloo4 and baloo are in conflict

Yes of course packages need to be removed when they become obsolete. Do you really expect every package that has ever been in the repos to stay there forever?

Offline

Board footer

Powered by FluxBB