You are not logged in.

#1 2003-11-27 22:39:23

Luis Q. R.
Member
Registered: 2003-02-20
Posts: 106

Error while executing dvdrip.

Hi, I came back to Arch after wasting some time with Suse. Now, I get this message:

[luisqr@pc luisqr]$ /usr/share/bin/dvdrip
Can't locate strict.pm in @INC (@INC contains: /usr/lib/perl5/5.8.2/i686-linux /usr/lib/perl5/5.8.2 /usr/lib/perl5/site_perl/5.8.2/i686-linux /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1/i686-linux /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl .) at /usr/share/bin/dvdrip line 17.
BEGIN failed--compilation aborted at /usr/share/bin/dvdrip line 17.

Some other applications like Gimp or Audacity return errors like this, though they work. What's wrong with Perl?

Offline

#2 2003-11-27 23:28:59

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Error while executing dvdrip.

there was an attempt to build perl in such a way that would not require the rebuilding of all packages that need perl.

you will have to submit bug report or contact the maintianers directly to rebuild these package so they will link properly with the new perl.

i don't know if there is special syntax needed in the PKGBUILD to make rebuilding unnecessary you may want to talk to xentac or dorphell about that.


AKA uknowme

I am not your friend

Offline

#3 2003-11-28 01:21:53

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Error while executing dvdrip.

Luis,

This is from an irc session i started on your behalf:

18:46 < dorphell> sarah31: i don't have a bbs accout so will you tell Luis the
                  following: if he has the current version of perl [perl
                  5.8.2-4] he should have strict.pm in
                  /usr/lib/perl5/current/strict.pm I'm pretty sure he has a
                  local problem, probably he has an old version of perl, ask
                  him to upgrade, strict.pm has only been around since 5.8.1 or
                  5.8.2 so if he doesn't have that it probably means he's on an
                  older version, ask him to give the output


AKA uknowme

I am not your friend

Offline

#4 2003-11-28 14:34:25

Luis Q. R.
Member
Registered: 2003-02-20
Posts: 106

Re: Error while executing dvdrip.

Thanks, Sarah. The Perl version installed in my pc is 5.8.2-4, and there is a strict.pm file in /usr/lib/perl5/current. But look again at the output, the program doesn't look for strict.pm in that dir.

I copied strict.pm to /usr/lib/perl5/5.8.2/i686-linux/strict.pm and then, while executing dvdrip, I get this new message:

Can't locate lib.pm in @INC (@INC contains: /usr/lib/perl5/5.8.2/i686-linux /usr/lib/perl5/5.8.2 /usr/lib/perl5/site_perl/5.8.2/i686-linux /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1/i686-linux /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl .) at /usr/share/bin/dvdrip line 18.
BEGIN failed--compilation aborted at /usr/share/bin/dvdrip line 18.

lib.pm is in /usr/lib/perl5/current/i686-linux/lib.pm so I copied it to one of the dirs above.

Again, I execute dvdrip and I get this message:

Can't locate Config.pm in @INC (@INC contains: /usr/lib/perl5/5.8.2/i686-linux /usr/lib/perl5/5.8.2 /usr/lib/perl5/site_perl/5.8.2/i686-linux /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1/i686-linux /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl .) at /usr/lib/perl5/5.8.2/i686-linux/lib.pm line 6.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.2/i686-linux/lib.pm line 6.
Compilation failed in require at /usr/share/bin/dvdrip line 18.
BEGIN failed--compilation aborted at /usr/share/bin/dvdrip line 18

Config.pm is in /usr/lib/perl5/current/i686-linux/Config.pm. So you see, dvdrip is not looking for those files in /usr/lib/perl5/current but in /usr/lib/perl5/5.8.2 and others. Should I rename the "current" dir to "5.8.2"?

Offline

#5 2003-11-28 15:05:41

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Error while executing dvdrip.

The changes that happened to 5.8.2-4 were supposed to create /usr/lib/perl5/{5.8.2,5.8.1,5.8.0} symlinks to /usr/lib/perl5/current.  If you create those then all will be well.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#6 2003-11-28 15:09:04

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Error while executing dvdrip.

nah i would file a bug for it to be rebuilt against the current incarnation of perl. i had this happen with irssi too and it was resolved by just rebuilding the package.


AKA uknowme

I am not your friend

Offline

#7 2006-02-06 13:24:30

MAC!EK
Member
Registered: 2005-09-27
Posts: 265

Re: Error while executing dvdrip.

This symlinks:

ln -s current 5.8.8

Should be created in /usr/lib/perl5/ and /usr/lib/perl5/site_perl/
After that perl 5.8.8 starts to work fine.

Offline

#8 2006-02-06 14:48:23

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: Error while executing dvdrip.

Current release is 5.8.7.

Oh, and this thread is over two years old ........... wink

Offline

Board footer

Powered by FluxBB