You are not logged in.

#1 2014-10-16 20:45:11

Dmitrii
Member
Registered: 2014-10-16
Posts: 19

[Solved] huge windows after upgrade to gnome 3.14

Hello
Today pacman upgrade gnome 3.12.1-1 to  gnome 3.14.0-1
and now i have some applications gigantic: icons, fonts etc.
and some   applications still normal
Haw to downgrade to gnome 3.12.1-1?


Solved.
This effect is due to HiDPI Window scaling.

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides 
   "{ 'Gdk/WindowScalingFactor':<1> }"

I find this "By default the window scaling goes from 1x to 2x for High-DPI screens (above 1080p)."

Last edited by Dmitrii (2014-10-24 20:21:19)

Offline

#2 2014-10-16 21:07:37

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 25,914
Website

Re: [Solved] huge windows after upgrade to gnome 3.14

https://wiki.archlinux.org/index.php/Downgrade

Mod note: moving to Newbie Corner.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#3 2014-10-16 21:13:21

hokasch
Member
Registered: 2007-09-23
Posts: 1,461

Re: [Solved] huge windows after upgrade to gnome 3.14

What icon theme are you using? You might need to update that (I had issues with elementary, fixed by installing from git).

Offline

#4 2014-10-16 21:40:02

Dmitrii
Member
Registered: 2014-10-16
Posts: 19

Re: [Solved] huge windows after upgrade to gnome 3.14

Adwaita


pacman -Qs adwaita
local/adwaita-icon-theme 3.14.0-1 (gnome)

Last edited by Dmitrii (2014-10-16 21:42:54)

Offline

#5 2014-10-16 22:29:17

ooo
Member
Registered: 2013-04-10
Posts: 1,631

Re: [Solved] huge windows after upgrade to gnome 3.14

It would be better long term solution to resolve the issue, instead of downgrading.

can you post a screenshot demonstrating the issue?

Offline

#6 2014-10-17 02:59:37

Dmitrii
Member
Registered: 2014-10-16
Posts: 19

Re: [Solved] huge windows after upgrade to gnome 3.14

Of course would be better  long term solution.

Screenshot_from_2014_10_17.jpg

Here Tweak tool:  reduce the size of fonts to 8
Nautilus: Icon and List View Default  50%
But  (for example)  nvidia x server settings all little
it is the same little fonts and window in zenmap, chromium, deluge, virtual box,gimp  etc

Last edited by Dmitrii (2014-10-17 03:40:53)

Offline

#7 2014-10-17 11:12:02

Radioactiveman
Member
From: Germany
Registered: 2010-05-13
Posts: 388

Re: [Solved] huge windows after upgrade to gnome 3.14

Please post the output of:

$ gsettings get org.gnome.desktop.interface scaling-factor

What you could also try is renaming the directory "~/.config/dconf/" to reset the Gnome settings.

Last edited by Radioactiveman (2014-10-17 11:41:09)

Offline

#8 2014-10-17 12:59:50

Dmitrii
Member
Registered: 2014-10-16
Posts: 19

Re: [Solved] huge windows after upgrade to gnome 3.14

Scaling-factor 0
Screenshot_Sc_1.jpg


Scaling-factor 3

Screenshot_Sc_3.jpg

Scaling-factor acts selectively.

Yes i  renaming the directory "~/.config/dconf/" and i re install all gnome few times,

All times  when upgrade  gnome to  3.14 from 3.12 i had this  issue and  only downgrade fixing  this  problem.
Something wrong with 3.14

Solved.
This effect is due to HiDPI Window scaling.
I find this "By default the window scaling goes from 1x to 2x for High-DPI screens (above 1080p)."
So this is feature. mad

Last edited by Dmitrii (2014-10-24 17:59:09)

Offline

#9 2014-10-17 21:56:08

Radioactiveman
Member
From: Germany
Registered: 2010-05-13
Posts: 388

Re: [Solved] huge windows after upgrade to gnome 3.14

What key in dconf has to be set to "auto"?

Also add [Solved] to the thread title by editing the first post.

Offline

#10 2014-10-17 23:48:16

Dmitrii
Member
Registered: 2014-10-16
Posts: 19

Re: [Solved] huge windows after upgrade to gnome 3.14

Thank you for the tip.

Screens (above 1080p) and upgrade (re install) to 3.14 will be set to "auto"

Last edited by Dmitrii (2014-10-19 11:21:52)

Offline

#11 2014-10-18 01:30:02

Radioactiveman
Member
From: Germany
Registered: 2010-05-13
Posts: 388

Re: [Solved] huge windows after upgrade to gnome 3.14

I still don't understand how you solved it.
What is "auto" now?

Offline

#12 2014-10-18 13:51:41

Dmitrii
Member
Registered: 2014-10-16
Posts: 19

Re: [Solved] huge windows after upgrade to gnome 3.14

This solved my  problem.

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides 
   "{ 'Gdk/WindowScalingFactor':<1> }"

Read here
"This is just the Gtk+ side, on the gnome desktop side we will have code to automatically enable this for high dpi screens."

No best idea from my point of view smile,  until at least.  I mean "automatically enable this".
Once again if  yours screens above 1080p, during installation you got   automatically

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides 
   "{ 'Gdk/WindowScalingFactor':<2> }"

Last edited by Dmitrii (2014-10-18 14:21:24)

Offline

#13 2014-10-18 23:01:13

jwhendy
Member
Registered: 2010-04-01
Posts: 621

Re: [Solved] huge windows after upgrade to gnome 3.14

I appears that one needs gnome-settings-daemon installed for this to work?

$ gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{ 'Gdk/WindowScalingFactor':<1> }"
No such schema 'org.gnome.settings-daemon.plugins.xsettings'

I'm on openbox and don't have all that much gnome stuff installed -- just things related to gtk themes or dependencies for other packages and whatnot:

$ pacman -Q |grep gnome
gnome-icon-theme 3.12.0-2
gnome-icon-theme-symbolic 3.12.0-2
gnome-themes-standard 3.14.0-1
libgnome-keyring 3.12.0-1
libreoffice-still-gnome 4.2.6-4

Is there a solution that doesn't require extra "stuff"

EDIT: this doesn't seem to fix it for me, at least if a logout/login, re-startx should make it work. My test application is evince where I noticed the issue. I'm using clarity-icon-theme and zukitwo-themes/zukitwo-themes-openbox from AUR. Re-installing evince-gtk from AUR to see if that does anything.

Last edited by jwhendy (2014-10-18 23:04:11)

Offline

#14 2014-10-19 10:49:45

Dmitrii
Member
Registered: 2014-10-16
Posts: 19

Re: [Solved] huge windows after upgrade to gnome 3.14

All information is here

sudo nano /etc/environment

And there GDK_SCALE=1

#
# This file is parsed by pam_env module
#
# Syntax: simple "KEY=VAL" pairs on separate lines
#

GDK_SCALE=1

Last edited by Dmitrii (2014-10-19 11:04:07)

Offline

#15 2014-10-19 13:41:47

freyr
Member
From: Hungary
Registered: 2010-02-04
Posts: 131

Re: [Solved] huge windows after upgrade to gnome 3.14

This all doesn't work for me. Openbox without a DE and GNOME apps have <b>HUGE<b> icons + some menu items like the ones in gedit don't respond to the cursor.  Like jwhendy, I don't have <i>org.gnome.settings-daemon.plugins.xsettings<i> schema and <i>GDK_SCALE=1<i> doesn't change anything.


What, so everyone's supposed to sleep every single night now? You realize that nighttime makes up half of all time?

Offline

#16 2014-10-19 14:03:01

kuminamoya
Member
Registered: 2013-10-29
Posts: 3

Re: [Solved] huge windows after upgrade to gnome 3.14

Hade the same problem (using i3). Solved it by changing the icon theme to Adwaita (from clarity) using lxappearance.

Offline

#17 2014-10-19 14:48:40

freyr
Member
From: Hungary
Registered: 2010-02-04
Posts: 131

Re: [Solved] huge windows after upgrade to gnome 3.14

kuminamoya wrote:

Hade the same problem (using i3). Solved it by changing the icon theme to Adwaita (from clarity) using lxappearance.

Now that's interesting. You're right. I also checked my other icon themes, only half of them are affected.
But this still doesn't solve the problem of the non-responsive gedit menu items. Does it look like this to everybody (apart from the color theme)?


What, so everyone's supposed to sleep every single night now? You realize that nighttime makes up half of all time?

Offline

#18 2014-10-19 19:26:21

jwhendy
Member
Registered: 2010-04-01
Posts: 621

Re: [Solved] huge windows after upgrade to gnome 3.14

Can we take a step back for a second? Would someone be able to point to:
- a file in an Arch package that sets GdkWindowScalingFactor=[not <1>]
- a file in an Arch package that sets GDK_SCALE=[not 1]

I may actually have a different bug. My windows aren't huge, just my icons, and so far I've only noticed it in Evince. The left side menu top bit is enormous, and switching from Clarity icons to something else seems to fix it.
ORJA6rB.png

I also get these errors when starting Evince from the command line, but rarely do it (only when there's a problem), so I don't know if they popped up around the time of this issue or not:

$ evince

(evince:30276): Gtk-WARNING **: Error setting gtk-xft-antialias in /home/jwhendy/.config/gtk-3.0/settings.ini: Key file contains key 'gtk-xft-antialias' in group 'Settings' which has a value that cannot be interpreted.

(evince:30276): Gtk-WARNING **: Error setting gtk-xft-hinting in /home/jwhendy/.config/gtk-3.0/settings.ini: Key file contains key 'gtk-xft-hinting' in group 'Settings' which has a value that cannot be interpreted.

(evince:30276): GLib-GObject-WARNING **: The property GtkSettings:gtk-menu-images is deprecated and shouldn't be used anymore. It will be removed in a future version.

And my settings.ini:

$ cat ~/.config/gtk-3.0/settings.ini 
[Settings]
gtk-theme-name=Zukitwo
gtk-icon-theme-name=clarity-dark_canus
gtk-font-name=Cantarell 10
gtk-cursor-theme-name=comix
gtk-cursor-theme-size=0
gtk-toolbar-style=GTK_TOOLBAR_ICONS
gtk-toolbar-icon-size=GTK_ICON_SIZE_LARGE_TOOLBAR
gtk-button-images=false
gtk-enable-event-sounds=true
gtk-enable-input-feedback-sounds=true
gtk-xft-hintstyle=hintslight
gtk-xft-rgba=rgb
gtk-menu-images=true
gtk-xft-antialias=true
gtk-xft-hinting=true

I set the above using lxappearance. If this is a separate issue (huge icons in evince != huge windows), I'll start a new thread.

@dmitrii: that's a pretty old post about trying an experimental branch. Do we have evidence (like the questions at the top of my thread) that Arch is shipping with scaling enabled by default? If so, is something wrong/unusual about my setup that it would create this strange and undesirable by-product? If not, it strikes me as highly unlikely that every Gnome/gtk user would have to edit /etc/environment when the new gnome pushes to their system. I'm inclined to think it's got nothing to do with scaling and that my icon theme hasn't updated to something related to 3.14?

@freyr: I don't use gedit, but this is what mine looks like. I can't tell if there's anything wrong with yours or not since I have no reference point. From taking a look at your screenshot, looked similar to mine?

Offline

#19 2014-10-19 20:56:20

freyr
Member
From: Hungary
Registered: 2010-02-04
Posts: 131

Re: [Solved] huge windows after upgrade to gnome 3.14

jwhendy wrote:

@freyr: I don't use gedit, but this is what mine looks like. I can't tell if there's anything wrong with yours or not since I have no reference point. From taking a look at your screenshot, looked similar to mine?

Technically similar. Since then I also noticed that if I change GTK theme, the problem goes away. But not with every GTK theme I have.
It seems to me that whatever "upgrade" just happened with GNOME and GTK, they've broken compatibility with lots of color/icon themes thus producing this bug. It's not the windows scaling, it's the theme management. Taking a closer look at the themes, every one of them have GTK3 compatibility but that's the closest look I can give. I'm following two threads at the moment, I think this is our problem, or at least mine.

Also if I open my gedit from terminal, I get your Gtk-WARNINGs but not your GLib-GObject-WARNING, instead I get this:

gedit

(gedit:3719): Gtk-WARNING **: Error setting gtk-xft-antialias in /home/lynx/.config/gtk-3.0/settings.ini: A kulcsfájl tartalmazza a(z) „gtk-xft-antialias” kulcsot a(z) „Settings” csoportban, amelynek értéke nem értelmezhető.

(gedit:3719): Gtk-WARNING **: Error setting gtk-xft-hinting in /home/lynx/.config/gtk-3.0/settings.ini: A kulcsfájl tartalmazza a(z) „gtk-xft-hinting” kulcsot a(z) „Settings” csoportban, amelynek értéke nem értelmezhető.

(gedit:3719): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:197:14: Theming engine 'adwaita' not found

(gedit:3719): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:610:15: Theming engine 'adwaita' not found

(gedit:3719): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:885:15: Theming engine 'adwaita' not found

(gedit:3719): dconf-WARNING **: Unable to open /root/.local/share/dconf/profile/user: Engedély megtagadva

The first two Gtk-WARNINGs are the same as

Gtk-WARNING **: Error setting gtk-xft-antialias in /home/jwhendy/.config/gtk-3.0/settings.ini: Key file contains key 'gtk-xft-antialias' in group 'Settings' which has a value that cannot be interpreted

but in Hungarian, and the last sentence translates to: Permission denied.

Last edited by freyr (2014-10-19 21:04:13)


What, so everyone's supposed to sleep every single night now? You realize that nighttime makes up half of all time?

Offline

#20 2014-10-23 22:42:05

MJBoa
Member
Registered: 2009-03-31
Posts: 31

Re: [Solved] huge windows after upgrade to gnome 3.14

Hi guys,

I had a seemingly related problem with my icons where certain ones were being displayed very large. I was getting the error:

(evince:14533): Gtk-WARNING **: Symbolic icon edit-find-symbolic-ltr of size 16 is in an icon theme directory of size 96

So I grepped for the edit-find-symbolic icon and found its directory, looked into the index.theme file of my theme at /usr/share/icons/theme-name/index.theme and found the entry for its folder "actions/scalable". Under that entry was the property "Type=scalable". I looked up the format for theme files and found that the value should be capitalized so I changed it to read "Type=Scalable" and that fixed the problem. No idea why that became a problem with the new version...
Hope this helps someone.

Offline

#21 2014-10-24 18:14:27

Dmitrii
Member
Registered: 2014-10-16
Posts: 19

Re: [Solved] huge windows after upgrade to gnome 3.14

jwhendy wrote:

Can we take a step back for a second? Would someone be able to point to:
- a file in an Arch package that sets GdkWindowScalingFactor=[not <1>]
- a file in an Arch package that sets GDK_SCALE=[not 1]

Try to read more carefully.
"pacman upgrade gnome" big_smile

Last edited by Dmitrii (2014-10-24 18:26:11)

Offline

#22 2014-10-24 20:19:01

jwhendy
Member
Registered: 2010-04-01
Posts: 621

Re: [Solved] huge windows after upgrade to gnome 3.14

@Dmitrii: really? Yeah, I got that part by now. My questions still stand:
- where is the file that requires overriding with gnome-settings-daemon?
- where is the file setting GDK_SCALE != 1 such that I need to edit /etc/environment override it?

I'm just trying to understand why these solutions don't work for some of us, but do work for you. So if we can start by looking at the common ground (say, a new 3.14 gnome file that features the line 'GDD_SCALE=2', I'll start to believe that /etc/environment has anything to do with this. Then again, a subset of us are just having issues with icons, so I don't even know if my issue is the same. Given that I can change my icon theme and my entire issue goes away, I don't think GdkWindowScalingFactor or GDK_SCALE have anything to do with me.

For the benefit of others, it would still be nice to understand why scaling is goofing. The gtk docs read to me like this shouldn't be messing up like it is (emphasis mine):

GDK_SCALE.  Must be set to an integer, typically 2. If set, GDK will scale all windows by the specified factor. Scaled output is meant to be used on high-dpi displays. Normally, GDK will pick up a suitable scale factor for each monitor from the display system. This environment variable allows to override that.

The docs don't suggest the user has to do anything, and by that I'd assume the default wouldn't make huge windows and icons for every gnome user.

Offline

#23 2014-10-25 09:17:45

jp
Member
Registered: 2014-10-25
Posts: 5

Re: [Solved] huge windows after upgrade to gnome 3.14

MJBoa wrote:

Hi guys,

I had a seemingly related problem with my icons where certain ones were being displayed very large. I was getting the error:

(evince:14533): Gtk-WARNING **: Symbolic icon edit-find-symbolic-ltr of size 16 is in an icon theme directory of size 96

So I grepped for the edit-find-symbolic icon and found its directory, looked into the index.theme file of my theme at /usr/share/icons/theme-name/index.theme and found the entry for its folder "actions/scalable". Under that entry was the property "Type=scalable". I looked up the format for theme files and found that the value should be capitalized so I changed it to read "Type=Scalable" and that fixed the problem. No idea why that became a problem with the new version...
Hope this helps someone.

This actually worked for me, thanks!

Offline

#24 2014-10-25 09:30:52

freyr
Member
From: Hungary
Registered: 2010-02-04
Posts: 131

Re: [Solved] huge windows after upgrade to gnome 3.14

jp wrote:
MJBoa wrote:

Hi guys,

I had a seemingly related problem with my icons where certain ones were being displayed very large. I was getting the error:

(evince:14533): Gtk-WARNING **: Symbolic icon edit-find-symbolic-ltr of size 16 is in an icon theme directory of size 96

So I grepped for the edit-find-symbolic icon and found its directory, looked into the index.theme file of my theme at /usr/share/icons/theme-name/index.theme and found the entry for its folder "actions/scalable". Under that entry was the property "Type=scalable". I looked up the format for theme files and found that the value should be capitalized so I changed it to read "Type=Scalable" and that fixed the problem. No idea why that became a problem with the new version...
Hope this helps someone.

This actually worked for me, thanks!

Not to me, my icon themes already have "Type=Scalable" or "Type=Fixed" in their index.theme files. The bug making some icons themes huge is doing something else. In your cases the icon theme itself could be wrongly made or simply was not updated to new requirements.

Last edited by freyr (2014-10-25 09:39:57)


What, so everyone's supposed to sleep every single night now? You realize that nighttime makes up half of all time?

Offline

#25 2014-10-27 16:33:18

bunghole
Member
Registered: 2011-06-10
Posts: 28

Re: [Solved] huge windows after upgrade to gnome 3.14

jp wrote:
MJBoa wrote:

Hi guys,

I had a seemingly related problem with my icons where certain ones were being displayed very large. I was getting the error:

(evince:14533): Gtk-WARNING **: Symbolic icon edit-find-symbolic-ltr of size 16 is in an icon theme directory of size 96

So I grepped for the edit-find-symbolic icon and found its directory, looked into the index.theme file of my theme at /usr/share/icons/theme-name/index.theme and found the entry for its folder "actions/scalable". Under that entry was the property "Type=scalable". I looked up the format for theme files and found that the value should be capitalized so I changed it to read "Type=Scalable" and that fixed the problem. No idea why that became a problem with the new version...
Hope this helps someone.

This actually worked for me, thanks!

At first I thought the proposed solution had failed in my case, but then I noticed that my preferred icon theme (Moka) depends on another icon theme (Faba). After applying the aforementioned fix there as well, everything looked normal again.

Thx for the tip! smile

Offline

Board footer

Powered by FluxBB