You are not logged in.

#1 2006-02-20 07:37:22

DeusExLinux
Member
Registered: 2005-03-18
Posts: 98

Unable to open Inital Console, kernel panic! (SOLVED)

I decided to, the other day, take the plunge into the new Udev and Xorg7.

I dealt with Xorg7 fine.

My major problem is with the new udev.  After rebooting, I realized I had to compile a new kernel (I use custom vanilla kernels, the stock kernels are a bit of a pain when it comes to Madwifi and my laptop support).  I have the latest 2.6.15.4 kernel source from www.kernel.org along with udev85-2.  I've gotten the stock Arch kernel to boot fine (it's 2.6.15)... but when  I try to load my kernel, with my custom make initrd file I get a crazy error while booting.  My kernel outputs "unable to open initial console, try adding init= to ..... I forget the rest.  I've tried adding the init line, and not the initrd line.  I've tried taking it out all together.  It's just being a pain in the butt.

Perhaps there's somethign wrong in the way I compiled my kernel, but it's never been an issue before.  Anyone got any ideas?


And on the 8th day, God gave the people Google so that all the problems of the universe could be researched from one central place.  And it was good.

Offline

#2 2006-02-20 08:04:21

_Gandalf_
Member
Registered: 2006-01-12
Posts: 735

Re: Unable to open Inital Console, kernel panic! (SOLVED)

it may be usefull if you post your used entries in ur grub/lilo conf files ... as well maybe ur custom kernel's PKGBUILD

Offline

#3 2006-02-20 09:39:44

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: Unable to open Inital Console, kernel panic! (SOLVED)

Here's a theory - your previous custom kernel did not use initrd, and therefore had the file system and disk controller support built-in. You compiled your new kernel using the same config, and then tagged on an initrd image. The problem arises because initrd needs the file system and disk controller support compiled as modules, but because there are no modules, the boot fails.

Am I close? smile

Offline

#4 2006-02-20 19:47:48

DeusExLinux
Member
Registered: 2005-03-18
Posts: 98

Re: Unable to open Inital Console, kernel panic! (SOLVED)

Ok, Recompiled all the fs as modules (I used resierfs), and my custom kernel still won't boot.  I don't use pkgbuilds for my kernels, I just do them the old fashioned way, but grub reads:

title Arch Newdev
root (hd0,3)
kernel (hd0,3)/boot/bzImage26154 root=/dev/hda3 ro devfs=nomount
initrd (hd0,3)/boot/initrd-2.6.15.4.img

title Arch, stock
root (hd0,3)
kernel /boot/vmlinuz26 root=/dev/hda4 splash=verbose
initrd (hd0,3)/boot/initrd26.img

When I try to boot my custom kernel, I get a "vfs error - unable to mount root fs on (hd3,3), which would be, /dev/hdc, which is my cdrom device.  Now, why would the bloody thing be trying to mount the root device on the cdrom.  I'm using the same fstab.  Perhaps there's a problem with my /etc/mkinitrd.conf?  Which is the following:

# Disable whole subsystems by setting to "1"
REMOVE_IDE=
REMOVE_SCSI=
REMOVE_SATA=1
REMOVE_CDROM=1
REMOVE_USB=1
REMOVE_FW=1
REMOVE_RAID=1
REMOVE_DM=1
REMOVE_FS=

# Enable auto-detection of HOSTCONTROLlER and FILESYSTEMS (set to "1")
#   (NOTE: This is still experimental, so it is disabled by default)
AUTODETECT=1

# Define which modules are needed by adding "moduleX moduleY"
# If left empty, all modules are included if they are not disabled above
HOSTCONTROLLER_IDE=
HOSTCONTROLLER_SCSI=
HOSTCONTROLLER_SATA=
HOSTCONTROLLER_USB=
FILESYSTEMS="reiserfs"

# Number of seconds to wait for USB devices to settle
USB_TIMEOUT=5

# If you have an encrypted root filesystem, set it here (eg, /dev/hda4)
CRYPT_DEVICE=

# If you use software RAID for your root device then list all the devices
# that belong to your root array here.  If your root RAID device is
# something other than md0, then change the RAID_ROOT_ARRAY setting.
#    eg, RAID_ROOT_DEVICES="/dev/hda3 /dev/hdc3"
RAID_ROOT_ARRAY="md0"
RAID_ROOT_DEVICES=

# If you use LVM on your root device, then specify it here
#    eg, LVM_ROOT="/dev/vg_root/lv_root"
LVM_ROOT=

# Define additional modules here
ADD_MODULE=
REMOVE_MODULE=

Tomk, you were close, I'm closer to having it boot..  smile


UPDATE:::::  I just noticed that, somehow, i upgraded gcc to 4.1, so I finally got my wireless working, which leads me to beleive this might have also created an issue with my kernel compilation.. retyrying now.


And on the 8th day, God gave the people Google so that all the problems of the universe could be researched from one central place.  And it was good.

Offline

#5 2006-02-20 23:32:35

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: Unable to open Inital Console, kernel panic! (SOLVED)

What about your disk controller? That has to be compiled as a module too, and then included in initrd. I use custom archck kernels with initramfs, and I have

HOSTCONTROLLER_IDE="piix"

in mkinitramfs.conf - piix is compiled as a module, of course.

On the Initrd Wiki page, there's a piece about mounting your initrd image so you can see exactly what it includes - you might like to have a look in the image's /lib directory to see exactly what modules are there.

Offline

#6 2006-02-21 01:11:56

DeusExLinux
Member
Registered: 2005-03-18
Posts: 98

Re: Unable to open Inital Console, kernel panic! (SOLVED)

That did the trick
thanks, mate.

MMM.. custom kernel back again.


Now, if I could only figure out where all my gnome icons went off to......


And on the 8th day, God gave the people Google so that all the problems of the universe could be researched from one central place.  And it was good.

Offline

Board footer

Powered by FluxBB