You are not logged in.

#1 2014-11-24 07:30:59

Registered: 2014-11-24
Posts: 1

Overwrite FACP ACPI Table to Fix Missing ASPM

I have bought a HP EliteBook 2570p notebook. The energy consumption is a bit high because HP has disabled ASPM in the ACPI FACP table. As described here … #post38399, this problem can be solved by overwriting the wrong values. I think the person there is using a FreeDOS environment before booting the other operating systems to write directly in the memory. I though it should also be possible to load a patched FACP table like a patched DSDT table. So I extracted the table:

acpidump > acpi.dat
acpixtract -a acpi.dat
iasl -d facp.dat

In facp.dst I changed the value 'PCIe ASPM Not Supported (V4)' from 1 to 0 and recompiled the table:

iasl -sa facp.dsl

This results in facp.aml, which I copied into /boot.
In Grub, I tried to load the new table with the entry

acpi /facp.aml

before the linux line.
After booting, unfortunately the new table is not loaded when I extract the ACPI tables again.
Does someone know if it is not possible to load a fixed FACP table in Grub? If it's not possible, is there an other way to fix this problem?

Edit: I have tested now the Grub acpi function with a modified DSDT table. This doesn't work, either. So I think it's a problem with Grub.

Last edited by Ununnilium (2014-11-24 09:03:27)


Board footer

Powered by FluxBB