You are not logged in.

#1 2014-12-11 21:51:29

douglasdouglasj
Member
Registered: 2014-12-11
Posts: 3

[SOLVED] OpenBox - keybindings for volume/brightness not working

I'm attempting to get the volume and brightness controls, as well as the multimedia controls, to work with the Fn-F4, Fn-F5, etc. keys. However, Im not having any luck.

Here's what I've done thus far;

I've edited my ./config/openbox/rc.xml file to reflect the XF86 keybindings under the Keybindings section, for volumeup, volumedown, and volumemute:

<keybind key="XF86AudioRaiseVolume">
      <action name="Execute">
        <command>amixer set Master 10%+</command>
      </action>
   </keybind>
    <keybind key="XF86AudioLowerVolume">
     <action name="Execute">
        <command>amixer set Master 10%-</command>
      </action>
    </keybind>
    <keybind key="XF86AudioMute">
      <action name="Execute">
        <command>amixer set Master toggle</command>volumeicon installed, and I can change the volume by scrolling
      </action>
   </keybind>

This doesen't work. I have a System76 panp9 notebook, which has the volume mute, down and up keys as Fn-F3, F5 and F6 respectively. Ive run xev, and when I try any of these, I only recieve a Focus in/out event. Same goes for the brightness and multimedia controls, as they are also on the Fn modifier set. I can use "amixer set Master +10%" at the command line and the volume changes.

I have volume icon 0.5.0 installed, and I can adjust the volume by scrolling on the icon, but its inconvient, as opposed to just hitting a key combo. I've been able to use the key combo on every DE without issue, so what would it take to program OB to recognize the Fn modifier and allow the keybindings to read?

Last edited by douglasdouglasj (2014-12-12 21:18:09)

Offline

#2 2014-12-11 22:34:41

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,439

Re: [SOLVED] OpenBox - keybindings for volume/brightness not working

I think you have to use the keycodes:
Raise volume is "0x1008ff13"
Lower volume is "0x1008ff11"
Mute is "0x1008ff12"

These appear to be universal.

Offline

#3 2014-12-11 22:42:43

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,261
Website

Re: [SOLVED] OpenBox - keybindings for volume/brightness not working

Did you restart openbox (or use openbox --reconfigure) after making the changes?  Did you run xev before or after making these changes?  Is some other key binding program running?


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#4 2014-12-12 20:22:43

douglasdouglasj
Member
Registered: 2014-12-11
Posts: 3

Re: [SOLVED] OpenBox - keybindings for volume/brightness not working

Head_on_a_Stick wrote:

I think you have to use the keycodes:
Raise volume is "0x1008ff13"
Lower volume is "0x1008ff11"
Mute is "0x1008ff12"

These appear to be universal.

OK, I appended the xml with your suggestion, and it works ike a charm!  Thanks!

Offline

#5 2014-12-12 20:32:40

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,439

Re: [SOLVED] OpenBox - keybindings for volume/brightness not working

Excellent!

If you edit the title of your first post & put "[SOLVED]" at the beginning, it will help others who have this problem wink

Offline

#6 2014-12-12 21:14:57

douglasdouglasj
Member
Registered: 2014-12-11
Posts: 3

Re: [SOLVED] OpenBox - keybindings for volume/brightness not working

Also, for future reference, where would I find the keysym equivalents for other keys as well?

Offline

#7 2014-12-12 21:28:20

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,439

Offline

Board footer

Powered by FluxBB