You are not logged in.

#1 2014-12-14 17:00:54

banshee28
Member
Registered: 2008-10-18
Posts: 336

[Solved] LxQT no longer starts!!!

Been running LxQT for about a month now with no issues. I have kept it up to date and done multiple reboots. Now when it reboots and i run startx, it tries to open the DE and after 5 seconds fails with "LxQt::Translator: QT translations not found". The only other thing i did was remove the sata connection on one of my data drives but I dont think that has anything to do with the LxQT starting?

I found this link https://github.com/lxde/lxqt/issues/375 but not sure if thats the same.issue or not.

Edit: Solved using metak's repo!

Last edited by banshee28 (2014-12-23 03:42:49)


Arch64, AMD64, LXDE

Offline

#2 2014-12-14 17:31:06

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,140

Re: [Solved] LxQT no longer starts!!!

QT5 was recently upgraded from 5.3.2 to 5.4.0 , have you tried rebuilding lxqt ?


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2014-12-14 17:42:02

hifi25nl
Member
Registered: 2011-05-07
Posts: 243
Website

Re: [Solved] LxQT no longer starts!!!

You must rebuild some lxqt packages. In my case (to be sure) I have rebuild lxqt-common lxqt-panel lxqt-qtplugin lxqt-session pcmanfm-qt. but maybe is better to rebuild ALL lxqt packages...

Offline

#4 2014-12-14 18:42:55

banshee28
Member
Registered: 2008-10-18
Posts: 336

Re: [Solved] LxQT no longer starts!!!

Nope, have not tried to rebuild anything. It sounds like that's the problem. Whats the quickest way to do this?


Arch64, AMD64, LXDE

Offline

#5 2014-12-14 22:45:50

hifi25nl
Member
Registered: 2011-05-07
Posts: 243
Website

Re: [Solved] LxQT no longer starts!!!

Reinstall from AUR

Offline

#6 2014-12-14 22:51:12

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,163
Website

Re: [Solved] LxQT no longer starts!!!

hifi25nl wrote:

Reinstall from AUR

Pretty much this.

If you're using a repository, then contact the repository maintainer informing them a rebuild is required against the new libraries might be a good idea as well.

Last edited by clfarron4 (2014-12-14 22:51:34)


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

#7 2014-12-15 00:34:01

banshee28
Member
Registered: 2008-10-18
Posts: 336

Re: [Solved] LxQT no longer starts!!!

Thanks, will work on it.


Arch64, AMD64, LXDE

Offline

#8 2014-12-19 13:16:17

Box0
Member
From: Italy
Registered: 2011-09-21
Posts: 218

Re: [Solved] LxQT no longer starts!!!

I have the same issue, but after a rebuild from AUR LXQt still does not start. Any idea what the cause might be?

Last edited by Box0 (2014-12-19 13:16:46)

Offline

#9 2014-12-19 17:38:17

metak
Member
Registered: 2009-09-27
Posts: 198

Re: [Solved] LxQT no longer starts!!!

Box0 wrote:

I have the same issue, but after a rebuild from AUR LXQt still does not start. Any idea what the cause might be?

Try using my lxqt repo? It works just fine for me...

[home_metakcahura_arch-lxqt_Arch_Extra]
SigLevel = Never
Server = http://download.opensuse.org/repositories/home:/metakcahura:/arch-lxqt/Arch_Extra/$arch

Offline

#10 2014-12-20 11:42:32

Box0
Member
From: Italy
Registered: 2011-09-21
Posts: 218

Re: [Solved] LxQT no longer starts!!!

metak wrote:

Try using my lxqt repo? It works just fine for me...

[home_metakcahura_arch-lxqt_Arch_Extra]
SigLevel = Never
Server = http://download.opensuse.org/repositories/home:/metakcahura:/arch-lxqt/Arch_Extra/$arch

Just tried, I got lots of "failed to retrieve some files ... from download.opensuse.org : Maximum file size exceeded"

Offline

#11 2014-12-20 16:51:34

metak
Member
Registered: 2009-09-27
Posts: 198

Re: [Solved] LxQT no longer starts!!!

Box0 wrote:

Just tried, I got lots of "failed to retrieve some files ... from download.opensuse.org : Maximum file size exceeded"

Yeah, that happens sometimes with download.opensuse... you can use another mirror since download.opensuse just redirects you to one anyway...

Server = http://anorien.csc.warwick.ac.uk/mirrors/download.opensuse.org/repositories/home:/metakcahura:/arch-lxqt/Arch_Extra/$arch

Last edited by metak (2014-12-20 16:52:30)

Offline

#12 2014-12-20 18:08:26

foppe
Member
Registered: 2011-04-02
Posts: 47

Re: [Solved] LxQT no longer starts!!!

Moving from the [lxqt-git] repository to AUR git packages (simply remove the [lxqt-git] repo in /etc/pacman.conf) I was able to built with only one change:
In package liblxqt-git change the dependency from libqtxdg-git to libqtxdg-qt5-git.

Offline

#13 2014-12-20 18:18:02

Box0
Member
From: Italy
Registered: 2011-09-21
Posts: 218

Re: [Solved] LxQT no longer starts!!!

I am able to rebuild, the problem is that after the rebuild the lxqt session doesn't start.

Edit:

metak wrote:

Yeah, that happens sometimes with download.opensuse... you can use another mirror since download.opensuse just redirects you to one anyway...

Server = http://anorien.csc.warwick.ac.uk/mirrors/download.opensuse.org/repositories/home:/metakcahura:/arch-lxqt/Arch_Extra/$arch

The mirror works fine and the lxqt session starts. Thank you very much for sharing your work smile

Last edited by Box0 (2014-12-20 20:45:17)

Offline

#14 2014-12-21 00:19:46

banshee28
Member
Registered: 2008-10-18
Posts: 336

Re: [Solved] LxQT no longer starts!!!

metak wrote:
Box0 wrote:

I have the same issue, but after a rebuild from AUR LXQt still does not start. Any idea what the cause might be?

Try using my lxqt repo? It works just fine for me...

[home_metakcahura_arch-lxqt_Arch_Extra]
SigLevel = Never
Server = http://download.opensuse.org/repositories/home:/metakcahura:/arch-lxqt/Arch_Extra/$arch

Thanks! I am hoping this will work for me also, but so far its not...lol

I am getting this error trying to install from your repo..

otal Installed Size:   20.70 MiB

:: Proceed with installation? [Y/n] 
(32/32) checking keys in keyring                                                                                               [#############################################################################] 100%
(32/32) checking package integrity                                                                                             [#############################################################################] 100%
(32/32) loading package files                                                                                                  [#############################################################################] 100%
(32/32) checking for file conflicts                                                                                            [#############################################################################] 100%
error: failed to commit transaction (conflicting files)
/usr/include/libfm/fm-extra.h exists in both 'libfm-extra' and 'libfm-extra-git'
/usr/include/libfm/fm-version.h exists in both 'libfm-extra' and 'libfm-extra-git'
/usr/include/libfm/fm-xml-file.h exists in both 'libfm-extra' and 'libfm-extra-git'
/usr/lib/libfm-extra.so exists in both 'libfm-extra' and 'libfm-extra-git'
/usr/lib/libfm-extra.so.4 exists in both 'libfm-extra' and 'libfm-extra-git'
/usr/lib/libfm-extra.so.4.0.3 exists in both 'libfm-extra' and 'libfm-extra-git'
/usr/lib/pkgconfig/libfm-extra.pc exists in both 'libfm-extra' and 'libfm-extra-git'
Errors occurred, no packages were upgraded.

I completely removed the old lxqt files so starting fresh.


Arch64, AMD64, LXDE

Offline

#15 2014-12-21 00:24:25

banshee28
Member
Registered: 2008-10-18
Posts: 336

Re: [Solved] LxQT no longer starts!!!

clfarron4 wrote:
hifi25nl wrote:

Reinstall from AUR

Pretty much this.

If you're using a repository, then contact the repository maintainer informing them a rebuild is required against the new libraries might be a good idea as well.

Thanks, I did but apparently its user responsibility... https://aur.archlinux.org/packages/lxqt/
Anyways, maybe i can use metak's repo if I can get past these errors...


Arch64, AMD64, LXDE

Offline

#16 2014-12-21 00:51:33

metak
Member
Registered: 2009-09-27
Posts: 198

Re: [Solved] LxQT no longer starts!!!

banshee28 wrote:

Anyways, maybe i can use metak's repo if I can get past these errors...

I've already added provides & conflicts to libfm in my repo and OBS is scheduled to rebuild all packages in a few hours or so.
In the mean time just remove your previously installed lxqt packages and if you're going to install git version of libfm remove the stable version first. (this should be fixed soon)

Offline

#17 2014-12-21 01:05:07

banshee28
Member
Registered: 2008-10-18
Posts: 336

Re: [Solved] LxQT no longer starts!!!

metak wrote:
banshee28 wrote:

Anyways, maybe i can use metak's repo if I can get past these errors...

I've already added provides & conflicts to libfm in my repo and OBS is scheduled to rebuild all packages in a few hours or so.
In the mean time just remove your previously installed lxqt packages and if you're going to install git version of libfm remove the stable version first. (this should be fixed soon)

I dont seem to have any more lxqt or libfm packages? I may just wait until you have the repo updated and hope that will work. Maybe this is broke now since I tried to remove lxqt and all its deps the other day?

Last edited by banshee28 (2014-12-21 01:05:48)


Arch64, AMD64, LXDE

Offline

#18 2014-12-22 04:11:21

mariojuniorjp
Member
Registered: 2014-07-06
Posts: 16

Re: [Solved] LxQT no longer starts!!!

I am also in trouble, only in my case is something between lxqt and xorg. Even posted my problem in linux arch community on Google Plus:

https://plus.google.com/116266651764812 … KA758q2LRM

Offline

#19 2014-12-22 05:33:08

banshee28
Member
Registered: 2008-10-18
Posts: 336

Re: [Solved] LxQT no longer starts!!!

Amazing!! I used metak's repo and it finally worked! Thanks metak for the updates, I think it finally is good. Are you going to keep this updated for a while?


Arch64, AMD64, LXDE

Offline

#20 2014-12-22 21:36:12

metak
Member
Registered: 2009-09-27
Posts: 198

Re: [Solved] LxQT no longer starts!!!

banshee28 wrote:

Amazing!! I used metak's repo and it finally worked! Thanks metak for the updates, I think it finally is good. Are you going to keep this updated for a while?

I'm currently using lxqt + kwin5 as wm and it works great for me so I'll probably keep it updated for a while...
OBS rebuilds ALL packages on a at least weekly basis and I would suggest you reinstall packages (remove from /var/cache/pacman/pkg) to keep them fresh.  ;-)
This is a known issue with arch in OBS... I reported it upstream long time ago. https://github.com/openSUSE/obs-build/issues/129

Offline

#21 2015-02-21 00:18:55

banshee28
Member
Registered: 2008-10-18
Posts: 336

Re: [Solved] LxQT no longer starts!!!

Edit: Creating new topic since this was about starting.

Last edited by banshee28 (2015-02-21 00:26:44)


Arch64, AMD64, LXDE

Offline

#22 2015-02-21 00:27:39

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,391

Re: [Solved] LxQT no longer starts!!!

@banshee28 -- LXQt is now in [community]

https://www.archlinux.org/packages/?q=lxqt

Offline

#23 2015-02-21 00:29:33

banshee28
Member
Registered: 2008-10-18
Posts: 336

Re: [Solved] LxQT no longer starts!!!

Head_on_a_Stick wrote:

@banshee28 -- LXQt is now in [community]

https://www.archlinux.org/packages/?q=lxqt

Right.....SO I thought that was great news but something is not right. Plus the package search https://www.archlinux.org/packages/?q=lxqt only shows them without "-git". I think they all need -git to work now??


Arch64, AMD64, LXDE

Offline

#24 2015-02-21 00:33:45

metak
Member
Registered: 2009-09-27
Posts: 198

Re: [Solved] LxQT no longer starts!!!

banshee28 wrote:
Head_on_a_Stick wrote:

@banshee28 -- LXQt is now in [community]

https://www.archlinux.org/packages/?q=lxqt

Right.....SO I thought that was great news but something is not right. Plus the package search https://www.archlinux.org/packages/?q=lxqt only shows them without "-git". I think they all need -git to work now??

Just remove the ones you installed from AUR and install lxqt from community repo. That should be enough.

btw git packages in my repo work just fine. Have you encountered some issue?

Offline

#25 2015-02-21 00:42:42

banshee28
Member
Registered: 2008-10-18
Posts: 336

Re: [Solved] LxQT no longer starts!!!

metak wrote:
banshee28 wrote:
Head_on_a_Stick wrote:

@banshee28 -- LXQt is now in [community]

https://www.archlinux.org/packages/?q=lxqt

Right.....SO I thought that was great news but something is not right. Plus the package search https://www.archlinux.org/packages/?q=lxqt only shows them without "-git". I think they all need -git to work now??

Just remove the ones you installed from AUR and install lxqt from community repo. That should be enough.

btw git packages in my repo work just fine. Have you encountered some issue?

Man, I was having so many issues I think i removed all of lxqt, even your repo and left it that way for a month. I just checked and I had [community] commented out! I did not realize that so thats why when I searched I did not find it.

Anyways, thanks for the help, let me start configuring it now since it did install in just a few seconds..LOL


Arch64, AMD64, LXDE

Offline

Board footer

Powered by FluxBB