You are not logged in.

#1 2015-01-18 16:57:11

MutantJohn
Member
Registered: 2012-12-17
Posts: 95

Can't upgrade with pacman -Syu due to failed nVidia dependencies...

error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia: requires nvidia-utils=343.36

That's the error I keep getting.

I checked google and so far it only seems like 343.35-1 is available. What's going on?

I googled the error and I see the Arch Linux links on google that display the package as the correct version but when I click on the link, the page appears differently (as version 35-1).

Here's the actual link I click on : https://www.archlinux.org/packages/extr … dia-utils/

And here's the google page : https://www.google.com/search?q=nvidia% … 5&ie=UTF-8

What's goin' on, man?

Offline

#2 2015-01-18 17:04:22

psorek
Member
Registered: 2012-08-26
Posts: 13

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

Moderator comment.  Merged threads

There is 346.35 "nvidia-utils" in non-testing repo and also 343.36 "nvidia" drivers package. It prevents me from upgrading my OS. Is that repository bug (official packages list confirms these versions)?

Last edited by ewaller (2015-01-18 17:53:53)

Offline

#3 2015-01-18 17:09:52

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,446
Website

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

Think your mirror is out of sync.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#4 2015-01-18 17:13:04

psorek
Member
Registered: 2012-08-26
Posts: 13

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

I am sure that it's not, I checked twice and even changed mirror to more recent. It's also same https://www.archlinux.org/packages/extra/x86_64/nvidia/ here.

Offline

#5 2015-01-18 17:13:36

koyote
Member
From: spain
Registered: 2012-10-10
Posts: 45

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

Yup, same problem here.

~$ LANG=en_US sudo pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia: requires nvidia-utils=343.36
:: nvidia-lts: requires nvidia-utils=343.36
extra/nvidia-utils 346.35-1 [installed: 343.36-1]
    NVIDIA drivers utilities

Desktop: ASUS P5Q · Intel Core2Duo E7400@2.8 Ghz · nVidia GeForce GT 440 · 8 GB DDR2/667 · WD RE4 500 GB
Laptop: Asus F554L - Intel Core i3 4005U@1.7 Ghz · 8 GB DDR3/1600 · Intel HD Graphics 4400 · Samsung EVO 850 · HL-DT-ST GUE1N
Barebone: Slimbook ONE - Intel Core i5-6200U@2.3 Ghz · 8 GB DDR3/1600 · Intel HD Graphics 520 · WD  120 Gb (SSD) + WD 1 Tb (HDD)

Offline

#6 2015-01-18 17:14:44

PootisBird
Member
Registered: 2014-04-16
Posts: 125

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

Well I got sniped.
https://www.archlinux.org/packages/extra/i686/nvidia/

Utils is 346 while Nvidia is 343.

Last edited by PootisBird (2015-01-18 17:16:07)

Offline

#7 2015-01-18 17:16:20

psorek
Member
Registered: 2012-08-26
Posts: 13

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

I'm glad pacman is not stupid and disagreed installing it...

Offline

#8 2015-01-18 17:47:42

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

MutantJohn wrote:

I googled the error and I see the Arch Linux links on google that display the package as the correct version but when I click on the link, the page appears differently (as version 35-1).

The package has been uploaded just 90 minutes ago, Google probably hasn't updated their cache yet. I don't know how often do they reindex the internet.

Offline

#9 2015-01-18 17:49:58

keepitsimpleengineer
Member
From: San Joaquin Valley, CA
Registered: 2012-06-25
Posts: 362

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

Uff da sad
https://www.archlinux.org/packages/extr … dia-utils/

:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia: requires nvidia-utils=343.36
:: nvidia-ck-sandybridge: requires nvidia-utils=343.36

Al Einstein: "Man soll die Dinge so einfach machen wie möglich ~ aber nicht einfacher." (Things should be as simple as possible ~ but not too simple.) ~ Al (Einstein) war ein Cousin von Albert, "Al" ist die Abkürzung für Aloysius

Offline

#10 2015-01-18 17:50:06

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,894

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

Merged Can't upgrade with pacman -Syu due to failed nVidia dependencies...  with Wrong Version of Nvidia in the Repositories (Or something to that effect)

Last edited by ewaller (2015-01-18 17:52:54)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#11 2015-01-18 18:17:30

binaryplease
Member
Registered: 2012-04-11
Posts: 16

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

Having the same problem:

» sudo pacman -Syu nvidia                                                                                                                                                                                     [19:14:06]
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia: requires nvidia-utils=343.36

Any solutions ?

EDIT: my graphics card:

 lspci | grep VGA                                                                                                                                                                       [19:39:36]
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 650M] (rev a1)
02:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 650M] (rev a1)

Last edited by binaryplease (2015-01-18 18:18:41)

Offline

#12 2015-01-18 18:33:50

\hbar
Member
Registered: 2014-03-15
Posts: 165

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

Looking at the git logs for the package, it seems that nvidia-utils was updated to 343.36 by one of the maintainers, and then later downgraded to 343.35 by another. It may be a mistake, or there may be a reason. A simple solution would be to get the nvidia-utils package from the ABS, change the package version in the PKGBUILD and make the package by hand.

Offline

#13 2015-01-18 18:50:36

Micah89
Member
Registered: 2011-05-01
Posts: 29

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

Yeh, same thing happening here. One way to upgrade would be to force ignore the nvidia-utils package but... that just seems more things to break in the future. Anyone has a suitable workaround for this?

Guess we'll have to wait until someones updates the nvidia package.

Offline

#14 2015-01-18 19:03:46

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,446
Website

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

My bad... I thought that nvidia and nvidia-utils were built by the same split pacakge which is why I suggested the sync error.  I see now that:
nvidia-utils = 346.35-1
nvidia=343.36-6

Guess you'll have to just hang in there or update the PKGBUILD for nvidia and build yourself.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#15 2015-01-18 19:19:10

MutantJohn
Member
Registered: 2012-12-17
Posts: 95

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

I'm glad to see all these posts.

I think I'm just going to wait for the official package to be upgraded. It's not like I have anything special I need upgraded anyway smile

Offline

#16 2015-01-18 19:21:09

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

No need to post 'me too'.
Bug report has already been filed: https://bugs.archlinux.org/task/43497

Offline

#17 2015-01-18 20:01:01

fisco
Member
From: USA
Registered: 2015-01-18
Posts: 5
Website

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

Until it's fixed, upgrade your system using:

pacman -Syuv --ignore *nvidia*

Offline

#18 2015-01-18 20:18:43

Svenstaro
Administrator
From: Germany
Registered: 2008-11-19
Posts: 386

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

One push fails and all Arch goes wild! Chill out guys, I pushed it again.

Offline

#19 2015-01-18 20:53:08

keepitsimpleengineer
Member
From: San Joaquin Valley, CA
Registered: 2012-06-25
Posts: 362

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

fisco wrote:

Until it's fixed, upgrade your system using:

pacman -Syuv --ignore *nvidia*

Fixed... smile already


Al Einstein: "Man soll die Dinge so einfach machen wie möglich ~ aber nicht einfacher." (Things should be as simple as possible ~ but not too simple.) ~ Al (Einstein) war ein Cousin von Albert, "Al" ist die Abkürzung für Aloysius

Offline

#20 2015-01-18 21:27:48

MutantJohn
Member
Registered: 2012-12-17
Posts: 95

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

So... the upgrade broke my computer. The newest nVidia stuff fails with gdm. What do I do?

Basically, I'm using Gnome 3 and today's upgrades and now when I try to turn on my computer and log in, a screen pops up telling me that an error has occurred and the system can't recover. What do I do?

How do I work around gdm being bad?

Offline

#21 2015-01-18 23:24:29

h54
Member
Registered: 2011-11-22
Posts: 96

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

MutantJohn wrote:

So... the upgrade broke my computer. The newest nVidia stuff fails with gdm. What do I do?

Basically, I'm using Gnome 3 and today's upgrades and now when I try to turn on my computer and log in, a screen pops up telling me that an error has occurred and the system can't recover. What do I do?

How do I work around gdm being bad?


I'm in the same boat.  The old packages aren't available via downgrade either... figures.

Offline

#22 2015-01-18 23:34:38

\hbar
Member
Registered: 2014-03-15
Posts: 165

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

h54 wrote:

I'm in the same boat.  The old packages aren't available via downgrade either... figures.

Have you checked the ARM ( http://seblu.net/a/arm/ )?

As for why the problem is occurring, could you provide some logs, or other information besides that it doesn't work?
edit: nevermind https://bbs.archlinux.org/viewtopic.php?id=192415

Last edited by \hbar (2015-01-18 23:35:57)

Offline

#23 2015-01-18 23:44:03

onslow77
Member
Registered: 2014-09-21
Posts: 279

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

Hello,

Latest nvidia drivers [346.35-2] broke my computer too, I could not  - startx

I solved it by downgrading with drivers from my /var/cache/pacman/pkg as stated In this wiki page here at Arch Linux

Regards
Martin

Last edited by onslow77 (2015-01-18 23:57:17)


It is advised to follow the How to post guide when posting on the Arch forum. If one consciously jumps over these elementary steps like reading the wiki and providing necessary information about the problem, one can be regarded as a Help Vampire.

Offline

#24 2015-01-19 00:40:21

fisco
Member
From: USA
Registered: 2015-01-18
Posts: 5
Website

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

\hbar wrote:
h54 wrote:

I'm in the same boat.  The old packages aren't available via downgrade either... figures.

Have you checked the ARM ( http://seblu.net/a/arm/ )?

As for why the problem is occurring, could you provide some logs, or other information besides that it doesn't work?
edit: nevermind https://bbs.archlinux.org/viewtopic.php?id=192415

Same problem...from the logs, I suspect these two are the most telling:

FBDEV(0): FBIOBLANK: Invalid argument
Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

Offline

#25 2015-01-19 02:28:28

fisco
Member
From: USA
Registered: 2015-01-18
Posts: 5
Website

Re: Can't upgrade with pacman -Syu due to failed nVidia dependencies...

fisco wrote:
\hbar wrote:
h54 wrote:

I'm in the same boat.  The old packages aren't available via downgrade either... figures.

Have you checked the ARM ( http://seblu.net/a/arm/ )?

As for why the problem is occurring, could you provide some logs, or other information besides that it doesn't work?
edit: nevermind https://bbs.archlinux.org/viewtopic.php?id=192415

Same problem...from the logs, I suspect these two are the most telling:

FBDEV(0): FBIOBLANK: Invalid argument
Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

OK...got it working, on my workstation at least. It appears that this version of the driver MUST have a Xorg conf file giving the PCI bus location of the video card you are using. So, to get my system to work, I added in /etc/X11/xorg.conf.d a file called "10-nvidia.conf".  In that file I have:

Section "Device"
   Identifier "Device0"
   Driver "nvidia"
   VendorName "NVIDIA Corporation"
   BoardName "GeForce GT 610"
   BusID "PCI:1:0:0"
EndSection

You can use this as a starting point, but you'll need to get the correct BusID for it to work. I believe VendorName and BoardName can be omitted. I assume your identifier needs to be unique.

You will probably need to use sudo to create this file.

Offline

Board footer

Powered by FluxBB