You are not logged in.

#1 2006-02-27 23:28:50

billbar
Member
Registered: 2004-02-14
Posts: 100

Camera detection (RESOLVED) back again

Really tried to research this question but solutions I found produce no joy.
My camera is an Olympus brio D-100.  When I plug it in to Mepis or almost anyplace else it turns up on /dev/sda1.

I just reinstalled from 0.7.1 and upgraded.  The version of udev is 084-4.

Here's the output of lsusb:
Bus 002 Device 003: ID 07b4:0102 Olympus Optical Co., Ltd Camedia E-10/C-220/C-50 Camera
Bus 002 Device 002: ID 04b8:010c Seiko Epson Corp. Perfection 640
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 046d:c03d Logitech, Inc.
Bus 001 Device 002: ID 03f0:1104 Hewlett-Packard DeskJet 959c
Bus 001 Device 001: ID 0000:0000

As instructed in another posting I added these lines to /etc/udev/rules.d/udev.rules;
ACTION=="add", SYSFS{idVendor}=="07b4", SYSFS{idProduct}=="0102", RUN+="/bin/chmod o-rwx $env{DEVICE}"
ACTION=="add", SYSFS{idVendor}=="07b4", SYSFS{idProduct}=="0102", RUN+="/bin/chgrp users $env{DEVICE}"
ACTION=="add", SYSFS{idVendor}=="07b4", SYSFS{idProduct}=="0102", RUN+="/bin/chmod g+rw $env{DEVICE}", OPTIONS="last_rule"

These entries are followed by:

LABEL="persistent_end"
#####################################
# Persistant block device stuff - end
#####################################

# debugging monitor
RUN+="socket:/org/kernel/udev/monitor"

I rebooted before executing digikam.

Appreciate your help with this problem.

Bill Barnes

Offline

#2 2006-02-28 02:52:30

viniosity
Member
From: New York, NY
Registered: 2005-01-22
Posts: 378
Website

Re: Camera detection (RESOLVED) back again

After you plug it in take a look at dmesg and see where it gets recognized.  Then you'll have to manually mount it.

Offline

#3 2006-02-28 10:08:52

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: Camera detection (RESOLVED) back again

Latest udev versions set up gphoto supported cameras automatically. You don't need any extra rules.
The question is what kind of camera is this? Does it work through gphoto or usb storage?

billbar wrote:

When I plug it in to Mepis or almost anyplace else it turns up on /dev/sda1.

This suggests that it works through usb storage and this is different from changing permissions to /proc directory via udev (I think).

There is only 1 brio camera mentioned on  gphoto supported hardware page but I guess it's similar to yours. There are some comments about it.

Theoretically it should work out of the box. When you plug in your camera usb-storage module should be loaded (if it wasn't loader ealier) and /dev/sdX, /dev/sdX1 link created. So what you need to automate it fully is some kind of automounter and/or something in /etc/fstab (depending on your window manager/desktop enviroment).

Is /dev/sdX1 created when you plug in your camera?
Is usb-storage module loaded when you do it (lsmod) ?
If not load usb-storage manually (modprobe usb-storage) and check again for /dev/sdX1. If it works you can add this module to MODULES in /etc/rc.conf.

Then you can also try automounting using pure udev rules only or any of the available automounters out there (search wiki & forum for configs).

Offline

#4 2006-02-28 14:37:03

Snarkout
Member
Registered: 2005-11-13
Posts: 542

Re: Camera detection (RESOLVED) back again

If you're using dbus and hal, you might see if there are any groups in /etc/group you need to add hal to - I found adding hal to the "disk" group especially useful.


Unthinking respect for authority is the greatest enemy of truth.
-Albert Einstein

Offline

#5 2006-02-28 18:35:23

billbar
Member
Registered: 2004-02-14
Posts: 100

Re: Camera detection (RESOLVED) back again

Found a way to get the camera images.
I can 'mount -t vfat /dev/sda1 /mnt/camera' as root and access the images with gimp, then save the image/s in a digikam users directory,
assuming that I will use digikam, which I don't see serves me any better than gimp.

The precaution I have to observe is 'umount' the device before unplugging the camera.  Otherwise, I end up with a 'device busy' when invoking umount.  I'll take a look at the automounting reference in your last post.

Thanks for the help.

Offline

#6 2006-02-28 19:14:06

viniosity
Member
From: New York, NY
Registered: 2005-01-22
Posts: 378
Website

Re: Camera detection (RESOLVED) back again

Also, try F-spot

Offline

#7 2006-02-28 20:57:24

Snarkout
Member
Registered: 2005-11-13
Posts: 542

Re: Camera detection (RESOLVED) back again

Snarkout wrote:

If you're using dbus and hal, you might see if there are any groups in /etc/group you need to add hal to - I found adding hal to the "disk" group especially useful.

Actually, scratch that.  My flippin' ipod isn't being mounted anymore.


Unthinking respect for authority is the greatest enemy of truth.
-Albert Einstein

Offline

#8 2006-03-01 09:51:59

Kern
Member
From: UK
Registered: 2005-02-09
Posts: 460

Re: Camera detection (RESOLVED) back again

altho you are working it ok now, have you tried pmount as a normal user?

Offline

#9 2006-03-24 03:40:52

billbar
Member
Registered: 2004-02-14
Posts: 100

Re: Camera detection (RESOLVED) back again

The problem is back in that /dev/sda1 can not be unmounted because it is busy, whether or no that I unplug it.
I added this to fstab '/dev/sda1    /media/camera    vfat        user,auto    0    0'.
This adds to the list in kwikdisk, so mounting is easy.
Short of rebooting how do I make this device 'unbusy'.

Thanks,
Bill

Offline

#10 2006-05-23 13:12:51

fdac
Member
From: Brisbane, Australia
Registered: 2005-06-19
Posts: 96

Re: Camera detection (RESOLVED) back again

billbar wrote:

As instructed in another posting I added these lines to /etc/udev/rules.d/udev.rules;
ACTION=="add", SYSFS{idVendor}=="07b4", SYSFS{idProduct}=="0102", RUN+="/bin/chmod o-rwx $env{DEVICE}"
ACTION=="add", SYSFS{idVendor}=="07b4", SYSFS{idProduct}=="0102", RUN+="/bin/chgrp users $env{DEVICE}"
ACTION=="add", SYSFS{idVendor}=="07b4", SYSFS{idProduct}=="0102", RUN+="/bin/chmod g+rw $env{DEVICE}", OPTIONS="last_rule"

Hi Bill, I had tried this solution too (from another forum post) but in the last few months it has stopped working.

My fix was to REMOVE those extra lines from 010.udev.rules because the updated versions of (udev? gphoto2?) seem to work properly right out of the box.   I think the quoted suggestion above no longer works and can actually stop the default configuration from working!

Hope this helps
Francis

Offline

Board footer

Powered by FluxBB