You are not logged in.

#1 2006-03-01 03:52:26

briancurtin
Member
From: Chicago, IL
Registered: 2006-02-11
Posts: 132
Website

various things shutting my computer down

read my later post in the thread about the newest problem


i was having this problem a few days ago and decided to just reinstall (nothing else going on one night so i redid everything), but this problem is still happening. it started after upgrading to xorg7: my computer just randomly decides to shut down, and it looks like gconf is doing it. i had another thread going earlier for a few days but started this new one since i edited everything out of the old one saying the problem was fixed. im running GNOME, using a few applications and all of a sudden my computer is shutting off, unannounced. this has happened probably 18 times in the last week, all abrupt hard shutdowns and they all leave the same footprint in /var/log/messages.log pointing towards something with gconf. im somewhat new to linux (8 months of every day experience) and am not sure where to go about this. since it looks to me like gconf is the culprit, and its shutting me down fairly often, i just want it gone. i dont use it (maybe i do but dont know it), but a bunch of stuff does.

anyone know a fix to this?
let me know if you need more information/log files
here is /var/log/messages.log after my most recent shutdown (the first one since reinstalling noodles): http://briancurtin.com/messages.log.txt

Offline

#2 2006-03-01 19:45:28

briancurtin
Member
From: Chicago, IL
Registered: 2006-02-11
Posts: 132
Website

Re: various things shutting my computer down

someone else has to be having this problem. i reinstalled, and all i installed was gdm and xfce and gconf is already taking a shit on me.

Offline

#3 2006-03-01 20:58:45

_Gandalf_
Member
Registered: 2006-01-12
Posts: 735

Re: various things shutting my computer down

is your home partition seperated? if yes then what about erasing ur ~/.gconf folder ?

Offline

#4 2006-03-01 23:10:12

briancurtin
Member
From: Chicago, IL
Registered: 2006-02-11
Posts: 132
Website

Re: various things shutting my computer down

yeah it is separated, and so i got rid of that folder. thanks a lot for that tip, i dont know anything about gconf or what it does so im reading up on it.

thanks a lot man

Offline

#5 2006-03-02 00:21:10

_Gandalf_
Member
Registered: 2006-01-12
Posts: 735

Re: various things shutting my computer down

no problem, gconf is equivalent to windows registry in windows, which is a kinda like a database that holds some configurations for application, for gnome panel, metacity, etc... etc.., look at it in Applications -> System Tools -> Configuration Editor..

Offline

#6 2006-03-02 18:14:10

briancurtin
Member
From: Chicago, IL
Registered: 2006-02-11
Posts: 132
Website

Re: various things shutting my computer down

new problem

so i did what gandalf recommended and it really didnt work out for me, still shut me down several times. so i decided to just try something else that wont use gconf...a fresh install with kde. ive been shutdown 4 times in the first hour and a half of me even being awake, once i got shut down after only being on after a restart for 3 minutes. my /var/log/messages.log has a bunch of renditions of the following file, one for each shutdown that occured. here goes, hopefully someone might know where to point me on this one. http://briancurtin.com/messages.log2.txt

id like to be using XFCE as its my favorite, but gconf hates me there too. i might try and install XFCE again over the next few days and see if gconf still hates me after coming back to it from kde.

Offline

#7 2006-03-02 19:46:09

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,039

Re: various things shutting my computer down

looking at your log file it seems your problems are with your modules, not so much gconf/kde.

it looks like you haven' t tweaked mkinitrd and are missing some modules for your chipset.

post your mkinitrd.conf and the output of

hwdetect --ide

the output of

hwdetect --modules

and your rc.conf will also shed some light.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Online

#8 2006-03-02 21:56:47

briancurtin
Member
From: Chicago, IL
Registered: 2006-02-11
Posts: 132
Website

Re: various things shutting my computer down

thats a correct assumption, havent touched mkinitrd.conf. i read that the default should be alright for the most part, so being the new guy to arch that i am, i left it how it was. i look a lot stupider now blaming problems on gconf when it was something i left out and didnt know how to do.

mkinitrd.conf

# Initial Ramdisk setup
# Attention:
# You need only the stuff to be able to mount your root device!
# USB/FW are only needed if you boot from such devices!

# REMOVE_IDE:           removes the complete IDE subsystem
# REMOVE_SCSI:          removes the complete SCSI subsystem
# REMOVE_SATA:          removes the complete SATA subsystem
# REMOVE_CDROM:         removes cdrom support
# REMOVE_USB:           removes the complete USB subsystem
# REMOVE_FW:            removes the complete Firewire subsystem
# REMOVE_RAID:          removes the complete Software RAID subsystem
# REMOVE_DM:            removes the complete device-mapper/LVM subsystem
# REMOVE_FS:            removes the complete Filesystems
#                       (you have to include the filesystem in kernel then!)
# AUTODETECT:           enables Arch Linux autodetection
# HOSTCONTROLLER_*:     specify the modules you need to setup the subsystem "moduleX moduleY",
#                       empty means all modules are included
# FILESYSTEMS:          specify your filesystem modules here, eg. "ext3 reiserfs"
#                       empty means all modules are included
# USB_TIMEOUT:          value means  seconds to wait for bringing up usb disks
# CRYPT_DEVICE:         the path to your encrypted root device, if you use one
# RAID_DEVICES:         a space-delimited list of the devices belonging in
#                       your /dev/md0 (root) RAID array
#                           (eg, "/dev/hda3 /dev/hdc3")
#
# ADD_MODULE:           adds modules e.g. "moduleX moduleY"
# REMOVE_MODULE:        removes modules e.g. "moduleX moduleY"
#
# To rebuild initrd for Arch standard kernel just rerun 'mkinitrd auto'



# Disable whole subsystems by setting to "1"
REMOVE_IDE=
REMOVE_SCSI=
REMOVE_SATA=
REMOVE_CDROM=
REMOVE_USB=1
REMOVE_FW=1
REMOVE_RAID=1
REMOVE_DM=1
REMOVE_FS=

# Enable auto-detection of HOSTCONTROLlER and FILESYSTEMS (set to "1")
#   (NOTE: This is still experimental, so it is disabled by default)
AUTODETECT=0

# Define which modules are needed by adding "moduleX moduleY"
# If left empty, all modules are included if they are not disabled above
HOSTCONTROLLER_IDE=
HOSTCONTROLLER_SCSI=
HOSTCONTROLLER_SATA=
HOSTCONTROLLER_USB=
FILESYSTEMS=

# Number of seconds to wait for USB devices to settle
USB_TIMEOUT=5

# If you have an encrypted root filesystem, set it here (eg, /dev/hda4)
CRYPT_DEVICE=

# If you use software RAID for your root device then list all the devices
# that belong to your root array here.  If your root RAID device is
# something other than md0, then change the RAID_ROOT_ARRAY setting.
#    eg, RAID_ROOT_DEVICES="/dev/hda3 /dev/hdc3"
RAID_ROOT_ARRAY="md0"
RAID_ROOT_DEVICES=

# If you use LVM on your root device, then specify it here
#    eg, LVM_ROOT="/dev/vg_root/lv_root"
LVM_ROOT=

# Define additional modules here
ADD_MODULE=
REMOVE_MODULE=

hwdetect --ide

HOSTCONTROLLER_IDE: generic piix

hwdetect --modules

MODULES=(cdrom agpgart intel-agp hw_random lp ppdev rtc evdev pcspkr serio_raw parport parport_pc pci_hotplug shpchp nvidia snd-mixer-oss snd-pcm-oss snd-page-alloc snd-timer snd snd-ac97-bus snd-ac97-codec snd-intel8x0 snd-intel8x0m soundcore ide-cd ide-core ide-disk generic piix 8139cp 8139too mii pcmcia_core rsrc_nonstatic yenta_socket usb-storage usblp usbhid usbcore ehci-hcd uhci-hcd eth1394 ieee1394 ohci1394 sbp2)

thanks a lot man

Offline

#9 2006-03-02 21:59:10

briancurtin
Member
From: Chicago, IL
Registered: 2006-02-11
Posts: 132
Website

Re: various things shutting my computer down

oh and heres rc.conf

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

#
# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/unimaps
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE=
HARDWARECLOCK="localtime"
TIMEZONE=America/New_York
KEYMAP=us
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

#
# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# Scan hardware and load required modules at bootup
MOD_AUTOLOAD="yes"
# Module Blacklist - modules in this list will never be loaded by hwdetect
MOD_BLACKLIST=()
#
# Modules to load at boot-up (in this order)
#   - prefix a module with a ! to disable it
#
MODULES=(!usbserial snd-pcm-oss snd-intel8x0)
# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

#
# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
HOSTNAME="schi6068dap"
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
eth0="dhcp"
INTERFACES=(lo eth0)
#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)
#
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network-profiles
#
#NET_PROFILES=(main)

#
# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng !hotplug !pcmcia network netfs crond alsa)

# End of file

Offline

#10 2006-03-04 15:14:47

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,039

Re: various things shutting my computer down

It seems you have 2 problems : one with the ide drivers, and another with the sound system.

As root (easiest from console) :

Change the red lines in mkinitrd.conf,  and run "mkinitrd auto"

# Disable whole subsystems by setting to "1"
REMOVE_IDE=
REMOVE_SCSI=1
REMOVE_SATA=1
REMOVE_CDROM=1
REMOVE_USB=1
REMOVE_FW=1
REMOVE_RAID=1
REMOVE_DM=1
REMOVE_FS=

# Enable auto-detection of HOSTCONTROLlER and FILESYSTEMS (set to "1")
#   (NOTE: This is still experimental, so it is disabled by default)
AUTODETECT=1

# Define which modules are needed by adding "moduleX moduleY"
# If left empty, all modules are included if they are not disabled above
HOSTCONTROLLER_IDE="piix"
HOSTCONTROLLER_SCSI=
HOSTCONTROLLER_SATA=
HOSTCONTROLLER_USB=
FILESYSTEMS=

--------------------------------------

About rc.conf :

Although snd-pcm-oss & snd-intel8x0 are modules needed for your chipset, Udev auto detection sometimes fails when modules are loaded in the wrong order.
The easiest way is probably to remove those 2 modules from rc.conf and let Udev decide what to do by itself.

just put MODULES=(!usbserial) in rc.conf, reboot, and let' s see what messages.log gives then.
If there are no more errors visible in messages.log , test if your sounds work.

These changes should make your system more stable.

Note : initrd will still load all filesystem modules, (if you are only using reiserfs this can also be tweaked further), but this should not give problems apart from some unused modules taking up some memory.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Online

#11 2006-03-21 00:37:56

briancurtin
Member
From: Chicago, IL
Registered: 2006-02-11
Posts: 132
Website

Re: various things shutting my computer down

i finally got around to redoing this stuff and i am now in with the changes you recommended.

its been very stable, but i just dont have any sound now. the only way ive been able to get sound to work in the past has been by doing what i did up above with adding the modules in rc.conf, but is there a better way i can get this done?

Offline

#12 2006-03-21 09:50:45

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: various things shutting my computer down

Did you remove the OSS compatibility in /etc/modprobe.conf?

Not doing this can in some case result in not having sound.

Offline

#13 2006-03-21 17:46:51

briancurtin
Member
From: Chicago, IL
Registered: 2006-02-11
Posts: 132
Website

Re: various things shutting my computer down

aha! there we go, sound at last. i commented out those two lines in modprobe.conf and came back to the sweet sounds i was looking for.

thanks a lot guys, i appreciate everyone helping me get set up *properly* here. i got my first install up, but wasnt done the right way, so thanks for the tips.

Offline

Board footer

Powered by FluxBB