You are not logged in.

#1 2015-02-01 07:11:16

nullified
Member
From: Massachusetts, USA
Registered: 2013-12-09
Posts: 468

[SOLVED] Cannot change fs.inotify.max_user_watches permanently

Hi,

I receive the following error in Atom:

Unable to watch path: config.cson. Make sure you have permissions to /home/vga/.atom/config.cson. On linux there are currently problems with watch sizes. See this document for more info.

This is a known issue, and is documented here and here. According to these pages, setting fs.inotify.max_user_watches to a higher value works, albeit temporarily:

sudo sysctl fs.inotify.max_user_watches=32768

This does in fact work for me, and I am able to use Atom. Unfortunately, the permanent solution to the problem does not work. This same solution is offered for various other related issues that I found including this issue for Dropbox on Arch.

The solution is to add the following line to /etc/sysctl.conf, or according to the Arch Dropbox wiki, to /etc/sysctl.d/99-sysctl.conf:

fs.inotify.max_user_watches = 100000

and then to run:

sysctl --system

I've done this a few times with one or the other file as well as both. The output:

* Applying /usr/lib/sysctl.d/50-coredump.conf ...
kernel.core_pattern = |/usr/lib/systemd/systemd-coredump %p %u %g %s %t %e
* Applying /usr/lib/sysctl.d/50-default.conf ...
kernel.sysrq = 16
kernel.core_uses_pid = 1
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.all.rp_filter = 1
net.ipv4.conf.default.accept_source_route = 0
net.ipv4.conf.all.accept_source_route = 0
net.ipv4.conf.default.promote_secondaries = 1
net.ipv4.conf.all.promote_secondaries = 1
net.core.default_qdisc = fq_codel
fs.protected_hardlinks = 1
fs.protected_symlinks = 1
* Applying /etc/sysctl.d/99-sysctl.conf ...
* Applying /etc/sysctl.conf ...
fs.inotify.max_user_watches = 100000

Again, Atom works after this command. But after a reboot it no longer works. For some reason /proc/sys/fs/inotify/max_user_watches is reset to:

8192

I've found this permanent solution on the Atom website, here on the Arch wiki for a related issue, and on a few other forums (Ubuntu, Red Hat). It always seems to be the solution for the issue. But I can't figure out why editing /etc/sysctl.conf is not making the fix permanent in my case.

Any guidance is appreciated!

Edit: according to this here: /etc/sysctl.conf is deprecated, and I should have caught that! But the change didn't hold when /etc/sysctl.d/99-sysctl.conf was edited either.

Last edited by nullified (2015-02-01 07:37:25)


"We may say most aptly, that the Analytical Engine weaves algebraical patterns just as the Jacquard-loom weaves flowers and leaves." - Ada Lovelace

Offline

#2 2015-02-01 07:22:34

nullified
Member
From: Massachusetts, USA
Registered: 2013-12-09
Posts: 468

Re: [SOLVED] Cannot change fs.inotify.max_user_watches permanently

Okay, I may have fixed my problem.

I've added

fs.inotify.max_user_watches = 100000

to /usr/lib/sysctl.d/50-default.conf  (I realized that I should try this after reading over my post).

I am still curious about this though. Why did editing this file work but not /etc/sysctl.conf? If this is not peculiar to my own case, then perhaps the Arch Dropbox wiki should be edited (as well as the Atom forum)? I don't want to do that without understanding the nature of the problem and what seems like a solution.

I will wait a short while before marking the thread [SOLVED] in case there is some issue lurking here.

EDIT: There is no lurking issue. /etc/sysctl.conf is deprecated and I should have caught that.

Last edited by nullified (2015-02-01 07:37:13)


"We may say most aptly, that the Analytical Engine weaves algebraical patterns just as the Jacquard-loom weaves flowers and leaves." - Ada Lovelace

Offline

#3 2017-05-08 07:04:31

thePanz
Member
Registered: 2017-05-08
Posts: 3

Re: [SOLVED] Cannot change fs.inotify.max_user_watches permanently

Thanks for sharing, the correct file where that setting should be added, as mentioned by the Arch `50-defaults.conf` is `/usr/lib/sysctl.d/90-override.conf` as it will be loaded after all previous configurations.
Looks weird that it did not work for you

Offline

#4 2017-05-08 10:02:37

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 6,980
Website

Re: [SOLVED] Cannot change fs.inotify.max_user_watches permanently


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB