You are not logged in.

#1 2015-02-04 11:14:44

Wilco
Member
Registered: 2008-11-09
Posts: 437

KDE5 correct way to disable baloo

Looking for the best way to permanently disable the baloo file indexer. The problem is a baloo_file spawns every now and then and it consumes 100% cpu indefinitely.

First I tried disabling baloo from the KDE settings, "Enable desktop search" is de-activated. Still, baloo_file is running.

$ balooctl status
Baloo File Indexer is running
Indexed 24013 / 24013 files

I can disable balooctl using the command line:

$ balooctl disable
Disabling the File Indexer

But the baloo_file process keeps running. Now I've symlinked /usr/bin/true to /usr/bin/baloo_file. This works, but this is a temporary solution until the next update. Anyone with insight into the correct way to stop baloo forever?

Offline

#2 2015-02-04 12:42:00

Roberth
Member
From: The Pale Blue Dot
Registered: 2007-01-12
Posts: 891

Re: KDE5 correct way to disable baloo

I had to reboot my computer after running balooctl disable.


Use the Source, Luke!

Offline

#3 2015-02-26 18:49:07

elfio
Member
Registered: 2011-05-03
Posts: 24

Re: KDE5 correct way to disable baloo

I have the same issue:

$ balooctl status
Baloo File Indexer is running
Indexed 46660 / 46660 files

Is there a way to make it work properly? I really want to give it a chance, but its eating my cpu and the fan keeps spining :-/
Maybe I should fill a bug report?
My laptop has a T8100 core2duo and a SSD.

SS of process-manager:
cSjJM9I.png

Last edited by elfio (2015-02-26 18:50:49)

Offline

#4 2015-03-05 11:25:12

elfio
Member
Registered: 2011-05-03
Posts: 24

Re: KDE5 correct way to disable baloo

Hi there!

I wiped all Baloo data in my /home and now it work like a charm.

Offline

#5 2015-03-06 15:03:39

theodore
Member
From: Aalborg / Denmark
Registered: 2008-09-09
Posts: 68

Re: KDE5 correct way to disable baloo

I have the same issue. Is this cpu consumption normal, or it is due to a bug. It is really frustrating.

Last edited by theodore (2015-03-06 15:03:59)

Offline

#6 2015-03-06 19:42:55

Soukyuu
Member
Registered: 2014-04-08
Posts: 844

Re: KDE5 correct way to disable baloo

It has to be a bug or a glitch, simply because on my installation it uses 0% CPU. The bigger question would be, what is triggering it. I never even saw it use any CPU at all.


[ Arch x86_64 | linux | ThinkPad X220 | Intel Core i5 2540M@3.3Ghz | Intel HD3000 | 16GB RAM | Main, docked to 2 Monitors ]
[ Arch x86_64 | linux-ck-k10 | Custom-built | AMD Phenom II X4@3,5Ghz | nVidia 260 GTX | 12GB RAM | Retired ]
[ Arch x86_64 | linux | Custom-built | Intel Celeron G3920@2,99Ghz | iGPU | 8GB RAM | Home server ]

Offline

#7 2015-03-10 23:31:06

Chuck Arch Linux
Member
Registered: 2011-06-23
Posts: 72

Re: KDE5 correct way to disable baloo

The best way I find to permanently wipe out baloo is search for all file on my system that contain baloo in it and delete all.
If I don't delete all baloo file in /usr/bin, I always get a baloo process running.

After this....all went calm again.

Offline

#8 2015-03-11 06:25:35

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 315
Website

Re: KDE5 correct way to disable baloo

And maybe... try "baloo-free" apps in place of those that baloo/milou depends: plasma-workspace-light, gwenview-light... See: https://aur.archlinux.org/packages/plas … pace-light, https://aur.archlinux.org/packages/gwenview-light/. After that, maybe, you can remove baloo and milou.

Offline

#9 2015-05-02 23:03:01

odido
Member
From: Bulgaria
Registered: 2015-01-31
Posts: 3

Re: KDE5 correct way to disable baloo

I have some strange issue smile

balooctl status
Baloo File Indexer is NOT running
Indexed 2882 / 2882 files

baloo is not runnig ,but continuing indexing files...

Offline

#10 2015-05-02 23:38:37

Soukyuu
Member
Registered: 2014-04-08
Posts: 844

Re: KDE5 correct way to disable baloo

You're reading that wrong. Baloo indexer is not running, but there are already files indexed. That usually happens if you execute 'balooctl stop'. running 'balooctl disable' should empty the index:

Baloo File Indexer is NOT running
Indexed 0 / 0 files
Failed to index 0 files

[ Arch x86_64 | linux | ThinkPad X220 | Intel Core i5 2540M@3.3Ghz | Intel HD3000 | 16GB RAM | Main, docked to 2 Monitors ]
[ Arch x86_64 | linux-ck-k10 | Custom-built | AMD Phenom II X4@3,5Ghz | nVidia 260 GTX | 12GB RAM | Retired ]
[ Arch x86_64 | linux | Custom-built | Intel Celeron G3920@2,99Ghz | iGPU | 8GB RAM | Home server ]

Offline

#11 2015-05-03 22:28:03

JKAbrams
Member
From: Sweden
Registered: 2011-11-07
Posts: 81

Re: KDE5 correct way to disable baloo

New Plasma update and Baloo is back to eating 100% CPU.

balooctl status
Baloo File Indexer is running
Indexed 31764 / 425378 files

AND

baloo_file is using 25% CPU (that is 100% on one core which makes the system laggy and unresponsive)

In System Settings Baloo I had  Beloo set to disabled, but it enabled itself.

Ran balooctl disable again, hopefully it'll sticks this time.

Offline

#12 2015-06-30 14:47:27

vhanda
Member
Registered: 2015-06-30
Posts: 1

Re: KDE5 correct way to disable baloo

Sorry about this.

There seems to have been a bug in Xapian (our underlying database in Plasma 5.3) which caused it to lock up and go into an infinite loop. Hence even though you disable baloo and tell it to quit, its stuck in that loop and ignores the quit command.

With the next release of Plasma we've moved away from Xapian and have more control of the underlying layers.

Offline

#13 2016-06-30 15:39:34

Square7
Member
Registered: 2015-11-20
Posts: 7

Re: KDE5 correct way to disable baloo

The problem still persists on 3 of my Arch systems. They are all configured similar but are totaly independent. Baloo allways uses one entire core, which is why I disabled it again although I would really love to use it.

Last edited by Square7 (2016-06-30 15:40:40)

Offline

#14 2017-04-17 19:27:10

thorjelly
Member
Registered: 2009-02-15
Posts: 52

Re: KDE5 correct way to disable baloo

Kind of an old thread, but I'm also getting this bug now. According to balooctl status:

Baloo File Indexer is running
Indexer state: Indexing file content
Indexed 40263 / 40264 files
Current size of index is 635.68 MiB

So it appears that there is a single file that it's stuck on and it keeps causing baloo to churn away at 100% CPU usage? Is there any way to find out what file this is?

Last edited by thorjelly (2017-04-17 19:27:35)

Offline

#15 2017-04-17 20:16:56

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,671

Re: KDE5 correct way to disable baloo

balooctl monitor

can be used to check what it is indexing.

Offline

#16 2017-08-06 12:02:05

firewalker
Member
From: Hellas (Greece).
Registered: 2006-06-05
Posts: 469

Re: KDE5 correct way to disable baloo

For me "balooctl monitor" doesn;t show anything. Just "Press ctrl+c to exit monitor".


Γίνε ρεαλιστής, μείνε ονειροπόλος ...

Offline

#17 2017-10-11 19:52:26

microMXL
Member
Registered: 2013-08-19
Posts: 1

Re: KDE5 correct way to disable baloo

well is indexing all the god damn android Sdk, I'll let him finish

Offline

#18 2017-10-27 02:50:51

Barkester
Member
Registered: 2017-07-01
Posts: 19

Re: KDE5 correct way to disable baloo

Been happening a couple years? Only just started for me.

Did top and quickly found out why my fan was nuts for a few days when barely used. Baloo just spinning away.

I've been killing it each time with kill since. Easily done after seeing top with the pid. Everything I use seems fine without it.

Chuck says he deleted it. I did the locate search and the list is pretty long. Still unsure. like to know more before. One says he wished he could use it, but I'm actually still vague on it's purpose. Haven't noticed anything not working after killing it. Deletion is looking good.

'Till better comes, Using top to get the pid and killing does work. considering an alias as its becoming a regular command.

I'll check back every now and then in the hopes of that better way. Bound to be one.

Offline

#19 2017-10-27 03:13:51

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,100

Re: KDE5 correct way to disable baloo

Barkester wrote:

Chuck says he deleted it. I did the locate search and the list is pretty long. Still unsure. like to know more before. One says he wished he could use it, but I'm actually still vague on it's purpose. Haven't noticed anything not working after killing it. Deletion is looking good.

And if Chuck says he drilled a hole through his keyboard, will you do that, too? Deleting files from directories controlled by pacman is never a good idea. It will usually break things sooner rather than later. Failing that, it will break things later when you've absolutely no idea what the cause of the breakage might be. In any case, it is usually ineffective. For example, everything will get replaced next time updates include baloo-related files. (If only some of them get updated, things may get really interesting. Otherwise, you're just back where you started.)

I'll check back every now and then in the hopes of that better way. Bound to be one.

Did you read the rest of the thread? Did you try balooctl distable?

$ balooctl status
Baloo File Indexer is running
Indexer state: Idle
Indexed 26183 / 26183 files
Current size of index is 939.90 MiB
$ balooctl disable
Disabling the File Indexer
$ balooctl status
Baloo is currently disabled. To enable, please run "balooctl enable"

Also, in system settings, check what is configured to start at login and which services you have enabled.

It does seem that disabling it in system settings is not sufficient. However, make sure that it is disabled there as well.

Startup & Shutdown
> check autostarting stuff
> check background services
> check search
   > file search should be disabled

[I'm not sure what plasma search is, but you can always try disabling this lot as well, see what breaks.]

The problem, as always in KDE, is not stopping the thing, but ensuring it doesn't start again when you're not looking.

Last edited by cfr (2017-10-27 03:27:38)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#20 2017-10-28 03:00:13

Barkester
Member
Registered: 2017-07-01
Posts: 19

Re: KDE5 correct way to disable baloo

I'll need a few days to say it definately worked, but its done.

KDE/enlightenment and KDE/Plasma are both nice. Like it more than Gnome, but it is so full of stuff. Never even realized how much so until I just now really went through each setting and turned most of it off. Keep experimentin'.
xfce sounds more like arch where you can add all kinds of stuff after while it itself is very small. Good on paper. Reckon I'll try it. The final baloo solution you might say. should take less time than these settings.

Thanks for the tips.

EDIT: I stuck with kde and with the baloo off using the above solution and the settings minimized. Its so nice, I'm gonna wait on the xfce 'till next fresh install. This is about 2 weeks later and not a hitch.

Last edited by Barkester (2017-11-10 05:56:12)

Offline

#21 2018-05-30 08:23:23

dalu
Member
Registered: 2014-04-16
Posts: 43

Re: KDE5 correct way to disable baloo

cfr wrote:

And if Chuck says he drilled a hole through his keyboard, will you do that, too?

I think you should reconsider how you talk to people and maintain a friendly tone. I'll report you anyhow.

Offline

#22 2018-05-30 08:41:55

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,671

Re: KDE5 correct way to disable baloo

It's an 8 month old offhand remark, that really is hard to construct as an actual insult in the context of the reply.

Don't bump a thread for something like that.

https://wiki.archlinux.org/index.php/Co … bumping.22

Closing.

Last edited by V1del (2018-05-30 08:42:59)

Offline

Board footer

Powered by FluxBB