You are not logged in.

#1 2015-02-07 08:23:49

Registered: 2013-05-31
Posts: 5

[SOLVED] Wrong symbolic links in ~/.steam folder

I have following problem. I can run steam successfully, but at start it shows error dialog: 'You are missing the following 32-bit libraries, and Steam may not run:'. It is widely known problem, Arch Wiki gives solution. I rather prefer to remove old steam libraries than setting STEAM_RUNTIME=0, but while trying to do so, I discovered that symbolic links in ~/.steam folder are incorrect.

[fenuks .steam]$ ls -l
total 24
lrwxrwxrwx 1 fenuks fenuks   26 lut  7 08:18 bin -> /home/fenuks//.steam/bin32
lrwxrwxrwx 1 fenuks fenuks   36 lut  7 08:18 bin32 -> /home/fenuks/.steam/root/ubuntu12_32
lrwxrwxrwx 1 fenuks fenuks   36 lut  7 08:18 bin64 -> /home/fenuks/.steam/root/ubuntu12_64
-rw-r--r-- 1 fenuks fenuks  708 lut  7 08:40 registry.vdf
-rw-r--r-- 1 fenuks fenuks 1106 lut  7 08:05 registry.vdf.bak
lrwxrwxrwx 1 fenuks fenuks   24 lut  7 08:18 root -> /home/fenuks/.steam/root
lrwxrwxrwx 1 fenuks fenuks   32 lut  7 08:18 sdk32 -> /home/fenuks/.steam/root/linux32
lrwxrwxrwx 1 fenuks fenuks   32 lut  7 08:18 sdk64 -> /home/fenuks/.steam/root/linux64
-rw-r--r-- 1 fenuks fenuks    0 lut  7 08:40 starting
lrwxrwxrwx 1 fenuks fenuks   24 lut  7 08:18 steam -> /home/fenuks/.steam/root
-rwxr-xr-x 1 fenuks fenuks 8860 lut  7 08:05 steam_install_agreement.txt
-rwxr--r-- 1 fenuks fenuks    5 lut  7 08:18
prwxr----- 1 fenuks fenuks    0 lut  7 08:05 steam.pipe

As you can see root is symbolic link to ~/.steam/root so basically it is symbolic link to itself. I can remove this root symbolic link, but at steam launch it is recreated and it still points to itself. I tried to remove whole ~/.steam folder (since games are now stored in ~/.local/share/Steam, but if I do so, steam can't launch and give me error:

find: File system loop detected; `/home/fenuks//.steam/steam/SteamApps/common/Eador. Masters of the Broken World/z:/sys/bus/cpu/devices/cpu0/node0/cpu1/driver/cpu2/firmware_node/subsystem/devices/PNP0303:00/physical_node/subsystem/devices/00:03/tty/ttyS0/subsystem/ttyS1/device/subsystem/devices/i8042/serio0/input/input0/event0/subsystem/js0/device/device/subsystem/devices/1-1/driver/usb1/1-0:1.0/driver/module/holders/ohci_hcd/holders/ohci_pci/drivers/pci:ohci-pci/0000:00:12.0/subsystem/devices/0000:00:02.0/0000:01:00.1/sound/card1/subsystem/pcmC0D0p/device/device/input10/event10/device' is part of the same file system loop as `/home/fenuks//.steam/steam/SteamApps/common/Eador. Masters of the Broken World/z:/sys/bus/cpu/devices/cpu0/node0/cpu1/driver/cpu2/firmware_node/subsystem/devices/PNP0303:00/physical_node/subsystem/devices/00:03/tty/ttyS0/subsystem/ttyS1/device/subsystem/devices/i8042/serio0/input/input0/event0/subsystem/js0/device/device/subsystem/devices/1-1/driver/usb1/1-0:1.0/driver/module/holders/ohci_hcd/holders/ohci_pci/drivers/pci:ohci-pci/0000:00:12.0/subsystem/devices/0000:00:02.0/0000:01:00.1/sound/card1/subsystem/pcmC0D0p/device/device/input10'.

I guess ~/.steam/root should point to ~/.local/share/Steam, but it gets rewritten every time at startup.

Everything seems to work OK, but just in case I would like to correct this. Can anyone confirm that they ~/.steam/root symbolic link is incorrect as well? Any solution?

After reinstalling steam package links are correct again. Sorry for false alarm.

I was wrong. Symlinks are correct before you submit login credentials, but after login steam changes them. I found issue on Valve github. This bug was introduced recently in beta channel, normal/stable is not affected.

Last edited by fenuks (2015-02-07 10:39:12)


#2 2015-07-22 12:06:27

From: Germany
Registered: 2015-07-22
Posts: 2

Re: [SOLVED] Wrong symbolic links in ~/.steam folder

I know this thread is a few month old.... Anyways this is not fixed by Valve and I will try to provide my solution to all who may find this over internet searches. Here a short explanation how the problem is caused, including the way to "fix" this.
Do the listing below to see the problem.

ln -s ~/.local/share/Steam/ ~/.steam/root

The problem is this link

 root -> ~/.steam/root

makes the whole think looping. Some games while acess this link to check whatever they need to do. And of course it leads to nowhere but iutself. Steam will overwrite this symbolic link everytime it gets restartet. What you need to do is to delete and replace the link  after steam has started. You can do this by hand by doing:

rm ~/.steam/root

Second is to make a link to where your steam data are. In most cases they are in


So do

ln -s ~/.local/share/Steam/ ~/.steam/root

At the end check if the link was correctly replaced by doing:

ln -s ~/.local/share/Steam/ ~/.steam/root

It should look like this now:

 root -> ~/.local/share/Steam/

Maybe  there is a way to modify the steam start script. To make this automate this. I do it with two scripts which opens steam and after 15sec it runs a script detecting if the link is broken and replaces it in that case.

If you want this script contact me via pm, not sure if I am allowed to advertise my homepage here.

Using Telegram? Feel free to contact me:


Board footer

Powered by FluxBB