You are not logged in.

#1 2006-03-08 09:28:33

gentoogod
Member
From: Ontario Canada
Registered: 2006-03-08
Posts: 7

grub wont even install

I tried installing arch 0.7.1 today and it fails at the bootloader installation. my hds are hdc (windows) and sda (linux). it gives an error about drive not found and i tried installing grub to all options that it lets me pick. my boot is sda1 so i have it set in grub root (sd0,0) and then i pick all options that it lets me pick and they all give the same error. I have installed grub many times being a former gentoo user so i have an idea of what im doing but with arch it dont seem to want to work.


using works like M$ and Microsuck doesnt make you funny it makes you sound like a retard.

Offline

#2 2006-03-08 17:29:26

Sander
Member
Registered: 2006-02-26
Posts: 137

Re: grub wont even install

(sd0,0) is not a valid GRUB device string roll

Try either (hd0,0) or (hd1,0). GRUB will assign device strings to your disks depending on the boot order of your disks in the bios: the first disk gets 0, the 2nd gets 1 etc.

I changed the order manually in the BIOS so my SATA disk would be (hd0) and the IDE disk would be (hd1).

(The following may or may not be relevant, but I'll add it anyways:)
Also note that the emulated grub shell (which you can start with the "grub" command when you've booted into the OS, and I believe grub-install also relies on it) assigns device strings based on the device names linux assigns, which may lead to differences between the "real GRUB" order and the "emulated GRUB" order. You can use a "device.map" file to manually assign Linux device names a GRUB device string.


You like cheese? You like peas? You'll love cheezy peas!

Offline

Board footer

Powered by FluxBB