You are not logged in.

#1 2015-03-14 10:17:43

Ajunta
Member
From: Moscow
Registered: 2009-05-31
Posts: 58

[SOLVED] razercfg, AUR and public keys.

Hello!

I am wandering about AUR package razercfg, recently is failed to build with error:

==> Verifying source file signatures with gpg...
    razercfg-0.31.tar.bz2 ... FAILED (unknown public key 5FB027474203454C)
==> ERROR: One or more PGP signatures could not be verified!
==> ERROR: Makepkg was unable to build razercfg.

In the comments to the package I read maintainer's note:

Import the author's key if you want makepkg to verify the source tarball:
http://bues.ch/cms/resources/contact.html#gnupg_pgp_key

So I went to http://bues.ch/cms/resources/contact.html#gnupg_pgp_key and found:

My PGP key has got the ID number 908D8B0E. It can be obtained from most public key servers like keys.gnupg.net or directly from this site.

So I imported it like that:

$ gpg --keyserver hkp://keys.gnupg.net/ --recv-key 908D8B0E
gpg: key 908D8B0E: public key "Michael Büsch <m@bues.ch>" imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 1
gpg:               imported: 1

The package is still failing to build with the same error. Afterwards I read notes by other users suggesting to import (another?) key:

gpg --keyserver hkp://keys.gnupg.net/ --recv-key 5FB027474203454C

I as understand 5FB027474203454C is the key mentioned in pkgbuild. But the author's page from the package maintainer's note suggests to import 908D8B0E not 5FB027474203454C. Could anyone help me please figure this out?

Last edited by Ajunta (2015-03-15 19:58:14)

Offline

#2 2015-03-14 11:00:07

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [SOLVED] razercfg, AUR and public keys.

Thy not use pacman-key? https://wiki.archlinux.org/index.php/Pacman-key
Edit: Is it because you've read https://wiki.archlinux.org/index.php/Ma … e_checking ?


I just googled the last 8 chars of validpgpkeys mentioned in the PKGBUILD in the AUR and got http://bues.ch/cms/resources/git.html - it's the key the author uses for git projects.

Edit:

$ sudo pacman-key -r 4203454C                                                                           
gpg: key 4203454C: public key "Michael Büsch (Git tag signing key) <m@bues.ch>" imported
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model

<snip>

Last edited by karol (2015-03-14 13:34:58)

Offline

#3 2015-03-15 20:03:14

Ajunta
Member
From: Moscow
Registered: 2009-05-31
Posts: 58

Re: [SOLVED] razercfg, AUR and public keys.

Thank you for the reply!

Regarding pacman-key, I just didn't know about it, because never before had the need to import keys manually. I use a few packages from AUR and they build well without manual key importing (I do not know whatever that is because they configured differently or they do not use signature checking).

Offline

#4 2015-03-15 20:16:15

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,315

Re: [SOLVED] razercfg, AUR and public keys.

pacman-key is not the answer. Read this: http://allanmcrae.com/2015/01/two-pgp-k … rch-linux/

Offline

#5 2017-02-20 17:35:31

rajat
Member
Registered: 2013-10-10
Posts: 10

Re: [SOLVED] razercfg, AUR and public keys.

gpg --keyserver hkp://keys.gnupg.net/ --recv-key <KEY THAT IS NOT RECOGNIZED BY > (unknown public key) Put the key and Run this command it imports the key successfully.

gpg --keyserver hkp://keys.gnupg.net/ --recv-key D1483FA6C3C07136
gpg: key 4E2C6E8793298290: public key "Tor Browser Developers (signing key) <torbrowser@torproject.org>" imported

Issue resolved. Thanks for help


Linux is easy.. People are Difficult

Offline

#6 2017-02-20 17:38:18

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,189
Website

Re: [SOLVED] razercfg, AUR and public keys.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB