You are not logged in.

#1 2015-03-27 01:50:37

htedrom
Member
Registered: 2012-04-21
Posts: 26

Laptop lid close "do nothing"

Hi all; this is I suspect an XFCE issue more than an arch issue, but here goes:

Although it is suggested elsewhere that there is a "Do nothing" option for closing the laptop lid in the XFCE power manager (see http://askubuntu.com/questions/407287/c … -terminal) I have no such option; only Lock Screen, Blank Screen, Suspend, and Hibernate. The Blank Screen option blanks the external monitor on lid close.

I want to connect to an external monitor, then be able to close my laptop lid, and I have a preference for affecting this change via CLI, because I'm writing a script to run when I connect the external that will include this change along with some xrandr changes.

I have tried setting the xfce power manager laptop lid behaviour via CLI to zero (which blanks screen) and numbers outside the range (which also blank screen), using this command

xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/lid-action-on-ac -s (number)

thanks for any comments!

xfce version: 4.12
xfce4-power-manager version 1.4.4
laptop: asus ux32VD

Offline

#2 2015-03-27 08:17:00

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 4,584
Website

Re: Laptop lid close "do nothing"

Check the settings in the file at /etc/systemd/logind.conf

Offline

#3 2015-03-27 08:55:40

htedrom
Member
Registered: 2012-04-21
Posts: 26

Re: Laptop lid close "do nothing"

ah should have mentioned; I also stopped systemd from handling the event

from my logind.conf:

HandlePowerKey=ignore
HandleSuspendKey=ignore
HandleHibernateKey=ignore
HandleLidSwitch=ignore

Offline

#4 2015-03-27 10:07:00

dice
Member
From: Germany
Registered: 2014-02-10
Posts: 413

Re: Laptop lid close "do nothing"

You could try setting

IgnoreLid=true

in /etc/UPower/UPower.conf
As xfce4-power-manager depends on upower that might work.


I put at button on it. Yes. I wish to press it, but I'm not sure what will happen if I do.  (Gune | Titan A.E.)

Offline

#5 2015-04-28 16:58:39

htedrom
Member
Registered: 2012-04-21
Posts: 26

Re: Laptop lid close "do nothing"

thanks; that worked perfectly

Offline

#6 2016-12-14 10:56:19

vkshah2
Member
Registered: 2016-12-14
Posts: 1

Re: Laptop lid close "do nothing"

I set the following as suggested and restarted. It worked. Thanks !

HandleLidSwitch=ignore in  /etc/systemd/logind.conf
IgnoreLid=true in etc/UPower/UPower.conf

Offline

#7 2016-12-15 19:16:51

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,345
Website

Re: Laptop lid close "do nothing"

Glad you've solved your problem, but please avoid bumping old threads.

https://wiki.archlinux.org/index.php/Co … bumping.22

Closing.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB