You are not logged in.

#1 2015-03-28 19:45:17

Dun
Member
Registered: 2014-12-28
Posts: 79

[SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

I recently updated/reinstalled the GHC and now I can't recompile Xmonad.

[dun@Dun ~]$ xmonad --recompile
Error detected while loading xmonad configuration file: /home/dun/.xmonad/xmonad.hs

xmonad.hs:6:8:
    Could not find module ‘XMonad.Hooks.DynamicLog’
    Use -v to see a list of the files searched for.

xmonad.hs:7:8:
    Could not find module ‘XMonad.Hooks.ManageDocks’
    Use -v to see a list of the files searched for.

xmonad.hs:8:8:
    Could not find module ‘XMonad.Hooks.ManageHelpers’
    Use -v to see a list of the files searched for.

xmonad.hs:9:8:
    Could not find module ‘XMonad.Hooks.SetWMName’
    Use -v to see a list of the files searched for.

xmonad.hs:10:8:
    Could not find module ‘XMonad.Config.Xfce’
    Perhaps you meant XMonad.Config (from xmonad-0.11.1)
    Use -v to see a list of the files searched for.

xmonad.hs:11:8:
    Could not find module ‘XMonad.Util.Run’
    Use -v to see a list of the files searched for.

xmonad.hs:12:8:
    Could not find module ‘XMonad.Util.EZConfig’
    Use -v to see a list of the files searched for.

xmonad.hs:14:8:
    Could not find module ‘XMonad.Layout.Fullscreen’
    Use -v to see a list of the files searched for.

xmonad.hs:15:8:
    Could not find module ‘XMonad.Layout.Spiral’
    Use -v to see a list of the files searched for.

xmonad.hs:16:8:
    Could not find module ‘XMonad.Layout.Tabbed’
    Use -v to see a list of the files searched for.

xmonad.hs:17:8:
    Could not find module ‘XMonad.Layout.ThreeColumns’
    Use -v to see a list of the files searched for.

xmonad.hs:18:8:
    Could not find module ‘XMonad.Layout.Spacing’
    Use -v to see a list of the files searched for.

xmonad.hs:19:8:
    Could not find module ‘XMonad.Layout.NoBorders’
    Use -v to see a list of the files searched for.

xmonad.hs:20:8:
    Could not find module ‘XMonad.Layout.PerWorkspace’
    Use -v to see a list of the files searched for.

xmonad.hs:21:8:
    Could not find module ‘XMonad.Layout.IM’
    Perhaps you meant XMonad.Layout (from xmonad-0.11.1)
    Use -v to see a list of the files searched for.

xmonad.hs:22:8:
    Could not find module ‘XMonad.Layout.Grid’
    Perhaps you meant XMonad.Layout (from xmonad-0.11.1)
    Use -v to see a list of the files searched for.

xmonad.hs:23:8:
    Could not find module ‘XMonad.Actions.GridSelect’
    Use -v to see a list of the files searched for.

xmonad.hs:25:8:
    Could not find module ‘XMonad.Actions.CycleWS’
    Use -v to see a list of the files searched for.

Please check the file for errors.

xmonad: xmessage: executeFile: does not exist (No such file or directory)

I know that I have to register those modules but I don't really know how. I tried reinstalling xmonad over cabal and it worked somehow, but I can't install xmonad-contrib, because I get this error which tells me that the compiler doesn't know 'Applicative'.

[dun@Dun ~]$ cabal install xmonad-contrib
Resolving dependencies...
Configuring xmonad-contrib-0.11.4...
Building xmonad-contrib-0.11.4...
Failed to install xmonad-contrib-0.11.4
Build log ( /home/dun/.cabal/logs/xmonad-contrib-0.11.4.log ):
Configuring xmonad-contrib-0.11.4...
Building xmonad-contrib-0.11.4...
Preprocessing library xmonad-contrib-0.11.4...
[  1 of 226] Compiling XMonad.Util.StringProp ( XMonad/Util/StringProp.hs, dist/build/XMonad/Util/StringProp.o )
[  2 of 226] Compiling XMonad.Util.Replace ( XMonad/Util/Replace.hs, dist/build/XMonad/Util/Replace.o )
[  3 of 226] Compiling XMonad.Util.CustomKeys ( XMonad/Util/CustomKeys.hs, dist/build/XMonad/Util/CustomKeys.o )
[  4 of 226] Compiling XMonad.Layout.ThreeColumns ( XMonad/Layout/ThreeColumns.hs, dist/build/XMonad/Layout/ThreeColumns.o )
[  5 of 226] Compiling XMonad.Layout.StackTile ( XMonad/Layout/StackTile.hs, dist/build/XMonad/Layout/StackTile.o )
[  6 of 226] Compiling XMonad.Layout.Spiral ( XMonad/Layout/Spiral.hs, dist/build/XMonad/Layout/Spiral.o )
[  7 of 226] Compiling XMonad.Layout.Roledex ( XMonad/Layout/Roledex.hs, dist/build/XMonad/Layout/Roledex.o )
[  8 of 226] Compiling XMonad.Layout.ResizableTile ( XMonad/Layout/ResizableTile.hs, dist/build/XMonad/Layout/ResizableTile.o )
[  9 of 226] Compiling XMonad.Layout.OneBig ( XMonad/Layout/OneBig.hs, dist/build/XMonad/Layout/OneBig.o )
[ 10 of 226] Compiling XMonad.Layout.MultiToggle ( XMonad/Layout/MultiToggle.hs, dist/build/XMonad/Layout/MultiToggle.o )
[ 11 of 226] Compiling XMonad.Layout.MultiColumns ( XMonad/Layout/MultiColumns.hs, dist/build/XMonad/Layout/MultiColumns.o )
[ 12 of 226] Compiling XMonad.Layout.MosaicAlt ( XMonad/Layout/MosaicAlt.hs, dist/build/XMonad/Layout/MosaicAlt.o )
[ 13 of 226] Compiling XMonad.Layout.Mosaic ( XMonad/Layout/Mosaic.hs, dist/build/XMonad/Layout/Mosaic.o )
[ 14 of 226] Compiling XMonad.Layout.LayoutBuilder ( XMonad/Layout/LayoutBuilder.hs, dist/build/XMonad/Layout/LayoutBuilder.o )
[ 15 of 226] Compiling XMonad.Layout.HintedGrid ( XMonad/Layout/HintedGrid.hs, dist/build/XMonad/Layout/HintedGrid.o )
[ 16 of 226] Compiling XMonad.Layout.Simplest ( XMonad/Layout/Simplest.hs, dist/build/XMonad/Layout/Simplest.o )
[ 17 of 226] Compiling XMonad.Util.Stack ( XMonad/Util/Stack.hs, dist/build/XMonad/Util/Stack.o )
[ 18 of 226] Compiling XMonad.Layout.Groups ( XMonad/Layout/Groups.hs, dist/build/XMonad/Layout/Groups.o )
[ 19 of 226] Compiling XMonad.Layout.GridVariants ( XMonad/Layout/GridVariants.hs, dist/build/XMonad/Layout/GridVariants.o )
[ 20 of 226] Compiling XMonad.Layout.Grid ( XMonad/Layout/Grid.hs, dist/build/XMonad/Layout/Grid.o )
[ 21 of 226] Compiling XMonad.Layout.FixedColumn ( XMonad/Layout/FixedColumn.hs, dist/build/XMonad/Layout/FixedColumn.o )
[ 22 of 226] Compiling XMonad.Layout.Dishes ( XMonad/Layout/Dishes.hs, dist/build/XMonad/Layout/Dishes.o )
[ 23 of 226] Compiling XMonad.Util.Invisible ( XMonad/Util/Invisible.hs, dist/build/XMonad/Util/Invisible.o )

XMonad/Util/Invisible.hs:31:59:
    Not in scope: type constructor or class ‘Applicative’
cabal: Error: some packages failed to install:
xmonad-contrib-0.11.4 failed during the building phase. The exception was:
ExitFailure 1

Here's the output of ghc-pkg list.

[dun@Dun ~]$ ghc-pkg list
/usr/lib/ghc-7.8.4/package.conf.d
   Cabal-1.18.1.5
   array-0.5.0.0
   base-4.7.0.2
   bin-package-db-0.0.0.0
   binary-0.7.1.0
   bytestring-0.10.4.0
   containers-0.5.5.1
   deepseq-1.3.0.2
   directory-1.2.1.0
   filepath-1.3.0.2
   ghc-7.8.4
   ghc-prim-0.3.1.0
   haskeline-0.7.1.2
   haskell2010-1.1.2.0
   haskell98-2.0.0.3
   hoopl-3.10.0.1
   hpc-0.6.0.1
   integer-gmp-0.5.1.0
   old-locale-1.0.0.6
   old-time-1.1.0.2
   pretty-1.1.1.1
   process-1.2.0.0
   rts-1.0
   template-haskell-2.9.0.0
   terminfo-0.4.0.0
   time-1.4.2
   transformers-0.3.0.0
   unix-2.7.0.1
   xhtml-3000.2.1
/home/dun/.ghc/x86_64-linux-7.8.4/package.conf.d
   X11-1.6.1.2
   X11-xft-0.3.1
   data-default-0.5.3
   data-default-class-0.0.1
   data-default-instances-base-0.0.1
   data-default-instances-containers-0.0.1
   data-default-instances-dlist-0.0.1
   data-default-instances-old-locale-0.0.1
   dlist-0.7.1.1
   extensible-exceptions-0.1.1.4
   mtl-2.2.1
   random-1.1
   transformers-0.4.3.0
   utf8-string-0.3.8
   xmonad-0.11.1

I don't have any perspective what to do now.

Last edited by Dun (2015-04-08 12:48:29)

Offline

#2 2015-03-28 23:13:42

Knute
Member
From: Minot, ND
Registered: 2009-03-17
Posts: 604

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

You may want to do a ghc-pkg check to see what is not working.

Once you get that list, you can then use pacman to reinstall the packages.


Knute

Offline

#3 2015-03-29 10:44:40

Dun
Member
Registered: 2014-12-28
Posts: 79

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

Knute wrote:

You may want to do a ghc-pkg check to see what is not working.

Once you get that list, you can then use pacman to reinstall the packages.

[dun@Dun ~]$ ghc-pkg check
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/xmonad-0.11.1
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/xmonad-0.11.1/html 
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/X11-xft-0.3.1
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/X11-xft-0.3.1/html 
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/X11-1.6.1.2/h
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/X11-1.6.1.2/html do
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/mtl-2.2.1/htm
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/mtl-2.2.1/html does
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/transformers-
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/transformers-0.4.3.
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-0.5.3/
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instan
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instan
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/utf8-string-0
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/utf8-string-0.3.8/h
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instan
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/random-1.1/ht
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/random-1.1/html doe
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instan
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/dlist-0.7.1.1
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/dlist-0.7.1.1/html 
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/extensible-ex
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/extensible-exceptio
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-class-

So I deleted .cabal, ran cabal update and now there is just no output.

[dun@Dun ~]$ ghc-pkg check
[dun@Dun ~]$ 

The output when I'm trying to reinstall over pacman:

[root@Dun dun]# pacman -S xmonad xmonad-contrib 
warning: xmonad-0.11-10 is up to date -- reinstalling
warning: xmonad-contrib-0.11.3-2 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (2) xmonad-0.11-10  xmonad-contrib-0.11.3-2

Total Installed Size:  58.42 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n] 
(2/2) checking keys in keyring                          [#############################] 100%
(2/2) checking package integrity                        [#############################] 100%
(2/2) loading package files                             [#############################] 100%
(2/2) checking for file conflicts                       [#############################] 100%
(2/2) checking available disk space                     [#############################] 100%
ghc-pkg: cannot find package xmonad-0.11
error: command failed to execute correctly
(1/2) reinstalling xmonad                               [#############################] 100%
Reading package info from stdin ... done.
xmonad-0.11: Warning: haddock-interfaces: /usr/share/doc/x86_64-linux-ghc-7.8.4/xmonad-0.11/html/xmonad.haddock doesn't exist or isn't a file
xmonad-0.11: Warning: haddock-html: /usr/share/doc/x86_64-linux-ghc-7.8.4/xmonad-0.11/html doesn't exist or isn't a directory
xmonad-0.11: dependency "X11-1.6.1.2-308eb1aa39b1d256e7575e6bb19ddd02" doesn't exist (use --force to override)
xmonad-0.11: dependency "extensible-exceptions-0.1.1.4-ff00541964e8b4f6fe7adae94cd5f3b4" doesn't exist (use --force to override)
xmonad-0.11: dependency "mtl-2.1.3.1-96f1a7910a7553352339ed05fb61c269" doesn't exist (use --force to override)
xmonad-0.11: dependency "utf8-string-0.3.8-013b7a7487c531302bf0b0ba6baedc8d" doesn't exist (use --force to override)
error: command failed to execute correctly
ghc-pkg: cannot find package xmonad-contrib-0.11.3
error: command failed to execute correctly
(2/2) reinstalling xmonad-contrib                       [#############################] 100%
Reading package info from stdin ... done.
xmonad-contrib-0.11.3: Warning: haddock-interfaces: /usr/share/doc/x86_64-linux-ghc-7.8.4/xmonad-contrib-0.11.3/html/xmonad-contrib.haddock doesn't exist or isn't a file
xmonad-contrib-0.11.3: Warning: haddock-html: /usr/share/doc/x86_64-linux-ghc-7.8.4/xmonad-contrib-0.11.3/html doesn't exist or isn't a directory
xmonad-contrib-0.11.3: dependency "X11-1.6.1.2-308eb1aa39b1d256e7575e6bb19ddd02" doesn't exist (use --force to override)
xmonad-contrib-0.11.3: dependency "X11-xft-0.3.1-552b86856585e522139ac486fe2ce27b" doesn't exist (use --force to override)
xmonad-contrib-0.11.3: dependency "extensible-exceptions-0.1.1.4-ff00541964e8b4f6fe7adae94cd5f3b4" doesn't exist (use --force to override)
xmonad-contrib-0.11.3: dependency "mtl-2.1.3.1-96f1a7910a7553352339ed05fb61c269" doesn't exist (use --force to override)
xmonad-contrib-0.11.3: dependency "random-1.1-092becd083af689459dfd417368314bf" doesn't exist (use --force to override)
xmonad-contrib-0.11.3: dependency "utf8-string-0.3.8-013b7a7487c531302bf0b0ba6baedc8d" doesn't exist (use --force to override)
xmonad-contrib-0.11.3: dependency "xmonad-0.11-22c90cf6cc4c3237b70ac9cd413c575e" doesn't exist (use --force to override)
error: command failed to execute correctly

Edit: After trying to install xmonad-contrib again over cabal ghc-pkg now has an output but I don't getting smarter reading it

[dun@Dun ~]$ ghc-pkg check
There are problems in package xmonad-0.11.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/xmonad-0.11.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/xmonad-0.11.1/html/xmonad.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/xmonad-0.11.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/xmonad-0.11.1 doesn't exist or isn't a directory
  cannot find any of ["XMonad.hi","XMonad.p_hi","XMonad.dyn_hi"]
  cannot find any of ["XMonad/Main.hi","XMonad/Main.p_hi","XMonad/Main.dyn_hi"]
  cannot find any of ["XMonad/Core.hi","XMonad/Core.p_hi","XMonad/Core.dyn_hi"]
  cannot find any of ["XMonad/Config.hi","XMonad/Config.p_hi","XMonad/Config.dyn_hi"]
  cannot find any of ["XMonad/Layout.hi","XMonad/Layout.p_hi","XMonad/Layout.dyn_hi"]
  cannot find any of ["XMonad/ManageHook.hi","XMonad/ManageHook.p_hi","XMonad/ManageHook.dyn_hi"]
  cannot find any of ["XMonad/Operations.hi","XMonad/Operations.p_hi","XMonad/Operations.dyn_hi"]
  cannot find any of ["XMonad/StackSet.hi","XMonad/StackSet.p_hi","XMonad/StackSet.dyn_hi"]
  cannot find any of ["libHSxmonad-0.11.1.a","libHSxmonad-0.11.1.p_a","libHSxmonad-0.11.1-ghc7.8.4.so","libHSxmonad-0.11.1-ghc7.8.4.dylib","HSxmonad-0.11.1-ghc7.8.4.dll"] on library path
There are problems in package X11-xft-0.3.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/X11-xft-0.3.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/X11-xft-0.3.1/html/X11-xft.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/X11-xft-0.3.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/X11-xft-0.3.1 doesn't exist or isn't a directory
  cannot find any of ["Graphics/X11/Xft.hi","Graphics/X11/Xft.p_hi","Graphics/X11/Xft.dyn_hi"]
  cannot find any of ["Graphics/X11/Xrender.hi","Graphics/X11/Xrender.p_hi","Graphics/X11/Xrender.dyn_hi"]
  cannot find any of ["libHSX11-xft-0.3.1.a","libHSX11-xft-0.3.1.p_a","libHSX11-xft-0.3.1-ghc7.8.4.so","libHSX11-xft-0.3.1-ghc7.8.4.dylib","HSX11-xft-0.3.1-ghc7.8.4.dll"] on library path
There are problems in package X11-1.6.1.2:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/X11-1.6.1.2 doesn't exist or isn't a directory
  Warning: include-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/X11-1.6.1.2/include doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/X11-1.6.1.2/html/X11.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/X11-1.6.1.2/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/X11-1.6.1.2 doesn't exist or isn't a directory
  cannot find any of ["Graphics/X11.hi","Graphics/X11.p_hi","Graphics/X11.dyn_hi"]
  cannot find any of ["Graphics/X11/Types.hi","Graphics/X11/Types.p_hi","Graphics/X11/Types.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib.hi","Graphics/X11/Xlib.p_hi","Graphics/X11/Xlib.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Atom.hi","Graphics/X11/Xlib/Atom.p_hi","Graphics/X11/Xlib/Atom.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Color.hi","Graphics/X11/Xlib/Color.p_hi","Graphics/X11/Xlib/Color.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Context.hi","Graphics/X11/Xlib/Context.p_hi","Graphics/X11/Xlib/Context.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Cursor.hi","Graphics/X11/Xlib/Cursor.p_hi","Graphics/X11/Xlib/Cursor.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Display.hi","Graphics/X11/Xlib/Display.p_hi","Graphics/X11/Xlib/Display.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Event.hi","Graphics/X11/Xlib/Event.p_hi","Graphics/X11/Xlib/Event.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Font.hi","Graphics/X11/Xlib/Font.p_hi","Graphics/X11/Xlib/Font.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Misc.hi","Graphics/X11/Xlib/Misc.p_hi","Graphics/X11/Xlib/Misc.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Region.hi","Graphics/X11/Xlib/Region.p_hi","Graphics/X11/Xlib/Region.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Screen.hi","Graphics/X11/Xlib/Screen.p_hi","Graphics/X11/Xlib/Screen.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Types.hi","Graphics/X11/Xlib/Types.p_hi","Graphics/X11/Xlib/Types.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Window.hi","Graphics/X11/Xlib/Window.p_hi","Graphics/X11/Xlib/Window.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Image.hi","Graphics/X11/Xlib/Image.p_hi","Graphics/X11/Xlib/Image.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Extras.hi","Graphics/X11/Xlib/Extras.p_hi","Graphics/X11/Xlib/Extras.dyn_hi"]
  cannot find any of ["Graphics/X11/Xinerama.hi","Graphics/X11/Xinerama.p_hi","Graphics/X11/Xinerama.dyn_hi"]
  cannot find any of ["Graphics/X11/Xrandr.hi","Graphics/X11/Xrandr.p_hi","Graphics/X11/Xrandr.dyn_hi"]
  cannot find any of ["Graphics/X11/XScreenSaver.hi","Graphics/X11/XScreenSaver.p_hi","Graphics/X11/XScreenSaver.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes.hi","Graphics/X11/ExtraTypes.p_hi","Graphics/X11/ExtraTypes.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/AP.hi","Graphics/X11/ExtraTypes/AP.p_hi","Graphics/X11/ExtraTypes/AP.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/DEC.hi","Graphics/X11/ExtraTypes/DEC.p_hi","Graphics/X11/ExtraTypes/DEC.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/HP.hi","Graphics/X11/ExtraTypes/HP.p_hi","Graphics/X11/ExtraTypes/HP.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/Sun.hi","Graphics/X11/ExtraTypes/Sun.p_hi","Graphics/X11/ExtraTypes/Sun.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/XF86.hi","Graphics/X11/ExtraTypes/XF86.p_hi","Graphics/X11/ExtraTypes/XF86.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/XorgDefault.hi","Graphics/X11/ExtraTypes/XorgDefault.p_hi","Graphics/X11/ExtraTypes/XorgDefault.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Internal.hi","Graphics/X11/Xlib/Internal.p_hi","Graphics/X11/Xlib/Internal.dyn_hi"]
  cannot find any of ["libHSX11-1.6.1.2.a","libHSX11-1.6.1.2.p_a","libHSX11-1.6.1.2-ghc7.8.4.so","libHSX11-1.6.1.2-ghc7.8.4.dylib","HSX11-1.6.1.2-ghc7.8.4.dll"] on library path
There are problems in package mtl-2.2.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/mtl-2.2.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/mtl-2.2.1/html/mtl.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/mtl-2.2.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/mtl-2.2.1 doesn't exist or isn't a directory
  cannot find any of ["Control/Monad/Cont.hi","Control/Monad/Cont.p_hi","Control/Monad/Cont.dyn_hi"]
  cannot find any of ["Control/Monad/Cont/Class.hi","Control/Monad/Cont/Class.p_hi","Control/Monad/Cont/Class.dyn_hi"]
  cannot find any of ["Control/Monad/Error.hi","Control/Monad/Error.p_hi","Control/Monad/Error.dyn_hi"]
  cannot find any of ["Control/Monad/Error/Class.hi","Control/Monad/Error/Class.p_hi","Control/Monad/Error/Class.dyn_hi"]
  cannot find any of ["Control/Monad/Except.hi","Control/Monad/Except.p_hi","Control/Monad/Except.dyn_hi"]
  cannot find any of ["Control/Monad/Identity.hi","Control/Monad/Identity.p_hi","Control/Monad/Identity.dyn_hi"]
  cannot find any of ["Control/Monad/List.hi","Control/Monad/List.p_hi","Control/Monad/List.dyn_hi"]
  cannot find any of ["Control/Monad/RWS.hi","Control/Monad/RWS.p_hi","Control/Monad/RWS.dyn_hi"]
  cannot find any of ["Control/Monad/RWS/Class.hi","Control/Monad/RWS/Class.p_hi","Control/Monad/RWS/Class.dyn_hi"]
  cannot find any of ["Control/Monad/RWS/Lazy.hi","Control/Monad/RWS/Lazy.p_hi","Control/Monad/RWS/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/RWS/Strict.hi","Control/Monad/RWS/Strict.p_hi","Control/Monad/RWS/Strict.dyn_hi"]
  cannot find any of ["Control/Monad/Reader.hi","Control/Monad/Reader.p_hi","Control/Monad/Reader.dyn_hi"]
  cannot find any of ["Control/Monad/Reader/Class.hi","Control/Monad/Reader/Class.p_hi","Control/Monad/Reader/Class.dyn_hi"]
  cannot find any of ["Control/Monad/State.hi","Control/Monad/State.p_hi","Control/Monad/State.dyn_hi"]
  cannot find any of ["Control/Monad/State/Class.hi","Control/Monad/State/Class.p_hi","Control/Monad/State/Class.dyn_hi"]
  cannot find any of ["Control/Monad/State/Lazy.hi","Control/Monad/State/Lazy.p_hi","Control/Monad/State/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/State/Strict.hi","Control/Monad/State/Strict.p_hi","Control/Monad/State/Strict.dyn_hi"]
  cannot find any of ["Control/Monad/Trans.hi","Control/Monad/Trans.p_hi","Control/Monad/Trans.dyn_hi"]
  cannot find any of ["Control/Monad/Writer.hi","Control/Monad/Writer.p_hi","Control/Monad/Writer.dyn_hi"]
  cannot find any of ["Control/Monad/Writer/Class.hi","Control/Monad/Writer/Class.p_hi","Control/Monad/Writer/Class.dyn_hi"]
  cannot find any of ["Control/Monad/Writer/Lazy.hi","Control/Monad/Writer/Lazy.p_hi","Control/Monad/Writer/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/Writer/Strict.hi","Control/Monad/Writer/Strict.p_hi","Control/Monad/Writer/Strict.dyn_hi"]
  cannot find any of ["libHSmtl-2.2.1.a","libHSmtl-2.2.1.p_a","libHSmtl-2.2.1-ghc7.8.4.so","libHSmtl-2.2.1-ghc7.8.4.dylib","HSmtl-2.2.1-ghc7.8.4.dll"] on library path
There are problems in package transformers-0.4.3.0:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/transformers-0.4.3.0 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/transformers-0.4.3.0/html/transformers.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/transformers-0.4.3.0/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/transformers-0.4.3.0 doesn't exist or isn't a directory
  cannot find any of ["Control/Applicative/Backwards.hi","Control/Applicative/Backwards.p_hi","Control/Applicative/Backwards.dyn_hi"]
  cannot find any of ["Control/Applicative/Lift.hi","Control/Applicative/Lift.p_hi","Control/Applicative/Lift.dyn_hi"]
  cannot find any of ["Control/Monad/IO/Class.hi","Control/Monad/IO/Class.p_hi","Control/Monad/IO/Class.dyn_hi"]
  cannot find any of ["Control/Monad/Signatures.hi","Control/Monad/Signatures.p_hi","Control/Monad/Signatures.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Class.hi","Control/Monad/Trans/Class.p_hi","Control/Monad/Trans/Class.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Cont.hi","Control/Monad/Trans/Cont.p_hi","Control/Monad/Trans/Cont.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Except.hi","Control/Monad/Trans/Except.p_hi","Control/Monad/Trans/Except.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Error.hi","Control/Monad/Trans/Error.p_hi","Control/Monad/Trans/Error.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Identity.hi","Control/Monad/Trans/Identity.p_hi","Control/Monad/Trans/Identity.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/List.hi","Control/Monad/Trans/List.p_hi","Control/Monad/Trans/List.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Maybe.hi","Control/Monad/Trans/Maybe.p_hi","Control/Monad/Trans/Maybe.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Reader.hi","Control/Monad/Trans/Reader.p_hi","Control/Monad/Trans/Reader.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/RWS.hi","Control/Monad/Trans/RWS.p_hi","Control/Monad/Trans/RWS.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/RWS/Lazy.hi","Control/Monad/Trans/RWS/Lazy.p_hi","Control/Monad/Trans/RWS/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/RWS/Strict.hi","Control/Monad/Trans/RWS/Strict.p_hi","Control/Monad/Trans/RWS/Strict.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/State.hi","Control/Monad/Trans/State.p_hi","Control/Monad/Trans/State.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/State/Lazy.hi","Control/Monad/Trans/State/Lazy.p_hi","Control/Monad/Trans/State/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/State/Strict.hi","Control/Monad/Trans/State/Strict.p_hi","Control/Monad/Trans/State/Strict.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Writer.hi","Control/Monad/Trans/Writer.p_hi","Control/Monad/Trans/Writer.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Writer/Lazy.hi","Control/Monad/Trans/Writer/Lazy.p_hi","Control/Monad/Trans/Writer/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Writer/Strict.hi","Control/Monad/Trans/Writer/Strict.p_hi","Control/Monad/Trans/Writer/Strict.dyn_hi"]
  cannot find any of ["Data/Functor/Classes.hi","Data/Functor/Classes.p_hi","Data/Functor/Classes.dyn_hi"]
  cannot find any of ["Data/Functor/Compose.hi","Data/Functor/Compose.p_hi","Data/Functor/Compose.dyn_hi"]
  cannot find any of ["Data/Functor/Constant.hi","Data/Functor/Constant.p_hi","Data/Functor/Constant.dyn_hi"]
  cannot find any of ["Data/Functor/Product.hi","Data/Functor/Product.p_hi","Data/Functor/Product.dyn_hi"]
  cannot find any of ["Data/Functor/Reverse.hi","Data/Functor/Reverse.p_hi","Data/Functor/Reverse.dyn_hi"]
  cannot find any of ["Data/Functor/Sum.hi","Data/Functor/Sum.p_hi","Data/Functor/Sum.dyn_hi"]
  cannot find any of ["Data/Functor/Identity.hi","Data/Functor/Identity.p_hi","Data/Functor/Identity.dyn_hi"]
  cannot find any of ["libHStransformers-0.4.3.0.a","libHStransformers-0.4.3.0.p_a","libHStransformers-0.4.3.0-ghc7.8.4.so","libHStransformers-0.4.3.0-ghc7.8.4.dylib","HStransformers-0.4.3.0-ghc7.8.4.dll"] on library path
There are problems in package data-default-0.5.3:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-0.5.3 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-0.5.3/html/data-default.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-0.5.3/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-0.5.3 doesn't exist or isn't a directory
  cannot find any of ["Data/Default.hi","Data/Default.p_hi","Data/Default.dyn_hi"]
  cannot find any of ["libHSdata-default-0.5.3.a","libHSdata-default-0.5.3.p_a","libHSdata-default-0.5.3-ghc7.8.4.so","libHSdata-default-0.5.3-ghc7.8.4.dylib","HSdata-default-0.5.3-ghc7.8.4.dll"] on library path
There are problems in package data-default-instances-dlist-0.0.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-dlist-0.0.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-dlist-0.0.1/html/data-default-instances-dlist.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-dlist-0.0.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-dlist-0.0.1 doesn't exist or isn't a directory
  cannot find any of ["Data/Default/Instances/DList.hi","Data/Default/Instances/DList.p_hi","Data/Default/Instances/DList.dyn_hi"]
  cannot find any of ["libHSdata-default-instances-dlist-0.0.1.a","libHSdata-default-instances-dlist-0.0.1.p_a","libHSdata-default-instances-dlist-0.0.1-ghc7.8.4.so","libHSdata-default-instances-dlist-0.0.1-ghc7.8.4.dylib","HSdata-default-instances-dlist-0.0.1-ghc7.8.4.dll"] on library path
There are problems in package data-default-instances-old-locale-0.0.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-old-locale-0.0.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-old-locale-0.0.1/html/data-default-instances-old-locale.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-old-locale-0.0.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-old-locale-0.0.1 doesn't exist or isn't a directory
  cannot find any of ["Data/Default/Instances/OldLocale.hi","Data/Default/Instances/OldLocale.p_hi","Data/Default/Instances/OldLocale.dyn_hi"]
  cannot find any of ["libHSdata-default-instances-old-locale-0.0.1.a","libHSdata-default-instances-old-locale-0.0.1.p_a","libHSdata-default-instances-old-locale-0.0.1-ghc7.8.4.so","libHSdata-default-instances-old-locale-0.0.1-ghc7.8.4.dylib","HSdata-default-instances-old-locale-0.0.1-ghc7.8.4.dll"] on library path
There are problems in package utf8-string-0.3.8:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/utf8-string-0.3.8 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/utf8-string-0.3.8/html/utf8-string.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/utf8-string-0.3.8/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/utf8-string-0.3.8 doesn't exist or isn't a directory
  cannot find any of ["Codec/Binary/UTF8/String.hi","Codec/Binary/UTF8/String.p_hi","Codec/Binary/UTF8/String.dyn_hi"]
  cannot find any of ["Codec/Binary/UTF8/Generic.hi","Codec/Binary/UTF8/Generic.p_hi","Codec/Binary/UTF8/Generic.dyn_hi"]
  cannot find any of ["System/IO/UTF8.hi","System/IO/UTF8.p_hi","System/IO/UTF8.dyn_hi"]
  cannot find any of ["System/Environment/UTF8.hi","System/Environment/UTF8.p_hi","System/Environment/UTF8.dyn_hi"]
  cannot find any of ["Data/String/UTF8.hi","Data/String/UTF8.p_hi","Data/String/UTF8.dyn_hi"]
  cannot find any of ["Data/ByteString/UTF8.hi","Data/ByteString/UTF8.p_hi","Data/ByteString/UTF8.dyn_hi"]
  cannot find any of ["Data/ByteString/Lazy/UTF8.hi","Data/ByteString/Lazy/UTF8.p_hi","Data/ByteString/Lazy/UTF8.dyn_hi"]
  cannot find any of ["libHSutf8-string-0.3.8.a","libHSutf8-string-0.3.8.p_a","libHSutf8-string-0.3.8-ghc7.8.4.so","libHSutf8-string-0.3.8-ghc7.8.4.dylib","HSutf8-string-0.3.8-ghc7.8.4.dll"] on library path
There are problems in package data-default-instances-containers-0.0.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-containers-0.0.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-containers-0.0.1/html/data-default-instances-containers.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-containers-0.0.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-containers-0.0.1 doesn't exist or isn't a directory
  cannot find any of ["Data/Default/Instances/Containers.hi","Data/Default/Instances/Containers.p_hi","Data/Default/Instances/Containers.dyn_hi"]
  cannot find any of ["libHSdata-default-instances-containers-0.0.1.a","libHSdata-default-instances-containers-0.0.1.p_a","libHSdata-default-instances-containers-0.0.1-ghc7.8.4.so","libHSdata-default-instances-containers-0.0.1-ghc7.8.4.dylib","HSdata-default-instances-containers-0.0.1-ghc7.8.4.dll"] on library path
There are problems in package random-1.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/random-1.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/random-1.1/html/random.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/random-1.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/random-1.1 doesn't exist or isn't a directory
  cannot find any of ["System/Random.hi","System/Random.p_hi","System/Random.dyn_hi"]
  cannot find any of ["libHSrandom-1.1.a","libHSrandom-1.1.p_a","libHSrandom-1.1-ghc7.8.4.so","libHSrandom-1.1-ghc7.8.4.dylib","HSrandom-1.1-ghc7.8.4.dll"] on library path
There are problems in package data-default-instances-base-0.0.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-base-0.0.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-base-0.0.1/html/data-default-instances-base.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-base-0.0.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-base-0.0.1 doesn't exist or isn't a directory
  cannot find any of ["Data/Default/Instances/Base.hi","Data/Default/Instances/Base.p_hi","Data/Default/Instances/Base.dyn_hi"]
  cannot find any of ["libHSdata-default-instances-base-0.0.1.a","libHSdata-default-instances-base-0.0.1.p_a","libHSdata-default-instances-base-0.0.1-ghc7.8.4.so","libHSdata-default-instances-base-0.0.1-ghc7.8.4.dylib","HSdata-default-instances-base-0.0.1-ghc7.8.4.dll"] on library path
There are problems in package dlist-0.7.1.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/dlist-0.7.1.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/dlist-0.7.1.1/html/dlist.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/dlist-0.7.1.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/dlist-0.7.1.1 doesn't exist or isn't a directory
  cannot find any of ["Data/DList.hi","Data/DList.p_hi","Data/DList.dyn_hi"]
  cannot find any of ["libHSdlist-0.7.1.1.a","libHSdlist-0.7.1.1.p_a","libHSdlist-0.7.1.1-ghc7.8.4.so","libHSdlist-0.7.1.1-ghc7.8.4.dylib","HSdlist-0.7.1.1-ghc7.8.4.dll"] on library path
There are problems in package extensible-exceptions-0.1.1.4:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/extensible-exceptions-0.1.1.4 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/extensible-exceptions-0.1.1.4/html/extensible-exceptions.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/extensible-exceptions-0.1.1.4/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/extensible-exceptions-0.1.1.4 doesn't exist or isn't a directory
  cannot find any of ["Control/Exception/Extensible.hi","Control/Exception/Extensible.p_hi","Control/Exception/Extensible.dyn_hi"]
  cannot find any of ["libHSextensible-exceptions-0.1.1.4.a","libHSextensible-exceptions-0.1.1.4.p_a","libHSextensible-exceptions-0.1.1.4-ghc7.8.4.so","libHSextensible-exceptions-0.1.1.4-ghc7.8.4.dylib","HSextensible-exceptions-0.1.1.4-ghc7.8.4.dll"] on library path
There are problems in package data-default-class-0.0.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-class-0.0.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-class-0.0.1/html/data-default-class.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-class-0.0.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-class-0.0.1 doesn't exist or isn't a directory
  cannot find any of ["Data/Default/Class.hi","Data/Default/Class.p_hi","Data/Default/Class.dyn_hi"]
  cannot find any of ["libHSdata-default-class-0.0.1.a","libHSdata-default-class-0.0.1.p_a","libHSdata-default-class-0.0.1-ghc7.8.4.so","libHSdata-default-class-0.0.1-ghc7.8.4.dylib","HSdata-default-class-0.0.1-ghc7.8.4.dll"] on library path

The following packages are broken, either because they have a problem
listed above, or because they depend on a broken package.
xmonad-0.11.1
X11-xft-0.3.1
X11-1.6.1.2
mtl-2.2.1
transformers-0.4.3.0
data-default-0.5.3
data-default-instances-dlist-0.0.1
data-default-instances-old-locale-0.0.1
utf8-string-0.3.8
data-default-instances-containers-0.0.1
random-1.1
data-default-instances-base-0.0.1
dlist-0.7.1.1
extensible-exceptions-0.1.1.4
data-default-class-0.0.1

I know that I have to register those somehow, but I just don't know what package I have to use, because I've never had to do such things with Xmonad. I just installed Xmonad 3 months ago and it was solid until now. Well it's still kinda solid because it still runs, I just can't compile the hs-File anymore.

Edit2: I've never had to use cabal, back when I'm installed Xmonad I used pacman, so I've never used it but now I'm forced to use it and I don't understand this.

I've now tried to reinstall those packages over cabal but it only confuses me more...

[dun@Dun ~]$ cabal install xmonad 
Resolving dependencies...
All the requested packages are already installed:
xmonad-0.11.1
Use --reinstall if you want to reinstall anyway.
[dun@Dun ~]$ cabal install xmonad --reinstall
Resolving dependencies...
In order, the following will be installed:
xmonad-0.11.1 (reinstall)
Warning: Note that reinstalls are always dangerous. Continuing anyway...
Configuring xmonad-0.11.1...
Building xmonad-0.11.1...
Failed to install xmonad-0.11.1
Build log ( /home/dun/.cabal/logs/xmonad-0.11.1.log ):
Configuring xmonad-0.11.1...
Building xmonad-0.11.1...
Preprocessing library xmonad-0.11.1...

XMonad/Core.hs:35:8:
    Could not find module ‘Codec.Binary.UTF8.String’
    There are files missing in the ‘utf8-string-0.3.8’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

XMonad/Core.hs:36:8:
    Could not find module ‘Control.Exception.Extensible’
    There are files missing in the ‘extensible-exceptions-0.1.1.4’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

XMonad/Operations.hs:39:8:
    Could not find module ‘Graphics.X11.Xinerama’
    There are files missing in the ‘X11-1.6.1.2’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

XMonad.hs:43:8:
    Could not find module ‘Graphics.X11’
    There are files missing in the ‘X11-1.6.1.2’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

XMonad.hs:44:8:
    Could not find module ‘Graphics.X11.Xlib.Extras’
    There are files missing in the ‘X11-1.6.1.2’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

XMonad.hs:46:8:
    Could not find module ‘Control.Monad.State’
    There are files missing in the ‘mtl-2.2.1’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

XMonad.hs:47:8:
    Could not find module ‘Control.Monad.Reader’
    There are files missing in the ‘mtl-2.2.1’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

XMonad/Main.hsc:34:8:
    Could not find module ‘Graphics.X11.Xlib’
    There are files missing in the ‘X11-1.6.1.2’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.
cabal: Error: some packages failed to install:
xmonad-0.11.1 failed during the building phase. The exception was:
ExitFailure 1

So I thought I have to install those packages first:

[dun@Dun ~]$ cabal install utf8-string --reinstall
Resolving dependencies...
In order, the following will be installed:
utf8-string-1 (reinstall)
Warning: Note that reinstalls are always dangerous. Continuing anyway...
Configuring utf8-string-1...
Building utf8-string-1...
Installed utf8-string-1
[dun@Dun ~]$ cabal update
Downloading the latest package list from hackage.haskell.org
[dun@Dun ~]$ cabal install utf8-string --reinstall
Resolving dependencies...
In order, the following will be installed:
utf8-string-1 (reinstall)
Warning: Note that reinstalls are always dangerous. Continuing anyway...
Configuring utf8-string-1...
Building utf8-string-1...
Installed utf8-string-1

But the output of "cabal install xmonad --reinstall" stays the same and it still can't find utf8-string-0.3.8.

Last edited by Dun (2015-03-29 12:15:10)

Offline

#4 2015-03-29 12:00:29

Knute
Member
From: Minot, ND
Registered: 2009-03-17
Posts: 604

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

Ok, it's not xmonad and xmonad-contrib that you need to reinstall.
You need to reinstall the packages listed that say that they are broken.

The community packages in pacman that you need to reinstall all follow the pattern of haskell-<package name>.  It's a dependencies thing.
I've encountered this myself, though it has been awhile since I've had to do this.


Knute

Offline

#5 2015-03-29 12:49:54

Dun
Member
Registered: 2014-12-28
Posts: 79

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

Knute wrote:

Ok, it's not xmonad and xmonad-contrib that you need to reinstall.
You need to reinstall the packages listed that say that they are broken.

The community packages in pacman that you need to reinstall all follow the pattern of haskell-<package name>.  It's a dependencies thing.
I've encountered this myself, though it has been awhile since I've had to do this.

Ok I tried to install those packages over pacman:

[dun@Dun ~]$ sudo pacman -S haskell-data-default haskell-data-default-class haskell-data-default-instances-base haskell-data-default-instances-containers haskell-data-default-instances-dlist haskell-data-default-instances-old-locale haskell-dlist haskell-haddock-api haskell-haddock-library haskell-mtl haskell-random haskell-utf8-string haskell-x11 haskell-x11-xft 
warning: haskell-data-default-0.5.3-6 is up to date -- reinstalling
warning: haskell-data-default-class-0.0.1-5 is up to date -- reinstalling
warning: haskell-data-default-instances-base-0.0.1-7 is up to date -- reinstalling
warning: haskell-data-default-instances-containers-0.0.1-5 is up to date -- reinstalling
warning: haskell-data-default-instances-dlist-0.0.1-6 is up to date -- reinstalling
warning: haskell-data-default-instances-old-locale-0.0.1-5 is up to date -- reinstalling
warning: haskell-dlist-0.7.1-1 is up to date -- reinstalling
warning: haskell-mtl-2.1.3.1-4 is up to date -- reinstalling
warning: haskell-random-1.1-1 is up to date -- reinstalling
warning: haskell-utf8-string-0.3.8-1 is up to date -- reinstalling
warning: haskell-x11-1.6.1.2-2 is up to date -- reinstalling
warning: haskell-x11-xft-0.3.1-12 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (15) haskell-ghc-paths-0.1.0.9-7  haskell-data-default-0.5.3-6
              haskell-data-default-class-0.0.1-5
              haskell-data-default-instances-base-0.0.1-7
              haskell-data-default-instances-containers-0.0.1-5
              haskell-data-default-instances-dlist-0.0.1-6
              haskell-data-default-instances-old-locale-0.0.1-5  haskell-dlist-0.7.1-1
              haskell-haddock-api-2.15.0.2-1  haskell-haddock-library-1.1.1-3
              haskell-mtl-2.1.3.1-4  haskell-random-1.1-1  haskell-utf8-string-0.3.8-1
              haskell-x11-1.6.1.2-2  haskell-x11-xft-0.3.1-12

Total Download Size:    2.09 MiB
Total Installed Size:  53.07 MiB
Net Upgrade Size:      23.35 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages ...
 haskell-ghc-paths-0.1.0....    27.6 KiB   587K/s 00:00 [#############################] 100%
 haskell-haddock-library-...   578.5 KiB  1468K/s 00:00 [#############################] 100%
 haskell-haddock-api-2.15...  1535.5 KiB  1806K/s 00:01 [#############################] 100%
(15/15) checking keys in keyring                        [#############################] 100%
(15/15) checking package integrity                      [#############################] 100%
(15/15) loading package files                           [#############################] 100%
(15/15) checking for file conflicts                     [#############################] 100%
(15/15) checking available disk space                   [#############################] 100%
unregistering data-default-class-0.0.1 would break the following packages: X11-xft-0.3.1 X11-1.6.1.2 data-default-0.5.3 data-default-instances-old-locale-0.0.1 data-default-instances-dlist-0.0.1 data-default-instances-containers-0.0.1 data-default-instances-base-0.0.1 (ignoring)
( 1/15) reinstalling haskell-data-default-class         [#############################] 100%
Reading package info from stdin ... done.
unregistering data-default-instances-base-0.0.1 would break the following packages: X11-xft-0.3.1 X11-1.6.1.2 data-default-0.5.3 (ignoring)
( 2/15) reinstalling haskell-data-default-instances...  [#############################] 100%
Reading package info from stdin ... done.
unregistering data-default-instances-containers-0.0.1 would break the following packages: X11-xft-0.3.1 X11-1.6.1.2 data-default-0.5.3 (ignoring)
( 3/15) reinstalling haskell-data-default-instances...  [#############################] 100%
Reading package info from stdin ... done.
unregistering dlist-0.7.1 would break the following packages: X11-xft-0.3.1 X11-1.6.1.2 data-default-0.5.3 data-default-instances-dlist-0.0.1 (ignoring)
( 4/15) reinstalling haskell-dlist                      [#############################] 100%
Reading package info from stdin ... done.
unregistering data-default-instances-dlist-0.0.1 would break the following packages: X11-xft-0.3.1 X11-1.6.1.2 data-default-0.5.3 (ignoring)
( 5/15) reinstalling haskell-data-default-instances-dlist                                                       [###################################################################] 100%
Reading package info from stdin ... done.
unregistering data-default-instances-old-locale-0.0.1 would break the following packages: X11-xft-0.3.1 X11-1.6.1.2 data-default-0.5.3 (ignoring)
( 6/15) reinstalling haskell-data-default-instances-old-locale                                                  [###################################################################] 100%
Reading package info from stdin ... done.
unregistering data-default-0.5.3 would break the following packages: X11-xft-0.3.1 X11-1.6.1.2 (ignoring)
( 7/15) reinstalling haskell-data-default                                                                       [###################################################################] 100%
Reading package info from stdin ... done.
( 8/15) installing haskell-ghc-paths                                                                            [###################################################################] 100%
Reading package info from stdin ... done.
( 9/15) installing haskell-haddock-library                                                                      [###################################################################] 100%
Reading package info from stdin ... done.
haddock-library-1.1.1: Warning: haddock-interfaces: /usr/share/doc/haskell-haddock-library/html/haddock-library.haddock doesn't exist or isn't a file
haddock-library-1.1.1: Warning: haddock-html: /usr/share/doc/haskell-haddock-library/html doesn't exist or isn't a directory
(10/15) installing haskell-haddock-api                                                                          [###################################################################] 100%
Reading package info from stdin ... done.
(11/15) reinstalling haskell-mtl                                                                                [###################################################################] 100%
Reading package info from stdin ... done.
(12/15) reinstalling haskell-random                                                                             [###################################################################] 100%
Reading package info from stdin ... done.
unregistering utf8-string-0.3.8 would break the following packages: X11-xft-0.3.1 (ignoring)
(13/15) reinstalling haskell-utf8-string                                                                        [###################################################################] 100%
Reading package info from stdin ... done.
unregistering X11-1.6.1.2 would break the following packages: X11-xft-0.3.1 (ignoring)
(14/15) reinstalling haskell-x11                                                                                [###################################################################] 100%
Reading package info from stdin ... done.
(15/15) reinstalling haskell-x11-xft                                                                            [###################################################################] 100%
Reading package info from stdin ... done.

ghc-pkg check but says that it still has its problems.

[dun@Dun ~]$ ghc-pkg check
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/utf8-string-1/html/utf8-string.haddock doesn't exist or isn't a file
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/utf8-string-1/html doesn't exist or isn't a directory
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/text-1.2.0.4/html/text.haddock doesn't exist or isn't a file
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/text-1.2.0.4/html doesn't exist or isn't a directory
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/network-2.6.0.2/html/network.haddock doesn't exist or isn't a file
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/network-2.6.0.2/html doesn't exist or isn't a directory
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/zlib-0.5.4.2/html/zlib.haddock doesn't exist or isn't a file
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/zlib-0.5.4.2/html doesn't exist or isn't a directory
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/stm-2.4.4/html/stm.haddock doesn't exist or isn't a file
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/stm-2.4.4/html doesn't exist or isn't a directory
There are problems in package xmonad-0.11.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/xmonad-0.11.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/xmonad-0.11.1/html/xmonad.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/xmonad-0.11.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/xmonad-0.11.1 doesn't exist or isn't a directory
  cannot find any of ["XMonad.hi","XMonad.p_hi","XMonad.dyn_hi"]
  cannot find any of ["XMonad/Main.hi","XMonad/Main.p_hi","XMonad/Main.dyn_hi"]
  cannot find any of ["XMonad/Core.hi","XMonad/Core.p_hi","XMonad/Core.dyn_hi"]
  cannot find any of ["XMonad/Config.hi","XMonad/Config.p_hi","XMonad/Config.dyn_hi"]
  cannot find any of ["XMonad/Layout.hi","XMonad/Layout.p_hi","XMonad/Layout.dyn_hi"]
  cannot find any of ["XMonad/ManageHook.hi","XMonad/ManageHook.p_hi","XMonad/ManageHook.dyn_hi"]
  cannot find any of ["XMonad/Operations.hi","XMonad/Operations.p_hi","XMonad/Operations.dyn_hi"]
  cannot find any of ["XMonad/StackSet.hi","XMonad/StackSet.p_hi","XMonad/StackSet.dyn_hi"]
  cannot find any of ["libHSxmonad-0.11.1.a","libHSxmonad-0.11.1.p_a","libHSxmonad-0.11.1-ghc7.8.4.so","libHSxmonad-0.11.1-ghc7.8.4.dylib","HSxmonad-0.11.1-ghc7.8.4.dll"] on library path
There are problems in package X11-xft-0.3.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/X11-xft-0.3.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/X11-xft-0.3.1/html/X11-xft.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/X11-xft-0.3.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/X11-xft-0.3.1 doesn't exist or isn't a directory
  cannot find any of ["Graphics/X11/Xft.hi","Graphics/X11/Xft.p_hi","Graphics/X11/Xft.dyn_hi"]
  cannot find any of ["Graphics/X11/Xrender.hi","Graphics/X11/Xrender.p_hi","Graphics/X11/Xrender.dyn_hi"]
  cannot find any of ["libHSX11-xft-0.3.1.a","libHSX11-xft-0.3.1.p_a","libHSX11-xft-0.3.1-ghc7.8.4.so","libHSX11-xft-0.3.1-ghc7.8.4.dylib","HSX11-xft-0.3.1-ghc7.8.4.dll"] on library path
There are problems in package X11-1.6.1.2:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/X11-1.6.1.2 doesn't exist or isn't a directory
  Warning: include-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/X11-1.6.1.2/include doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/X11-1.6.1.2/html/X11.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/X11-1.6.1.2/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/X11-1.6.1.2 doesn't exist or isn't a directory
  cannot find any of ["Graphics/X11.hi","Graphics/X11.p_hi","Graphics/X11.dyn_hi"]
  cannot find any of ["Graphics/X11/Types.hi","Graphics/X11/Types.p_hi","Graphics/X11/Types.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib.hi","Graphics/X11/Xlib.p_hi","Graphics/X11/Xlib.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Atom.hi","Graphics/X11/Xlib/Atom.p_hi","Graphics/X11/Xlib/Atom.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Color.hi","Graphics/X11/Xlib/Color.p_hi","Graphics/X11/Xlib/Color.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Context.hi","Graphics/X11/Xlib/Context.p_hi","Graphics/X11/Xlib/Context.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Cursor.hi","Graphics/X11/Xlib/Cursor.p_hi","Graphics/X11/Xlib/Cursor.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Display.hi","Graphics/X11/Xlib/Display.p_hi","Graphics/X11/Xlib/Display.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Event.hi","Graphics/X11/Xlib/Event.p_hi","Graphics/X11/Xlib/Event.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Font.hi","Graphics/X11/Xlib/Font.p_hi","Graphics/X11/Xlib/Font.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Misc.hi","Graphics/X11/Xlib/Misc.p_hi","Graphics/X11/Xlib/Misc.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Region.hi","Graphics/X11/Xlib/Region.p_hi","Graphics/X11/Xlib/Region.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Screen.hi","Graphics/X11/Xlib/Screen.p_hi","Graphics/X11/Xlib/Screen.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Types.hi","Graphics/X11/Xlib/Types.p_hi","Graphics/X11/Xlib/Types.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Window.hi","Graphics/X11/Xlib/Window.p_hi","Graphics/X11/Xlib/Window.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Image.hi","Graphics/X11/Xlib/Image.p_hi","Graphics/X11/Xlib/Image.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Extras.hi","Graphics/X11/Xlib/Extras.p_hi","Graphics/X11/Xlib/Extras.dyn_hi"]
  cannot find any of ["Graphics/X11/Xinerama.hi","Graphics/X11/Xinerama.p_hi","Graphics/X11/Xinerama.dyn_hi"]
  cannot find any of ["Graphics/X11/Xrandr.hi","Graphics/X11/Xrandr.p_hi","Graphics/X11/Xrandr.dyn_hi"]
  cannot find any of ["Graphics/X11/XScreenSaver.hi","Graphics/X11/XScreenSaver.p_hi","Graphics/X11/XScreenSaver.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes.hi","Graphics/X11/ExtraTypes.p_hi","Graphics/X11/ExtraTypes.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/AP.hi","Graphics/X11/ExtraTypes/AP.p_hi","Graphics/X11/ExtraTypes/AP.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/DEC.hi","Graphics/X11/ExtraTypes/DEC.p_hi","Graphics/X11/ExtraTypes/DEC.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/HP.hi","Graphics/X11/ExtraTypes/HP.p_hi","Graphics/X11/ExtraTypes/HP.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/Sun.hi","Graphics/X11/ExtraTypes/Sun.p_hi","Graphics/X11/ExtraTypes/Sun.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/XF86.hi","Graphics/X11/ExtraTypes/XF86.p_hi","Graphics/X11/ExtraTypes/XF86.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/XorgDefault.hi","Graphics/X11/ExtraTypes/XorgDefault.p_hi","Graphics/X11/ExtraTypes/XorgDefault.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Internal.hi","Graphics/X11/Xlib/Internal.p_hi","Graphics/X11/Xlib/Internal.dyn_hi"]
  cannot find any of ["libHSX11-1.6.1.2.a","libHSX11-1.6.1.2.p_a","libHSX11-1.6.1.2-ghc7.8.4.so","libHSX11-1.6.1.2-ghc7.8.4.dylib","HSX11-1.6.1.2-ghc7.8.4.dll"] on library path
There are problems in package mtl-2.2.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/mtl-2.2.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/mtl-2.2.1/html/mtl.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/mtl-2.2.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/mtl-2.2.1 doesn't exist or isn't a directory
  cannot find any of ["Control/Monad/Cont.hi","Control/Monad/Cont.p_hi","Control/Monad/Cont.dyn_hi"]
  cannot find any of ["Control/Monad/Cont/Class.hi","Control/Monad/Cont/Class.p_hi","Control/Monad/Cont/Class.dyn_hi"]
  cannot find any of ["Control/Monad/Error.hi","Control/Monad/Error.p_hi","Control/Monad/Error.dyn_hi"]
  cannot find any of ["Control/Monad/Error/Class.hi","Control/Monad/Error/Class.p_hi","Control/Monad/Error/Class.dyn_hi"]
  cannot find any of ["Control/Monad/Except.hi","Control/Monad/Except.p_hi","Control/Monad/Except.dyn_hi"]
  cannot find any of ["Control/Monad/Identity.hi","Control/Monad/Identity.p_hi","Control/Monad/Identity.dyn_hi"]
  cannot find any of ["Control/Monad/List.hi","Control/Monad/List.p_hi","Control/Monad/List.dyn_hi"]
  cannot find any of ["Control/Monad/RWS.hi","Control/Monad/RWS.p_hi","Control/Monad/RWS.dyn_hi"]
  cannot find any of ["Control/Monad/RWS/Class.hi","Control/Monad/RWS/Class.p_hi","Control/Monad/RWS/Class.dyn_hi"]
  cannot find any of ["Control/Monad/RWS/Lazy.hi","Control/Monad/RWS/Lazy.p_hi","Control/Monad/RWS/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/RWS/Strict.hi","Control/Monad/RWS/Strict.p_hi","Control/Monad/RWS/Strict.dyn_hi"]
  cannot find any of ["Control/Monad/Reader.hi","Control/Monad/Reader.p_hi","Control/Monad/Reader.dyn_hi"]
  cannot find any of ["Control/Monad/Reader/Class.hi","Control/Monad/Reader/Class.p_hi","Control/Monad/Reader/Class.dyn_hi"]
  cannot find any of ["Control/Monad/State.hi","Control/Monad/State.p_hi","Control/Monad/State.dyn_hi"]
  cannot find any of ["Control/Monad/State/Class.hi","Control/Monad/State/Class.p_hi","Control/Monad/State/Class.dyn_hi"]
  cannot find any of ["Control/Monad/State/Lazy.hi","Control/Monad/State/Lazy.p_hi","Control/Monad/State/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/State/Strict.hi","Control/Monad/State/Strict.p_hi","Control/Monad/State/Strict.dyn_hi"]
  cannot find any of ["Control/Monad/Trans.hi","Control/Monad/Trans.p_hi","Control/Monad/Trans.dyn_hi"]
  cannot find any of ["Control/Monad/Writer.hi","Control/Monad/Writer.p_hi","Control/Monad/Writer.dyn_hi"]
  cannot find any of ["Control/Monad/Writer/Class.hi","Control/Monad/Writer/Class.p_hi","Control/Monad/Writer/Class.dyn_hi"]
  cannot find any of ["Control/Monad/Writer/Lazy.hi","Control/Monad/Writer/Lazy.p_hi","Control/Monad/Writer/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/Writer/Strict.hi","Control/Monad/Writer/Strict.p_hi","Control/Monad/Writer/Strict.dyn_hi"]
  cannot find any of ["libHSmtl-2.2.1.a","libHSmtl-2.2.1.p_a","libHSmtl-2.2.1-ghc7.8.4.so","libHSmtl-2.2.1-ghc7.8.4.dylib","HSmtl-2.2.1-ghc7.8.4.dll"] on library path
There are problems in package transformers-0.4.3.0:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/transformers-0.4.3.0 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/transformers-0.4.3.0/html/transformers.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/transformers-0.4.3.0/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/transformers-0.4.3.0 doesn't exist or isn't a directory
  cannot find any of ["Control/Applicative/Backwards.hi","Control/Applicative/Backwards.p_hi","Control/Applicative/Backwards.dyn_hi"]
  cannot find any of ["Control/Applicative/Lift.hi","Control/Applicative/Lift.p_hi","Control/Applicative/Lift.dyn_hi"]
  cannot find any of ["Control/Monad/IO/Class.hi","Control/Monad/IO/Class.p_hi","Control/Monad/IO/Class.dyn_hi"]
  cannot find any of ["Control/Monad/Signatures.hi","Control/Monad/Signatures.p_hi","Control/Monad/Signatures.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Class.hi","Control/Monad/Trans/Class.p_hi","Control/Monad/Trans/Class.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Cont.hi","Control/Monad/Trans/Cont.p_hi","Control/Monad/Trans/Cont.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Except.hi","Control/Monad/Trans/Except.p_hi","Control/Monad/Trans/Except.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Error.hi","Control/Monad/Trans/Error.p_hi","Control/Monad/Trans/Error.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Identity.hi","Control/Monad/Trans/Identity.p_hi","Control/Monad/Trans/Identity.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/List.hi","Control/Monad/Trans/List.p_hi","Control/Monad/Trans/List.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Maybe.hi","Control/Monad/Trans/Maybe.p_hi","Control/Monad/Trans/Maybe.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Reader.hi","Control/Monad/Trans/Reader.p_hi","Control/Monad/Trans/Reader.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/RWS.hi","Control/Monad/Trans/RWS.p_hi","Control/Monad/Trans/RWS.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/RWS/Lazy.hi","Control/Monad/Trans/RWS/Lazy.p_hi","Control/Monad/Trans/RWS/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/RWS/Strict.hi","Control/Monad/Trans/RWS/Strict.p_hi","Control/Monad/Trans/RWS/Strict.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/State.hi","Control/Monad/Trans/State.p_hi","Control/Monad/Trans/State.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/State/Lazy.hi","Control/Monad/Trans/State/Lazy.p_hi","Control/Monad/Trans/State/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/State/Strict.hi","Control/Monad/Trans/State/Strict.p_hi","Control/Monad/Trans/State/Strict.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Writer.hi","Control/Monad/Trans/Writer.p_hi","Control/Monad/Trans/Writer.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Writer/Lazy.hi","Control/Monad/Trans/Writer/Lazy.p_hi","Control/Monad/Trans/Writer/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Writer/Strict.hi","Control/Monad/Trans/Writer/Strict.p_hi","Control/Monad/Trans/Writer/Strict.dyn_hi"]
  cannot find any of ["Data/Functor/Classes.hi","Data/Functor/Classes.p_hi","Data/Functor/Classes.dyn_hi"]
  cannot find any of ["Data/Functor/Compose.hi","Data/Functor/Compose.p_hi","Data/Functor/Compose.dyn_hi"]
  cannot find any of ["Data/Functor/Constant.hi","Data/Functor/Constant.p_hi","Data/Functor/Constant.dyn_hi"]
  cannot find any of ["Data/Functor/Product.hi","Data/Functor/Product.p_hi","Data/Functor/Product.dyn_hi"]
  cannot find any of ["Data/Functor/Reverse.hi","Data/Functor/Reverse.p_hi","Data/Functor/Reverse.dyn_hi"]
  cannot find any of ["Data/Functor/Sum.hi","Data/Functor/Sum.p_hi","Data/Functor/Sum.dyn_hi"]
  cannot find any of ["Data/Functor/Identity.hi","Data/Functor/Identity.p_hi","Data/Functor/Identity.dyn_hi"]
  cannot find any of ["libHStransformers-0.4.3.0.a","libHStransformers-0.4.3.0.p_a","libHStransformers-0.4.3.0-ghc7.8.4.so","libHStransformers-0.4.3.0-ghc7.8.4.dylib","HStransformers-0.4.3.0-ghc7.8.4.dll"] on library path
There are problems in package data-default-0.5.3:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-0.5.3 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-0.5.3/html/data-default.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-0.5.3/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-0.5.3 doesn't exist or isn't a directory
  cannot find any of ["Data/Default.hi","Data/Default.p_hi","Data/Default.dyn_hi"]
  cannot find any of ["libHSdata-default-0.5.3.a","libHSdata-default-0.5.3.p_a","libHSdata-default-0.5.3-ghc7.8.4.so","libHSdata-default-0.5.3-ghc7.8.4.dylib","HSdata-default-0.5.3-ghc7.8.4.dll"] on library path
There are problems in package data-default-instances-dlist-0.0.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-dlist-0.0.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-dlist-0.0.1/html/data-default-instances-dlist.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-dlist-0.0.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-dlist-0.0.1 doesn't exist or isn't a directory
  cannot find any of ["Data/Default/Instances/DList.hi","Data/Default/Instances/DList.p_hi","Data/Default/Instances/DList.dyn_hi"]
  cannot find any of ["libHSdata-default-instances-dlist-0.0.1.a","libHSdata-default-instances-dlist-0.0.1.p_a","libHSdata-default-instances-dlist-0.0.1-ghc7.8.4.so","libHSdata-default-instances-dlist-0.0.1-ghc7.8.4.dylib","HSdata-default-instances-dlist-0.0.1-ghc7.8.4.dll"] on library path
There are problems in package data-default-instances-old-locale-0.0.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-old-locale-0.0.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-old-locale-0.0.1/html/data-default-instances-old-locale.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-old-locale-0.0.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-old-locale-0.0.1 doesn't exist or isn't a directory
  cannot find any of ["Data/Default/Instances/OldLocale.hi","Data/Default/Instances/OldLocale.p_hi","Data/Default/Instances/OldLocale.dyn_hi"]
  cannot find any of ["libHSdata-default-instances-old-locale-0.0.1.a","libHSdata-default-instances-old-locale-0.0.1.p_a","libHSdata-default-instances-old-locale-0.0.1-ghc7.8.4.so","libHSdata-default-instances-old-locale-0.0.1-ghc7.8.4.dylib","HSdata-default-instances-old-locale-0.0.1-ghc7.8.4.dll"] on library path
There are problems in package utf8-string-0.3.8:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/utf8-string-0.3.8 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/utf8-string-0.3.8/html/utf8-string.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/utf8-string-0.3.8/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/utf8-string-0.3.8 doesn't exist or isn't a directory
  cannot find any of ["Codec/Binary/UTF8/String.hi","Codec/Binary/UTF8/String.p_hi","Codec/Binary/UTF8/String.dyn_hi"]
  cannot find any of ["Codec/Binary/UTF8/Generic.hi","Codec/Binary/UTF8/Generic.p_hi","Codec/Binary/UTF8/Generic.dyn_hi"]
  cannot find any of ["System/IO/UTF8.hi","System/IO/UTF8.p_hi","System/IO/UTF8.dyn_hi"]
  cannot find any of ["System/Environment/UTF8.hi","System/Environment/UTF8.p_hi","System/Environment/UTF8.dyn_hi"]
  cannot find any of ["Data/String/UTF8.hi","Data/String/UTF8.p_hi","Data/String/UTF8.dyn_hi"]
  cannot find any of ["Data/ByteString/UTF8.hi","Data/ByteString/UTF8.p_hi","Data/ByteString/UTF8.dyn_hi"]
  cannot find any of ["Data/ByteString/Lazy/UTF8.hi","Data/ByteString/Lazy/UTF8.p_hi","Data/ByteString/Lazy/UTF8.dyn_hi"]
  cannot find any of ["libHSutf8-string-0.3.8.a","libHSutf8-string-0.3.8.p_a","libHSutf8-string-0.3.8-ghc7.8.4.so","libHSutf8-string-0.3.8-ghc7.8.4.dylib","HSutf8-string-0.3.8-ghc7.8.4.dll"] on library path
There are problems in package data-default-instances-containers-0.0.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-containers-0.0.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-containers-0.0.1/html/data-default-instances-containers.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-containers-0.0.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-containers-0.0.1 doesn't exist or isn't a directory
  cannot find any of ["Data/Default/Instances/Containers.hi","Data/Default/Instances/Containers.p_hi","Data/Default/Instances/Containers.dyn_hi"]
  cannot find any of ["libHSdata-default-instances-containers-0.0.1.a","libHSdata-default-instances-containers-0.0.1.p_a","libHSdata-default-instances-containers-0.0.1-ghc7.8.4.so","libHSdata-default-instances-containers-0.0.1-ghc7.8.4.dylib","HSdata-default-instances-containers-0.0.1-ghc7.8.4.dll"] on library path
There are problems in package random-1.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/random-1.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/random-1.1/html/random.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/random-1.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/random-1.1 doesn't exist or isn't a directory
  cannot find any of ["System/Random.hi","System/Random.p_hi","System/Random.dyn_hi"]
  cannot find any of ["libHSrandom-1.1.a","libHSrandom-1.1.p_a","libHSrandom-1.1-ghc7.8.4.so","libHSrandom-1.1-ghc7.8.4.dylib","HSrandom-1.1-ghc7.8.4.dll"] on library path
There are problems in package data-default-instances-base-0.0.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-base-0.0.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-base-0.0.1/html/data-default-instances-base.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-base-0.0.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-base-0.0.1 doesn't exist or isn't a directory
  cannot find any of ["Data/Default/Instances/Base.hi","Data/Default/Instances/Base.p_hi","Data/Default/Instances/Base.dyn_hi"]
  cannot find any of ["libHSdata-default-instances-base-0.0.1.a","libHSdata-default-instances-base-0.0.1.p_a","libHSdata-default-instances-base-0.0.1-ghc7.8.4.so","libHSdata-default-instances-base-0.0.1-ghc7.8.4.dylib","HSdata-default-instances-base-0.0.1-ghc7.8.4.dll"] on library path
There are problems in package dlist-0.7.1.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/dlist-0.7.1.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/dlist-0.7.1.1/html/dlist.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/dlist-0.7.1.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/dlist-0.7.1.1 doesn't exist or isn't a directory
  cannot find any of ["Data/DList.hi","Data/DList.p_hi","Data/DList.dyn_hi"]
  cannot find any of ["libHSdlist-0.7.1.1.a","libHSdlist-0.7.1.1.p_a","libHSdlist-0.7.1.1-ghc7.8.4.so","libHSdlist-0.7.1.1-ghc7.8.4.dylib","HSdlist-0.7.1.1-ghc7.8.4.dll"] on library path
There are problems in package extensible-exceptions-0.1.1.4:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/extensible-exceptions-0.1.1.4 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/extensible-exceptions-0.1.1.4/html/extensible-exceptions.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/extensible-exceptions-0.1.1.4/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/extensible-exceptions-0.1.1.4 doesn't exist or isn't a directory
  cannot find any of ["Control/Exception/Extensible.hi","Control/Exception/Extensible.p_hi","Control/Exception/Extensible.dyn_hi"]
  cannot find any of ["libHSextensible-exceptions-0.1.1.4.a","libHSextensible-exceptions-0.1.1.4.p_a","libHSextensible-exceptions-0.1.1.4-ghc7.8.4.so","libHSextensible-exceptions-0.1.1.4-ghc7.8.4.dylib","HSextensible-exceptions-0.1.1.4-ghc7.8.4.dll"] on library path
There are problems in package data-default-class-0.0.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-class-0.0.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-class-0.0.1/html/data-default-class.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-class-0.0.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-class-0.0.1 doesn't exist or isn't a directory
  cannot find any of ["Data/Default/Class.hi","Data/Default/Class.p_hi","Data/Default/Class.dyn_hi"]
  cannot find any of ["libHSdata-default-class-0.0.1.a","libHSdata-default-class-0.0.1.p_a","libHSdata-default-class-0.0.1-ghc7.8.4.so","libHSdata-default-class-0.0.1-ghc7.8.4.dylib","HSdata-default-class-0.0.1-ghc7.8.4.dll"] on library path
Warning: haddock-interfaces: /usr/share/doc/haskell-haddock-library/html/haddock-library.haddock doesn't exist or isn't a file
Warning: haddock-html: /usr/share/doc/haskell-haddock-library/html doesn't exist or isn't a directory

The following packages are broken, either because they have a problem
listed above, or because they depend on a broken package.
xmonad-0.11.1
X11-xft-0.3.1
X11-1.6.1.2
mtl-2.2.1
transformers-0.4.3.0
data-default-0.5.3
data-default-instances-dlist-0.0.1
data-default-instances-old-locale-0.0.1
utf8-string-0.3.8
data-default-instances-containers-0.0.1
random-1.1
data-default-instances-base-0.0.1
dlist-0.7.1.1
extensible-exceptions-0.1.1.4
data-default-class-0.0.1

Offline

#6 2015-03-29 15:14:56

Knute
Member
From: Minot, ND
Registered: 2009-03-17
Posts: 604

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

Hrmmm....  In looking over what you posted, it appears that you originally installed xmonad with cabal?  If you use pacman it put it in /usr/lib/ghc-<version>.

What happens if you use ghc-pkg recache to regenerate your package db, and then redo the check afterwards.


Knute

Offline

#7 2015-03-29 15:34:04

Dun
Member
Registered: 2014-12-28
Posts: 79

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

Knute wrote:

Hrmmm....  In looking over what you posted, it appears that you originally installed xmonad with cabal?  If you use pacman it put it in /usr/lib/ghc-<version>.

What happens if you use ghc-pkg recache to regenerate your package db, and then redo the check afterwards.

When I installed Xmonad in the first place I used pacman to install it. I've never used cabal for Xmonad and it was probably only installed recently because I installed an Eclipse extension for GHC. Should I just remove Cabal? Or should I remove just everything and install Xmonad freshly with Cabal? But will that ensure that I will not have this problem in the future?

Recache doesn't seem to change anything.

[dun@Dun ~]$ ghc-pkg recache
[dun@Dun ~]$ ghc-pkg check
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/utf8-string-1/html/utf8-string.haddock doesn't exist or isn't a file
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/utf8-string-1/html doesn't exist or isn't a directory
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/text-1.2.0.4/html/text.haddock doesn't exist or isn't a file
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/text-1.2.0.4/html doesn't exist or isn't a directory
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/network-2.6.0.2/html/network.haddock doesn't exist or isn't a file
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/network-2.6.0.2/html doesn't exist or isn't a directory
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/zlib-0.5.4.2/html/zlib.haddock doesn't exist or isn't a file
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/zlib-0.5.4.2/html doesn't exist or isn't a directory
Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/stm-2.4.4/html/stm.haddock doesn't exist or isn't a file
Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/stm-2.4.4/html doesn't exist or isn't a directory
There are problems in package xmonad-0.11.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/xmonad-0.11.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/xmonad-0.11.1/html/xmonad.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/xmonad-0.11.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/xmonad-0.11.1 doesn't exist or isn't a directory
  cannot find any of ["XMonad.hi","XMonad.p_hi","XMonad.dyn_hi"]
  cannot find any of ["XMonad/Main.hi","XMonad/Main.p_hi","XMonad/Main.dyn_hi"]
  cannot find any of ["XMonad/Core.hi","XMonad/Core.p_hi","XMonad/Core.dyn_hi"]
  cannot find any of ["XMonad/Config.hi","XMonad/Config.p_hi","XMonad/Config.dyn_hi"]
  cannot find any of ["XMonad/Layout.hi","XMonad/Layout.p_hi","XMonad/Layout.dyn_hi"]
  cannot find any of ["XMonad/ManageHook.hi","XMonad/ManageHook.p_hi","XMonad/ManageHook.dyn_hi"]
  cannot find any of ["XMonad/Operations.hi","XMonad/Operations.p_hi","XMonad/Operations.dyn_hi"]
  cannot find any of ["XMonad/StackSet.hi","XMonad/StackSet.p_hi","XMonad/StackSet.dyn_hi"]
  cannot find any of ["libHSxmonad-0.11.1.a","libHSxmonad-0.11.1.p_a","libHSxmonad-0.11.1-ghc7.8.4.so","libHSxmonad-0.11.1-ghc7.8.4.dylib","HSxmonad-0.11.1-ghc7.8.4.dll"] on library path
There are problems in package X11-xft-0.3.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/X11-xft-0.3.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/X11-xft-0.3.1/html/X11-xft.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/X11-xft-0.3.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/X11-xft-0.3.1 doesn't exist or isn't a directory
  cannot find any of ["Graphics/X11/Xft.hi","Graphics/X11/Xft.p_hi","Graphics/X11/Xft.dyn_hi"]
  cannot find any of ["Graphics/X11/Xrender.hi","Graphics/X11/Xrender.p_hi","Graphics/X11/Xrender.dyn_hi"]
  cannot find any of ["libHSX11-xft-0.3.1.a","libHSX11-xft-0.3.1.p_a","libHSX11-xft-0.3.1-ghc7.8.4.so","libHSX11-xft-0.3.1-ghc7.8.4.dylib","HSX11-xft-0.3.1-ghc7.8.4.dll"] on library path
There are problems in package X11-1.6.1.2:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/X11-1.6.1.2 doesn't exist or isn't a directory
  Warning: include-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/X11-1.6.1.2/include doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/X11-1.6.1.2/html/X11.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/X11-1.6.1.2/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/X11-1.6.1.2 doesn't exist or isn't a directory
  cannot find any of ["Graphics/X11.hi","Graphics/X11.p_hi","Graphics/X11.dyn_hi"]
  cannot find any of ["Graphics/X11/Types.hi","Graphics/X11/Types.p_hi","Graphics/X11/Types.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib.hi","Graphics/X11/Xlib.p_hi","Graphics/X11/Xlib.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Atom.hi","Graphics/X11/Xlib/Atom.p_hi","Graphics/X11/Xlib/Atom.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Color.hi","Graphics/X11/Xlib/Color.p_hi","Graphics/X11/Xlib/Color.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Context.hi","Graphics/X11/Xlib/Context.p_hi","Graphics/X11/Xlib/Context.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Cursor.hi","Graphics/X11/Xlib/Cursor.p_hi","Graphics/X11/Xlib/Cursor.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Display.hi","Graphics/X11/Xlib/Display.p_hi","Graphics/X11/Xlib/Display.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Event.hi","Graphics/X11/Xlib/Event.p_hi","Graphics/X11/Xlib/Event.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Font.hi","Graphics/X11/Xlib/Font.p_hi","Graphics/X11/Xlib/Font.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Misc.hi","Graphics/X11/Xlib/Misc.p_hi","Graphics/X11/Xlib/Misc.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Region.hi","Graphics/X11/Xlib/Region.p_hi","Graphics/X11/Xlib/Region.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Screen.hi","Graphics/X11/Xlib/Screen.p_hi","Graphics/X11/Xlib/Screen.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Types.hi","Graphics/X11/Xlib/Types.p_hi","Graphics/X11/Xlib/Types.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Window.hi","Graphics/X11/Xlib/Window.p_hi","Graphics/X11/Xlib/Window.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Image.hi","Graphics/X11/Xlib/Image.p_hi","Graphics/X11/Xlib/Image.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Extras.hi","Graphics/X11/Xlib/Extras.p_hi","Graphics/X11/Xlib/Extras.dyn_hi"]
  cannot find any of ["Graphics/X11/Xinerama.hi","Graphics/X11/Xinerama.p_hi","Graphics/X11/Xinerama.dyn_hi"]
  cannot find any of ["Graphics/X11/Xrandr.hi","Graphics/X11/Xrandr.p_hi","Graphics/X11/Xrandr.dyn_hi"]
  cannot find any of ["Graphics/X11/XScreenSaver.hi","Graphics/X11/XScreenSaver.p_hi","Graphics/X11/XScreenSaver.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes.hi","Graphics/X11/ExtraTypes.p_hi","Graphics/X11/ExtraTypes.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/AP.hi","Graphics/X11/ExtraTypes/AP.p_hi","Graphics/X11/ExtraTypes/AP.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/DEC.hi","Graphics/X11/ExtraTypes/DEC.p_hi","Graphics/X11/ExtraTypes/DEC.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/HP.hi","Graphics/X11/ExtraTypes/HP.p_hi","Graphics/X11/ExtraTypes/HP.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/Sun.hi","Graphics/X11/ExtraTypes/Sun.p_hi","Graphics/X11/ExtraTypes/Sun.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/XF86.hi","Graphics/X11/ExtraTypes/XF86.p_hi","Graphics/X11/ExtraTypes/XF86.dyn_hi"]
  cannot find any of ["Graphics/X11/ExtraTypes/XorgDefault.hi","Graphics/X11/ExtraTypes/XorgDefault.p_hi","Graphics/X11/ExtraTypes/XorgDefault.dyn_hi"]
  cannot find any of ["Graphics/X11/Xlib/Internal.hi","Graphics/X11/Xlib/Internal.p_hi","Graphics/X11/Xlib/Internal.dyn_hi"]
  cannot find any of ["libHSX11-1.6.1.2.a","libHSX11-1.6.1.2.p_a","libHSX11-1.6.1.2-ghc7.8.4.so","libHSX11-1.6.1.2-ghc7.8.4.dylib","HSX11-1.6.1.2-ghc7.8.4.dll"] on library path
There are problems in package mtl-2.2.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/mtl-2.2.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/mtl-2.2.1/html/mtl.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/mtl-2.2.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/mtl-2.2.1 doesn't exist or isn't a directory
  cannot find any of ["Control/Monad/Cont.hi","Control/Monad/Cont.p_hi","Control/Monad/Cont.dyn_hi"]
  cannot find any of ["Control/Monad/Cont/Class.hi","Control/Monad/Cont/Class.p_hi","Control/Monad/Cont/Class.dyn_hi"]
  cannot find any of ["Control/Monad/Error.hi","Control/Monad/Error.p_hi","Control/Monad/Error.dyn_hi"]
  cannot find any of ["Control/Monad/Error/Class.hi","Control/Monad/Error/Class.p_hi","Control/Monad/Error/Class.dyn_hi"]
  cannot find any of ["Control/Monad/Except.hi","Control/Monad/Except.p_hi","Control/Monad/Except.dyn_hi"]
  cannot find any of ["Control/Monad/Identity.hi","Control/Monad/Identity.p_hi","Control/Monad/Identity.dyn_hi"]
  cannot find any of ["Control/Monad/List.hi","Control/Monad/List.p_hi","Control/Monad/List.dyn_hi"]
  cannot find any of ["Control/Monad/RWS.hi","Control/Monad/RWS.p_hi","Control/Monad/RWS.dyn_hi"]
  cannot find any of ["Control/Monad/RWS/Class.hi","Control/Monad/RWS/Class.p_hi","Control/Monad/RWS/Class.dyn_hi"]
  cannot find any of ["Control/Monad/RWS/Lazy.hi","Control/Monad/RWS/Lazy.p_hi","Control/Monad/RWS/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/RWS/Strict.hi","Control/Monad/RWS/Strict.p_hi","Control/Monad/RWS/Strict.dyn_hi"]
  cannot find any of ["Control/Monad/Reader.hi","Control/Monad/Reader.p_hi","Control/Monad/Reader.dyn_hi"]
  cannot find any of ["Control/Monad/Reader/Class.hi","Control/Monad/Reader/Class.p_hi","Control/Monad/Reader/Class.dyn_hi"]
  cannot find any of ["Control/Monad/State.hi","Control/Monad/State.p_hi","Control/Monad/State.dyn_hi"]
  cannot find any of ["Control/Monad/State/Class.hi","Control/Monad/State/Class.p_hi","Control/Monad/State/Class.dyn_hi"]
  cannot find any of ["Control/Monad/State/Lazy.hi","Control/Monad/State/Lazy.p_hi","Control/Monad/State/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/State/Strict.hi","Control/Monad/State/Strict.p_hi","Control/Monad/State/Strict.dyn_hi"]
  cannot find any of ["Control/Monad/Trans.hi","Control/Monad/Trans.p_hi","Control/Monad/Trans.dyn_hi"]
  cannot find any of ["Control/Monad/Writer.hi","Control/Monad/Writer.p_hi","Control/Monad/Writer.dyn_hi"]
  cannot find any of ["Control/Monad/Writer/Class.hi","Control/Monad/Writer/Class.p_hi","Control/Monad/Writer/Class.dyn_hi"]
  cannot find any of ["Control/Monad/Writer/Lazy.hi","Control/Monad/Writer/Lazy.p_hi","Control/Monad/Writer/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/Writer/Strict.hi","Control/Monad/Writer/Strict.p_hi","Control/Monad/Writer/Strict.dyn_hi"]
  cannot find any of ["libHSmtl-2.2.1.a","libHSmtl-2.2.1.p_a","libHSmtl-2.2.1-ghc7.8.4.so","libHSmtl-2.2.1-ghc7.8.4.dylib","HSmtl-2.2.1-ghc7.8.4.dll"] on library path
There are problems in package transformers-0.4.3.0:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/transformers-0.4.3.0 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/transformers-0.4.3.0/html/transformers.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/transformers-0.4.3.0/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/transformers-0.4.3.0 doesn't exist or isn't a directory
  cannot find any of ["Control/Applicative/Backwards.hi","Control/Applicative/Backwards.p_hi","Control/Applicative/Backwards.dyn_hi"]
  cannot find any of ["Control/Applicative/Lift.hi","Control/Applicative/Lift.p_hi","Control/Applicative/Lift.dyn_hi"]
  cannot find any of ["Control/Monad/IO/Class.hi","Control/Monad/IO/Class.p_hi","Control/Monad/IO/Class.dyn_hi"]
  cannot find any of ["Control/Monad/Signatures.hi","Control/Monad/Signatures.p_hi","Control/Monad/Signatures.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Class.hi","Control/Monad/Trans/Class.p_hi","Control/Monad/Trans/Class.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Cont.hi","Control/Monad/Trans/Cont.p_hi","Control/Monad/Trans/Cont.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Except.hi","Control/Monad/Trans/Except.p_hi","Control/Monad/Trans/Except.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Error.hi","Control/Monad/Trans/Error.p_hi","Control/Monad/Trans/Error.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Identity.hi","Control/Monad/Trans/Identity.p_hi","Control/Monad/Trans/Identity.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/List.hi","Control/Monad/Trans/List.p_hi","Control/Monad/Trans/List.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Maybe.hi","Control/Monad/Trans/Maybe.p_hi","Control/Monad/Trans/Maybe.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Reader.hi","Control/Monad/Trans/Reader.p_hi","Control/Monad/Trans/Reader.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/RWS.hi","Control/Monad/Trans/RWS.p_hi","Control/Monad/Trans/RWS.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/RWS/Lazy.hi","Control/Monad/Trans/RWS/Lazy.p_hi","Control/Monad/Trans/RWS/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/RWS/Strict.hi","Control/Monad/Trans/RWS/Strict.p_hi","Control/Monad/Trans/RWS/Strict.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/State.hi","Control/Monad/Trans/State.p_hi","Control/Monad/Trans/State.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/State/Lazy.hi","Control/Monad/Trans/State/Lazy.p_hi","Control/Monad/Trans/State/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/State/Strict.hi","Control/Monad/Trans/State/Strict.p_hi","Control/Monad/Trans/State/Strict.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Writer.hi","Control/Monad/Trans/Writer.p_hi","Control/Monad/Trans/Writer.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Writer/Lazy.hi","Control/Monad/Trans/Writer/Lazy.p_hi","Control/Monad/Trans/Writer/Lazy.dyn_hi"]
  cannot find any of ["Control/Monad/Trans/Writer/Strict.hi","Control/Monad/Trans/Writer/Strict.p_hi","Control/Monad/Trans/Writer/Strict.dyn_hi"]
  cannot find any of ["Data/Functor/Classes.hi","Data/Functor/Classes.p_hi","Data/Functor/Classes.dyn_hi"]
  cannot find any of ["Data/Functor/Compose.hi","Data/Functor/Compose.p_hi","Data/Functor/Compose.dyn_hi"]
  cannot find any of ["Data/Functor/Constant.hi","Data/Functor/Constant.p_hi","Data/Functor/Constant.dyn_hi"]
  cannot find any of ["Data/Functor/Product.hi","Data/Functor/Product.p_hi","Data/Functor/Product.dyn_hi"]
  cannot find any of ["Data/Functor/Reverse.hi","Data/Functor/Reverse.p_hi","Data/Functor/Reverse.dyn_hi"]
  cannot find any of ["Data/Functor/Sum.hi","Data/Functor/Sum.p_hi","Data/Functor/Sum.dyn_hi"]
  cannot find any of ["Data/Functor/Identity.hi","Data/Functor/Identity.p_hi","Data/Functor/Identity.dyn_hi"]
  cannot find any of ["libHStransformers-0.4.3.0.a","libHStransformers-0.4.3.0.p_a","libHStransformers-0.4.3.0-ghc7.8.4.so","libHStransformers-0.4.3.0-ghc7.8.4.dylib","HStransformers-0.4.3.0-ghc7.8.4.dll"] on library path
There are problems in package data-default-0.5.3:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-0.5.3 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-0.5.3/html/data-default.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-0.5.3/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-0.5.3 doesn't exist or isn't a directory
  cannot find any of ["Data/Default.hi","Data/Default.p_hi","Data/Default.dyn_hi"]
  cannot find any of ["libHSdata-default-0.5.3.a","libHSdata-default-0.5.3.p_a","libHSdata-default-0.5.3-ghc7.8.4.so","libHSdata-default-0.5.3-ghc7.8.4.dylib","HSdata-default-0.5.3-ghc7.8.4.dll"] on library path
There are problems in package data-default-instances-dlist-0.0.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-dlist-0.0.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-dlist-0.0.1/html/data-default-instances-dlist.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-dlist-0.0.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-dlist-0.0.1 doesn't exist or isn't a directory
  cannot find any of ["Data/Default/Instances/DList.hi","Data/Default/Instances/DList.p_hi","Data/Default/Instances/DList.dyn_hi"]
  cannot find any of ["libHSdata-default-instances-dlist-0.0.1.a","libHSdata-default-instances-dlist-0.0.1.p_a","libHSdata-default-instances-dlist-0.0.1-ghc7.8.4.so","libHSdata-default-instances-dlist-0.0.1-ghc7.8.4.dylib","HSdata-default-instances-dlist-0.0.1-ghc7.8.4.dll"] on library path
There are problems in package data-default-instances-old-locale-0.0.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-old-locale-0.0.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-old-locale-0.0.1/html/data-default-instances-old-locale.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-old-locale-0.0.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-old-locale-0.0.1 doesn't exist or isn't a directory
  cannot find any of ["Data/Default/Instances/OldLocale.hi","Data/Default/Instances/OldLocale.p_hi","Data/Default/Instances/OldLocale.dyn_hi"]
  cannot find any of ["libHSdata-default-instances-old-locale-0.0.1.a","libHSdata-default-instances-old-locale-0.0.1.p_a","libHSdata-default-instances-old-locale-0.0.1-ghc7.8.4.so","libHSdata-default-instances-old-locale-0.0.1-ghc7.8.4.dylib","HSdata-default-instances-old-locale-0.0.1-ghc7.8.4.dll"] on library path
There are problems in package utf8-string-0.3.8:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/utf8-string-0.3.8 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/utf8-string-0.3.8/html/utf8-string.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/utf8-string-0.3.8/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/utf8-string-0.3.8 doesn't exist or isn't a directory
  cannot find any of ["Codec/Binary/UTF8/String.hi","Codec/Binary/UTF8/String.p_hi","Codec/Binary/UTF8/String.dyn_hi"]
  cannot find any of ["Codec/Binary/UTF8/Generic.hi","Codec/Binary/UTF8/Generic.p_hi","Codec/Binary/UTF8/Generic.dyn_hi"]
  cannot find any of ["System/IO/UTF8.hi","System/IO/UTF8.p_hi","System/IO/UTF8.dyn_hi"]
  cannot find any of ["System/Environment/UTF8.hi","System/Environment/UTF8.p_hi","System/Environment/UTF8.dyn_hi"]
  cannot find any of ["Data/String/UTF8.hi","Data/String/UTF8.p_hi","Data/String/UTF8.dyn_hi"]
  cannot find any of ["Data/ByteString/UTF8.hi","Data/ByteString/UTF8.p_hi","Data/ByteString/UTF8.dyn_hi"]
  cannot find any of ["Data/ByteString/Lazy/UTF8.hi","Data/ByteString/Lazy/UTF8.p_hi","Data/ByteString/Lazy/UTF8.dyn_hi"]
  cannot find any of ["libHSutf8-string-0.3.8.a","libHSutf8-string-0.3.8.p_a","libHSutf8-string-0.3.8-ghc7.8.4.so","libHSutf8-string-0.3.8-ghc7.8.4.dylib","HSutf8-string-0.3.8-ghc7.8.4.dll"] on library path
There are problems in package data-default-instances-containers-0.0.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-containers-0.0.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-containers-0.0.1/html/data-default-instances-containers.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-containers-0.0.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-containers-0.0.1 doesn't exist or isn't a directory
  cannot find any of ["Data/Default/Instances/Containers.hi","Data/Default/Instances/Containers.p_hi","Data/Default/Instances/Containers.dyn_hi"]
  cannot find any of ["libHSdata-default-instances-containers-0.0.1.a","libHSdata-default-instances-containers-0.0.1.p_a","libHSdata-default-instances-containers-0.0.1-ghc7.8.4.so","libHSdata-default-instances-containers-0.0.1-ghc7.8.4.dylib","HSdata-default-instances-containers-0.0.1-ghc7.8.4.dll"] on library path
There are problems in package random-1.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/random-1.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/random-1.1/html/random.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/random-1.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/random-1.1 doesn't exist or isn't a directory
  cannot find any of ["System/Random.hi","System/Random.p_hi","System/Random.dyn_hi"]
  cannot find any of ["libHSrandom-1.1.a","libHSrandom-1.1.p_a","libHSrandom-1.1-ghc7.8.4.so","libHSrandom-1.1-ghc7.8.4.dylib","HSrandom-1.1-ghc7.8.4.dll"] on library path
There are problems in package data-default-instances-base-0.0.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-base-0.0.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-base-0.0.1/html/data-default-instances-base.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-instances-base-0.0.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-instances-base-0.0.1 doesn't exist or isn't a directory
  cannot find any of ["Data/Default/Instances/Base.hi","Data/Default/Instances/Base.p_hi","Data/Default/Instances/Base.dyn_hi"]
  cannot find any of ["libHSdata-default-instances-base-0.0.1.a","libHSdata-default-instances-base-0.0.1.p_a","libHSdata-default-instances-base-0.0.1-ghc7.8.4.so","libHSdata-default-instances-base-0.0.1-ghc7.8.4.dylib","HSdata-default-instances-base-0.0.1-ghc7.8.4.dll"] on library path
There are problems in package dlist-0.7.1.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/dlist-0.7.1.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/dlist-0.7.1.1/html/dlist.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/dlist-0.7.1.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/dlist-0.7.1.1 doesn't exist or isn't a directory
  cannot find any of ["Data/DList.hi","Data/DList.p_hi","Data/DList.dyn_hi"]
  cannot find any of ["libHSdlist-0.7.1.1.a","libHSdlist-0.7.1.1.p_a","libHSdlist-0.7.1.1-ghc7.8.4.so","libHSdlist-0.7.1.1-ghc7.8.4.dylib","HSdlist-0.7.1.1-ghc7.8.4.dll"] on library path
There are problems in package extensible-exceptions-0.1.1.4:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/extensible-exceptions-0.1.1.4 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/extensible-exceptions-0.1.1.4/html/extensible-exceptions.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/extensible-exceptions-0.1.1.4/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/extensible-exceptions-0.1.1.4 doesn't exist or isn't a directory
  cannot find any of ["Control/Exception/Extensible.hi","Control/Exception/Extensible.p_hi","Control/Exception/Extensible.dyn_hi"]
  cannot find any of ["libHSextensible-exceptions-0.1.1.4.a","libHSextensible-exceptions-0.1.1.4.p_a","libHSextensible-exceptions-0.1.1.4-ghc7.8.4.so","libHSextensible-exceptions-0.1.1.4-ghc7.8.4.dylib","HSextensible-exceptions-0.1.1.4-ghc7.8.4.dll"] on library path
There are problems in package data-default-class-0.0.1:
  Warning: library-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-class-0.0.1 doesn't exist or isn't a directory
  Warning: haddock-interfaces: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-class-0.0.1/html/data-default-class.haddock doesn't exist or isn't a file
  Warning: haddock-html: /home/dun/.cabal/share/doc/x86_64-linux-ghc-7.8.4/data-default-class-0.0.1/html doesn't exist or isn't a directory
  import-dirs: /home/dun/.cabal/lib/x86_64-linux-ghc-7.8.4/data-default-class-0.0.1 doesn't exist or isn't a directory
  cannot find any of ["Data/Default/Class.hi","Data/Default/Class.p_hi","Data/Default/Class.dyn_hi"]
  cannot find any of ["libHSdata-default-class-0.0.1.a","libHSdata-default-class-0.0.1.p_a","libHSdata-default-class-0.0.1-ghc7.8.4.so","libHSdata-default-class-0.0.1-ghc7.8.4.dylib","HSdata-default-class-0.0.1-ghc7.8.4.dll"] on library path
Warning: haddock-interfaces: /usr/share/doc/haskell-haddock-library/html/haddock-library.haddock doesn't exist or isn't a file
Warning: haddock-html: /usr/share/doc/haskell-haddock-library/html doesn't exist or isn't a directory

The following packages are broken, either because they have a problem
listed above, or because they depend on a broken package.
xmonad-0.11.1
X11-xft-0.3.1
X11-1.6.1.2
mtl-2.2.1
transformers-0.4.3.0
data-default-0.5.3
data-default-instances-dlist-0.0.1
data-default-instances-old-locale-0.0.1
utf8-string-0.3.8
data-default-instances-containers-0.0.1
random-1.1
data-default-instances-base-0.0.1
dlist-0.7.1.1
extensible-exceptions-0.1.1.4
data-default-class-0.0.1

Thank you very much answering me. You are already now a big help for me.

Last edited by Dun (2015-03-29 15:35:56)

Offline

#8 2015-03-29 15:56:39

Knute
Member
From: Minot, ND
Registered: 2009-03-17
Posts: 604

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

You are most welcome.  I'm sorry that I am not sure where to go from here.

When I do the ghc-pkg check on my own system, it gives the haddock warnings but it's looking in /usr/share/doc, rather than in my home directory.


Knute

Offline

#9 2015-03-29 20:36:08

Dun
Member
Registered: 2014-12-28
Posts: 79

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

So due to my little knowledge about Linux I "destroyed" my system and had to reinstall it completely.
Good sideeffect is that I can compile Xmonad without any errors, but I think if I'm installing Cabal on my system it will be broken again.  Looks like I have to read more about Cabal and Ghc to use it properly, so I don't encounter this problem in the future, but for now I'm stuck configuring my system.

Offline

#10 2015-03-30 18:49:26

jmarvin_
Member
From: Chestnut Hill, MA
Registered: 2015-03-30
Posts: 9
Website

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

I am currently dealing with this exact same issue, down to most of the same error reports.  I've tried a thousand permutations of uninstalling and reinstalling xmonad, ghc, cabal, etc, using pacman, the AUR, the haskell-xmonad packages from the Haskell repo, but to no avail.  Any attempt to install xmonad-contrib with cabal results in the error message in the first post.  Installing haskell-xmonad-contrib with pacman seems to work, but doesn't fix the compilation issue; see the original codebox on the first post.

Does anyone know what could be the cause of this? It seems strange that two people have encountered the exact same issue within two days.

Offline

#11 2015-03-30 20:44:06

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,942

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

Generally when this happens it's because of the use of packages from different repos or cabal/pacman. Haskell packages not only go by versioning like regular packages, but they also have a hash key to identify them. Even mixing and matching packages from the Arch repos and [haskell-core] can do this. For instance, say that one is using [haskell-core] but has it listed in pacman.conf below the Arch repos. If a new version of GHC gets installed from the regular repos, then all of the installed packages from [haskell-core] will then be broken. If you want to use cabal, then only install GHC from the repos. If you want to use [haskell-core], uninstall all of you haskell packages and then reinstall with the new repo. If you go that route, put [haskell-core] above all other repos in pacman.conf so that your packages don't get clobbered.

Offline

#12 2015-03-31 01:28:56

jmarvin_
Member
From: Chestnut Hill, MA
Registered: 2015-03-30
Posts: 9
Website

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

Skottish: I uninstalled cabal-install and ghc+all dependents (ie pacman -Rsc ghc) and then did a clean install of haskell-xmonad and haskell-xmonad-contrib with pacman alone.  Pacman supposedly installed it all corectly, but I got the same error upon trying to recompile xmonad.  Am I forgetting something obvious, or do i just need to do a more thorough scouring of every haskell-related package and file I can find?

Offline

#13 2015-03-31 01:33:07

Knute
Member
From: Minot, ND
Registered: 2009-03-17
Posts: 604

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

Actually, if you edit your /etc/pacman.conf file and put the haskell-core repo first in the list of repos (even before testing, community, etc), and then do pacman -Syu haskell-xmonad haskell-xmonad-contrib  it will update everything for you.


Knute

Offline

#14 2015-03-31 02:53:38

jmarvin_
Member
From: Chestnut Hill, MA
Registered: 2015-03-30
Posts: 9
Website

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

I just used pacman to uninstall ghc and all of its dependent packages (ie everything haskell related, including xmonad).  I also used pacman to uninstall cabal-install.  I then went into / and scoured it for any trace of ghc, cabal, xmonad, or the like; I cleared out every lib, bin, or doc left over related to haskell.  Once I was convinced it was totally clean, and with haskell-core at the top of my repo list, I did pacman -Syu haskell-xmonad haskell-xmonad-contrib.  The installation ran smoothly, or so it seemed.

Even after totally wiping haskell from the system (assuming I wasn't forgetting anything) and having a clean, pacman-officiated reinstall, xmonad refuses to recompile, citing what I'm pretty sure are a bunch of modules from xmonad-contrib which it claims are "missing" (see: first post).

I really don't know what to think of this.  I'm either forgetting something or the actual haskell-xmonad/haskell-xmonad-contrib packages are currently dysfunctional.

P.S. - For reference, ghc-pkg check gives only the expected haddock warnings; it doesn't seem to think anything's wrong.

Last edited by jmarvin_ (2015-03-31 02:58:26)

Offline

#15 2015-03-31 03:01:32

Knute
Member
From: Minot, ND
Registered: 2009-03-17
Posts: 604

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

Can you post your /etc/pacman.conf file please?

My guess is that the haskell-core repo is AFTER the arch repos.  You need to move the haskell-core report before the arch repos so that haskell-core is done before the arch.


Knute

Offline

#16 2015-03-31 03:06:59

jmarvin_
Member
From: Chestnut Hill, MA
Registered: 2015-03-30
Posts: 9
Website

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

No, it's first; I made sure of this before I ran the re-installation.

#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
#Color
#TotalDownload
CheckSpace
#VerbosePkgLists

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#Include = /etc/pacman.d/mirrorlist
[haskell-core]
SigLevel=Never
Server = http://xsounds.org/~haskell/core/$arch

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

Offline

#17 2015-03-31 03:10:15

Knute
Member
From: Minot, ND
Registered: 2009-03-17
Posts: 604

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

It's an easy thing to overlook.  I learned along time ago that it's always good to ask.  smile

If you do a listing of your haskell packages do they all show that they are from haskell-core?


Knute

Offline

#18 2015-03-31 03:26:54

jmarvin_
Member
From: Chestnut Hill, MA
Registered: 2015-03-30
Posts: 9
Website

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

Definitely is worth checking; thanks for all of your help so far.

I ran yaourt -Q | grep haskell and it revealed all haskell packages (including ghc itself) as being installed from haskell-core.

Offline

#19 2015-03-31 03:45:03

Knute
Member
From: Minot, ND
Registered: 2009-03-17
Posts: 604

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

Have you tried logging out and logging back in again?  (As I was writing that I know I sounded just like M$ tech support! lol)


Knute

Offline

#20 2015-03-31 04:04:33

jmarvin_
Member
From: Chestnut Hill, MA
Registered: 2015-03-30
Posts: 9
Website

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

(ha- unfortunately for them, it's usually worth saying)

Full reboot and the same failure to compile, citing the same "missing" modules as in the original post.  It's not that xmonad doesn't work; I'm able to run applications and terminals and all that jazz just fine through the default xmonad.hs that loads up when the custom one can't compile, but this compilation issue is concerning.

The fact that two people encountered this issue at about the same time, and that everything certainly seems like it should work, makes me think there might be a mismatch somewhere in the latest xmonad and xmonad-contrib packages and/or their dependencies.  Of course, that hasn't even approached being proven.

I also was encountering the same issue with installing xmonad-contrib through cabal as in the first post.  I think that's sufficient reason to deem the issues related, maybe even caused by the same underlying problem.

Offline

#21 2015-04-01 11:20:10

silasdavis
Member
Registered: 2013-02-13
Posts: 17

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

Also having the same issue running from a cabal-based install of xmonad. I tried installing/removing ghc, cabal, reinstalling from haskell-core, etc. I ended up with some stale ghc configuration in various places. to get back to a clean state try the following:

Remove haskelly things:

pacman -Qq | grep haskell | xargs pacman --noconfirm -R

Remove ghc:

pacman -R ghc

Remove stale ghc cache (some was left behind by remove for me):

rm /usr/lib/ghc-*

Remove user ghc cache/db:

rm -rf ~/.ghc

Remove cabal local repo:

rm -rf ~/.cabal

Add the haskell-core repo to pacman.conf (above core).

Then do as Knute suggests and:

pacman -Syu haskell-xmonad haskell-xmonad-contrib

This should pull in haskell-core version of ghc and restore things to working order. Let me know if it works for you.

Offline

#22 2015-04-01 11:22:54

silasdavis
Member
Registered: 2013-02-13
Posts: 17

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

I should also add I performed a clean cabal-based install and got the same issue, so it looks like an upstream bug with the latest versions in hackage, see: https://hackage.haskell.org/package/xmo … /reports/1

Should probably file a bug somewhere. I don't have time immediately, but will try to later.

Offline

#23 2015-04-02 10:31:04

jmarvin_
Member
From: Chestnut Hill, MA
Registered: 2015-03-30
Posts: 9
Website

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

silasdavis wrote:

Also having the same issue running from a cabal-based install of xmonad. I tried installing/removing ghc, cabal, reinstalling from haskell-core, etc. I ended up with some stale ghc configuration in various places. to get back to a clean state try the following:

Remove haskelly things:

pacman -Qq | grep haskell | xargs pacman --noconfirm -R

Remove ghc:

pacman -R ghc

Remove stale ghc cache (some was left behind by remove for me):

rm /usr/lib/ghc-*

Remove user ghc cache/db:

rm -rf ~/.ghc

Remove cabal local repo:

rm -rf ~/.cabal

Add the haskell-core repo to pacman.conf (above core).

Then do as Knute suggests and:

pacman -Syu haskell-xmonad haskell-xmonad-contrib

This should pull in haskell-core version of ghc and restore things to working order. Let me know if it works for you.

This worked for me; I must've missed something on my first "clear out all haskell/ghc things" attempt.  Thanks for your help- I can use xmonad again!

Offline

#24 2015-04-02 11:15:27

silasdavis
Member
Registered: 2013-02-13
Posts: 17

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

I'm glad it worked. Can we mark this as solved?

Offline

#25 2015-04-06 16:39:35

ashbreeze
Member
Registered: 2014-03-02
Posts: 9

Re: [SOLVED]Xmonad wont recompile / Can't install xmonad-contrib with Caba

I'm still having problems with this.  I have the haskell-core at the top of the pacman.conf list...

sudo pacman -Syy
:: Synchronizing package databases...
 haskell-core                                                                                                         270.9 KiB   459K/s 00:01 [#######################################################################################] 100%
 core                                                                                                                 121.3 KiB   491K/s 00:00 [#######################################################################################] 100%
 extra                                                                                                               1788.0 KiB   692K/s 00:03 [#######################################################################################] 100%
 community                                                                                                              2.6 MiB   695K/s 00:04 [#######################################################################################] 100%
 multilib                                                                                                             124.1 KiB   713K/s 00:00 [#######################################################################################] 100%
sudo pacman -S haskell-xmonad haskell-xmonad-contrib
error: target not found: haskell-xmonad
error: target not found: haskell-xmonad-contrib

As you can see, I have the haskell-core at the top of the list, but haskell-xmonad haskell-xmonad-contrib aren't found. I have done everything suggested above by silasdavis (rm all the files and other cleanup, reboot, ...)

I don't understand why the "target not found" persists.!

Last edited by ashbreeze (2015-04-06 16:40:31)

Offline

Board footer

Powered by FluxBB