You are not logged in.

#1 2015-04-01 12:17:18

Max Ammann
Member
Registered: 2015-04-01
Posts: 5

[ALC1150] constant background noise | How did I fix it?

Heyho,

for some reason my onboard soundcard outputs a constant background noise.
It's not loud but it's loud enough to be disturbing while having my headset
on.

I found a solution about a year ago. Setting the option model=generic solved
my problem. But after reinstalling my system lately I lookup up what
generic means:

"The model name "generic" is treated as a special case.  When this model is
given, the driver uses the generic codec parser without
"codec-patch".  It's sometimes good for testing and debugging."

So why does the background noise disapprear with generic? Is there a better
solution than using a debugging configuration?

Here's the output of alsa-info.sh.
My motherboard is the: MAXIMUS VII RANGER


It's about soundcard 0: HDA-Intel - HDA Intel PCH

Offline

#2 2015-04-01 15:35:50

mike_r
Member
Registered: 2009-01-22
Posts: 114

Re: [ALC1150] constant background noise | How did I fix it?

Assuming "constant background noise" means a typical white noise hiss, have you gone through the exercise of simply turning down or muting all unnecessary options?  I note from your alsa-info output that many of the gains are set to maximum and the capture levels are non-zero (assuming you are not also trying to record input). I can't explain why generic vs specific would make a difference, except that the interpretation of a gain setting might be different between the drivers. Also, any chance of a stale asound.state file laying around? (Normally in /var/lib/alsa/asound.state.)


Linux User #353 - SLS -> Slackware -> Red Hat -> Mandrake -> Fedora -> Arch

Offline

#3 2015-04-01 20:43:51

Max Ammann
Member
Registered: 2015-04-01
Posts: 5

Re: [ALC1150] constant background noise | How did I fix it?

Yeah it's some kind of white noise. I tried turning all channels in alsamixer down, but there were no changes. The noise stopped after I muted the soundcard, but yeah, then it's muted big_smile

I also record my mic through this soundcard.

There's the my current alsa.state: http://pastebin.com/qGkgb0sh
Don't have an old one without model=generic option laying around, but I could get one if it helps you.

Another info:
The noise starts when alsa inizialises and stops when the kernel is shut down. So absolutly is an alsa/driver problem.

Not sure, but maybe alsa doesn't auto-detect my soundcard correctly, or only partly correct. Maybe snd_hda_intel has some options which are not constant over the ALC1150 codec?

Offline

Board footer

Powered by FluxBB