You are not logged in.

#1 2015-04-08 13:12:30

t0m5k1
Member
From: overthere
Registered: 2012-02-10
Posts: 310

[SOLVED] unable to update nepomuk-core requires baloo!!

Hi

for the past 3 days I have been unable to update & when I try I get the following:

 
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace kfilemetadata with extra/kfilemetadata4? [Y/n] 
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: nepomuk-core: requires baloo

a cursory search shows there is no package directly called "baloo"

extra/baloo-frameworks 5.6.2-1
    A framework for searching and managing metadata
extra/baloo4 4.14.3-2 [installed: 4.14.3-1]
    A KDE4 framework for searching and managing metadata
extra/baloo4-akonadi 4.14.3-2 [installed: 4.14.3-1]
    Baloo resource for Akonadi
extra/baloo4-widgets 4.14.3-1
    Widgets for Baloo
extra/libbaloo4 4.14.3-2 [installed: 4.14.3-1]
    Libraries for baloo4
extra/milou 5.2.2-1 (plasma)
    A dedicated search application built on top of Baloo

as you can see I do have baloo4 installed which was updated recently

oddly when I search for nepomuk-core & nepomuk I get no results!

How do i resolve this & upgrade?
Is this part of the KDE framework?
no I don't use KDE (perhaps 1 or 2 apps that pulled this as a dep) so I have no clue as to why this is affecting me.

Last edited by t0m5k1 (2015-04-08 14:05:12)


Optiplex 790, Intel Core i3-2100 CPU @ 3.10GHz 16Mb Corsair Vengeance 1333Mhz - GeForce 970 - AwesomeWM (occasionally XFCE, i3)

If everything in life was easy, we would learn nothing!
Linux User: 401820   Last FM

Offline

#2 2015-04-08 13:23:00

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,638

Re: [SOLVED] unable to update nepomuk-core requires baloo!!

Searching for nepomuk-core and nepomuk gets no results because they're in the AUR now.

baloo-frameworks "provides" baloo.

Offline

#3 2015-04-08 13:26:05

Raynman
Member
Registered: 2011-10-22
Posts: 1,186

Re: [SOLVED] unable to update nepomuk-core requires baloo!!

Offline

#4 2015-04-08 13:39:57

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 259
Website

Re: [SOLVED] unable to update nepomuk-core requires baloo!!

Please send us output of:

pacman -Qi nepomuk-core

Offline

#5 2015-04-08 13:58:44

t0m5k1
Member
From: overthere
Registered: 2012-02-10
Posts: 310

Re: [SOLVED] unable to update nepomuk-core requires baloo!!

ok I'll remove it

┌─(t0m5k1@l4pt0p)-(2960/pts/0)-(02:09pm:08/04/15)
├─>(%:~)
└─>> sudo pacman -Qi nepomuk-core
[sudo] password for t0m5k1: 
Name           : nepomuk-core
Version        : 4.13.1-1
Description    : Contains the central Nepomuk services like file indexing, file system monitoring, query, storage, client libraries
Architecture   : x86_64
URL            : https://projects.kde.org/projects/kde/kdelibs/nepomuk-core
Licences       : GPL  LGPL  FDL
Groups         : None
Provides       : None
Depends On     : kdelibs  poppler-qt  taglib  ffmpeg  ebook-tools  kdegraphics-mobipocket  shared-desktop-ontologies  baloo
Optional Deps  : None
Required By    : None
Optional For   : None
Conflicts With : None
Replaces       : None
Installed Size :   3.88 MiB
Packager       : Unknown Packager
Build Date     : Sun 18 May 2014 20:14:01 BST
Install Date   : Sun 18 May 2014 20:17:36 BST
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By   : None

but first I guess I have to work out is I need these:

┌─(t0m5k1@l4pt0p)-(2963/pts/0)-(02:56pm:08/04/15)
├─>(%:~)
└─>> sudo pacman -Rns nepomuk-core
checking dependencies...
:: apr-util optionally requires libmariadbclient: enable mysql/mariadb support
:: kdebase-runtime optionally requires kdepimlibs: for kwalletd, and is needed by DrKonqi to send crash reports to KDE.org
:: qt4 optionally requires libmariadbclient: MariaDB driver
:: qt5-base optionally requires libmariadbclient: MariaDB driver

Packages (21) akonadi-1.13.0-3  baloo4-4.14.3-1  baloo4-akonadi-4.14.3-1  convertlit-1.8-7  ebook-tools-0.2.2-2  jemalloc-3.6.0-1  kdegraphics-mobipocket-14.12.3-1
              kdepimlibs-4.14.6-1  kfilemetadata-4.14.3-1  libbaloo4-4.14.3-1  libdmtx-0.7.4-5  libmariadbclient-10.0.17-2  libzip-0.11.2-1  mariadb-10.0.17-2
              mariadb-clients-10.0.17-2  poppler-qt4-0.31.0-1  prison-1.1.1-1  qjson-0.8.1-3  shared-desktop-ontologies-0.11.0-1  xapian-core-1:1.2.20-1
              nepomuk-core-4.13.1-1

Total Removed Size:  197.46 MiB

oh what fun ...god knows how I ended up keeping this hmm


Optiplex 790, Intel Core i3-2100 CPU @ 3.10GHz 16Mb Corsair Vengeance 1333Mhz - GeForce 970 - AwesomeWM (occasionally XFCE, i3)

If everything in life was easy, we would learn nothing!
Linux User: 401820   Last FM

Offline

Board footer

Powered by FluxBB