You are not logged in.

#1 2015-04-09 21:17:55

gabor_bernat
Member
From: Budapest
Registered: 2014-10-21
Posts: 7
Website

cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

The change enables gdk backend. At the moment the only solution is to export the x11 backend from console, and replace cinnamon.
export CLUTTER_BACKEND=x11; cinnamon --replace

Any better fixes?

Last edited by gabor_bernat (2015-04-09 21:18:23)


"In a moment, everything can change, Feel the wind on your shoulder, For a minute, all the world can wait, Let go of your yesterday."

Offline

#2 2015-04-09 22:42:25

dice
Member
From: Germany
Registered: 2014-02-10
Posts: 413

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

I can confirm this. And as I had no idea what is going I have to thank you for posting this workaround.
All I could do was laugh about cinnamon's error message

Apr 10 00:18:09 obsidian cinnamon-session[849]: CRITICAL: We failed, but the fail whale is dead. Sorry....

After that it dumped the core. Not much information about the actual error.
How did you find out what happened?


I put at button on it. Yes. I wish to press it, but I'm not sure what will happen if I do.  (Gune | Titan A.E.)

Offline

#3 2015-04-10 00:50:23

OK38
Member
Registered: 2014-08-07
Posts: 4

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

I have the same issue.

For the moment, I take your solution ...

Any other?

Offline

#4 2015-04-10 01:11:45

BaNkS
Member
From: Houston, TX
Registered: 2015-04-10
Posts: 2

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

sudo your-text-editor /etc/X11/xinit/xinitrc.d/cinnamonfix.sh

#!/bin/bash

# Temp fix for Cinnamon
export CLUTTER_BACKEND=x11

save file

Make it executable from your terminal.

sudo chmod 755 /etc/X11/xinit/xinitrc.d/cinnamonfix.sh

reboot

That way it exports before x starts. Works for me.

Offline

#5 2015-04-10 04:54:13

KeNaCo
Member
Registered: 2012-11-01
Posts: 10

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

Confirm here! Thanx for workaround..

Offline

#6 2015-04-10 05:14:35

dkaylor
Member
Registered: 2015-04-10
Posts: 4

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

A bug has been filed at https://bugs.archlinux.org/task/44523

Offline

#7 2015-04-10 08:07:16

Cyberess
Member
Registered: 2015-02-19
Posts: 5

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

What a nasty bug!     I was hit as well, lost a good hour, as I really didn't know what happened at first, after reading the bug report I rolled back "clutter"

Archlinux has a rollback machine  https://wiki.archlinux.org/index.php/Ar … ck_Machine

wget -c http://seblu.net/a/arm/week/extra/os/x86_64/clutter-1.20.0-4-x86_64.pkg.tar.xz
sudo pacman -Ud clutter-1.20.0-4-x86_64.pkg.tar.xz

# Edit your /etc/pacman.conf to include
IgnorePkg    = clutter


reboot wink


Keep a eye on the bug report https://bugs.archlinux.org/task/44523    --  to know when it's safe to upgrade the "clutter" package

Cheers

Offline

#8 2015-04-10 09:19:10

Nico
Member
Registered: 2015-04-10
Posts: 1

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

hi,

I tried your answer, but i have the same issue sad

downgrade gnome, clutter, cinnamon... ever same issue

another idea ?

Offline

#9 2015-04-10 10:04:02

dice
Member
From: Germany
Registered: 2014-02-10
Posts: 413

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

@Nico: did you try the script mentioned above?

After all MY current solution (as suggested on the bug report) is to rebuild using abs and applying the upstream patch https://github.com/linuxmint/cinnamon-s … bbd3.patch.
Of course only until this commit is included in the official package.


I put at button on it. Yes. I wish to press it, but I'm not sure what will happen if I do.  (Gune | Titan A.E.)

Offline

#10 2015-04-10 11:26:41

PâtéDeCerf
Member
Registered: 2014-07-18
Posts: 16

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

Hi,

same here. I tried both options mentioned here, and none of them work, i.e.

  • Downgrading clutter-1.22.0-2 to clutter-1.20.0-4

  • Edit /etc/X11/xinit/xinitrc.d/cinnamonfix.sh with export CLUTTER_BACKEND=x11

Last edited by PâtéDeCerf (2015-04-11 09:52:26)

Offline

#11 2015-04-10 14:00:42

TheCreeL
Member
Registered: 2011-08-23
Posts: 30

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

Reporting in for the cinnamon crash since last update.

The script above worked for me and everything's now running as usual.

Anyone know what could be the possible cause of this bug?

Offline

#12 2015-04-10 14:10:50

lev
Member
Registered: 2010-05-05
Posts: 5

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

dice wrote:

After all MY current solution (as suggested on the bug report) is to rebuild using abs and applying the upstream patch https://github.com/linuxmint/cinnamon-s … bbd3.patch.

This patch alone didn't solve all problems for me. Cinnamon did start but all window decorations were black. This commit is also needed:
https://github.com/dalcde/muffin/commit … 39661ed7e2

I opened a bug report for this patch to be added to muffin:
https://bugs.archlinux.org/task/44533

Offline

#13 2015-04-10 14:16:18

lukesium
Member
Registered: 2015-04-10
Posts: 1

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

also tried
Downgrading clutter-1.22.0-2 to clutter-1.20.0-4
and
Edit /etc/X11/xinit/xinitrc.d/cinnamonfix.sh with export CLUTTER_BACKEND=x11

with no success

Offline

#14 2015-04-10 14:34:50

dice
Member
From: Germany
Registered: 2014-02-10
Posts: 413

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

@lev my window decorations look fine.

I used ABS to rebuild cinnamon. I modified the PKGBUILD like thisDo this at your own risk wink
If neither the script nor dowgrading nor patching cinnamon-session work there might be another issue.


I put at button on it. Yes. I wish to press it, but I'm not sure what will happen if I do.  (Gune | Titan A.E.)

Offline

#15 2015-04-10 20:52:16

Chris Cromer
Member
From: Chile
Registered: 2014-08-30
Posts: 30

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

lev wrote:
dice wrote:

After all MY current solution (as suggested on the bug report) is to rebuild using abs and applying the upstream patch https://github.com/linuxmint/cinnamon-s … bbd3.patch.

This patch alone didn't solve all problems for me. Cinnamon did start but all window decorations were black. This commit is also needed:
https://github.com/dalcde/muffin/commit … 39661ed7e2

I opened a bug report for this patch to be added to muffin:
https://bugs.archlinux.org/task/44533

I have rolled back clutter and now cinnamon can launch.
I also rolled back gnome-themes-standard which fixed the adwaita parts of the themes that were missing.

However my window decorations are still black as well. I am using clearlooks phenix from the AUR. Have you found a solution to this problem?


Chris Cromer

Offline

#16 2015-04-10 21:40:07

dice
Member
From: Germany
Registered: 2014-02-10
Posts: 413

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

I use numix themes from aur. So far there were no issues with black borders


I put at button on it. Yes. I wish to press it, but I'm not sure what will happen if I do.  (Gune | Titan A.E.)

Offline

#17 2015-04-10 22:19:06

bartonc
Member
From: Minden, Nevada, USA
Registered: 2012-02-27
Posts: 25

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

Here to confirm that this workaround did the trick for me.
Thank you @BaNks

Note that 2.4.8 is already up with some other fix (decorations are wrong?).

Also, note that all of my GTK3 core is frozen at 3.10:
local/gtk3 3.10.7-1
local/gtkmm 2.24.4-1
local/gtkmm3 3.10.1-1
local/gtksourceview3 3.10.2-1
local/gtksourceviewmm 3.2.0-4

With those few Gnome apps that I must have coming from the same era:
# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
IgnorePkg    = gtk3 gtkmm3 gtksourceview3 gksu libgksu libgtop gnome-terminal gnome-system-monitor file-roller eog

Offline

#18 2015-04-10 22:24:57

Chris Cromer
Member
From: Chile
Registered: 2014-08-30
Posts: 30

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

bartonc wrote:

Here to confirm that this workaround did the trick for me.
Thank you @BaNks

Note that 2.4.8 is already up with some other fix (decorations are wrong?).

Also, note that all of my GTK3 core is frozen at 3.10:
local/gtk3 3.10.7-1
local/gtkmm 2.24.4-1
local/gtkmm3 3.10.1-1
local/gtksourceview3 3.10.2-1
local/gtksourceviewmm 3.2.0-4

With those few Gnome apps that I must have coming from the same era:
# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
IgnorePkg    = gtk3 gtkmm3 gtksourceview3 gksu libgksu libgtop gnome-terminal gnome-system-monitor file-roller eog

I didn't roll back all of those. I only rolled back gtk3 to the previous version and it fixed the black border on my theme after I rebooted. Thanks.


Chris Cromer

Offline

#19 2015-04-10 22:35:23

mirbeksm
Member
Registered: 2015-02-09
Posts: 4

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

updated my system:

[ALPM] upgraded cinnamon (2.4.7-1 -> 2.4.8-1)
[ALPM] upgraded clutter-gtk (1.6.0-1 -> 1.6.0-2)

and then encountered this bug.

After applying workaround from BaNkS everything seems fine.

Offline

#20 2015-04-10 23:05:39

OK38
Member
Registered: 2014-08-07
Posts: 4

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

Downgrade gtk3-3.16.1-1 to gtk3-3.14.9-1 and clutter-1.22.0-2 to clutter-1.20.0-4 fixed window decoration.

Offline

#21 2015-04-11 01:16:26

dkaylor
Member
Registered: 2015-04-10
Posts: 4

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

For those that were unsuccessful with the workaround before the cinnamon 2.4.8 update, what display manager were you using? Or were you using the startx method. With SDDM and the workaround mentioned earlier, everything was fine for me.

Also, for those with window decoration issues, there is still an issue with muffin, and a recent commit that deals with it, so watch for an update to muffin soon, hopefully. See https://bugs.archlinux.org/task/44533

Offline

#22 2015-04-11 02:22:38

Chris Cromer
Member
From: Chile
Registered: 2014-08-30
Posts: 30

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

dkaylor wrote:

For those that were unsuccessful with the workaround before the cinnamon 2.4.8 update, what display manager were you using? Or were you using the startx method. With SDDM and the workaround mentioned earlier, everything was fine for me.

Also, for those with window decoration issues, there is still an issue with muffin, and a recent commit that deals with it, so watch for an update to muffin soon, hopefully. See https://bugs.archlinux.org/task/44533

In my case I am using lightdm.


Chris Cromer

Offline

#23 2015-04-11 09:18:18

PâtéDeCerf
Member
Registered: 2014-07-18
Posts: 16

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

dkaylor wrote:

For those that were unsuccessful with the workaround before the cinnamon 2.4.8 update, what display manager were you using? Or were you using the startx method. With SDDM and the workaround mentioned earlier, everything was fine for me.

The workaround doesn't work for me, and I use Start X at login, no DM. Does it makes a difference in this issue ?

Offline

#24 2015-04-11 09:26:48

Syl
Member
Registered: 2009-06-24
Posts: 36

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

https://github.com/linuxmint/Cinnamon/issues/4039

summarize everything necessary with all the explanation and fixes ...


広島のお好み焼きおたくです

Offline

#25 2015-04-11 11:43:10

ZoLA
Member
Registered: 2014-04-07
Posts: 22

Re: cinnamon 2.4.7-1 does not start after upgrading clutter-gtk 1.6.0-2

I'm also affected with this bug.. Downgrading clutter and gnome-themes-standard solve my problem i hope that this bug will be fixes in packages very soon...

Offline

Board footer

Powered by FluxBB