You are not logged in.

#1 2015-04-10 17:26:27

rgomes
Member
Registered: 2013-11-15
Posts: 43

Gnome 3.16 - Touchpad disable bug

I just updated to Gnome 3.16, and while I do enjoy some of the improvements, others I find a bit unfortunate.
First, I found a bug: I use a touchscreen, and touchpad, and for some reason chrome is having issues with that (look here for more info: https://code.google.com/p/chromium/issu … id=475410).
So part of my boot up routine was to disable the touchpad, start chrome, and then enable the touchpad.
This time, right after I disabled the touchpad, the option to enable it again was gone, and it had me looking for how to enable it again. The touchpad was still working, and detected, because if I logged out, it would work, it was just the setting. I found that I could enable it again with the following command:

gsettings set org.gnome.desktop.peripherals.touchpad send-events 'enabled'

But had no GUI way of doing it.
Is this a legitimate bug (that is, can people reproduce it), or is it my specific configuration?
As a note, I created a new user to test, and had the same issue.
Where would I go to submit a bug for gnome?

Offline

#2 2015-04-10 22:33:11

bulletmark
Member
From: Brisbane, Australia
Registered: 2013-10-22
Posts: 511

Re: Gnome 3.16 - Touchpad disable bug

Could it be related to https://plus.google.com/u/0/+MaxWachtel … zr7j6Sy6GS, i.e. see if installing xf86-input-libinput fixes it?

Offline

#3 2015-04-10 23:14:11

rgomes
Member
Registered: 2013-11-15
Posts: 43

Re: Gnome 3.16 - Touchpad disable bug

So, I was hopeful that would fix it, but instead it made my computer completely non-functional hmm
I had to uninstall if through a live CD. It just crashed in the login service.
Any suggestions on how I could debug this?

Offline

#4 2015-04-11 19:08:12

Риал Краесис
Member
Registered: 2015-02-19
Posts: 17

Re: Gnome 3.16 - Touchpad disable bug

faced that bug today after updating to gnome 3.16!!!!

Last edited by Риал Краесис (2015-04-11 19:11:34)

Offline

#5 2015-04-14 23:06:43

ratdude747
Member
From: Madison, IN
Registered: 2013-07-05
Posts: 42

Re: Gnome 3.16 - Touchpad disable bug

Having a similar issue even after today's updates... on my Dell Latitude E5530, If I try to disable the touchpad using the keyboard shortcut, nothing happens on the first press. On the second, gnome crashes and prompts for a re-login.

Offline

#6 2015-04-15 09:23:13

Alcasa
Member
Registered: 2013-05-18
Posts: 46

Re: Gnome 3.16 - Touchpad disable bug

Installing libinput seems to remove the crashing on my laptop. But the Fn-F8 Touchpad toggle is now nonfunctional.

Offline

#7 2015-04-15 14:24:24

vorbote
Member
From: 8375 ft closer to the stars
Registered: 2011-02-07
Posts: 38
Website

Re: Gnome 3.16 - Touchpad disable bug

The problem was with mutter; version 3.16.1.1, already in the repos, should fix the crasher. (See https://projects.archlinux.org/svntogit … ges/mutter for the bug history).

Last edited by vorbote (2015-04-15 14:27:59)


I break things and put them back together for fun and sometimes profit, because it is the only way to learn.

Offline

#8 2015-04-15 15:56:14

syms
Member
Registered: 2008-12-25
Posts: 296

Re: Gnome 3.16 - Touchpad disable bug

vorbote wrote:

The problem was with mutter; version 3.16.1.1, already in the repos, should fix the crasher. (See https://projects.archlinux.org/svntogit … ges/mutter for the bug history).

still not fixed, i press fn + f9 two times and gnome shell crashes

Offline

#9 2015-04-15 16:16:51

Dowefu
Member
Registered: 2014-03-25
Posts: 68

Re: Gnome 3.16 - Touchpad disable bug

syms wrote:

still not fixed, i press fn + f9 two times and gnome shell crashes

Do you have the gpointing-device-settings package installed?

Last edited by Dowefu (2015-04-15 16:17:32)

Offline

#10 2015-04-15 17:06:38

ratdude747
Member
From: Madison, IN
Registered: 2013-07-05
Posts: 42

Re: Gnome 3.16 - Touchpad disable bug

Still broke over here, and installing/uninstalling gpointing-device-settings makes no difference. libinput was already installed; I'll re-install to see if it happens to fix anything

PS- FWIW, on my Dell, it's FN+F5. Not sure on the actual keycode (not listed in keyboard shortcuts, as far as I could tell by skimming).

edit- it comes up as "touchpad toggle"; I tried re-assigning it to a "test" custom shortcut, which did not work, as pressing it once changed the text on screen of the settings (after setting the new assignment, which didn't prompt an assignment conflict warning), the second press, as before, crashed gnome. I'll take some screenshots to illustrate.

Last edited by ratdude747 (2015-04-15 17:12:39)

Offline

#11 2015-04-16 17:33:49

baqtor
Member
Registered: 2014-03-27
Posts: 4

Re: Gnome 3.16 - Touchpad disable bug

I fixed it logging out, choosing Gnome on Wayland as session and enabling touchpad in mouse settings as you normally would.

Offline

#12 2015-05-12 06:04:53

akshay2000
Member
From: Kanpur
Registered: 2011-08-01
Posts: 29
Website

Re: Gnome 3.16 - Touchpad disable bug

baqtor wrote:

I fixed it logging out, choosing Gnome on Wayland as session and enabling touchpad in mouse settings as you normally would.

Are you required to choose Wayland every time you log in? Or is there a better way to debug/fix this?


Wit beyond measure is man's greatest treasure!
Windows Phone app for Linux!

Offline

Board footer

Powered by FluxBB