You are not logged in.

#1 2015-04-14 18:18:05

Markus.N2
Member
From: Germany
Registered: 2013-08-22
Posts: 49

[SOLVED] How can I disable "overlay scrollbars" in GTK-apps on XFCE ?

Hi,

Since one of the latest updates, I have "overlay scrollbars" in many GTK-applications, e.g. remmina. What I mean by this is: the scrollbars are hidden most times and if you move the mouse within the window, they appear (like the auto-hiding bottom panel of XFCE).
The problem (especially in remmina) is that they hide the window content underneath. So, I can not move the mouse to the bottom of the remote desktop any more. This makes the bottom panel unrachable.

I have not knowingly activated such a feature, nor did I install any *overlay-scrollbar* package. The folks at the XFCE forums say that this is not an XFCE feature.

Because the new scrollbars make some areas of the window content unreachable for the mouse, this is not just a cosmetic problem.

How can I disable them (pereferrably for all applications, but at least for remmina) ?

Thanks,
Markus

Last edited by Markus.N2 (2015-04-14 19:18:22)

Offline

#2 2015-04-14 18:48:43

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: [SOLVED] How can I disable "overlay scrollbars" in GTK-apps on XFCE ?

I can only mention it's a feature of the newest Gnome.

-edit-

Judging by https://plus.google.com/+WorldofGnomeOr … Dx9wNo3Cd8, developers of remmina could disable them if they are causing problems.

Last edited by lucke (2015-04-14 18:54:48)

Offline

#3 2015-04-14 18:55:17

toz
Member
Registered: 2011-10-28
Posts: 326

Re: [SOLVED] How can I disable "overlay scrollbars" in GTK-apps on XFCE ?

There was further discussion about this at the Xfce forums post. Adding this:

export GTK_OVERLAY_SCROLLING=0

...to your shell startup file disables them.

Offline

#4 2015-04-14 19:00:57

Markus.N2
Member
From: Germany
Registered: 2013-08-22
Posts: 49

Re: [SOLVED] How can I disable "overlay scrollbars" in GTK-apps on XFCE ?

So there is no hope for a system-wide setting ?

EDIT:
oops, too slow :-)

EDIT 2:
Whow, it worked !

Thanks a lot.

Last edited by Markus.N2 (2015-04-14 19:18:00)

Offline

#5 2015-05-05 06:21:06

andreyv
Member
From: Riga, Latvia
Registered: 2012-11-02
Posts: 31

Re: [SOLVED] How can I disable "overlay scrollbars" in GTK-apps on XFCE ?

Thanks, it helped me too.

Offline

#6 2015-07-22 07:57:17

M0nt3c1t0
Member
Registered: 2015-07-22
Posts: 1

Re: [SOLVED] How can I disable "overlay scrollbars" in GTK-apps on XFCE ?

Markus.N2 wrote:

So there is no hope for a system-wide setting ?

I appended "GTK_OVERLAY_SCROLLING=0" to /etc/environment. This worked for me to disable the overlay globally.

Offline

Board footer

Powered by FluxBB