You are not logged in.

#1 2015-04-16 23:30:13

Shino
Member
Registered: 2015-02-01
Posts: 47

GDM ignores monitors.xml

Hello,

I upgraded GDM a few minutes ago.

GDM is now ignoring its monitors.xml
Because of that my login screen is on the wrong monitor.
Is there a way to fix this?

Last edited by Shino (2015-04-16 23:30:31)

Offline

#2 2015-04-23 12:46:52

wichmannpas
Member
Registered: 2015-04-23
Posts: 1

Re: GDM ignores monitors.xml

Same bug affects me since the last update of gdm.

Seems like there is already a similar bug report existing since 01/21 at Red Hat's bug tracker for Fedora:
https://bugzilla.redhat.com/show_bug.cgi?id=1184617

Does not seem to be something user-fixable unless they made a new configuration opportunity somewehere else.

Offline

#3 2015-10-14 21:01:11

liGNUx
Member
From: Germany
Registered: 2015-10-14
Posts: 4

Re: GDM ignores monitors.xml

There is a workaround for this problem. With GDM using Wayland and not Xorg for some time as a default setting, some things seem to be a bit different now. I made GDM respect /var/lib/gdm/.config/monitors.xml by telling it not to run on Wayland by uncommenting this line in /etc/gdm/custom.conf

WaylandEnable=false

With this configuration I have my login screen on my VGA monitor which is by default considered as secondary.
As this solution is probably not the "official" way to go, there are some issues with this workaround: E.g., I encounter some strange visual effects in GDM (like squares and dots appearing before GDM shows its actual login interface) which I didn't when using Wayland. Also the tty behaviour of the GNOME shell session could now be different.


"Join us now and share the software"
                                        - Richard Stallman

Avatar by the GNU project (CC BY-SA 2.0)

Offline

#4 2015-10-28 10:02:45

anon5
Member
Registered: 2015-10-28
Posts: 3

Re: GDM ignores monitors.xml

liGNUx wrote:

There is a workaround for this problem. With GDM using Wayland and not Xorg for some time as a default setting, some things seem to be a bit different now. I made GDM respect /var/lib/gdm/.config/monitors.xml by telling it not to run on Wayland by uncommenting this line in /etc/gdm/custom.conf

WaylandEnable=false

With this configuration I have my login screen on my VGA monitor which is by default considered as secondary.
As this solution is probably not the "official" way to go, there are some issues with this workaround: E.g., I encounter some strange visual effects in GDM (like squares and dots appearing before GDM shows its actual login interface) which I didn't when using Wayland. Also the tty behaviour of the GNOME shell session could now be different.

I've been searching for this answer 2 days straight. Thanks a lot for posting it! This indeed fixed the problem.

Thanks!

Offline

Board footer

Powered by FluxBB